/[smecontribs]/rpms/GeoIP-GeoLite-data/contribs10/GeoIP-GeoLite-data.spec
ViewVC logotype

Annotation of /rpms/GeoIP-GeoLite-data/contribs10/GeoIP-GeoLite-data.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Sun Mar 14 06:28:12 2021 UTC (3 years, 2 months ago) by jpp
Branch: MAIN
CVS Tags: GeoIP-GeoLite-data-2018_06-5_el7_sme
Initial import

1 jpp 1.1 Name: GeoIP-GeoLite-data
2     # The geolite databases were traditionally updated on the first Tuesday of each month,
3     # hence we use a versioning scheme of YYYY.MM for the Fedora package.
4     #
5     # No further releases of IPv4 GeoLite Legacy databases will be made from April 2018.
6     Version: 2018.06
7     Release: 5%{?dist}
8     Summary: Free GeoLite IP geolocation country database
9     # License specified at http://dev.maxmind.com/geoip/legacy/geolite/#License
10     License: CC-BY-SA
11     URL: http://dev.maxmind.com/geoip/legacy/geolite/
12     Source0: http://geolite.maxmind.com/download/geoip/database/GeoLiteCountry/GeoIP.dat.gz
13     Source1: http://geolite.maxmind.com/download/geoip/database/GeoIPv6.dat.gz
14     Source2: http://geolite.maxmind.com/download/geoip/database/GeoLiteCity.dat.gz
15     Source3: http://geolite.maxmind.com/download/geoip/database/GeoLiteCityv6-beta/GeoLiteCityv6.dat.gz
16     Source4: http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNum.dat.gz
17     Source5: http://download.maxmind.com/download/geoip/database/asnum/GeoIPASNumv6.dat.gz
18     BuildArch: noarch
19     # For compatibility with monolithic GeoIP packages in Fedora 21 and older
20     # releases, we ensure that all databases are installed together; going
21     # forward, only the IPv4 country database is installed by default and the user
22     # can choose whether or not to install the databases from the extra package
23     %if 0%{?fedora} < 22 && 0%{?rhel} < 8
24     Requires: GeoIP-GeoLite-data-extra = %{version}-%{release}
25     %endif
26     # This data has previously been available in differently-named packages
27     Obsoletes: GeoIP-data < 1.6.4-10
28     Provides: GeoIP-data = %{version}
29     Obsoletes: geoip-geolite < %{version}
30     Provides: geoip-geolite = %{version}
31     # The data was unbundled from GeoIP at 1.6.4-3
32     Conflicts: GeoIP < 1.6.4-3
33    
34     %description
35     The GeoLite databases are free IP geolocation databases. This package contains
36     a database that maps IPv4 addresses to countries.
37    
38     This product includes GeoLite data created by MaxMind, available from
39     http://www.maxmind.com/
40    
41     %package extra
42     Summary: Free GeoLite IP geolocation databases
43     License: CC-BY-SA
44     Requires: %{name} = %{version}-%{release}
45    
46     %description extra
47     The GeoLite databases are free IP geolocation databases. This package contains
48     databases that map IPv6 addresses to countries, plus IPv4 and IPv6 addresses
49     to cities and autonomous system numbers.
50    
51     This product includes GeoLite data created by MaxMind, available from
52     http://www.maxmind.com/
53    
54     %prep
55     %setup -q -T -c
56    
57     install -p -m 644 %{SOURCE0} GeoLiteCountry.dat.gz; gunzip GeoLiteCountry.dat
58     install -p -m 644 %{SOURCE1} GeoIPv6.dat.gz; gunzip GeoIPv6.dat
59     install -p -m 644 %{SOURCE2} GeoLiteCity.dat.gz; gunzip GeoLiteCity.dat
60     install -p -m 644 %{SOURCE3} GeoLiteCityv6.dat.gz; gunzip GeoLiteCityv6.dat
61     install -p -m 644 %{SOURCE4} GeoLiteASNum.dat.gz; gunzip GeoLiteASNum.dat
62     install -p -m 644 %{SOURCE5} GeoIPASNumv6.dat.gz; gunzip GeoIPASNumv6.dat
63    
64     %build
65     # This section intentionally left empty
66    
67     %install
68     mkdir -p %{buildroot}%{_datadir}/GeoIP/
69     for db in \
70     GeoLiteCountry.dat \
71     GeoIPv6.dat \
72     GeoLiteCity.dat \
73     GeoLiteCityv6.dat \
74     GeoLiteASNum.dat \
75     GeoIPASNumv6.dat
76     do
77     install -p -m 644 $db %{buildroot}%{_datadir}/GeoIP/
78     done
79    
80     # Add compat symlinks for GeoIPASNum.dat and GeoLiteASNumv6.dat
81     # ([upstream] database names used in the old geoip-geolite package)
82     ln -sf GeoLiteASNum.dat %{buildroot}%{_datadir}/GeoIP/GeoIPASNum.dat
83     ln -sf GeoIPASNumv6.dat %{buildroot}%{_datadir}/GeoIP/GeoLiteASNumv6.dat
84    
85     # Symlinks for City databases to be where upstream expects them
86     # (geoiplookup -v ...)
87     ln -sf GeoLiteCity.dat %{buildroot}%{_datadir}/GeoIP/GeoIPCity.dat
88     ln -sf GeoLiteCityv6.dat %{buildroot}%{_datadir}/GeoIP/GeoIPCityv6.dat
89    
90     %preun
91     # If the package is being uninstalled (rather than upgraded), we remove
92     # the GeoIP.dat symlink, provided that it points to GeoLiteCountry.dat;
93     # rpm will then be able to remove the %%{_datadir}/GeoIP directory
94     if [ $1 = 0 ]; then
95     if [ -h %{_datadir}/GeoIP/GeoIP.dat ]; then
96     geoipdat=`readlink %{_datadir}/GeoIP/GeoIP.dat`
97     if [ "$geoipdat" = "GeoLiteCountry.dat" ]; then
98     rm -f %{_datadir}/GeoIP/GeoIP.dat
99     fi
100     fi
101     fi
102     exit 0
103    
104     %posttrans
105     # Create the default GeoIP.dat as a symlink to GeoLiteCountry.dat
106     #
107     # This has to be done in %%posttrans rather than %%post because an old
108     # package's GeoIP.dat may still be present during %%post in an upgrade
109     #
110     # Don't do this if there is any existing GeoIP.dat, as we don't want to
111     # override what the user has put there
112     #
113     # Also, if there's an existing GeoIP.dat.rpmsave, we're probably doing
114     # an upgrade from an old version of GeoIP that packaged GeoIP.dat as
115     # %%config(noreplace), so rename GeoIP.dat.rpmsave back to GeoIP.dat
116     # instead of creating a new symlink
117     if [ ! -e %{_datadir}/GeoIP/GeoIP.dat ]; then
118     if [ -e %{_datadir}/GeoIP/GeoIP.dat.rpmsave ]; then
119     mv %{_datadir}/GeoIP/GeoIP.dat.rpmsave \
120     %{_datadir}/GeoIP/GeoIP.dat
121     else
122     ln -sf GeoLiteCountry.dat %{_datadir}/GeoIP/GeoIP.dat
123     fi
124     fi
125     exit 0
126    
127     %files
128     %dir %{_datadir}/GeoIP/
129     # The databases are %%verify(not md5 size mtime) so that they can be updated
130     # via cron scripts and rpm will not moan about the files having changed
131     %verify(not md5 size mtime) %{_datadir}/GeoIP/GeoLiteCountry.dat
132    
133     %files extra
134     # The databases are %%verify(not md5 size mtime) so that they can be updated
135     # via cron scripts and rpm will not moan about the files having changed
136     %verify(not md5 size mtime) %{_datadir}/GeoIP/GeoIPv6.dat
137     %verify(not md5 size mtime) %{_datadir}/GeoIP/GeoLiteCity.dat
138     %verify(not md5 size mtime) %{_datadir}/GeoIP/GeoLiteCityv6.dat
139     %verify(not md5 size mtime) %{_datadir}/GeoIP/GeoLiteASNum.dat
140     %verify(not md5 size mtime) %{_datadir}/GeoIP/GeoIPASNumv6.dat
141     # The compat symlinks are just regular files as they should never need to be
142     # changed
143     %{_datadir}/GeoIP/GeoIPASNum.dat
144     %{_datadir}/GeoIP/GeoIPCity.dat
145     %{_datadir}/GeoIP/GeoIPCityv6.dat
146     %{_datadir}/GeoIP/GeoLiteASNumv6.dat
147    
148     %changelog
149     * Thu Nov 28 2019 Thomas Andrejak <thomas.andrejak@gmail.com> - 2018.06-5
150     - Rebuilt for EPEL8
151    
152     * Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2018.06-4
153     - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
154    
155     * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2018.06-3
156     - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
157    
158     * Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2018.06-2
159     - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
160    
161     * Tue Jun 19 2018 Paul Howarth <paul@city-fan.org> - 2018.06-1
162     - IPv6 databases are still seeing updates in June 2018
163     - IPv4 databases are unchanged from previous release
164    
165     * Wed Apr 4 2018 Paul Howarth <paul@city-fan.org> - 2018.04-1
166     - Final update of GeoLite Legacy databases from Maxmind
167    
168     * Wed Mar 21 2018 Paul Howarth <paul@city-fan.org> - 2018.03-1
169     - Update to March 2018 databases
170    
171     * Fri Feb 2 2018 Paul Howarth <paul@city-fan.org> - 2018.02-1
172     - Update to February 2018 databases
173    
174     * Mon Jan 8 2018 Paul Howarth <paul@city-fan.org> - 2018.01-1
175     - Update to January 2018 databases
176    
177     * Thu Dec 21 2017 Paul Howarth <paul@city-fan.org> - 2017.12-1
178     - Update to December 2017 databases
179    
180     * Mon Oct 9 2017 Paul Howarth <paul@city-fan.org> - 2017.10-1
181     - Update to October 2017 databases
182    
183     * Mon Sep 11 2017 Paul Howarth <paul@city-fan.org> - 2017.09-1
184     - Update to September 2017 databases
185    
186     * Wed Aug 9 2017 Paul Howarth <paul@city-fan.org> - 2017.08-1
187     - Update to August 2017 databases
188    
189     * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2017.07-2
190     - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
191    
192     * Sun Jul 23 2017 Paul Howarth <paul@city-fan.org> - 2017.07-1
193     - Update to July 2017 databases
194    
195     * Tue Jun 13 2017 Paul Howarth <paul@city-fan.org> - 2017.06-1
196     - Update to June 2017 databases
197    
198     * Tue May 9 2017 Paul Howarth <paul@city-fan.org> - 2017.05-1
199     - Update to May 2017 databases
200    
201     * Wed Apr 5 2017 Paul Howarth <paul@city-fan.org> - 2017.04-1
202     - Update to April 2017 databases
203     - Drop EL-5 support as it's now EOL
204    
205     * Fri Mar 10 2017 Paul Howarth <paul@city-fan.org> - 2017.03-1
206     - Update to March 2017 databases
207    
208     * Thu Feb 9 2017 Paul Howarth <paul@city-fan.org> - 2017.02-1
209     - Update to February 2017 databases
210    
211     * Tue Jan 17 2017 Paul Howarth <paul@city-fan.org> - 2017.01-1
212     - Update to January 2017 databases
213    
214     * Tue Dec 6 2016 Paul Howarth <paul@city-fan.org> - 2016.12-1
215     - Update to December 2016 databases
216    
217     * Fri Nov 25 2016 Paul Howarth <paul@city-fan.org> - 2016.11-1
218     - Update to November 2016 databases
219    
220     * Thu Oct 13 2016 Paul Howarth <paul@city-fan.org> - 2016.10-1
221     - Update to October 2016 databases
222    
223     * Tue Sep 6 2016 Paul Howarth <paul@city-fan.org> - 2016.09-1
224     - Update to September 2016 databases
225    
226     * Fri Aug 5 2016 Paul Howarth <paul@city-fan.org> - 2016.08-1
227     - Update to August 2016 databases
228    
229     * Mon Jul 11 2016 Paul Howarth <paul@city-fan.org> - 2016.07-1
230     - Update to July 2016 databases
231    
232     * Tue Jun 21 2016 Paul Howarth <paul@city-fan.org> - 2016.06-1
233     - Update to June 2016 databases
234    
235     * Mon May 9 2016 Paul Howarth <paul@city-fan.org> - 2016.05-1
236     - Update to May 2016 databases
237    
238     * Wed Apr 6 2016 Paul Howarth <paul@city-fan.org> - 2016.04-1
239     - Update to April 2016 databases
240    
241     * Tue Mar 8 2016 Paul Howarth <paul@city-fan.org> - 2016.03-1
242     - Update to March 2016 databases
243    
244     * Tue Feb 23 2016 Paul Howarth <paul@city-fan.org> - 2016.02-1
245     - Update to February 2016 databases
246    
247     * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2016.01-2
248     - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
249    
250     * Fri Jan 22 2016 Paul Howarth <paul@city-fan.org> - 2016.01-1
251     - Update to January 2016 databases
252    
253     * Fri Dec 11 2015 Paul Howarth <paul@city-fan.org> - 2015.12-1
254     - Update to December 2015 databases
255    
256     * Mon Nov 9 2015 Paul Howarth <paul@city-fan.org> - 2015.11-1
257     - Update to November 2015 databases
258    
259     * Wed Sep 9 2015 Paul Howarth <paul@city-fan.org> - 2015.09-1
260     - Update to September 2015 databases
261    
262     * Tue Aug 18 2015 Paul Howarth <paul@city-fan.org> - 2015.08-1
263     - Update to August 2015 databases
264    
265     * Wed Jul 8 2015 Paul Howarth <paul@city-fan.org> - 2015.07-1
266     - Update to July 2015 databases
267    
268     * Tue Jun 16 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2015.06-2
269     - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
270    
271     * Sun Jun 14 2015 Paul Howarth <paul@city-fan.org> - 2015.06-1
272     - Update to June 2015 databases
273    
274     * Tue May 12 2015 Paul Howarth <paul@city-fan.org> - 2015.05-1
275     - Update to May 2015 databases
276    
277     * Mon Apr 27 2015 Paul Howarth <paul@city-fan.org> - 2015.04-2
278     - Add symlinks for City databases to be where upstream expects them
279     (thanks to nucleo for the suggestion in #1194798)
280    
281     * Sun Apr 12 2015 Paul Howarth <paul@city-fan.org> - 2015.04-1
282     - Update to April 2015 databases
283     - Add %%preun script to remove GeoIP.dat symlink if package is uninstalled
284    
285     * Wed Apr 1 2015 Paul Howarth <paul@city-fan.org> - 2015.03-3
286     - Incorporate review feedback (#1194798)
287     - Don't package GeoIP.dat symlink; create it in %%posttrans if it doesn't
288     exist
289     - Update IPASNum databases to current upstream
290     - Wrap comments at 80 characters
291     - Comment use of EPEL-5 idioms
292     - Comment where upstream declares licensing
293    
294     * Thu Mar 5 2015 Paul Howarth <paul@city-fan.org> - 2015.03-1
295     - Update to March 2015 databases
296    
297     * Fri Feb 20 2015 Paul Howarth <paul@city-fan.org> - 2015.02-1
298     - Databases unbundled from GeoIP, like the old geoip-geolite package

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed