/[smecontribs]/rpms/GeoIP/contribs10/GeoIP.spec
ViewVC logotype

Annotation of /rpms/GeoIP/contribs10/GeoIP.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Sun Mar 14 04:08:55 2021 UTC (3 years, 3 months ago) by jpp
Branch: MAIN
CVS Tags: GeoIP-1_6_12-7_el7_sme
Initial import

1 jpp 1.1 # Tests require network access so fail in koji; build using --with tests to run them yourself
2     %bcond_with tests
3    
4     Name: GeoIP
5     Version: 1.6.12
6     Release: 7%{?dist}
7     Summary: Library for country/city/organization to IP address or hostname mapping
8     License: LGPLv2+
9     URL: http://www.maxmind.com/app/c
10     Source0: https://github.com/maxmind/geoip-api-c/releases/download/v%{version}/GeoIP-%{version}.tar.gz
11     BuildRequires: coreutils
12     BuildRequires: gcc
13     BuildRequires: make
14     BuildRequires: sed
15     BuildRequires: zlib-devel
16     Requires: GeoIP-data
17    
18     # For compatibility with original release of GeoIP in old distributions
19     %if 0%{?fedora} < 22 && 0%{?rhel} < 8
20     Requires: geoipupdate
21     %endif
22    
23     # Old name of GeoIP library package
24     Obsoletes: geoip < %{version}-%{release}
25     Provides: geoip = %{version}-%{release}
26    
27     %description
28     GeoIP is a C library that enables the user to find the country that any IP
29     address or hostname originates from.
30    
31     It uses file based databases that can optionally be updated on a weekly basis
32     by installing the geoipupdate-cron (IPv4) and/or geoipupdate-cron6 (IPv6)
33     packages.
34    
35     %package devel
36     Summary: Development headers and libraries for GeoIP
37     Requires: %{name} = %{version}-%{release}
38     Provides: geoip-devel = %{version}-%{release}
39     Obsoletes: geoip-devel < %{version}-%{release}
40    
41     %description devel
42     Development headers and static libraries for building GeoIP-based applications.
43    
44     %prep
45     %setup -q
46    
47     %build
48     %configure --disable-static --disable-dependency-tracking
49    
50     # Kill bogus rpaths
51     sed -i -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \
52     -e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
53    
54     make %{?_smp_mflags}
55    
56     %install
57     make DESTDIR=%{buildroot} INSTALL="install -p" install
58    
59     # nix the stuff we don't need like .la files.
60     rm -f %{buildroot}%{_libdir}/*.la
61    
62     %check
63     # Tests require network access so fail in koji; build using --with tests to run them yourself
64     %{?with_tests:LD_LIBRARY_PATH=%{buildroot}%{_libdir} make check}
65    
66     %ldconfig_scriptlets
67    
68     %files
69     %if 0%{?_licensedir:1}
70     %license COPYING
71     %else
72     %doc COPYING
73     %endif
74     %doc AUTHORS ChangeLog NEWS.md README.md
75     %{_bindir}/geoiplookup
76     %{_bindir}/geoiplookup6
77     %{_libdir}/libGeoIP.so.1
78     %{_libdir}/libGeoIP.so.1.*
79     %{_mandir}/man1/geoiplookup.1*
80     %{_mandir}/man1/geoiplookup6.1*
81    
82     %files devel
83     %{_includedir}/GeoIP.h
84     %{_includedir}/GeoIPCity.h
85     %{_libdir}/libGeoIP.so
86     %{_libdir}/pkgconfig/geoip.pc
87    
88     %changelog
89     * Thu Nov 28 2019 Thomas Andrejak <thomas.andrejak@gmail.com> - 1.6.12-7
90     - Rebuilt for EPEL8
91    
92     * Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.12-6
93     - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
94    
95     * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.12-5
96     - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
97    
98     * Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.12-4
99     - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
100    
101     * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.12-3
102     - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
103    
104     * Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.6.12-2
105     - Switch to %%ldconfig_scriptlets
106    
107     * Thu Jan 18 2018 Paul Howarth <paul@city-fan.org> - 1.6.12-1
108     - Update to 1.6.12
109     - Populate metro and area code when performing lookups in IPv6 City
110     databases; previously this was only done when using IPv4 City
111     databases
112    
113     * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.11-3
114     - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
115    
116     * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.11-2
117     - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
118    
119     * Tue May 16 2017 Paul Howarth <paul@city-fan.org> - 1.6.11-1
120     - Update to 1.6.11
121     - Fix use of a NULL pointer when opening a corrupt database with 'GeoIP_open'
122     (GH#87)
123     - Drop EL-5 support
124     - Drop redundant BuildRoot: and Group: tags
125     - Drop EL5-only dependency on GeoIP-GeoLite-data
126     - Drop explicit pkgconfig dependency in devel package
127     - Drop buildroot cleaning in %%install section
128     - Drop explicit %%clean section
129    
130     * Thu Mar 30 2017 Paul Howarth <paul@city-fan.org> - 1.6.10-1
131     - Update to 1.6.10
132     - GeoIP_database_info now returns the full version string rather than
133     incorrectly truncating it (GH#79)
134     - This API is now distributed with a small test copy of GeoIP.dat rather than
135     a full copy
136     - Fix issue where Visual Studio 2015 was optimizing out initialization code
137     (GH#81)
138     - Fix test/benchmark on Windows (GH#75)
139    
140     * Sun Feb 26 2017 Paul Howarth <paul@city-fan.org> - 1.6.9-4
141     - Fix GeoIP_database_info truncation issue (#1426853, GH#79, GH#80)
142    
143     * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.9-3
144     - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
145    
146     * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.9-2
147     - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
148    
149     * Tue Jan 12 2016 Paul Howarth <paul@city-fan.org> - 1.6.9-1
150     - Update to 1.6.9
151     - Allow compilation on older systems by relaxing the autoconf and automake
152     minimum versions
153     - Avoid potential problems in multi-threaded environments by consistently
154     using pread() rather than read()
155     - Fix various small issues reported by clang's static analyser
156     - Fix a regression introduced in version 1.6.8, which caused
157     GeoIP_database_info to erroneously return NULL
158    
159     * Sun Nov 1 2015 Paul Howarth <paul@city-fan.org> - 1.6.7-1
160     - Update to 1.6.7
161     - Fixed a MSVC parser stack overflow when parsing 'regionName.c' and
162     'timeZone.c' (GH#54)
163     - Updated region codes and timezones
164     - When using 'GEOIP_MEMORY_CACHE' with an invalid database file, the search
165     tree traversal could attempt to read memory outside of the memory allocated
166     for the memory cache, resulting in a segmentation fault; a check was added
167     to ensure that the traversal code does not try to read beyond the end of
168     the file, whether in memory, memory mapped, or on disk
169     - Previously the return values from file reads were ignored; we now check
170     these values to ensure that there were no errors
171    
172     * Thu Jul 30 2015 Paul Howarth <paul@city-fan.org> - 1.6.6-1
173     - Update to 1.6.6
174     - Replaced usage of deprecated fileno, read, and lseek on Visual Studio 2005+
175     with their ISO C++ conformant replacements (GH#55)
176     - A warning about using a double as a float was fixed (GH#56)
177     - Fixed segfault when doing a lookup on an empty database (GH#62)
178     - Fixed a memcheck error from valgrind in the '_check_mtime' function (GH#60)
179     - Fixed '_check_mtime' to check the return value of 'gettimeofday' rather
180     than just assuming it worked
181    
182     * Tue Jun 16 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.5-3
183     - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
184    
185     * Thu Apr 23 2015 Paul Howarth <paul@city-fan.org> - 1.6.5-2
186     - Work around problems with old GeoIP-data package in CentOS 5 Extras
187     repo (http://bugs.centos.org/view.php?id=8488) by requiring
188     GeoIP-GeoLite-data rather than the virtual GeoIP-data for EL-5 builds only
189    
190     * Mon Mar 2 2015 Paul Howarth <paul@city-fan.org> - 1.6.5-1
191     - Update to 1.6.5
192     - Fixed a segmentation fault in geoiplookup when the utility was passed an
193     invalid database (#1180874)
194     - Additional validation was added for the size used in the creation of the
195     index cache (#832913)
196     - Changed the code to only look up country codes by using functions that
197     ensure that we do not try to look past the end of an array (GitHub #53)
198    
199     * Fri Feb 20 2015 Paul Howarth <paul@city-fan.org> - 1.6.4-4
200     - Databases now unbundled to the GeoIP-GeoLite-data package
201     - Drop long-unused perl helper scripts
202     - Add explicit pkgconfig dependency for EL-5 build
203     - Drop timestamp hack for configure, no longer needed
204    
205     * Tue Feb 10 2015 Paul Howarth <paul@city-fan.org> - 1.6.4-3
206     - Sub-package the data; going forward, this would be better as a separate
207     package, since it has separate upstream releases than the library
208    
209     * Fri Feb 6 2015 Paul Howarth <paul@city-fan.org> - 1.6.4-2
210     - Only require geoipupdate prior to F-22, for back-compatibility
211     - Use %%license where possible
212     - GeoIP-devel provides geoip-devel as well as obsoleting it
213     - Update bundled databases
214    
215     * Thu Jan 29 2015 Philip Prindeville <philipp@fedoraproject.org> - 1.6.4-1
216     - Require geoipupdate per Paul
217    
218     * Tue Jan 20 2015 Philip Prindeville <philipp@fedoraproject.org> - 1.6.4-0
219     - Version bump to 1.6.4 per bz #1158667 (okay, that bug was for 1.6.3)
220     - Remove geoipupdate as it will be moving into its own package
221    
222     * Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-6
223     - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
224    
225     * Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-5
226     - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
227    
228     * Tue Feb 25 2014 Paul Howarth <paul@city-fan.org> - 1.5.1-4
229     - Add %%check, so we can run tests by building using --with tests
230     - Update databases from upstream
231    
232     * Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-3
233     - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
234    
235     * Tue Jun 18 2013 Paul Howarth <paul@city-fan.org> - 1.5.1-2
236     - Properly provide all of the GeoLite databases and their IPv6 equivalents, as
237     per the geoip-geolite package that we're obsoleting/providing
238     - Provide compatibility symlinks for database files that historically had
239     different names in GeoIP and geoip-geolite
240     - Don't distribute unbundled LICENSE files, as per packaging guidelines
241     - Update license tag to reflect distribution of CC-BY-SA database content
242     - No longer try to update the databases in %%post
243     - Maintain timestamps where possible
244     - Set up GeoIP.dat symlink in package and don't touch it again
245     - Add update6 package to update the IPv6 databases; have to use wget for this
246     rather than geoipupdate as the databases are still in beta
247    
248     * Wed Jun 12 2013 Philip Prindeville <philipp@fedoraproject.org> - 1.5.1-1
249     - Bump to version 1.5.1
250     - Fix exit codes for various situations (MaxMind support #129155)
251     - Use versioned obsoletes/provides for geoip-geolite
252     - Update UTF8 patch
253     - Change symlink from GeoIP-initial.dat to GeoLiteCountry.dat if we had a
254     successful download and now have the latter file.
255    
256     * Mon Jun 10 2013 Philip Prindeville <philipp@fedoraproject.org> - 1.5.0-7
257     - Annotate conflict with geoip-geolite package (#968074)
258    
259     * Mon Jun 10 2013 Paul Howarth <paul@city-fan.org> - 1.5.0-6
260     - Update sub-package requires main package for geoipupdate script
261    
262     * Sat Jun 8 2013 Paul Howarth <paul@city-fan.org> - 1.5.0-5
263     - Make GeoIP.dat -> GeoIP-initial.dat symlink in %%install, not %%post,
264     and don't %%ghost it
265     - Run geoipupdate silently in %%post and cron job
266     - Create empty database files for %%ghost to work with old rpm versions
267     - Don't try to use noarch subpackages on old rpm versions
268     - Update %%description to mention database updates
269     - Drop outdated README.Fedora
270    
271     * Sat Jun 08 2013 Philip Prindeville <philipp@fedoraproject.org> - 1.5.0-4
272     - Revert ability to replace 3rd-party package
273    
274     * Fri Jun 07 2013 Philip Prindeville <philipp@fedoraproject.org> - 1.5.0-3
275     - Add attributes for %%ghost files
276    
277     * Fri Jun 07 2013 Philip Prindeville <philipp@fedoraproject.org> - 1.5.0-2
278     - Make update subpackage be noarch.
279    
280     * Fri Jun 07 2013 Philip Prindeville <philipp@fedoraproject.org> - 1.5.0-1
281     - Version bump to 1.5.0
282     - Have GeoIP.dat be a symlink to the real data, and install the canned
283     GeoIP.dat as GeoIP-initial.dat
284     - Change config as per Boris' instructions to use 'lite' databases which are
285     regularly updated.
286     - Add pkgconfig (.pc) file into devel subpackage
287     - Add cron support for refreshing the lite databases and make a separate
288     subpackage.
289    
290     * Sun Mar 24 2013 Paul Howarth <paul@city-fan.org> - 1.4.8-6
291     - Fix config.guess and config.sub to add aarch64 support (#925403)
292    
293     * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-5
294     - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
295    
296     * Mon Oct 22 2012 Paul Howarth <paul@city-fan.org> - 1.4.8-4
297     - libGeoIPUpdate and geoipupdate (which is linked against it) are GPL-licensed
298     rather than LGPL-licensed (#840896)
299     - Don't package generic INSTALL file (#661625)
300     - Kill bogus rpaths on x86_64
301     - Hardcode library sonames in %%files list to avoid nasty surprises in the
302     future
303     - Drop %%defattr, redundant since rpm 4.4
304     - Recode docs as UTF-8
305     - Don't use macros for commands
306     - Use tabs
307    
308     * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-3.1
309     - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
310    
311     * Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-2.1
312     - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
313    
314     * Tue Sep 6 2011 Michael Fleming <mfleming+rpm@thatfleminggent.com> - 1.4.8-1.1
315     - Remove -ipv6 patch
316     - Bump to 1.4.8 release
317    
318     * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-0.2.20090931cvs
319     - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
320    
321     * Mon Aug 31 2009 Matt Domsch <mdomsch@fedoraproject.org> - 1.4.7.0.1.20090931
322     - apply CVS HEAD 20090931 which includes IPv6 functions
323    
324     * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.6-2
325     - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
326    
327     * Sun Mar 08 2009 Michael Fleming <mfleming+rpm@enlartenment.com> - 1.4.6-1
328     - Add geoiplookup6 man page
329     - Update to 1.4.6
330    
331     * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.5-3
332     - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
333    
334     * Sat Nov 29 2008 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.5-2
335     - Update to 1.4.5
336     - Fix database URL locations in Perl helper scripts
337    
338     * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.4-2
339     - Autorebuild for GCC 4.3
340    
341     * Mon Jan 28 2008 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.4-1
342     - New upstream release.
343    
344     * Wed Sep 5 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.3-1
345     - New upstream release.
346     - Fix GeoIPCity fetcher script
347     - Update License tag
348    
349     * Mon Feb 12 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.2-1
350     - New upstream release.
351    
352     * Mon Jan 8 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.1-2
353     - License is actually LGPL now.
354    
355     * Sun Jan 7 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.1-1
356     - New upstream release
357     - Add fetch-geoipdata* scripts to pull free databases automatically if
358     desired (bz #198137)
359     - README.fedora added to briefly explain above.
360    
361     * Mon Nov 27 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.0-4
362     - Fix %%install scripts to satisfy newer mock builds
363    
364     * Sun Sep 3 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.0-3
365     - Upstream upgrade
366     - Added LICENSE.txt file to %%doc, covering GeoIP country/city data license
367     (bz #198137)
368    
369     * Mon May 15 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.17-1
370     - New upstream release (minor fixes)
371    
372     * Mon May 1 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.16-1
373     - New upstream release
374     - Add INSTALL document to package.
375    
376     * Sat Feb 18 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-3
377     - Fix Obsoletes/Provides for old "geoip"-convention packages
378     - Move .so symlinks to -devel where they should be
379    
380     * Fri Feb 10 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-2
381     - Remamed to match upstream tarball name
382     - Removed static libraries
383     - Added symlinks to packages
384     - Mark config file noreplace
385    
386     * Sun Feb 5 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-1
387     - Initial review package for Extras

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed