1 |
jpp |
1.1 |
# Tests require network access so fail in koji; build using --with tests to run them yourself |
2 |
|
|
%bcond_with tests |
3 |
|
|
|
4 |
|
|
Name: GeoIP |
5 |
|
|
Version: 1.6.12 |
6 |
jpp |
1.3 |
Release: 9%{?dist} |
7 |
jpp |
1.1 |
Summary: Library for country/city/organization to IP address or hostname mapping |
8 |
|
|
License: LGPLv2+ |
9 |
|
|
URL: http://www.maxmind.com/app/c |
10 |
|
|
Source0: https://github.com/maxmind/geoip-api-c/releases/download/v%{version}/GeoIP-%{version}.tar.gz |
11 |
|
|
BuildRequires: coreutils |
12 |
|
|
BuildRequires: gcc |
13 |
|
|
BuildRequires: make |
14 |
|
|
BuildRequires: sed |
15 |
|
|
BuildRequires: zlib-devel |
16 |
|
|
Requires: GeoIP-data |
17 |
|
|
|
18 |
|
|
# For compatibility with original release of GeoIP in old distributions |
19 |
|
|
%if 0%{?fedora} < 22 && 0%{?rhel} < 8 |
20 |
|
|
Requires: geoipupdate |
21 |
|
|
%endif |
22 |
|
|
|
23 |
|
|
# Old name of GeoIP library package |
24 |
|
|
Obsoletes: geoip < %{version}-%{release} |
25 |
|
|
Provides: geoip = %{version}-%{release} |
26 |
|
|
|
27 |
|
|
%description |
28 |
|
|
GeoIP is a C library that enables the user to find the country that any IP |
29 |
|
|
address or hostname originates from. |
30 |
|
|
|
31 |
|
|
It uses file based databases that can optionally be updated on a weekly basis |
32 |
|
|
by installing the geoipupdate-cron (IPv4) and/or geoipupdate-cron6 (IPv6) |
33 |
|
|
packages. |
34 |
|
|
|
35 |
|
|
%package devel |
36 |
|
|
Summary: Development headers and libraries for GeoIP |
37 |
|
|
Requires: %{name} = %{version}-%{release} |
38 |
|
|
Provides: geoip-devel = %{version}-%{release} |
39 |
|
|
Obsoletes: geoip-devel < %{version}-%{release} |
40 |
|
|
|
41 |
|
|
%description devel |
42 |
|
|
Development headers and static libraries for building GeoIP-based applications. |
43 |
|
|
|
44 |
|
|
%prep |
45 |
|
|
%setup -q |
46 |
|
|
|
47 |
|
|
%build |
48 |
|
|
%configure --disable-static --disable-dependency-tracking |
49 |
|
|
|
50 |
|
|
# Kill bogus rpaths |
51 |
|
|
sed -i -e 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' \ |
52 |
|
|
-e 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool |
53 |
|
|
|
54 |
|
|
make %{?_smp_mflags} |
55 |
|
|
|
56 |
|
|
%install |
57 |
|
|
make DESTDIR=%{buildroot} INSTALL="install -p" install |
58 |
|
|
|
59 |
|
|
# nix the stuff we don't need like .la files. |
60 |
|
|
rm -f %{buildroot}%{_libdir}/*.la |
61 |
|
|
|
62 |
|
|
%check |
63 |
|
|
# Tests require network access so fail in koji; build using --with tests to run them yourself |
64 |
|
|
%{?with_tests:LD_LIBRARY_PATH=%{buildroot}%{_libdir} make check} |
65 |
|
|
|
66 |
jpp |
1.3 |
%post -p /sbin/ldconfig |
67 |
|
|
|
68 |
|
|
%postun -p /sbin/ldconfig |
69 |
jpp |
1.1 |
|
70 |
|
|
%files |
71 |
|
|
%if 0%{?_licensedir:1} |
72 |
|
|
%license COPYING |
73 |
|
|
%else |
74 |
|
|
%doc COPYING |
75 |
|
|
%endif |
76 |
|
|
%doc AUTHORS ChangeLog NEWS.md README.md |
77 |
|
|
%{_bindir}/geoiplookup |
78 |
|
|
%{_bindir}/geoiplookup6 |
79 |
|
|
%{_libdir}/libGeoIP.so.1 |
80 |
|
|
%{_libdir}/libGeoIP.so.1.* |
81 |
|
|
%{_mandir}/man1/geoiplookup.1* |
82 |
|
|
%{_mandir}/man1/geoiplookup6.1* |
83 |
|
|
|
84 |
|
|
%files devel |
85 |
|
|
%{_includedir}/GeoIP.h |
86 |
|
|
%{_includedir}/GeoIPCity.h |
87 |
|
|
%{_libdir}/libGeoIP.so |
88 |
|
|
%{_libdir}/pkgconfig/geoip.pc |
89 |
|
|
|
90 |
|
|
%changelog |
91 |
jpp |
1.3 |
* Sat Mar 13 2021 Jean-Philipe Pialasse <tests@pialasse.com> 1.6.12-9.sme |
92 |
jpp |
1.2 |
- Rebuilt for SME10 |
93 |
jpp |
1.3 |
- remove ldconfig scriptlet missing on buildsys |
94 |
jpp |
1.2 |
|
95 |
jpp |
1.1 |
* Thu Nov 28 2019 Thomas Andrejak <thomas.andrejak@gmail.com> - 1.6.12-7 |
96 |
|
|
- Rebuilt for EPEL8 |
97 |
|
|
|
98 |
|
|
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.12-6 |
99 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild |
100 |
|
|
|
101 |
|
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.12-5 |
102 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild |
103 |
|
|
|
104 |
|
|
* Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.12-4 |
105 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild |
106 |
|
|
|
107 |
|
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.12-3 |
108 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild |
109 |
|
|
|
110 |
|
|
* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.6.12-2 |
111 |
|
|
- Switch to %%ldconfig_scriptlets |
112 |
|
|
|
113 |
|
|
* Thu Jan 18 2018 Paul Howarth <paul@city-fan.org> - 1.6.12-1 |
114 |
|
|
- Update to 1.6.12 |
115 |
|
|
- Populate metro and area code when performing lookups in IPv6 City |
116 |
|
|
databases; previously this was only done when using IPv4 City |
117 |
|
|
databases |
118 |
|
|
|
119 |
|
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.11-3 |
120 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild |
121 |
|
|
|
122 |
|
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.11-2 |
123 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild |
124 |
|
|
|
125 |
|
|
* Tue May 16 2017 Paul Howarth <paul@city-fan.org> - 1.6.11-1 |
126 |
|
|
- Update to 1.6.11 |
127 |
|
|
- Fix use of a NULL pointer when opening a corrupt database with 'GeoIP_open' |
128 |
|
|
(GH#87) |
129 |
|
|
- Drop EL-5 support |
130 |
|
|
- Drop redundant BuildRoot: and Group: tags |
131 |
|
|
- Drop EL5-only dependency on GeoIP-GeoLite-data |
132 |
|
|
- Drop explicit pkgconfig dependency in devel package |
133 |
|
|
- Drop buildroot cleaning in %%install section |
134 |
|
|
- Drop explicit %%clean section |
135 |
|
|
|
136 |
|
|
* Thu Mar 30 2017 Paul Howarth <paul@city-fan.org> - 1.6.10-1 |
137 |
|
|
- Update to 1.6.10 |
138 |
|
|
- GeoIP_database_info now returns the full version string rather than |
139 |
|
|
incorrectly truncating it (GH#79) |
140 |
|
|
- This API is now distributed with a small test copy of GeoIP.dat rather than |
141 |
|
|
a full copy |
142 |
|
|
- Fix issue where Visual Studio 2015 was optimizing out initialization code |
143 |
|
|
(GH#81) |
144 |
|
|
- Fix test/benchmark on Windows (GH#75) |
145 |
|
|
|
146 |
|
|
* Sun Feb 26 2017 Paul Howarth <paul@city-fan.org> - 1.6.9-4 |
147 |
|
|
- Fix GeoIP_database_info truncation issue (#1426853, GH#79, GH#80) |
148 |
|
|
|
149 |
|
|
* Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.9-3 |
150 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild |
151 |
|
|
|
152 |
|
|
* Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.9-2 |
153 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild |
154 |
|
|
|
155 |
|
|
* Tue Jan 12 2016 Paul Howarth <paul@city-fan.org> - 1.6.9-1 |
156 |
|
|
- Update to 1.6.9 |
157 |
|
|
- Allow compilation on older systems by relaxing the autoconf and automake |
158 |
|
|
minimum versions |
159 |
|
|
- Avoid potential problems in multi-threaded environments by consistently |
160 |
|
|
using pread() rather than read() |
161 |
|
|
- Fix various small issues reported by clang's static analyser |
162 |
|
|
- Fix a regression introduced in version 1.6.8, which caused |
163 |
|
|
GeoIP_database_info to erroneously return NULL |
164 |
|
|
|
165 |
|
|
* Sun Nov 1 2015 Paul Howarth <paul@city-fan.org> - 1.6.7-1 |
166 |
|
|
- Update to 1.6.7 |
167 |
|
|
- Fixed a MSVC parser stack overflow when parsing 'regionName.c' and |
168 |
|
|
'timeZone.c' (GH#54) |
169 |
|
|
- Updated region codes and timezones |
170 |
|
|
- When using 'GEOIP_MEMORY_CACHE' with an invalid database file, the search |
171 |
|
|
tree traversal could attempt to read memory outside of the memory allocated |
172 |
|
|
for the memory cache, resulting in a segmentation fault; a check was added |
173 |
|
|
to ensure that the traversal code does not try to read beyond the end of |
174 |
|
|
the file, whether in memory, memory mapped, or on disk |
175 |
|
|
- Previously the return values from file reads were ignored; we now check |
176 |
|
|
these values to ensure that there were no errors |
177 |
|
|
|
178 |
|
|
* Thu Jul 30 2015 Paul Howarth <paul@city-fan.org> - 1.6.6-1 |
179 |
|
|
- Update to 1.6.6 |
180 |
|
|
- Replaced usage of deprecated fileno, read, and lseek on Visual Studio 2005+ |
181 |
|
|
with their ISO C++ conformant replacements (GH#55) |
182 |
|
|
- A warning about using a double as a float was fixed (GH#56) |
183 |
|
|
- Fixed segfault when doing a lookup on an empty database (GH#62) |
184 |
|
|
- Fixed a memcheck error from valgrind in the '_check_mtime' function (GH#60) |
185 |
|
|
- Fixed '_check_mtime' to check the return value of 'gettimeofday' rather |
186 |
|
|
than just assuming it worked |
187 |
|
|
|
188 |
|
|
* Tue Jun 16 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.5-3 |
189 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild |
190 |
|
|
|
191 |
|
|
* Thu Apr 23 2015 Paul Howarth <paul@city-fan.org> - 1.6.5-2 |
192 |
|
|
- Work around problems with old GeoIP-data package in CentOS 5 Extras |
193 |
|
|
repo (http://bugs.centos.org/view.php?id=8488) by requiring |
194 |
|
|
GeoIP-GeoLite-data rather than the virtual GeoIP-data for EL-5 builds only |
195 |
|
|
|
196 |
|
|
* Mon Mar 2 2015 Paul Howarth <paul@city-fan.org> - 1.6.5-1 |
197 |
|
|
- Update to 1.6.5 |
198 |
|
|
- Fixed a segmentation fault in geoiplookup when the utility was passed an |
199 |
|
|
invalid database (#1180874) |
200 |
|
|
- Additional validation was added for the size used in the creation of the |
201 |
|
|
index cache (#832913) |
202 |
|
|
- Changed the code to only look up country codes by using functions that |
203 |
|
|
ensure that we do not try to look past the end of an array (GitHub #53) |
204 |
|
|
|
205 |
|
|
* Fri Feb 20 2015 Paul Howarth <paul@city-fan.org> - 1.6.4-4 |
206 |
|
|
- Databases now unbundled to the GeoIP-GeoLite-data package |
207 |
|
|
- Drop long-unused perl helper scripts |
208 |
|
|
- Add explicit pkgconfig dependency for EL-5 build |
209 |
|
|
- Drop timestamp hack for configure, no longer needed |
210 |
|
|
|
211 |
|
|
* Tue Feb 10 2015 Paul Howarth <paul@city-fan.org> - 1.6.4-3 |
212 |
|
|
- Sub-package the data; going forward, this would be better as a separate |
213 |
|
|
package, since it has separate upstream releases than the library |
214 |
|
|
|
215 |
|
|
* Fri Feb 6 2015 Paul Howarth <paul@city-fan.org> - 1.6.4-2 |
216 |
|
|
- Only require geoipupdate prior to F-22, for back-compatibility |
217 |
|
|
- Use %%license where possible |
218 |
|
|
- GeoIP-devel provides geoip-devel as well as obsoleting it |
219 |
|
|
- Update bundled databases |
220 |
|
|
|
221 |
|
|
* Thu Jan 29 2015 Philip Prindeville <philipp@fedoraproject.org> - 1.6.4-1 |
222 |
|
|
- Require geoipupdate per Paul |
223 |
|
|
|
224 |
|
|
* Tue Jan 20 2015 Philip Prindeville <philipp@fedoraproject.org> - 1.6.4-0 |
225 |
|
|
- Version bump to 1.6.4 per bz #1158667 (okay, that bug was for 1.6.3) |
226 |
|
|
- Remove geoipupdate as it will be moving into its own package |
227 |
|
|
|
228 |
|
|
* Fri Aug 15 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-6 |
229 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild |
230 |
|
|
|
231 |
|
|
* Fri Jun 06 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-5 |
232 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild |
233 |
|
|
|
234 |
|
|
* Tue Feb 25 2014 Paul Howarth <paul@city-fan.org> - 1.5.1-4 |
235 |
|
|
- Add %%check, so we can run tests by building using --with tests |
236 |
|
|
- Update databases from upstream |
237 |
|
|
|
238 |
|
|
* Fri Aug 02 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-3 |
239 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild |
240 |
|
|
|
241 |
|
|
* Tue Jun 18 2013 Paul Howarth <paul@city-fan.org> - 1.5.1-2 |
242 |
|
|
- Properly provide all of the GeoLite databases and their IPv6 equivalents, as |
243 |
|
|
per the geoip-geolite package that we're obsoleting/providing |
244 |
|
|
- Provide compatibility symlinks for database files that historically had |
245 |
|
|
different names in GeoIP and geoip-geolite |
246 |
|
|
- Don't distribute unbundled LICENSE files, as per packaging guidelines |
247 |
|
|
- Update license tag to reflect distribution of CC-BY-SA database content |
248 |
|
|
- No longer try to update the databases in %%post |
249 |
|
|
- Maintain timestamps where possible |
250 |
|
|
- Set up GeoIP.dat symlink in package and don't touch it again |
251 |
|
|
- Add update6 package to update the IPv6 databases; have to use wget for this |
252 |
|
|
rather than geoipupdate as the databases are still in beta |
253 |
|
|
|
254 |
|
|
* Wed Jun 12 2013 Philip Prindeville <philipp@fedoraproject.org> - 1.5.1-1 |
255 |
|
|
- Bump to version 1.5.1 |
256 |
|
|
- Fix exit codes for various situations (MaxMind support #129155) |
257 |
|
|
- Use versioned obsoletes/provides for geoip-geolite |
258 |
|
|
- Update UTF8 patch |
259 |
|
|
- Change symlink from GeoIP-initial.dat to GeoLiteCountry.dat if we had a |
260 |
|
|
successful download and now have the latter file. |
261 |
|
|
|
262 |
|
|
* Mon Jun 10 2013 Philip Prindeville <philipp@fedoraproject.org> - 1.5.0-7 |
263 |
|
|
- Annotate conflict with geoip-geolite package (#968074) |
264 |
|
|
|
265 |
|
|
* Mon Jun 10 2013 Paul Howarth <paul@city-fan.org> - 1.5.0-6 |
266 |
|
|
- Update sub-package requires main package for geoipupdate script |
267 |
|
|
|
268 |
|
|
* Sat Jun 8 2013 Paul Howarth <paul@city-fan.org> - 1.5.0-5 |
269 |
|
|
- Make GeoIP.dat -> GeoIP-initial.dat symlink in %%install, not %%post, |
270 |
|
|
and don't %%ghost it |
271 |
|
|
- Run geoipupdate silently in %%post and cron job |
272 |
|
|
- Create empty database files for %%ghost to work with old rpm versions |
273 |
|
|
- Don't try to use noarch subpackages on old rpm versions |
274 |
|
|
- Update %%description to mention database updates |
275 |
|
|
- Drop outdated README.Fedora |
276 |
|
|
|
277 |
|
|
* Sat Jun 08 2013 Philip Prindeville <philipp@fedoraproject.org> - 1.5.0-4 |
278 |
|
|
- Revert ability to replace 3rd-party package |
279 |
|
|
|
280 |
|
|
* Fri Jun 07 2013 Philip Prindeville <philipp@fedoraproject.org> - 1.5.0-3 |
281 |
|
|
- Add attributes for %%ghost files |
282 |
|
|
|
283 |
|
|
* Fri Jun 07 2013 Philip Prindeville <philipp@fedoraproject.org> - 1.5.0-2 |
284 |
|
|
- Make update subpackage be noarch. |
285 |
|
|
|
286 |
|
|
* Fri Jun 07 2013 Philip Prindeville <philipp@fedoraproject.org> - 1.5.0-1 |
287 |
|
|
- Version bump to 1.5.0 |
288 |
|
|
- Have GeoIP.dat be a symlink to the real data, and install the canned |
289 |
|
|
GeoIP.dat as GeoIP-initial.dat |
290 |
|
|
- Change config as per Boris' instructions to use 'lite' databases which are |
291 |
|
|
regularly updated. |
292 |
|
|
- Add pkgconfig (.pc) file into devel subpackage |
293 |
|
|
- Add cron support for refreshing the lite databases and make a separate |
294 |
|
|
subpackage. |
295 |
|
|
|
296 |
|
|
* Sun Mar 24 2013 Paul Howarth <paul@city-fan.org> - 1.4.8-6 |
297 |
|
|
- Fix config.guess and config.sub to add aarch64 support (#925403) |
298 |
|
|
|
299 |
|
|
* Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-5 |
300 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild |
301 |
|
|
|
302 |
|
|
* Mon Oct 22 2012 Paul Howarth <paul@city-fan.org> - 1.4.8-4 |
303 |
|
|
- libGeoIPUpdate and geoipupdate (which is linked against it) are GPL-licensed |
304 |
|
|
rather than LGPL-licensed (#840896) |
305 |
|
|
- Don't package generic INSTALL file (#661625) |
306 |
|
|
- Kill bogus rpaths on x86_64 |
307 |
|
|
- Hardcode library sonames in %%files list to avoid nasty surprises in the |
308 |
|
|
future |
309 |
|
|
- Drop %%defattr, redundant since rpm 4.4 |
310 |
|
|
- Recode docs as UTF-8 |
311 |
|
|
- Don't use macros for commands |
312 |
|
|
- Use tabs |
313 |
|
|
|
314 |
|
|
* Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-3.1 |
315 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild |
316 |
|
|
|
317 |
|
|
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-2.1 |
318 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild |
319 |
|
|
|
320 |
|
|
* Tue Sep 6 2011 Michael Fleming <mfleming+rpm@thatfleminggent.com> - 1.4.8-1.1 |
321 |
|
|
- Remove -ipv6 patch |
322 |
|
|
- Bump to 1.4.8 release |
323 |
|
|
|
324 |
|
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.7-0.2.20090931cvs |
325 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild |
326 |
|
|
|
327 |
|
|
* Mon Aug 31 2009 Matt Domsch <mdomsch@fedoraproject.org> - 1.4.7.0.1.20090931 |
328 |
|
|
- apply CVS HEAD 20090931 which includes IPv6 functions |
329 |
|
|
|
330 |
|
|
* Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.6-2 |
331 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild |
332 |
|
|
|
333 |
|
|
* Sun Mar 08 2009 Michael Fleming <mfleming+rpm@enlartenment.com> - 1.4.6-1 |
334 |
|
|
- Add geoiplookup6 man page |
335 |
|
|
- Update to 1.4.6 |
336 |
|
|
|
337 |
|
|
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.5-3 |
338 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
339 |
|
|
|
340 |
|
|
* Sat Nov 29 2008 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.5-2 |
341 |
|
|
- Update to 1.4.5 |
342 |
|
|
- Fix database URL locations in Perl helper scripts |
343 |
|
|
|
344 |
|
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.4.4-2 |
345 |
|
|
- Autorebuild for GCC 4.3 |
346 |
|
|
|
347 |
|
|
* Mon Jan 28 2008 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.4-1 |
348 |
|
|
- New upstream release. |
349 |
|
|
|
350 |
|
|
* Wed Sep 5 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.3-1 |
351 |
|
|
- New upstream release. |
352 |
|
|
- Fix GeoIPCity fetcher script |
353 |
|
|
- Update License tag |
354 |
|
|
|
355 |
|
|
* Mon Feb 12 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.2-1 |
356 |
|
|
- New upstream release. |
357 |
|
|
|
358 |
|
|
* Mon Jan 8 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.1-2 |
359 |
|
|
- License is actually LGPL now. |
360 |
|
|
|
361 |
|
|
* Sun Jan 7 2007 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.1-1 |
362 |
|
|
- New upstream release |
363 |
|
|
- Add fetch-geoipdata* scripts to pull free databases automatically if |
364 |
|
|
desired (bz #198137) |
365 |
|
|
- README.fedora added to briefly explain above. |
366 |
|
|
|
367 |
|
|
* Mon Nov 27 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.0-4 |
368 |
|
|
- Fix %%install scripts to satisfy newer mock builds |
369 |
|
|
|
370 |
|
|
* Sun Sep 3 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.4.0-3 |
371 |
|
|
- Upstream upgrade |
372 |
|
|
- Added LICENSE.txt file to %%doc, covering GeoIP country/city data license |
373 |
|
|
(bz #198137) |
374 |
|
|
|
375 |
|
|
* Mon May 15 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.17-1 |
376 |
|
|
- New upstream release (minor fixes) |
377 |
|
|
|
378 |
|
|
* Mon May 1 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.16-1 |
379 |
|
|
- New upstream release |
380 |
|
|
- Add INSTALL document to package. |
381 |
|
|
|
382 |
|
|
* Sat Feb 18 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-3 |
383 |
|
|
- Fix Obsoletes/Provides for old "geoip"-convention packages |
384 |
|
|
- Move .so symlinks to -devel where they should be |
385 |
|
|
|
386 |
|
|
* Fri Feb 10 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-2 |
387 |
|
|
- Remamed to match upstream tarball name |
388 |
|
|
- Removed static libraries |
389 |
|
|
- Added symlinks to packages |
390 |
|
|
- Mark config file noreplace |
391 |
|
|
|
392 |
|
|
* Sun Feb 5 2006 Michael Fleming <mfleming+rpm@enlartenment.com> 1.3.14-1 |
393 |
|
|
- Initial review package for Extras |