1 |
slords |
1.1 |
Summary: An interface to MySQL |
2 |
|
|
Name: MySQL-python |
3 |
|
|
Version: 1.2.3 |
4 |
|
|
Release: 0.4.c1%{?dist} |
5 |
|
|
License: GPLv2+ |
6 |
|
|
Group: Development/Libraries |
7 |
|
|
URL: http://sourceforge.net/projects/mysql-python/ |
8 |
|
|
|
9 |
|
|
Source0: http://prdownloads.sourceforge.net/mysql-python/MySQL-python-%{version}c1.tar.gz |
10 |
|
|
Patch1: format-mismatch.patch |
11 |
|
|
Patch2: escape-fix.patch |
12 |
|
|
|
13 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root |
14 |
|
|
BuildRequires: python-devel python-setuptools |
15 |
|
|
BuildRequires: mysql-devel zlib-devel |
16 |
|
|
# is this still needed? |
17 |
|
|
# Requires: mx |
18 |
|
|
|
19 |
|
|
%description |
20 |
|
|
Python interface to MySQL |
21 |
|
|
|
22 |
|
|
MySQLdb is an interface to the popular MySQL database server for Python. |
23 |
|
|
The design goals are: |
24 |
|
|
|
25 |
|
|
- Compliance with Python database API version 2.0 |
26 |
|
|
- Thread-safety |
27 |
|
|
- Thread-friendliness (threads will not block each other) |
28 |
|
|
- Compatibility with MySQL 3.23 and up |
29 |
|
|
|
30 |
|
|
This module should be mostly compatible with an older interface |
31 |
|
|
written by Joe Skinner and others. However, the older version is |
32 |
|
|
a) not thread-friendly, b) written for MySQL 3.21, c) apparently |
33 |
|
|
not actively maintained. No code from that version is used in MySQLdb. |
34 |
|
|
|
35 |
|
|
%prep |
36 |
|
|
%setup -q -n %{name}-%{version}c1 |
37 |
|
|
|
38 |
|
|
%patch1 -p1 |
39 |
|
|
%patch2 -p1 |
40 |
|
|
|
41 |
|
|
%build |
42 |
|
|
rm -f doc/*~ |
43 |
|
|
export libdirname=%{_lib} |
44 |
|
|
CFLAGS="$RPM_OPT_FLAGS" python setup.py build |
45 |
|
|
|
46 |
|
|
%install |
47 |
|
|
rm -rf $RPM_BUILD_ROOT |
48 |
|
|
|
49 |
|
|
export libdirname=%{_lib} |
50 |
|
|
python setup.py install --root=$RPM_BUILD_ROOT --record=INSTALLED_FILES |
51 |
|
|
|
52 |
|
|
%clean |
53 |
|
|
rm -rf $RPM_BUILD_ROOT |
54 |
|
|
|
55 |
|
|
%files -f INSTALLED_FILES |
56 |
|
|
%defattr(-,root,root) |
57 |
|
|
%doc README GPL doc/* |
58 |
|
|
%dir %{_libdir}/python?.?/site-packages/MySQLdb |
59 |
|
|
%{_libdir}/python?.?/site-packages/MySQLdb/*.pyo |
60 |
|
|
%{_libdir}/python?.?/site-packages/MySQLdb/constants/*.pyo |
61 |
|
|
%{_libdir}/python?.?/site-packages/*.pyo |
62 |
|
|
%dir /usr/%{_lib}/python?.?/site-packages/MySQLdb/constants |
63 |
|
|
|
64 |
|
|
%changelog |
65 |
|
|
* Mon Nov 23 2009 Tom Lane <tgl@redhat.com> 1.2.3-0.4.c1 |
66 |
|
|
- Fix format mismatch in _mysql_ConnectionObject_kill |
67 |
|
|
Resolves: #538234 |
68 |
|
|
|
69 |
|
|
* Sun Jun 28 2009 Tom Lane <tgl@redhat.com> 1.2.3-0.1.c1 |
70 |
|
|
- Update to release candidate 1.2.3c1 for better mysql 5.1 and python 2.6 |
71 |
|
|
compatibility |
72 |
|
|
Resolves: #505611 |
73 |
|
|
- Use python-setuptools instead of distutils, stop using old setup.py |
74 |
|
|
Resolves: #467510 |
75 |
|
|
- Remove unnecessary manual Requires: specifications |
76 |
|
|
Resolves: #507750 |
77 |
|
|
|
78 |
|
|
* Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-10 |
79 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
80 |
|
|
|
81 |
|
|
* Thu Jan 22 2009 Tom Lane <tgl@redhat.com> 1.2.2-9 |
82 |
|
|
- Rebuild for mysql 5.1 |
83 |
|
|
|
84 |
|
|
* Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2.2-8 |
85 |
|
|
- Rebuild for Python 2.6 |
86 |
|
|
|
87 |
|
|
* Thu Jun 19 2008 Tom Lane <tgl@redhat.com> 1.2.2-7 |
88 |
|
|
- Fix broken escape() method |
89 |
|
|
Resolves: #331021 |
90 |
|
|
|
91 |
|
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-6 |
92 |
|
|
- Autorebuild for GCC 4.3 |
93 |
|
|
|
94 |
|
|
* Wed Dec 5 2007 Tom Lane <tgl@redhat.com> 1.2.2-5 |
95 |
|
|
- Rebuild for new openssl |
96 |
|
|
|
97 |
|
|
* Thu Aug 2 2007 Tom Lane <tgl@redhat.com> 1.2.2-4 |
98 |
|
|
- Update License tag to match code. |
99 |
|
|
|
100 |
|
|
* Tue Jul 3 2007 Tom Lane <tgl@redhat.com> 1.2.2-3 |
101 |
|
|
- Ooops, previous fix for quoting bug was wrong, because it converted the |
102 |
|
|
version_info tuple to a string in Python's eyes |
103 |
|
|
Resolves: #246366 |
104 |
|
|
|
105 |
|
|
* Tue Jun 12 2007 Tom Lane <tgl@redhat.com> 1.2.2-2 |
106 |
|
|
- Fix quoting bug in use of older setup.py: need to quote version_info now |
107 |
|
|
Resolves: #243877 |
108 |
|
|
|
109 |
|
|
* Fri Apr 20 2007 Tom Lane <tgl@redhat.com> 1.2.2-1 |
110 |
|
|
- Update to 1.2.2, but not 1.2.2 setup.py (since we don't ship setuptools yet) |
111 |
|
|
|
112 |
|
|
* Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 1.2.1_p2-2 |
113 |
|
|
- rebuild for python 2.5 |
114 |
|
|
|
115 |
|
|
* Wed Dec 6 2006 Tom Lane <tgl@redhat.com> 1.2.1_p2-1 |
116 |
|
|
- Update to 1.2.1_p2 |
117 |
|
|
|
118 |
|
|
* Fri Jul 21 2006 Tom Lane <tgl@redhat.com> 1.2.1-1 |
119 |
|
|
- Update to 1.2.1 |
120 |
|
|
- Remove hardwired python version number in favor of asking Python |
121 |
|
|
|
122 |
|
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2.2.1 |
123 |
|
|
- rebuild |
124 |
|
|
|
125 |
|
|
* Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2.2 |
126 |
|
|
- rebump for build order issues during double-long bump |
127 |
|
|
|
128 |
|
|
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2.1 |
129 |
|
|
- bump again for double-long bug on ppc(64) |
130 |
|
|
|
131 |
|
|
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2 |
132 |
|
|
- rebuilt for new gcc4.1 snapshot and glibc changes |
133 |
|
|
|
134 |
|
|
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com> |
135 |
|
|
- rebuilt |
136 |
|
|
|
137 |
|
|
* Wed Nov 9 2005 Tom Lane <tgl@redhat.com> 1.2.0-3 |
138 |
|
|
- Rebuild due to mysql 5.0 update and openssl library update. |
139 |
|
|
|
140 |
|
|
* Wed Aug 03 2005 Karsten Hopp <karsten@redhat.de> 1.2.0-2 |
141 |
|
|
- package all python files. INSTALLED_FILES doesn't contain files created |
142 |
|
|
by the brp-python-bytecompile script |
143 |
|
|
|
144 |
|
|
* Thu Apr 21 2005 Tom Lane <tgl@redhat.com> 1.2.0-1 |
145 |
|
|
- Update to 1.2.0, per bug #155341 |
146 |
|
|
- Link against mysql 4.x not 3.x, per bug #150828 |
147 |
|
|
|
148 |
|
|
* Sun Mar 6 2005 Tom Lane <tgl@redhat.com> 1.0.0-3 |
149 |
|
|
- Rebuild with gcc4. |
150 |
|
|
|
151 |
|
|
* Thu Nov 11 2004 Tom Lane <tgl@redhat.com> 1.0.0-2 |
152 |
|
|
- bring us to python 2.4 |
153 |
|
|
|
154 |
|
|
* Thu Nov 11 2004 Tom Lane <tgl@redhat.com> 1.0.0-1 |
155 |
|
|
- update to 1.0.0; rebuild against mysqlclient10 |
156 |
|
|
|
157 |
|
|
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> |
158 |
|
|
- rebuilt |
159 |
|
|
|
160 |
|
|
* Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com> |
161 |
|
|
- rebuilt |
162 |
|
|
|
163 |
|
|
* Fri Feb 20 2004 Tom Lane <tgl@redhat.com> |
164 |
|
|
- reinstate (and update) patch for /usr/lib64 compatibility |
165 |
|
|
- rebuilt |
166 |
|
|
|
167 |
|
|
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> |
168 |
|
|
- rebuilt |
169 |
|
|
|
170 |
|
|
* Tue Nov 25 2003 Patrick Macdonald <patrickm@redhat.com> 0.9.2-1 |
171 |
|
|
- update to 0.9.2 |
172 |
|
|
- remove patches (no longer applicable) |
173 |
|
|
|
174 |
|
|
* Sat Nov 15 2003 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.1-10 |
175 |
|
|
- bring us to python 2.3 |
176 |
|
|
|
177 |
|
|
* Thu Jul 03 2003 Patrick Macdonald <patrickm@redhat.com> 0.9.1-9 |
178 |
|
|
- rebuilt |
179 |
|
|
|
180 |
|
|
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> 0.9.1-8 |
181 |
|
|
- rebuilt |
182 |
|
|
|
183 |
|
|
* Tue Mar 04 2003 Patrick Macdonald <patrickm@redhat.com> 0.9.1-7 |
184 |
|
|
- explicitly define the constants directory in case a more |
185 |
|
|
restrictive umask is encountered (#74019) |
186 |
|
|
|
187 |
|
|
* Wed Jan 22 2003 Tim Powers <timp@redhat.com> |
188 |
|
|
- rebuilt |
189 |
|
|
|
190 |
|
|
* Wed Dec 11 2002 Tim Powers <timp@redhat.com> 0.9.1-5 |
191 |
|
|
- lib64'ize |
192 |
|
|
|
193 |
|
|
* Fri Jun 21 2002 Tim Powers <timp@redhat.com> |
194 |
|
|
- automated rebuild |
195 |
|
|
|
196 |
|
|
* Thu May 23 2002 Tim Powers <timp@redhat.com> |
197 |
|
|
- automated rebuild |
198 |
|
|
|
199 |
|
|
* Mon May 13 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.9.1-2 |
200 |
|
|
- Build for newer python |
201 |
|
|
|
202 |
|
|
* Wed Mar 13 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.9.1-1 |
203 |
|
|
- 0.9.1 |
204 |
|
|
|
205 |
|
|
* Tue Feb 26 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.9.0-6 |
206 |
|
|
- Rebuild |
207 |
|
|
|
208 |
|
|
* Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 0.9.0-5 |
209 |
|
|
- Change python conflicts to requires |
210 |
|
|
- Use pybasever/pynextver macros. |
211 |
|
|
|
212 |
|
|
* Wed Jan 09 2002 Tim Powers <timp@redhat.com> |
213 |
|
|
- automated rebuild |
214 |
|
|
|
215 |
|
|
* Fri Sep 14 2001 Trond Eivind Glomsrd <teg@redhat.com> 0.9.0-3 |
216 |
|
|
- Build for Python 2.2 |
217 |
|
|
|
218 |
|
|
* Mon Jul 23 2001 Trond Eivind Glomsrd <teg@redhat.com> |
219 |
|
|
- Add zlib-devel to buildrequires (#49788) |
220 |
|
|
|
221 |
|
|
* Tue Jun 19 2001 Trond Eivind Glomsrd <teg@redhat.com> |
222 |
|
|
- Initial build |