/[smecontribs]/rpms/MySQL-python/contribs8/MySQL-python.spec
ViewVC logotype

Annotation of /rpms/MySQL-python/contribs8/MySQL-python.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Thu Feb 25 16:21:21 2010 UTC (14 years, 2 months ago) by slords
Branch: MAIN
CVS Tags: HEAD
Changes since 1.1: +4 -0 lines
Cleanup

1 slords 1.2 # $Id$
2     # Authority: slords
3     # Name: Shad L. Lords
4    
5 slords 1.1 Summary: An interface to MySQL
6     Name: MySQL-python
7     Version: 1.2.3
8     Release: 0.4.c1%{?dist}
9     License: GPLv2+
10     Group: Development/Libraries
11     URL: http://sourceforge.net/projects/mysql-python/
12    
13     Source0: http://prdownloads.sourceforge.net/mysql-python/MySQL-python-%{version}c1.tar.gz
14     Patch1: format-mismatch.patch
15     Patch2: escape-fix.patch
16    
17     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18     BuildRequires: python-devel python-setuptools
19     BuildRequires: mysql-devel zlib-devel
20     # is this still needed?
21     # Requires: mx
22    
23     %description
24     Python interface to MySQL
25    
26     MySQLdb is an interface to the popular MySQL database server for Python.
27     The design goals are:
28    
29     - Compliance with Python database API version 2.0
30     - Thread-safety
31     - Thread-friendliness (threads will not block each other)
32     - Compatibility with MySQL 3.23 and up
33    
34     This module should be mostly compatible with an older interface
35     written by Joe Skinner and others. However, the older version is
36     a) not thread-friendly, b) written for MySQL 3.21, c) apparently
37     not actively maintained. No code from that version is used in MySQLdb.
38    
39     %prep
40     %setup -q -n %{name}-%{version}c1
41    
42     %patch1 -p1
43     %patch2 -p1
44    
45     %build
46     rm -f doc/*~
47     export libdirname=%{_lib}
48     CFLAGS="$RPM_OPT_FLAGS" python setup.py build
49    
50     %install
51     rm -rf $RPM_BUILD_ROOT
52    
53     export libdirname=%{_lib}
54     python setup.py install --root=$RPM_BUILD_ROOT --record=INSTALLED_FILES
55    
56     %clean
57     rm -rf $RPM_BUILD_ROOT
58    
59     %files -f INSTALLED_FILES
60     %defattr(-,root,root)
61     %doc README GPL doc/*
62     %dir %{_libdir}/python?.?/site-packages/MySQLdb
63     %{_libdir}/python?.?/site-packages/MySQLdb/*.pyo
64     %{_libdir}/python?.?/site-packages/MySQLdb/constants/*.pyo
65     %{_libdir}/python?.?/site-packages/*.pyo
66     %dir /usr/%{_lib}/python?.?/site-packages/MySQLdb/constants
67    
68     %changelog
69     * Mon Nov 23 2009 Tom Lane <tgl@redhat.com> 1.2.3-0.4.c1
70     - Fix format mismatch in _mysql_ConnectionObject_kill
71     Resolves: #538234
72    
73     * Sun Jun 28 2009 Tom Lane <tgl@redhat.com> 1.2.3-0.1.c1
74     - Update to release candidate 1.2.3c1 for better mysql 5.1 and python 2.6
75     compatibility
76     Resolves: #505611
77     - Use python-setuptools instead of distutils, stop using old setup.py
78     Resolves: #467510
79     - Remove unnecessary manual Requires: specifications
80     Resolves: #507750
81    
82     * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.2-10
83     - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
84    
85     * Thu Jan 22 2009 Tom Lane <tgl@redhat.com> 1.2.2-9
86     - Rebuild for mysql 5.1
87    
88     * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.2.2-8
89     - Rebuild for Python 2.6
90    
91     * Thu Jun 19 2008 Tom Lane <tgl@redhat.com> 1.2.2-7
92     - Fix broken escape() method
93     Resolves: #331021
94    
95     * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-6
96     - Autorebuild for GCC 4.3
97    
98     * Wed Dec 5 2007 Tom Lane <tgl@redhat.com> 1.2.2-5
99     - Rebuild for new openssl
100    
101     * Thu Aug 2 2007 Tom Lane <tgl@redhat.com> 1.2.2-4
102     - Update License tag to match code.
103    
104     * Tue Jul 3 2007 Tom Lane <tgl@redhat.com> 1.2.2-3
105     - Ooops, previous fix for quoting bug was wrong, because it converted the
106     version_info tuple to a string in Python's eyes
107     Resolves: #246366
108    
109     * Tue Jun 12 2007 Tom Lane <tgl@redhat.com> 1.2.2-2
110     - Fix quoting bug in use of older setup.py: need to quote version_info now
111     Resolves: #243877
112    
113     * Fri Apr 20 2007 Tom Lane <tgl@redhat.com> 1.2.2-1
114     - Update to 1.2.2, but not 1.2.2 setup.py (since we don't ship setuptools yet)
115    
116     * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 1.2.1_p2-2
117     - rebuild for python 2.5
118    
119     * Wed Dec 6 2006 Tom Lane <tgl@redhat.com> 1.2.1_p2-1
120     - Update to 1.2.1_p2
121    
122     * Fri Jul 21 2006 Tom Lane <tgl@redhat.com> 1.2.1-1
123     - Update to 1.2.1
124     - Remove hardwired python version number in favor of asking Python
125    
126     * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2.2.1
127     - rebuild
128    
129     * Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2.2
130     - rebump for build order issues during double-long bump
131    
132     * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2.1
133     - bump again for double-long bug on ppc(64)
134    
135     * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2.0-3.2
136     - rebuilt for new gcc4.1 snapshot and glibc changes
137    
138     * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
139     - rebuilt
140    
141     * Wed Nov 9 2005 Tom Lane <tgl@redhat.com> 1.2.0-3
142     - Rebuild due to mysql 5.0 update and openssl library update.
143    
144     * Wed Aug 03 2005 Karsten Hopp <karsten@redhat.de> 1.2.0-2
145     - package all python files. INSTALLED_FILES doesn't contain files created
146     by the brp-python-bytecompile script
147    
148     * Thu Apr 21 2005 Tom Lane <tgl@redhat.com> 1.2.0-1
149     - Update to 1.2.0, per bug #155341
150     - Link against mysql 4.x not 3.x, per bug #150828
151    
152     * Sun Mar 6 2005 Tom Lane <tgl@redhat.com> 1.0.0-3
153     - Rebuild with gcc4.
154    
155     * Thu Nov 11 2004 Tom Lane <tgl@redhat.com> 1.0.0-2
156     - bring us to python 2.4
157    
158     * Thu Nov 11 2004 Tom Lane <tgl@redhat.com> 1.0.0-1
159     - update to 1.0.0; rebuild against mysqlclient10
160    
161     * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
162     - rebuilt
163    
164     * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
165     - rebuilt
166    
167     * Fri Feb 20 2004 Tom Lane <tgl@redhat.com>
168     - reinstate (and update) patch for /usr/lib64 compatibility
169     - rebuilt
170    
171     * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
172     - rebuilt
173    
174     * Tue Nov 25 2003 Patrick Macdonald <patrickm@redhat.com> 0.9.2-1
175     - update to 0.9.2
176     - remove patches (no longer applicable)
177    
178     * Sat Nov 15 2003 Tom "spot" Callaway <tcallawa@redhat.com> 0.9.1-10
179     - bring us to python 2.3
180    
181     * Thu Jul 03 2003 Patrick Macdonald <patrickm@redhat.com> 0.9.1-9
182     - rebuilt
183    
184     * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com> 0.9.1-8
185     - rebuilt
186    
187     * Tue Mar 04 2003 Patrick Macdonald <patrickm@redhat.com> 0.9.1-7
188     - explicitly define the constants directory in case a more
189     restrictive umask is encountered (#74019)
190    
191     * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
192     - rebuilt
193    
194     * Wed Dec 11 2002 Tim Powers <timp@redhat.com> 0.9.1-5
195     - lib64'ize
196    
197     * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
198     - automated rebuild
199    
200     * Thu May 23 2002 Tim Powers <timp@redhat.com>
201     - automated rebuild
202    
203     * Mon May 13 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.9.1-2
204     - Build for newer python
205    
206     * Wed Mar 13 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.9.1-1
207     - 0.9.1
208    
209     * Tue Feb 26 2002 Trond Eivind Glomsrd <teg@redhat.com> 0.9.0-6
210     - Rebuild
211    
212     * Thu Jan 31 2002 Elliot Lee <sopwith@redhat.com> 0.9.0-5
213     - Change python conflicts to requires
214     - Use pybasever/pynextver macros.
215    
216     * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
217     - automated rebuild
218    
219     * Fri Sep 14 2001 Trond Eivind Glomsrd <teg@redhat.com> 0.9.0-3
220     - Build for Python 2.2
221    
222     * Mon Jul 23 2001 Trond Eivind Glomsrd <teg@redhat.com>
223     - Add zlib-devel to buildrequires (#49788)
224    
225     * Tue Jun 19 2001 Trond Eivind Glomsrd <teg@redhat.com>
226     - Initial build

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed