1 |
# $Id: pylucene.spec,v 1.3 2008/04/02 15:22:03 slords Exp $ |
2 |
# Authority: slords |
3 |
# Name: Shad L. Lords |
4 |
|
5 |
|
6 |
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")} |
7 |
|
8 |
%define rev 338 |
9 |
|
10 |
# How to fetch the sources from svn: |
11 |
# |
12 |
# svn checkout --revision=%{rev} http://svn.osafoundation.org/pylucene/trunk |
13 |
# svn export trunk PyLucene-svn%{rev} |
14 |
# tar -czf PyLucene-svn%{rev}.tar.gz PyLucene-svn%{rev} |
15 |
# rm -rf trunk PyLucene-svn%{rev} |
16 |
# |
17 |
# svn checkout --revision=549438 http://svn.apache.org/repos/asf/lucene/java/trunk |
18 |
# svn export trunk lucene-java-2.2.0-549438 |
19 |
# tar -czf lucene-java-2.2.0-549438.tar.gz lucene-java-2.2.0-549438 |
20 |
# rm -rf trunk lucene-java-2.2.0-549438 |
21 |
|
22 |
Name: PyLucene |
23 |
Version: 2.2.0 |
24 |
Release: 2.svn%{rev}%{?dist} |
25 |
Summary: Python search engine library |
26 |
|
27 |
Group: Development/Languages |
28 |
License: MIT license |
29 |
URL: http://pylucene.osafoundation.org |
30 |
Source0: %{name}-svn%{rev}.tar.gz |
31 |
Source1: lucene-java-2.2.0-549438.tar.gz |
32 |
Patch0: pylucene_dev-config.patch |
33 |
|
34 |
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
35 |
BuildRequires: ant python-devel |
36 |
|
37 |
%description |
38 |
PyLucene is a GCJ-compiled version of Java Lucene integrated with Python. Its |
39 |
goal is to allow you to use Lucene's text indexing and searching capabilities |
40 |
from Python. It is designed to be API compatible with the latest version of |
41 |
Java Lucene. |
42 |
|
43 |
%package docs |
44 |
Summary: PyLucene documentation |
45 |
Group: Documentation |
46 |
|
47 |
%description docs |
48 |
PyLucene is a GCJ-compiled version of Java Lucene integrated with Python. Its |
49 |
goal is to allow you to use Lucene's text indexing and searching capabilities |
50 |
from Python. |
51 |
|
52 |
This package contains the documentation and samples for PyLucene. |
53 |
|
54 |
|
55 |
%prep |
56 |
# PyLucene does not use autoconf, so we need a custom mechanism to tell the |
57 |
# Makefile if it should use 'lib' oder 'lib64'. |
58 |
export LIBDIR_NAME=`echo %{_libdir} | sed -e "s/^.*\/\(lib6\?4\?\).*$/\1/"` |
59 |
%setup -q -n %{name}-svn%{rev} |
60 |
# -D Do not delete the directory before unpacking. |
61 |
# -a # will untar Source# after cd'ing into the directory. |
62 |
%setup -D -a 1 -n %{name}-svn%{rev} |
63 |
%patch0 |
64 |
|
65 |
%build |
66 |
export LIBDIR_NAME=`echo %{_libdir} | sed -e "s/^.*\/\(lib6\?4\?\).*$/\1/"` |
67 |
make |
68 |
|
69 |
|
70 |
%install |
71 |
rm -rf $RPM_BUILD_ROOT |
72 |
export LIBDIR_NAME=`echo %{_libdir} | sed -e "s/^.*\/\(lib6\?4\?\).*$/\1/"` |
73 |
make install DESTDIR=%{buildroot} |
74 |
|
75 |
%clean |
76 |
rm -rf $RPM_BUILD_ROOT |
77 |
|
78 |
%files |
79 |
%defattr(-,root,root,-) |
80 |
%doc CHANGES LICENSE README |
81 |
# For arch-specific packages: sitearch |
82 |
%{python_sitearch}/* |
83 |
|
84 |
%files docs |
85 |
%doc samples |
86 |
|
87 |
%changelog |
88 |
* Sat Sep 22 2007 Felix Schwarz <felix.schwarz@web.de> - 2.2.0-2.svn338 |
89 |
- (build) requirements corrected |
90 |
- package will built correctly on i386 and x86_64 |
91 |
|
92 |
* Fri Sep 21 2007 Felix Schwarz <felix.schwarz@web.de> - 2.2.0-1.svn338 |
93 |
- switched to latest trunk version (r338) because stable version does not work |
94 |
with gcj 4.1 |
95 |
|
96 |
* Thu Sep 20 2007 Felix Schwarz <felix.schwarz@web.de> - 2.2.0-1.1 |
97 |
- initial spec file creation |
98 |
|