1 |
jpp |
1.1 |
%global commit e694813431720d9fe7ba7b0adc88194d022f4bf5 |
2 |
|
|
%global shortcommit %(c=%{commit}; echo ${c:0:7}) |
3 |
|
|
%global snapshotdate 20180806 |
4 |
|
|
Name: SoapySDR |
5 |
|
|
Version: 0.6.1 |
6 |
|
|
Release: 2.%{snapshotdate}git%{shortcommit}%{?dist} |
7 |
|
|
Summary: A Vendor Neutral and Platform Independent SDR Support Library |
8 |
|
|
|
9 |
|
|
License: Boost |
10 |
|
|
URL: https://github.com/pothosware/%{name} |
11 |
|
|
Source0: https://github.com/pothosware/%{name}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz |
12 |
|
|
|
13 |
|
|
BuildRequires: cmake gcc-c++ swig doxygen |
14 |
|
|
BuildRequires: python2-devel python2-numpy |
15 |
|
|
BuildRequires: python3-devel python3-numpy |
16 |
|
|
|
17 |
|
|
%description |
18 |
|
|
SoapySDR is an open-source generalized C/C++ API and runtime library |
19 |
|
|
for interfacing with Software-Defined Radio (SDR) devices. |
20 |
|
|
|
21 |
|
|
%package -n python2-%{name} |
22 |
|
|
Summary: Python2 Bindings for SoapySDR |
23 |
|
|
%{?python_provide:%python_provide python2-%{name}} |
24 |
|
|
|
25 |
|
|
%description -n python2-%{name} |
26 |
|
|
SoapySDR is an open-source generalized C/C++ API and runtime library |
27 |
|
|
for interfacing with Software-Defined Radio (SDR) devices. |
28 |
|
|
|
29 |
|
|
%package -n python3-%{name} |
30 |
|
|
Summary: Python3 Bindings for SoapySDR |
31 |
|
|
%{?python_provide:%python_provide python3-%{name}} |
32 |
|
|
|
33 |
|
|
%description -n python3-%{name} |
34 |
|
|
SoapySDR is an open-source generalized C/C++ API and runtime library |
35 |
|
|
for interfacing with Software-Defined Radio (SDR) devices. |
36 |
|
|
|
37 |
|
|
%package -n %{name}-devel |
38 |
|
|
Summary: Development Files for SoapySDR |
39 |
|
|
Requires: %{name}%{?_isa} = %{version}-%{release} |
40 |
|
|
|
41 |
|
|
%description -n %{name}-devel |
42 |
|
|
SoapySDR is an open-source generalized C/C++ API and runtime library |
43 |
|
|
for interfacing with Software-Defined Radio (SDR) devices. |
44 |
|
|
|
45 |
|
|
%package -n %{name}-doc |
46 |
|
|
Summary: Development Files for SoapySDR |
47 |
|
|
BuildArch: noarch |
48 |
|
|
|
49 |
|
|
%description -n %{name}-doc |
50 |
|
|
SoapySDR is an open-source generalized C/C++ API and runtime library |
51 |
|
|
for interfacing with Software-Defined Radio (SDR) devices. This package includes |
52 |
|
|
library header file documentation. |
53 |
|
|
|
54 |
|
|
|
55 |
|
|
%prep |
56 |
|
|
%autosetup -n %{name}-%{commit} |
57 |
|
|
|
58 |
|
|
%build |
59 |
|
|
export Python_ADDITIONAL_VERSIONS="%{python2_version} %{python3_version}" |
60 |
|
|
%cmake . -DUSE_PYTHON_CONFIG=ON -DPYTHON_EXECUTABLE=%{__python2} -DPYTHON3_EXECUTABLE=%{__python3} |
61 |
|
|
%make_build |
62 |
|
|
|
63 |
|
|
|
64 |
|
|
%install |
65 |
|
|
%make_install |
66 |
|
|
mkdir -p $RPM_BUILD_ROOT/%{_libdir}/%{name}/modules0.7 |
67 |
|
|
|
68 |
|
|
%check |
69 |
|
|
ctest -V %{?_smp_mflags} |
70 |
|
|
|
71 |
|
|
%ldconfig_scriptlets |
72 |
|
|
%files |
73 |
|
|
%license LICENSE_1_0.txt |
74 |
|
|
%{_bindir}/SoapySDRUtil |
75 |
|
|
%{_libdir}/libSoapySDR.so.0.7.0 |
76 |
|
|
%{_libdir}/libSoapySDR.so.0.7 |
77 |
|
|
%{_mandir}/man1/* |
78 |
|
|
%doc README.md |
79 |
|
|
# for hardware support modules |
80 |
|
|
%dir %{_libdir}/%{name} |
81 |
|
|
%dir %{_libdir}/%{name}/modules0.7 |
82 |
|
|
|
83 |
|
|
%files -n python2-%{name} |
84 |
|
|
%license LICENSE_1_0.txt |
85 |
|
|
%{python2_sitearch}/SoapySDR.py* |
86 |
|
|
%{python2_sitearch}/_SoapySDR.so |
87 |
|
|
|
88 |
|
|
%files -n python3-%{name} |
89 |
|
|
%license LICENSE_1_0.txt |
90 |
|
|
%{python3_sitearch}/SoapySDR.py |
91 |
|
|
%{python3_sitearch}/_SoapySDR.so |
92 |
|
|
%{python3_sitearch}/__pycache__/SoapySDR.cpython-*.opt-1.pyc |
93 |
|
|
%{python3_sitearch}/__pycache__/SoapySDR.cpython-*.pyc |
94 |
|
|
|
95 |
|
|
|
96 |
|
|
%files -n %{name}-devel |
97 |
|
|
%{_includedir}/%{name} |
98 |
|
|
%{_libdir}/libSoapySDR.so |
99 |
|
|
%{_libdir}/pkgconfig/* |
100 |
|
|
%dir %{_datadir}/cmake/%{name} |
101 |
|
|
%{_datadir}/cmake/%{name}/* |
102 |
|
|
|
103 |
|
|
%files -n %{name}-doc |
104 |
|
|
%license LICENSE_1_0.txt |
105 |
|
|
%doc docs/html/* |
106 |
|
|
|
107 |
|
|
|
108 |
|
|
|
109 |
|
|
%changelog |
110 |
|
|
* Wed Aug 15 2018 Matt Domsch <matt@domsch.com> 0.6.1-2.20180806gite694813 |
111 |
|
|
- bump release for rebuild |
112 |
|
|
|
113 |
|
|
* Mon Aug 6 2018 Matt Domsch <matt@domsch.com> 0.6.1-1.20180806gite694813 |
114 |
|
|
- initial Fedora packaging |