1 |
jpp |
1.1 |
%global commit e694813431720d9fe7ba7b0adc88194d022f4bf5 |
2 |
|
|
%global shortcommit %(c=%{commit}; echo ${c:0:7}) |
3 |
|
|
%global snapshotdate 20180806 |
4 |
|
|
Name: SoapySDR |
5 |
|
|
Version: 0.6.1 |
6 |
|
|
Release: 2.%{snapshotdate}git%{shortcommit}%{?dist} |
7 |
|
|
Summary: A Vendor Neutral and Platform Independent SDR Support Library |
8 |
|
|
|
9 |
|
|
License: Boost |
10 |
|
|
URL: https://github.com/pothosware/%{name} |
11 |
|
|
Source0: https://github.com/pothosware/%{name}/archive/%{commit}/%{name}-%{shortcommit}.tar.gz |
12 |
|
|
|
13 |
|
|
BuildRequires: cmake gcc-c++ swig doxygen |
14 |
jpp |
1.2 |
BuildRequires: python2-devel python2-numpy |
15 |
|
|
#BuildRequires: python3-devel python3-numpy |
16 |
jpp |
1.1 |
|
17 |
|
|
%description |
18 |
|
|
SoapySDR is an open-source generalized C/C++ API and runtime library |
19 |
|
|
for interfacing with Software-Defined Radio (SDR) devices. |
20 |
|
|
|
21 |
|
|
%package -n python2-%{name} |
22 |
|
|
Summary: Python2 Bindings for SoapySDR |
23 |
jpp |
1.2 |
|
24 |
|
|
# %#{?python_provide:%python_provide python2-%{name}} |
25 |
jpp |
1.1 |
|
26 |
|
|
%description -n python2-%{name} |
27 |
|
|
SoapySDR is an open-source generalized C/C++ API and runtime library |
28 |
|
|
for interfacing with Software-Defined Radio (SDR) devices. |
29 |
|
|
|
30 |
jpp |
1.2 |
#%package -n python3-%{name} |
31 |
|
|
#Summary: Python3 Bindings for SoapySDR |
32 |
|
|
# %#{?python_provide:%python_provide python3-%{name}} |
33 |
|
|
|
34 |
|
|
#%description -n python3-%{name} |
35 |
|
|
#SoapySDR is an open-source generalized C/C++ API and runtime library |
36 |
|
|
#for interfacing with Software-Defined Radio (SDR) devices. |
37 |
jpp |
1.1 |
|
38 |
|
|
%package -n %{name}-devel |
39 |
|
|
Summary: Development Files for SoapySDR |
40 |
|
|
Requires: %{name}%{?_isa} = %{version}-%{release} |
41 |
|
|
|
42 |
|
|
%description -n %{name}-devel |
43 |
|
|
SoapySDR is an open-source generalized C/C++ API and runtime library |
44 |
|
|
for interfacing with Software-Defined Radio (SDR) devices. |
45 |
|
|
|
46 |
|
|
%package -n %{name}-doc |
47 |
|
|
Summary: Development Files for SoapySDR |
48 |
|
|
BuildArch: noarch |
49 |
|
|
|
50 |
|
|
%description -n %{name}-doc |
51 |
|
|
SoapySDR is an open-source generalized C/C++ API and runtime library |
52 |
|
|
for interfacing with Software-Defined Radio (SDR) devices. This package includes |
53 |
|
|
library header file documentation. |
54 |
|
|
|
55 |
|
|
|
56 |
|
|
%prep |
57 |
|
|
%autosetup -n %{name}-%{commit} |
58 |
|
|
|
59 |
|
|
%build |
60 |
jpp |
1.2 |
export Python_ADDITIONAL_VERSIONS="%{python2_version}" |
61 |
|
|
# %{python3_version}" |
62 |
|
|
%cmake . |
63 |
|
|
#-DUSE_PYTHON_CONFIG=ON -DPYTHON_EXECUTABLE=%{__python2} -DBUILD_PYTHON3=FALSE |
64 |
|
|
#-DPYTHON3_EXECUTABLE=%{__python3} |
65 |
jpp |
1.1 |
%make_build |
66 |
|
|
|
67 |
|
|
|
68 |
|
|
%install |
69 |
|
|
%make_install |
70 |
|
|
mkdir -p $RPM_BUILD_ROOT/%{_libdir}/%{name}/modules0.7 |
71 |
|
|
|
72 |
|
|
%check |
73 |
|
|
ctest -V %{?_smp_mflags} |
74 |
|
|
|
75 |
|
|
%ldconfig_scriptlets |
76 |
|
|
%files |
77 |
|
|
%license LICENSE_1_0.txt |
78 |
|
|
%{_bindir}/SoapySDRUtil |
79 |
|
|
%{_libdir}/libSoapySDR.so.0.7.0 |
80 |
|
|
%{_libdir}/libSoapySDR.so.0.7 |
81 |
|
|
%{_mandir}/man1/* |
82 |
|
|
%doc README.md |
83 |
|
|
# for hardware support modules |
84 |
|
|
%dir %{_libdir}/%{name} |
85 |
|
|
%dir %{_libdir}/%{name}/modules0.7 |
86 |
|
|
|
87 |
|
|
%files -n python2-%{name} |
88 |
|
|
%license LICENSE_1_0.txt |
89 |
|
|
%{python2_sitearch}/SoapySDR.py* |
90 |
|
|
%{python2_sitearch}/_SoapySDR.so |
91 |
|
|
|
92 |
jpp |
1.2 |
#%files -n python3-%{name} |
93 |
|
|
#%license LICENSE_1_0.txt |
94 |
|
|
#%{python3_sitearch}/SoapySDR.py |
95 |
|
|
#%{python3_sitearch}/_SoapySDR.so |
96 |
|
|
#%{python3_sitearch}/__pycache__/SoapySDR.cpython-*.opt-1.pyc |
97 |
|
|
#%{python3_sitearch}/__pycache__/SoapySDR.cpython-*.pyc |
98 |
jpp |
1.1 |
|
99 |
|
|
|
100 |
|
|
%files -n %{name}-devel |
101 |
|
|
%{_includedir}/%{name} |
102 |
|
|
%{_libdir}/libSoapySDR.so |
103 |
|
|
%{_libdir}/pkgconfig/* |
104 |
|
|
%dir %{_datadir}/cmake/%{name} |
105 |
|
|
%{_datadir}/cmake/%{name}/* |
106 |
|
|
|
107 |
|
|
%files -n %{name}-doc |
108 |
|
|
%license LICENSE_1_0.txt |
109 |
|
|
%doc docs/html/* |
110 |
|
|
|
111 |
|
|
|
112 |
|
|
|
113 |
|
|
%changelog |
114 |
|
|
* Wed Aug 15 2018 Matt Domsch <matt@domsch.com> 0.6.1-2.20180806gite694813 |
115 |
|
|
- bump release for rebuild |
116 |
|
|
|
117 |
|
|
* Mon Aug 6 2018 Matt Domsch <matt@domsch.com> 0.6.1-1.20180806gite694813 |
118 |
|
|
- initial Fedora packaging |