/[smecontribs]/rpms/alac/contribs9/alac.spec
ViewVC logotype

Annotation of /rpms/alac/contribs9/alac.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Sun Apr 26 02:21:57 2020 UTC (4 years, 1 month ago) by jpp
Branch: MAIN
CVS Tags: alac-0_0+git_20160511-lp151_2_4
Initial import

1 jpp 1.1 #
2     # spec file for package alac
3     #
4     # Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
5     #
6     # All modifications and additions to the file contributed by third parties
7     # remain the property of their copyright owners, unless otherwise agreed
8     # upon. The license for this file, and modifications and additions to the
9     # file, is the same license as for the pristine package itself (unless the
10     # license for the pristine package is not an Open Source License, in which
11     # case the license is the MIT License). An "Open Source License" is a
12     # license that conforms to the Open Source Definition (Version 1.9)
13     # published by the Open Source Initiative.
14    
15     # Please submit bugfixes or comments via http://bugs.opensuse.org/
16     #
17    
18    
19     %define sover 0
20     Name: alac
21     Version: 0.0+git.20160511
22     Release: lp151.2.4
23     Summary: Apple Lossless Audio Codec
24     License: Apache-2.0
25     Group: Productivity/Multimedia/Sound/Editors and Convertors
26     Url: https://macosforge.github.io/alac/
27     Source: %{name}-%{version}.tar.xz
28     Patch1: libalac-makefile.patch
29     Patch2: alac-endian.patch
30     BuildRequires: gcc-c++
31     BuildRequires: pkgconfig
32     BuildRequires: xz
33     BuildRoot: %{_tmppath}/%{name}-%{version}-build
34    
35     %description
36     The Apple Lossless Audio Codec (ALAC) is an audio codec developed by Apple and
37     supported on iPhone, iPad, most iPods, Mac and iTunes. ALAC is a data
38     compression method which reduces the size of audio files with no loss of
39     information. A decoded ALAC stream is bit-for-bit identical to the original
40     uncompressed audio file.
41    
42     This package contains a command-line utility to convert the ALAC format.
43    
44     %package -n lib%{name}%{sover}
45     Summary: Apple Lossless Audio Codec
46     Group: System/Libraries
47    
48     %description -n lib%{name}%{sover}
49     The Apple Lossless Audio Codec (ALAC) is an audio codec developed by Apple and
50     supported on iPhone, iPad, most iPods, Mac and iTunes. ALAC is a data
51     compression method which reduces the size of audio files with no loss of
52     information. A decoded ALAC stream is bit-for-bit identical to the original
53     uncompressed audio file.
54    
55     %package devel
56     Summary: Apple Lossless Audio Codec
57     Group: Development/Libraries/C and C++
58     Requires: lib%{name}%{sover} = %{version}
59     Provides: lib%{name}-devel = %{version}
60     Obsoletes: lib%{name}-devel < %{version}
61    
62     %description devel
63     The Apple Lossless Audio Codec (ALAC) is an audio codec developed by Apple and
64     supported on iPhone, iPad, most iPods, Mac and iTunes. ALAC is a data
65     compression method which reduces the size of audio files with no loss of
66     information. A decoded ALAC stream is bit-for-bit identical to the original
67     uncompressed audio file.
68    
69     %prep
70     %setup -q
71     %patch1
72     %patch2
73    
74     %build
75     for d in codec convert-utility; do
76     make -C "$d" \
77     OPTFLAGS="%{optflags} -fvisibility-inlines-hidden -fno-strict-aliasing -D_GNU_SOURCE" \
78     CC="g++"
79     done
80    
81     %install
82     install -D -p -m 0755 convert-utility/alacconvert \
83     %{buildroot}%{_bindir}/alacconvert
84    
85     install -d %{buildroot}%{_includedir}
86     cp -a codec/*.h %{buildroot}%{_includedir}/
87    
88     install -d %{buildroot}%{_libdir}
89     cp -a codec/libalac.so* %{buildroot}%{_libdir}/
90    
91     %post -n lib%{name}%{sover} -p /sbin/ldconfig
92     %postun -n lib%{name}%{sover} -p /sbin/ldconfig
93    
94     %files
95     %defattr(-,root,root)
96     %doc codec/APPLE_LICENSE.txt LICENSE
97     %{_bindir}/alacconvert
98    
99     %files -n lib%{name}%{sover}
100     %defattr(-,root,root)
101     %doc codec/APPLE_LICENSE.txt LICENSE
102     %{_libdir}/libalac.so.%{sover}*
103    
104     %files devel
105     %defattr(-,root,root)
106     %doc codec/APPLE_LICENSE.txt LICENSE
107     %{_includedir}/*.h
108     %{_libdir}/libalac.so
109    
110     %changelog
111     * Thu Jun 29 2017 tchvatal@suse.com
112     - Fix obvious typo where we had missing %% in provides/obsoletes
113     * Wed Oct 19 2016 mpluskal@suse.com
114     - Update project url
115     - Use _service to fetch sources from git
116     - Update to version 0.0+git.20160511
117     - Refresh patches:
118     * alac-endian.patch
119     * libalac-makefile.patch
120     * Tue Jan 19 2016 jengelh@inai.de
121     - Change the SRPM name to alac (follow apparent upstream project
122     name).
123     * Fri Jan 15 2016 mpluskal@suse.com
124     - Install both license files
125     * Mon Apr 13 2015 mpluskal@suse.com
126     - Remove devel-static package as it has no users
127     * Sun Apr 12 2015 mpluskal@suse.com
128     - Cleanup spec file with spec-cleaner
129     - Update dependencies
130     * Fri Jan 3 2014 crrodriguez@opensuse.org
131     - libalac-makefile.patch update, OPTFLAGS must be used
132     at linking time as well.
133     - alac-endian.patch, fix endian conversion routines
134     * They were inneficient, use optimized versions provided by the OS.
135     * They were wrong, assumes for example that ARM is not little endian
136     and that powerpc is always big endian.
137     - fix cflags so large file support is enabled, GNU_SOURCE is defined,
138     strict aliasing is disabled and C++ inlines get hidden visibility.
139     * Sat Jul 20 2013 zaitor@opensuse.org
140     - Update license to new format, Apache-2.0.
141     * Fri Oct 28 2011 pascal.bleser@opensuse.org
142     - split out libalac.a into libalac-devel-static
143     * Fri Oct 28 2011 pascal.bleser@opensuse.org
144     - initial version (0+r3)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed