1 |
%define release 1 |
2 |
%define version 0.0+git.20160511 |
3 |
|
4 |
# |
5 |
# spec file for package alac |
6 |
# |
7 |
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany. |
8 |
# |
9 |
# All modifications and additions to the file contributed by third parties |
10 |
# remain the property of their copyright owners, unless otherwise agreed |
11 |
# upon. The license for this file, and modifications and additions to the |
12 |
# file, is the same license as for the pristine package itself (unless the |
13 |
# license for the pristine package is not an Open Source License, in which |
14 |
# case the license is the MIT License). An "Open Source License" is a |
15 |
# license that conforms to the Open Source Definition (Version 1.9) |
16 |
# published by the Open Source Initiative. |
17 |
|
18 |
# Please submit bugfixes or comments via http://bugs.opensuse.org/ |
19 |
# |
20 |
|
21 |
|
22 |
%define sover 0 |
23 |
Name: alac |
24 |
Version: %{version} |
25 |
Release: 151.2.4.%{release}%{?dist} |
26 |
Summary: Apple Lossless Audio Codec |
27 |
License: Apache-2.0 |
28 |
Group: Productivity/Multimedia/Sound/Editors and Convertors |
29 |
Url: https://macosforge.github.io/alac/ |
30 |
Source: %{name}-%{version}.tar.xz |
31 |
Patch1: libalac-makefile.patch |
32 |
Patch2: alac-endian.patch |
33 |
BuildRequires: gcc-c++ |
34 |
BuildRequires: pkgconfig |
35 |
BuildRequires: xz |
36 |
BuildRoot: %{_tmppath}/%{name}-%{version}-build |
37 |
|
38 |
%description |
39 |
The Apple Lossless Audio Codec (ALAC) is an audio codec developed by Apple and |
40 |
supported on iPhone, iPad, most iPods, Mac and iTunes. ALAC is a data |
41 |
compression method which reduces the size of audio files with no loss of |
42 |
information. A decoded ALAC stream is bit-for-bit identical to the original |
43 |
uncompressed audio file. |
44 |
|
45 |
This package contains a command-line utility to convert the ALAC format. |
46 |
|
47 |
%package -n lib%{name}%{sover} |
48 |
Summary: Apple Lossless Audio Codec |
49 |
Group: System/Libraries |
50 |
|
51 |
%description -n lib%{name}%{sover} |
52 |
The Apple Lossless Audio Codec (ALAC) is an audio codec developed by Apple and |
53 |
supported on iPhone, iPad, most iPods, Mac and iTunes. ALAC is a data |
54 |
compression method which reduces the size of audio files with no loss of |
55 |
information. A decoded ALAC stream is bit-for-bit identical to the original |
56 |
uncompressed audio file. |
57 |
|
58 |
%package devel |
59 |
Summary: Apple Lossless Audio Codec |
60 |
Group: Development/Libraries/C and C++ |
61 |
Requires: lib%{name}%{sover} = %{version} |
62 |
Provides: lib%{name}-devel = %{version} |
63 |
Obsoletes: lib%{name}-devel < %{version} |
64 |
|
65 |
%description devel |
66 |
The Apple Lossless Audio Codec (ALAC) is an audio codec developed by Apple and |
67 |
supported on iPhone, iPad, most iPods, Mac and iTunes. ALAC is a data |
68 |
compression method which reduces the size of audio files with no loss of |
69 |
information. A decoded ALAC stream is bit-for-bit identical to the original |
70 |
uncompressed audio file. |
71 |
|
72 |
%prep |
73 |
%setup -q |
74 |
%patch1 |
75 |
%patch2 |
76 |
|
77 |
%build |
78 |
for d in codec convert-utility; do |
79 |
make -C "$d" \ |
80 |
OPTFLAGS="%{optflags} -fvisibility-inlines-hidden -fno-strict-aliasing -D_GNU_SOURCE" \ |
81 |
CC="g++" |
82 |
done |
83 |
|
84 |
%install |
85 |
install -D -p -m 0755 convert-utility/alacconvert \ |
86 |
%{buildroot}%{_bindir}/alacconvert |
87 |
|
88 |
install -d %{buildroot}%{_includedir} |
89 |
cp -a codec/*.h %{buildroot}%{_includedir}/ |
90 |
|
91 |
install -d %{buildroot}%{_libdir} |
92 |
cp -a codec/libalac.so* %{buildroot}%{_libdir}/ |
93 |
|
94 |
%post -n lib%{name}%{sover} -p /sbin/ldconfig |
95 |
%postun -n lib%{name}%{sover} -p /sbin/ldconfig |
96 |
|
97 |
%files |
98 |
%defattr(-,root,root) |
99 |
%doc codec/APPLE_LICENSE.txt LICENSE |
100 |
%{_bindir}/alacconvert |
101 |
|
102 |
%files -n lib%{name}%{sover} |
103 |
%defattr(-,root,root) |
104 |
%doc codec/APPLE_LICENSE.txt LICENSE |
105 |
%{_libdir}/libalac.so.%{sover}* |
106 |
|
107 |
%files devel |
108 |
%defattr(-,root,root) |
109 |
%doc codec/APPLE_LICENSE.txt LICENSE |
110 |
%{_includedir}/*.h |
111 |
%{_libdir}/libalac.so |
112 |
|
113 |
%changelog |
114 |
* Sat Apr 25 2020 Jean-Philipe Pialasse <tests@pialasse.com> 0.0+git.20160511-1.sme |
115 |
- first import for SME |
116 |
|
117 |
* Thu Jun 29 2017 tchvatal@suse.com |
118 |
- Fix obvious typo where we had missing %% in provides/obsoletes |
119 |
* Wed Oct 19 2016 mpluskal@suse.com |
120 |
- Update project url |
121 |
- Use _service to fetch sources from git |
122 |
- Update to version 0.0+git.20160511 |
123 |
- Refresh patches: |
124 |
* alac-endian.patch |
125 |
* libalac-makefile.patch |
126 |
* Tue Jan 19 2016 jengelh@inai.de |
127 |
- Change the SRPM name to alac (follow apparent upstream project |
128 |
name). |
129 |
* Fri Jan 15 2016 mpluskal@suse.com |
130 |
- Install both license files |
131 |
* Mon Apr 13 2015 mpluskal@suse.com |
132 |
- Remove devel-static package as it has no users |
133 |
* Sun Apr 12 2015 mpluskal@suse.com |
134 |
- Cleanup spec file with spec-cleaner |
135 |
- Update dependencies |
136 |
* Fri Jan 3 2014 crrodriguez@opensuse.org |
137 |
- libalac-makefile.patch update, OPTFLAGS must be used |
138 |
at linking time as well. |
139 |
- alac-endian.patch, fix endian conversion routines |
140 |
* They were inneficient, use optimized versions provided by the OS. |
141 |
* They were wrong, assumes for example that ARM is not little endian |
142 |
and that powerpc is always big endian. |
143 |
- fix cflags so large file support is enabled, GNU_SOURCE is defined, |
144 |
strict aliasing is disabled and C++ inlines get hidden visibility. |
145 |
* Sat Jul 20 2013 zaitor@opensuse.org |
146 |
- Update license to new format, Apache-2.0. |
147 |
* Fri Oct 28 2011 pascal.bleser@opensuse.org |
148 |
- split out libalac.a into libalac-devel-static |
149 |
* Fri Oct 28 2011 pascal.bleser@opensuse.org |
150 |
- initial version (0+r3) |