/[smecontribs]/rpms/bugzilla/contribs10/bugzilla.spec
ViewVC logotype

Contents of /rpms/bugzilla/contribs10/bugzilla.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (show annotations) (download)
Mon May 23 19:29:52 2022 UTC (2 years, 1 month ago) by jpp
Branch: MAIN
CVS Tags: bugzilla-5_0_6-14_fc36
Initial import

1 %define bzinstallprefix %{_datadir}
2 %define bzdatadir %{_sharedstatedir}/bugzilla
3
4 Summary: Bug tracking system
5 URL: https://www.bugzilla.org/
6 Name: bugzilla
7 Version: 5.0.6
8 Release: 14%{?dist}
9 License: MPLv1.1
10 Source0: https://github.com/bugzilla/bugzilla/archive/release-%{version}.tar.gz
11 Source1: bugzilla-httpd-conf
12 Source2: README.fedora.bugzilla
13 Source3: bugzilla.cron-daily
14 Patch0: bugzilla-rw-paths.patch
15 Patch1: bugzilla-dnf.patch
16 Patch2: bugzilla-1438957-concatenate-assets.patch
17 # https://bug1657496.bmoattachments.org/attachment.cgi?id=9169528
18 Patch3: bugzilla-1855962-non-html-mail.patch
19
20 BuildArch: noarch
21 Requires: patchutils
22 Requires: perl(CGI) >= 3.51
23 Requires: perl(Digest::SHA)
24 Requires: perl(Date::Format) >= 2.23
25 Requires: perl(DateTime) >= 0.75
26 Requires: perl(DateTime::TimeZone) >= 1.64
27 Requires: perl(DBI) >= 1.614
28 Requires: perl(ExtUtils::MM)
29 Requires: perl(Template) >= 2.24
30 Requires: perl(Email::Sender) >= 1.300011
31 Requires: perl(Email::MIME) >= 1.904
32 Requires: perl(URI) >= 1.55
33 Requires: perl(List::MoreUtils) >= 0.32
34 Requires: perl(Math::Random::ISAAC) >= 1.0.1
35 Requires: perl(File::Slurp) >= 9999.13
36 Requires: perl(JSON::XS) >= 2.01
37 Requires: perl(Locale::Language)
38 Requires: webserver
39 Requires: which
40
41 # for building docs
42 BuildRequires: latexmk
43 BuildRequires: make
44 BuildRequires: perl-generators
45 BuildRequires: perl(constant)
46 BuildRequires: perl(Cwd)
47 BuildRequires: perl(Exporter)
48 BuildRequires: perl(File::Basename)
49 BuildRequires: perl(File::Copy::Recursive)
50 BuildRequires: perl(File::Find)
51 BuildRequires: perl(File::Path)
52 BuildRequires: perl(File::Which)
53 BuildRequires: perl(lib)
54 BuildRequires: perl(Memoize)
55 BuildRequires: perl(parent)
56 BuildRequires: perl(Pod::Simple)
57 BuildRequires: perl(strict)
58 BuildRequires: perl(warnings)
59 BuildRequires: python3-sphinx
60 BuildRequires: texlive-collection-latexrecommended
61 BuildRequires: texlive-collection-basic
62 BuildRequires: tex(fncychap.sty)
63 BuildRequires: tex(framed.sty)
64 BuildRequires: tex(multirow.sty)
65 BuildRequires: tex(threeparttable.sty)
66 BuildRequires: tex(titlesec.sty)
67 BuildRequires: tex(wrapfig.sty)
68 %if 0%{?fedora}
69 BuildRequires: tex(capt-of.sty)
70 BuildRequires: tex(eqparbox.sty)
71 BuildRequires: tex(needspace.sty)
72 BuildRequires: tex(tabulary.sty)
73 BuildRequires: tex(upquote.sty)
74 %endif
75
76 %package doc
77 Summary: Bugzilla documentation
78
79 %package doc-build
80 Summary: Tools to generate the Bugzilla documentation
81
82 %package contrib
83 Summary: Bugzilla contributed scripts
84 BuildRequires: python3-devel
85
86 %{?perl_default_filter}
87
88 # Remove private modules from the requires stream
89 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(sanitycheck.cgi\\)$
90
91 # Remove all optional modules from the requires stream
92 # mod_perl modules
93 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Apache2::
94 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(ModPerl::
95 # installation of optional modules
96 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Config\\)$
97 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(CPAN\\)$
98 # authentification modules
99 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Authen::Radius\\)$
100 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Net::LDAP
101 # database modules
102 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(DBD::Oracle\\)$
103 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(DBD::Pg\\)$
104 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(DBI::db\\)$
105 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(DBI::st\\)$
106 # graphical reports and charts
107 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Chart::Lines\\)$
108 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(GD::Graph\\)$
109 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Template::Plugin::GD::Image\\)$
110 # inbound email modules
111 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Email::MIME::Attachment::Stripper\\)$
112 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Email::Reply\\)$
113 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(HTML::FormatText::WithLinks\\)$
114 # automatic charset detection for text attachments
115 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Encode
116 # sniff MIME type of attachments
117 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(File::MimeInfo::Magic\\)$
118 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(IO::Scalar\\)$
119 # mail queueing
120 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(TheSchwartz\\)$
121 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Daemon::Generic\\)$
122 # smtp security
123 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Authen::SASL\\)$
124 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Net::SMTP::SSL\\)$
125 # bug moving modules
126 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(MIME::Parser\\)$
127 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(XML::Twig\\)$
128 # update notifications
129 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(LWP::UserAgent\\)$
130 # use html in product and group descriptions
131 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(HTML::Parser\\)$
132 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(HTML::Scrubber\\)$
133 # memcached support
134 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Cache::Memcached\\)$
135 # documentation
136 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(File::Copy::Recursive\\)$
137 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(File::Which\\)$
138 # xml-rpc and json-rpc modules
139 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(XMLRPC::
140 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(HTTP::Message\\)$
141 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Test::Taint\\)$
142 # extension modules
143 %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Image::Magick\\)$
144
145 # and remove the extensions from the provides stream
146 %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::BmpConvert\\)$
147 %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::Example\\)$
148 %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::Example::Auth::Login\\)$
149 %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::Example::Auth::Verify\\)$
150 %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::Example::Config\\)$
151 %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::Example::WebService\\)$
152 %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::OldBugMove\\)$
153 %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::OldBugMove::Params\\)$
154 %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::Voting\\)$
155
156 %description
157 Bugzilla is a popular bug tracking system used by multiple open source projects
158 It requires a database engine installed - either MySQL, PostgreSQL or Oracle.
159 Without one of these database engines (local or remote), Bugzilla will not work
160 - see the Release Notes for details.
161
162 %description doc
163 Documentation distributed with the Bugzilla bug tracking system
164
165 %description doc-build
166 Tools to generate the documentation distributed with Bugzilla
167
168 %description contrib
169 Contributed scripts and functions for Bugzilla
170
171 %prep
172 %setup -q -n %{name}-release-%{version}
173 %patch0 -p1
174 %patch1 -p1
175 %patch2 -p1
176 %patch3 -p1
177
178 # Deal with changing /usr/local paths here instead of via patches
179 /usr/bin/perl -pi -e 's|/usr/local/bin/python\b|%{__python3}|' contrib/*.py
180 /usr/bin/rm -rf contrib/bugzilla-submit
181
182 grep -rl '/usr/lib/sendmail\b' contrib docs \
183 | xargs /usr/bin/perl -pi -e 's|/usr/lib/sendmail\b|%{_sbindir}/sendmail|'
184
185 %build
186 # Build docs
187 docs/makedocs.pl --with-pdf
188 # Remove the execute bit from files that don't start with #!
189 for file in `find -type f -perm /111`; do
190 if head -1 $file | grep -E -v '^\#!' &>/dev/null; then
191 chmod a-x $file
192 fi
193 done
194 # Ensure shebang shell scripts have executable bit set
195 for file in `find -type f -perm /664`; do
196 if head -1 $file | grep -E '^\#!' &>/dev/null; then
197 chmod a+x $file
198 fi
199 done
200
201 %install
202 mkdir -p %{buildroot}%{bzinstallprefix}/bugzilla
203 # these files are only used for testing Bugzilla code
204 # see https://bugzilla.mozilla.org/show_bug.cgi?id=995209
205 rm Build.PL MANIFEST.SKIP
206 cp -pr * %{buildroot}%{bzinstallprefix}/bugzilla
207 echo "0-59/15 * * * * apache cd %{bzinstallprefix}/bugzilla && env LANG=C %{bzinstallprefix}/bugzilla/whine.pl" > %{buildroot}%{bzinstallprefix}/bugzilla/cron.whine
208 rm -f %{buildroot}%{bzinstallprefix}/bugzilla/README \
209 %{buildroot}%{bzinstallprefix}/bugzilla/docs/TODO \
210 %{buildroot}%{bzinstallprefix}/bugzilla/docs/en/Makefile \
211 %{buildroot}%{bzinstallprefix}/bugzilla/docs/en/make.bat
212 cp %{SOURCE2} ./README.fedora
213 mkdir -p %{buildroot}%{bzdatadir}/assets
214 mkdir -p %{buildroot}%{_sysconfdir}/bugzilla
215 install -m 0644 -D -p %{SOURCE1} %{buildroot}%{_sysconfdir}/httpd/conf.d/bugzilla.conf
216 install -m 0755 -D -p %{SOURCE3} %{buildroot}%{bzinstallprefix}/bugzilla/cron.daily
217 ln -s ../../..%{bzdatadir}/assets %{buildroot}%{bzinstallprefix}/bugzilla/assets
218
219 %post
220 (pushd %{bzinstallprefix}/bugzilla > /dev/null
221 [ -f /etc/bugzilla/localconfig ] || ./checksetup.pl > /dev/null
222 popd > /dev/null)
223
224 %files
225 %defattr(-,root,apache,-)
226 %dir %{bzinstallprefix}/bugzilla
227 %{bzinstallprefix}/bugzilla/LICENSE
228 %{bzinstallprefix}/bugzilla/*.cgi
229 %{bzinstallprefix}/bugzilla/*.json
230 %{bzinstallprefix}/bugzilla/*.pl
231 %{bzinstallprefix}/bugzilla/Bugzilla.pm
232 %{bzinstallprefix}/bugzilla/robots.txt
233 %{bzinstallprefix}/bugzilla/Bugzilla
234 %{bzinstallprefix}/bugzilla/extensions
235 %{bzinstallprefix}/bugzilla/images
236 %{bzinstallprefix}/bugzilla/js
237 %{bzinstallprefix}/bugzilla/lib
238 %{bzinstallprefix}/bugzilla/skins
239 %{bzinstallprefix}/bugzilla/t
240 %{bzinstallprefix}/bugzilla/xt
241 %{bzinstallprefix}/bugzilla/template
242 %{bzinstallprefix}/bugzilla/cron.daily
243 %{bzinstallprefix}/bugzilla/cron.whine
244 %{bzinstallprefix}/bugzilla/contrib/README
245 %{bzinstallprefix}/bugzilla/assets
246 %config(noreplace) %{_sysconfdir}/httpd/conf.d/bugzilla.conf
247 %attr(770,root,apache) %dir %{bzdatadir}
248 %attr(770,root,apache) %dir %{bzdatadir}/assets
249 %attr(750,root,apache) %dir %{_sysconfdir}/bugzilla
250 %defattr(-,root,root,-)
251 %doc README
252 %doc README.fedora
253
254 %files doc
255 %defattr(-,root,apache,-)
256 %{bzinstallprefix}/bugzilla/docs/en/html
257 %{bzinstallprefix}/bugzilla/docs/en/images
258 %{bzinstallprefix}/bugzilla/docs/en/pdf
259 %{bzinstallprefix}/bugzilla/docs/en/txt
260 %{bzinstallprefix}/bugzilla/docs/en/rst
261 %{bzinstallprefix}/bugzilla/docs/style.css
262
263
264 %files doc-build
265 %defattr(-,root,apache,-)
266 %{bzinstallprefix}/bugzilla/docs/makedocs.pl
267 %{bzinstallprefix}/bugzilla/docs/lib
268
269 %files contrib
270 %defattr(-,root,apache,-)
271 %{bzinstallprefix}/bugzilla/contrib/bugzilla-queue.rhel
272 %{bzinstallprefix}/bugzilla/contrib/bugzilla-queue.suse
273 %{bzinstallprefix}/bugzilla/contrib/bzdbcopy.pl
274 %{bzinstallprefix}/bugzilla/contrib/bz_webservice_demo.pl
275 %{bzinstallprefix}/bugzilla/contrib/cmdline
276 %{bzinstallprefix}/bugzilla/contrib/console.pl
277 %{bzinstallprefix}/bugzilla/contrib/convert-workflow.pl
278 %{bzinstallprefix}/bugzilla/contrib/extension-convert.pl
279 %{bzinstallprefix}/bugzilla/contrib/fixperms.pl
280 %{bzinstallprefix}/bugzilla/contrib/jb2bz.py*
281 %{bzinstallprefix}/bugzilla/contrib/merge-users.pl
282 %{bzinstallprefix}/bugzilla/contrib/mysqld-watcher.pl
283 %{bzinstallprefix}/bugzilla/contrib/new-yui.sh
284 %{bzinstallprefix}/bugzilla/contrib/perl-fmt
285 %{bzinstallprefix}/bugzilla/contrib/recode.pl
286 %{bzinstallprefix}/bugzilla/contrib/sendbugmail.pl
287 %{bzinstallprefix}/bugzilla/contrib/sendunsentbugmail.pl
288 %{bzinstallprefix}/bugzilla/contrib/syncLDAP.pl
289 %{bzinstallprefix}/bugzilla/contrib/Bugzilla.pm
290
291 %changelog
292 * Wed Jan 19 2022 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-14
293 - Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
294
295 * Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-13
296 - Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
297
298 * Sun Feb 14 2021 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.6-12
299 - Add make to BuildRequires
300
301 * Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-11
302 - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
303
304 * Mon Oct 19 2020 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.6-10
305 - Replace calls to %%{__perl} with /usr/bin/perl
306 - Remove contrib/bugzilla-submit (no longers works) (#1835451)
307
308 * Tue Sep 29 2020 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.6-9
309 - Remove automagic Python bytecompilation macro
310 - Include upstream patch for text mails (#1855962)
311
312 * Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-8
313 - Second attempt - Rebuilt for
314 https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
315
316 * Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-7
317 - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
318 * Tue Mar 24 2020 Jitka Plesnikova <jplesnik@redhat.com> - 5.0.6-6
319 - Add all perl dependencies needed for build
320
321 * Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-5
322 - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
323
324 * Wed Sep 04 2019 Miro Hrončok <mhroncok@redhat.com> - 5.0.6-4
325 - Drop unused build dependency on Python 2
326
327 * Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-3
328 - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
329
330 * Sun Mar 10 2019 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.6-2
331 - Use %%{__python3} instead of %%{__python2}
332 - Depend on python3-sphinx instead of python2-sphinx
333
334 * Thu Feb 14 2019 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.6-1
335 - Update to 5.0.6
336
337 * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.4-3
338 - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
339
340 * Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.4-2
341 - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
342
343 * Sun Feb 18 2018 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.4-1
344 - Update to 5.0.4
345 - Remove backported File::Slurp patch, no longer needed
346 - use %%{__python2} instead of %%{__python}
347 - Disable the concatenation of assets (#1438957)
348
349 * Wed Feb 07 2018 Iryna Shcherbina <ishcherb@redhat.com> - 5.0.3-10
350 - Update Python 2 dependency declarations to new packaging standards
351 (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
352
353 * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.3-9
354 - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
355
356 * Sun Aug 20 2017 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.3-8
357 - Tighten macro expansion (thanks to ppisar)
358 - Drop Group tag
359 - Use tex(..) BuildRequires where possible
360
361 * Mon Aug 07 2017 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.3-7
362 - Add doc-building requirement to fix FTBS
363 - Add perl(ExtUtils::MM) to the list of required modules
364
365 * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.3-6
366 - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
367
368 * Tue Apr 04 2017 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.3-5
369 - Include more dependencies to fix FTBFS (#1423283)
370 - Allow AuthConfig directives in Bugzilla's directory (#1403588)
371 - Backport patch to use internal functions rather than File::Slurp (#1425077)
372
373 * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.3-4
374 - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
375
376 * Sun Nov 27 2016 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.3-3
377 - Check for perl(JSON::RPC::Legacy::Server::CGI) instead of perl(JSON::RPC)
378
379 * Sun Jul 17 2016 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.3-2
380 - Add build requirements for texlive sub-packages
381 - Filter out more optional dependencies
382
383 * Mon May 16 2016 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.3-1
384 - Update to 5.0.3, dropping backported patch
385
386 * Sun May 01 2016 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.2-3
387 - backport patch to prevent email address encoding
388
389 * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.2-2
390 - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
391
392 * Sat Jan 16 2016 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.2-1
393 - Update to 5.0.2, with thanks to Tuomo Soini (#1275609)
394 - Use dnf instead of yum when advising to install perl modules
395 - Change documentation URL to bugzilla.readthedocs.org
396
397 * Mon Sep 28 2015 Tuomo Soini <tis@foobar.fi> - 5.0.1-3
398 - fix data directory permissions and config dir permissions
399
400 * Mon Sep 28 2015 Tuomo Soini <tis@foobar.fi> - 5.0.1-2
401 - Fix file owners to be mostly correct
402 - rewrite patching of paths in Constants.pm
403
404 * Fri Sep 11 2015 Tuomo Soini <tis@foobar.fi> - 5.0.1-1
405 - Update to 5.0.1 new stable series
406 - update dependencies for 5.0.1
407 - build documentation
408 - add documentation build dependencies
409
410 * Thu Sep 10 2015 Tuomo Soini <tis@foobar.fi> - 4.4.10-1
411 - Update to 4.4.10 to fix CVE-2015-4499
412
413 * Wed Jun 17 2015 Tuomo Soini <tis@foobar.fi> - 4.4.9-1
414 - Update to 4.4.9 for several important bug fixes
415
416 * Tue Jun 16 2015 Tuomo Soini <tis@foobar.fi> - 4.4.8-1
417 - Import from rawhide (F23)
418
419 * Sat Jan 31 2015 Emmanuel Seyman <emmanuel@seyman.fr> - 4.4.8-1
420 - Update to 4.4.8 (fixes regressions in 4.4.7 which itself
421 fixed security flaws) (CVE-2014-1571, CVE-2014-8630)
422
423 * Sun Jan 04 2015 Emmanuel Seyman <emmanuel@seyman.fr> - 4.4.6-2
424 - Remove bundled binary files (#1000245)
425 - Add webdot directory perms to apache configuration
426
427 * Wed Oct 08 2014 Emmanuel Seyman <emmanuel@seyman.fr> - 4.4.6-1
428 - Update to 4.4.6
429
430 * Fri Jul 25 2014 Emmanuel Seyman <emmanuel@seyman.fr> - 4.4.5-1
431 - Update to 4.4.5
432
433 * Mon Jul 07 2014 Emmanuel Seyman <emmanuel@seyman.fr> - 4.4.4-1
434 - Update to 4.4.4
435
436 * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.9-2
437 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
438
439 * Sat Apr 19 2014 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.9-1
440 - Update to 4.2.9 (regression fix for 4.2.8 which was a security update)
441 - Drop backported patches
442
443 * Tue Jan 14 2014 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.7-3
444 - Fix the comparison of module versions (#1044854)
445 - Really honor the PROJECT environment variable (#911943)
446
447 * Thu Nov 14 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.7-2
448 - Add patch to cache bz_locations() (bmo #843457)
449 - Fix constants patch to honor the PROJECT environment variable (#911943)
450
451 * Thu Oct 17 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.7-1
452 - Update to 4.2.7 (security updates)
453 - Patch bugzilla to write compiled templates under /var (#949130)
454
455 * Thu Aug 15 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.6-5
456 - Stop creating /usr/share/doc/bugzilla-<version> (#993688)
457 - Fix incorrect date in changelog
458
459 * Sun Aug 04 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.6-4
460 - Change apache conf to enable access to all machines
461
462 * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.6-3
463 - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
464
465 * Thu Jul 18 2013 Petr Pisar <ppisar@redhat.com> - 4.2.6-2
466 - Perl 5.18 rebuild
467
468 * Sun May 26 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.6-1
469 - Update to 4.2.6
470
471 * Wed Feb 20 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.5-1
472 - Update to 4.2.5 (fixes CVE-2013-0785)
473
474 * Tue Feb 05 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.4-2
475 - Update httpd configuration file for Apache 2.4
476 - Update httpd configuration file for the upcoming bugzilla 4.4
477
478 * Wed Nov 14 2012 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.4-1
479 - Update to 4.2.4
480 - Remove the defattr and clean macros (no longer used)
481
482 * Sun Sep 02 2012 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.3-1
483 - Update to 4.2.3
484
485 * Mon Jul 30 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.2.2-1
486 - Update to 4.2.2
487
488 * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.1-2
489 - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
490
491 * Fri Apr 20 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.2.1-1
492 - Update to 4.2.1 (CVE-2012-0465, CVE-2012-0466)
493
494 * Sun Feb 26 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.2-1
495 - Update to 4.2 (#797225)
496 - Include contrib/README instead of contrib/recode.pl in the main package
497
498 * Sun Feb 26 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0.5-2
499 - Leave perl(Bugzilla::Extension::Example::Util) in the provides stream
500
501 * Thu Feb 23 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0.5-1
502 - Update to 4.0.5 to fix security issues
503 - Block all ModPerl::* and Apache2::* from requires
504 - Remove rpm4.8 filters
505
506 * Wed Feb 1 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0.4-1
507 - Update to 4.0.4 to fix security flaws (#786550)
508 - Remove JSON:RPC patch, upstreamed (bmo #706753)
509 - Correct upstream URL in README.fedora.bugzilla, thanks to Ken Dreyer (#783014)
510
511 * Tue Jan 10 2012 Tom Callaway <spot@fedoraproject.org> - 4.0.3-2
512 - patch bz to use JSON::RPC::Legacy::Server::CGI
513
514 * Fri Dec 30 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0.3-1
515 - Update to 4.0.3
516 - Add perl(Locale::Language) to the Requires
517 - Put the xml docs source in the doc-build subpackage
518 - Add index.html to the DirectoryIndex
519 - Fix typo in README.fedora.bugzilla
520
521 * Fri Aug 05 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0.2-1
522 - Update to 4.0.2
523 - Add RPM-4.9-style filtering
524 - Put graphs in /var/lib/bugzilla/graphs.
525
526 * Sun May 01 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0.1-1
527 - Update to 4.0.1
528 - Patch the installation procedure to recommend yum
529
530 * Sun Mar 27 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0-1
531 - Update to 4.0
532
533 * Sun Mar 06 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.4-7
534 - Put contrib/recode.pl in the main package so that it no longer depends on
535 python and ruby
536 - Remove the contents of the lib/ directory, not the directory itself.
537
538 * Tue Feb 15 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.4-6
539 - More filtering
540
541 * Mon Feb 14 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.4-5
542 - Fix broken dependencies
543 - Remove unused patch
544
545 * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.4-4
546 - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
547
548 * Sat Jan 29 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.4-3
549 - Remove no-longer-needed files
550
551 * Sat Jan 29 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.4-2
552 - Move to the current filtering system for provides and requires
553
554 * Tue Jan 25 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.4-1
555 - Update to 3.6.4
556 - Add RPM-4.9-style filtering
557 -
558
559 * Wed Nov 03 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.3-1
560 - Update to 3.6.3 (#649406)
561 - Fix webdot alias in /etc/httpd/conf.d/bugzilla (#630255)
562 - Do not apply graphs patch (upstreamed)
563
564 * Wed Aug 18 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.2-1
565 - Update to 3.6.2 (#623426)
566 - Only run checksetup if /etc/bugzilla/localconfig does not exist (#610210)
567 - Add bugzilla-contrib to Requires (#610198)
568
569 * Wed Aug 11 2010 David Malcolm <dmalcolm@redhat.com> - 3.6.1-2
570 - recompiling .py files against Python 2.7 (rhbz#623281)
571
572 * Fri Jun 25 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.1-1
573 - Update to 3.6.1
574
575 * Sun Jun 6 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6-3
576 - Remove mod_perl from the requirements (#600924)
577
578 * Sun Jun 6 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6-2
579 - Fix missing provides (#600922)
580
581 * Tue Apr 13 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6-1
582 - Update to 3.6 (#598377)
583 - Patch to put graphs in /var/lib/bugzilla/ (brc #564450, bmo #313739)
584
585 * Mon Feb 01 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.4.5-1
586 - Update to 3.4.5 (CVE-2009-3989, CVE-2009-3387)
587 - Remove bugzilla-EL5-perl-versions.patch which is EPEL-specific
588
589 * Thu Nov 19 2009 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.4.4-1
590 - Update to 3.4.4 (CVE-2009-3386)
591
592 * Wed Nov 11 2009 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.4.3-1
593 - Update to 3.4.3 (fixes memory leak issues)
594 - Add perl(Digest::SHA) in the Requires
595 - Specify Perl module versions in the Requires (fixes #524309)
596 - Add an alias to make $webdotdir a working path (fixes #458848)
597
598 * Fri Sep 11 2009 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.4.2-1
599 - Update to 3.4.2 (CVE-2009-3125, CVE-2009-3165 and CVE-2009-3166)
600
601 * Tue Aug 04 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 3.4.1-2
602 - fix EL-5 perl dependencies bz#515158
603
604 * Sun Aug 02 2009 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.4.1-1
605 - Update to 3.4.1, fixing a security leak
606
607 * Wed Jul 29 2009 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.4-1
608 - Update to 3.4 (fixes #514315)
609 - move makedocs.pl to its own package (fixes #509041)
610 - move the extensions dir to /usr/share/ (fixes #450636)
611
612 * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.4-2
613 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
614
615 * Wed Jul 08 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 3.2.4-1
616 - fix https://bugzilla.mozilla.org/show_bug.cgi?id=495257
617
618 * Mon Apr 06 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> 3.2.3-1
619 - fix CVE-2009-1213
620
621 * Thu Mar 05 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> 3.2.2-2
622 - fix from BZ #474250 Comment #16, from Chris Eveleigh -->
623 - add python BR for contrib subpackage
624 - fix description
625 - change Requires perl-SOAP-Lite to perl(SOAP::Lite) according guidelines
626
627 * Sun Mar 01 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> 3.2.2-1
628 - thanks to Chris Eveleigh <chris dot eveleigh at planningportal dot gov dot uk>
629 - for contributing with patches :-)
630 - Upgrade to upstream 3.2.2 to fix multiple security vulns
631 - Removed old perl_requires exclusions, added new ones for RADIUS, Oracle and sanitycheck.cgi
632 - Added Oracle to supported DBs in description (and moved line breaks)
633 - Include a patch to fix max_allowed_packet warnin when using with mysql
634
635 * Sat Feb 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> 3.0.8-1
636 - Upgrade to 3.0.8, fix #466077 #438080
637 - fix macro in changelog rpmlint warning
638 - fix files-attr-not-set rpmlint warning for doc and contrib sub-packages
639
640 * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.4-4
641 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
642
643 * Mon Feb 2 2009 Stepan Kasal <skasal@redhat.com> - 3.0.4-3
644 - do not require perl-Email-Simple, it is (no longer) in use
645 - remove several explicit perl-* requires; the automatic dependencies
646 do handle them
647
648 * Mon Jul 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.0.4-2
649 - fix license tag
650
651 * Fri May 9 2008 John Berninger <john at ncphotography dot com> - 3.0.4-1
652 - Update to upstream 3.0.4 to fix multiple security vulns
653 - Change perms on /etc/bugzilla for bz 427981
654
655 * Sun May 4 2008 John Berninger <john at ncphotography dot com> - 3.0.3-0
656 - Update to upstream 3.0.3 - bz 444669
657
658 * Fri Dec 28 2007 John Berninger <john at ncphotography dot com> - 3.0.2-6
659 - Add cron.daily, cron.whine to payload list
660
661 * Fri Dec 28 2007 John Berninger <john at ncphotography dot com> - 3.0.2-5
662 - Typo in spec file, rebuild
663
664 * Fri Dec 28 2007 John Berninger <john at ncphotography dot com> - 3.0.2-3
665 - bz 426465 - don't enable cron jobs so cron doesn't complain about
666 an unconfigured installation
667
668 * Fri Oct 26 2007 John Berninger <john at ncphotography dot com> - 3.0.2-2
669 - fix issue with AlowOverride Options
670
671 * Mon Oct 22 2007 John Berninger <john at ncphotography dot com> - 3.0.2-1
672 - updates to requires and httpd conf for BZ's 279961, 295861, 339531
673
674 * Mon Sep 24 2007 John Berninger <john at ncphotography dot com> - 3.0.2-0
675 - update to 3.0.2 - bz 299981
676
677 * Mon Aug 27 2007 John Berninger <john at ncphotography dot com> - 3.0.1-0
678 - update to 3.0.1 - bz 256021
679
680 * Fri May 18 2007 John Berninger <jwb at redhat dot com> - 3.0-2
681 - update Requires for bz's 241037, 241206
682
683 * Fri May 18 2007 John Berninger <jwb at redhat dot com> - 3.0-1
684 - update to upstream version 3.0
685 - add new dependencies on mod_perl, perl-SOAP-Lite
686 - refactor patch(es) to change paths for read-only /usr
687
688 * Tue Feb 20 2007 John Berninger <jwb at redhat dot com> - 2.22.2-1
689 - update to 2.22.2 - bz 229163
690
691 * Wed Feb 14 2007 John Berninger <jwb at redhat dot com> - 2.22-12
692 - More cron job fixes
693
694 * Wed Jan 31 2007 John Berninger <jwb at redhat dot com> - 2.22-11
695 - Fix cron job perms
696
697 * Sat Jan 27 2007 John Berninger <jwb at redhat dot com> - 2.22-10
698 - Fix collectstats cron job, bx 224550
699
700 * Mon Jan 22 2007 John Berninger <jwb at redhat dot com> - 2.22-9
701 - Fix linebreak issues in specfile
702
703 * Mon Jan 22 2007 John Berninger <jwb at redhat dot com> - 2.22-8
704 - Put daily and hourly cronjobs in place per bz 223747
705
706 * Wed Nov 8 2006 John Berninger <johnw at berningeronline dot net> - 2.22-7
707 - Fixes for bz # 212355
708
709 * Tue Jun 27 2006 John Berninger <johnw at berningeronline dot net> - 2.22-6
710 - Clean up BugzillaEmail requires (filter it out)
711
712 * Mon Jun 26 2006 John Berninger <johnw at berningeronline dot net> - 2.22-5
713 - License is MPL, not GPL
714 - Clean up %%doc specs
715
716 * Sun Jun 25 2006 John Benringer <johnw at berningeronline dot net> - 2.22-4
717 - Remove localconfig file per upstream
718 - Patch to have localconfig appear in /etc/bugzilla when checksetup.pl is run
719
720 * Tue Jun 20 2006 John Berninger <johnw at berningeronline dot net> - 2.22-3
721 - Add README.fedora file
722 - Add additional requires per comments from upstream
723
724 * Mon Jun 19 2006 John Berninger <johnw at berningeronline dot net> - 2.22-2
725 - Code to /usr/share, data to /var/lib/bugzilla per FE packaging req's
726
727 * Tue Jun 13 2006 John Berninger <johnw at berningeronline dot net> - 2.22-1
728 - Shift to /var/lib/bugzilla install dir per discussion in review request
729 - Minor change in filtering requires
730
731 * Tue May 23 2006 John Berninger <johnw at berningeronline dot net> - 2.22-0
732 - Update to upstream 2.22 release
733 - Split off -contrib package, but keep it where it usually gets installed
734
735 * Wed Apr 26 2006 John Berninger <johnw at berningeronline dot net> - 2.20.1-4
736 - rpmlint cleanups
737
738 * Mon Apr 24 2006 John Berninger <johnw at berningeronline dot net> - 2.20.1-3
739 - Cleanup of prov/req filters
740 - Split docs into -doc package
741
742 * Thu Apr 20 2006 John Berninger <johnw at berningeronline dot net> - 2.20.1-2
743 - No need for CVS tarball - I was thinking things too far through. Change
744 to 2.20.1 release.
745
746 * Fri Apr 7 2006 John Berninger <johnw at berningeronline dot net> - 2.20-0.1cvs20060407
747 - Initial spec creation/build for Fedora Extras packaging.
748

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed