/[smecontribs]/rpms/bugzilla/contribs10/bugzilla.spec
ViewVC logotype

Annotation of /rpms/bugzilla/contribs10/bugzilla.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Tue May 24 01:30:55 2022 UTC (2 years, 1 month ago) by jpp
Branch: MAIN
CVS Tags: bugzilla-5_0_6-16_el7_sme, HEAD
Changes since 1.2: +3 -3 lines
* Mon May 23 2022 Jean-Philippe Pialasse <tests@pialasse.com> 5.0.6-16.sme
- first build for SME Server 10 [SME: 11977]

1 jpp 1.1 %define bzinstallprefix %{_datadir}
2     %define bzdatadir %{_sharedstatedir}/bugzilla
3    
4     Summary: Bug tracking system
5     URL: https://www.bugzilla.org/
6     Name: bugzilla
7     Version: 5.0.6
8 jpp 1.3 Release: 16%{?dist}
9 jpp 1.1 License: MPLv1.1
10     Source0: https://github.com/bugzilla/bugzilla/archive/release-%{version}.tar.gz
11     Source1: bugzilla-httpd-conf
12     Source2: README.fedora.bugzilla
13     Source3: bugzilla.cron-daily
14     Patch0: bugzilla-rw-paths.patch
15     Patch1: bugzilla-dnf.patch
16     Patch2: bugzilla-1438957-concatenate-assets.patch
17     # https://bug1657496.bmoattachments.org/attachment.cgi?id=9169528
18     Patch3: bugzilla-1855962-non-html-mail.patch
19    
20     BuildArch: noarch
21     Requires: patchutils
22     Requires: perl(CGI) >= 3.51
23     Requires: perl(Digest::SHA)
24     Requires: perl(Date::Format) >= 2.23
25     Requires: perl(DateTime) >= 0.75
26     Requires: perl(DateTime::TimeZone) >= 1.64
27     Requires: perl(DBI) >= 1.614
28     Requires: perl(ExtUtils::MM)
29     Requires: perl(Template) >= 2.24
30     Requires: perl(Email::Sender) >= 1.300011
31     Requires: perl(Email::MIME) >= 1.904
32     Requires: perl(URI) >= 1.55
33     Requires: perl(List::MoreUtils) >= 0.32
34     Requires: perl(Math::Random::ISAAC) >= 1.0.1
35     Requires: perl(File::Slurp) >= 9999.13
36     Requires: perl(JSON::XS) >= 2.01
37     Requires: perl(Locale::Language)
38     Requires: webserver
39     Requires: which
40    
41     # for building docs
42     BuildRequires: latexmk
43     BuildRequires: make
44     BuildRequires: perl-generators
45     BuildRequires: perl(constant)
46     BuildRequires: perl(Cwd)
47     BuildRequires: perl(Exporter)
48     BuildRequires: perl(File::Basename)
49     BuildRequires: perl(File::Copy::Recursive)
50     BuildRequires: perl(File::Find)
51     BuildRequires: perl(File::Path)
52     BuildRequires: perl(File::Which)
53     BuildRequires: perl(lib)
54     BuildRequires: perl(Memoize)
55     BuildRequires: perl(parent)
56     BuildRequires: perl(Pod::Simple)
57     BuildRequires: perl(strict)
58     BuildRequires: perl(warnings)
59     BuildRequires: python3-sphinx
60     BuildRequires: texlive-collection-latexrecommended
61     BuildRequires: texlive-collection-basic
62     BuildRequires: tex(fncychap.sty)
63     BuildRequires: tex(framed.sty)
64     BuildRequires: tex(multirow.sty)
65     BuildRequires: tex(threeparttable.sty)
66     BuildRequires: tex(titlesec.sty)
67     BuildRequires: tex(wrapfig.sty)
68     %if 0%{?fedora}
69     BuildRequires: tex(capt-of.sty)
70     BuildRequires: tex(eqparbox.sty)
71     BuildRequires: tex(needspace.sty)
72     BuildRequires: tex(tabulary.sty)
73     BuildRequires: tex(upquote.sty)
74     %endif
75 jpp 1.2 #ADD for Koozali builder
76     BuildRequires: python-sphinx
77 jpp 1.1
78     %package doc
79     Summary: Bugzilla documentation
80    
81     %package doc-build
82     Summary: Tools to generate the Bugzilla documentation
83    
84     %package contrib
85     Summary: Bugzilla contributed scripts
86     BuildRequires: python3-devel
87    
88     %{?perl_default_filter}
89    
90     # Remove private modules from the requires stream
91     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(sanitycheck.cgi\\)$
92    
93     # Remove all optional modules from the requires stream
94     # mod_perl modules
95     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Apache2::
96     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(ModPerl::
97     # installation of optional modules
98     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Config\\)$
99     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(CPAN\\)$
100     # authentification modules
101     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Authen::Radius\\)$
102     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Net::LDAP
103     # database modules
104     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(DBD::Oracle\\)$
105     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(DBD::Pg\\)$
106     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(DBI::db\\)$
107     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(DBI::st\\)$
108     # graphical reports and charts
109     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Chart::Lines\\)$
110     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(GD::Graph\\)$
111     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Template::Plugin::GD::Image\\)$
112     # inbound email modules
113     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Email::MIME::Attachment::Stripper\\)$
114     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Email::Reply\\)$
115     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(HTML::FormatText::WithLinks\\)$
116     # automatic charset detection for text attachments
117     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Encode
118     # sniff MIME type of attachments
119     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(File::MimeInfo::Magic\\)$
120     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(IO::Scalar\\)$
121     # mail queueing
122     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(TheSchwartz\\)$
123     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Daemon::Generic\\)$
124     # smtp security
125     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Authen::SASL\\)$
126     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Net::SMTP::SSL\\)$
127     # bug moving modules
128     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(MIME::Parser\\)$
129     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(XML::Twig\\)$
130     # update notifications
131     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(LWP::UserAgent\\)$
132     # use html in product and group descriptions
133     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(HTML::Parser\\)$
134     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(HTML::Scrubber\\)$
135     # memcached support
136     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Cache::Memcached\\)$
137     # documentation
138     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(File::Copy::Recursive\\)$
139     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(File::Which\\)$
140     # xml-rpc and json-rpc modules
141     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(XMLRPC::
142     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(HTTP::Message\\)$
143     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Test::Taint\\)$
144     # extension modules
145     %global __requires_exclude %{?__requires_exclude:%{__requires_exclude}|}^perl\\(Image::Magick\\)$
146    
147     # and remove the extensions from the provides stream
148     %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::BmpConvert\\)$
149     %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::Example\\)$
150     %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::Example::Auth::Login\\)$
151     %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::Example::Auth::Verify\\)$
152     %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::Example::Config\\)$
153     %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::Example::WebService\\)$
154     %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::OldBugMove\\)$
155     %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::OldBugMove::Params\\)$
156     %global __provides_exclude %{?__provides_exclude:%{__provides_exclude}|}^perl\\(Bugzilla::Extension::Voting\\)$
157    
158     %description
159     Bugzilla is a popular bug tracking system used by multiple open source projects
160     It requires a database engine installed - either MySQL, PostgreSQL or Oracle.
161     Without one of these database engines (local or remote), Bugzilla will not work
162     - see the Release Notes for details.
163    
164     %description doc
165     Documentation distributed with the Bugzilla bug tracking system
166    
167     %description doc-build
168     Tools to generate the documentation distributed with Bugzilla
169    
170     %description contrib
171     Contributed scripts and functions for Bugzilla
172    
173     %prep
174     %setup -q -n %{name}-release-%{version}
175     %patch0 -p1
176     %patch1 -p1
177     %patch2 -p1
178     %patch3 -p1
179    
180     # Deal with changing /usr/local paths here instead of via patches
181     /usr/bin/perl -pi -e 's|/usr/local/bin/python\b|%{__python3}|' contrib/*.py
182     /usr/bin/rm -rf contrib/bugzilla-submit
183    
184     grep -rl '/usr/lib/sendmail\b' contrib docs \
185     | xargs /usr/bin/perl -pi -e 's|/usr/lib/sendmail\b|%{_sbindir}/sendmail|'
186    
187     %build
188     # Build docs
189     docs/makedocs.pl --with-pdf
190     # Remove the execute bit from files that don't start with #!
191     for file in `find -type f -perm /111`; do
192     if head -1 $file | grep -E -v '^\#!' &>/dev/null; then
193     chmod a-x $file
194     fi
195     done
196     # Ensure shebang shell scripts have executable bit set
197     for file in `find -type f -perm /664`; do
198     if head -1 $file | grep -E '^\#!' &>/dev/null; then
199     chmod a+x $file
200     fi
201     done
202    
203     %install
204     mkdir -p %{buildroot}%{bzinstallprefix}/bugzilla
205     # these files are only used for testing Bugzilla code
206     # see https://bugzilla.mozilla.org/show_bug.cgi?id=995209
207     rm Build.PL MANIFEST.SKIP
208     cp -pr * %{buildroot}%{bzinstallprefix}/bugzilla
209     echo "0-59/15 * * * * apache cd %{bzinstallprefix}/bugzilla && env LANG=C %{bzinstallprefix}/bugzilla/whine.pl" > %{buildroot}%{bzinstallprefix}/bugzilla/cron.whine
210     rm -f %{buildroot}%{bzinstallprefix}/bugzilla/README \
211     %{buildroot}%{bzinstallprefix}/bugzilla/docs/TODO \
212     %{buildroot}%{bzinstallprefix}/bugzilla/docs/en/Makefile \
213     %{buildroot}%{bzinstallprefix}/bugzilla/docs/en/make.bat
214     cp %{SOURCE2} ./README.fedora
215     mkdir -p %{buildroot}%{bzdatadir}/assets
216     mkdir -p %{buildroot}%{_sysconfdir}/bugzilla
217     install -m 0644 -D -p %{SOURCE1} %{buildroot}%{_sysconfdir}/httpd/conf.d/bugzilla.conf
218     install -m 0755 -D -p %{SOURCE3} %{buildroot}%{bzinstallprefix}/bugzilla/cron.daily
219     ln -s ../../..%{bzdatadir}/assets %{buildroot}%{bzinstallprefix}/bugzilla/assets
220    
221     %post
222     (pushd %{bzinstallprefix}/bugzilla > /dev/null
223     [ -f /etc/bugzilla/localconfig ] || ./checksetup.pl > /dev/null
224     popd > /dev/null)
225    
226     %files
227     %defattr(-,root,apache,-)
228     %dir %{bzinstallprefix}/bugzilla
229     %{bzinstallprefix}/bugzilla/LICENSE
230     %{bzinstallprefix}/bugzilla/*.cgi
231     %{bzinstallprefix}/bugzilla/*.json
232     %{bzinstallprefix}/bugzilla/*.pl
233     %{bzinstallprefix}/bugzilla/Bugzilla.pm
234     %{bzinstallprefix}/bugzilla/robots.txt
235     %{bzinstallprefix}/bugzilla/Bugzilla
236     %{bzinstallprefix}/bugzilla/extensions
237     %{bzinstallprefix}/bugzilla/images
238     %{bzinstallprefix}/bugzilla/js
239     %{bzinstallprefix}/bugzilla/lib
240     %{bzinstallprefix}/bugzilla/skins
241     %{bzinstallprefix}/bugzilla/t
242     %{bzinstallprefix}/bugzilla/xt
243     %{bzinstallprefix}/bugzilla/template
244     %{bzinstallprefix}/bugzilla/cron.daily
245     %{bzinstallprefix}/bugzilla/cron.whine
246     %{bzinstallprefix}/bugzilla/contrib/README
247     %{bzinstallprefix}/bugzilla/assets
248     %config(noreplace) %{_sysconfdir}/httpd/conf.d/bugzilla.conf
249     %attr(770,root,apache) %dir %{bzdatadir}
250     %attr(770,root,apache) %dir %{bzdatadir}/assets
251     %attr(750,root,apache) %dir %{_sysconfdir}/bugzilla
252     %defattr(-,root,root,-)
253     %doc README
254     %doc README.fedora
255    
256     %files doc
257     %defattr(-,root,apache,-)
258     %{bzinstallprefix}/bugzilla/docs/en/html
259     %{bzinstallprefix}/bugzilla/docs/en/images
260     %{bzinstallprefix}/bugzilla/docs/en/pdf
261     %{bzinstallprefix}/bugzilla/docs/en/txt
262     %{bzinstallprefix}/bugzilla/docs/en/rst
263     %{bzinstallprefix}/bugzilla/docs/style.css
264    
265    
266     %files doc-build
267     %defattr(-,root,apache,-)
268     %{bzinstallprefix}/bugzilla/docs/makedocs.pl
269     %{bzinstallprefix}/bugzilla/docs/lib
270    
271     %files contrib
272     %defattr(-,root,apache,-)
273     %{bzinstallprefix}/bugzilla/contrib/bugzilla-queue.rhel
274     %{bzinstallprefix}/bugzilla/contrib/bugzilla-queue.suse
275     %{bzinstallprefix}/bugzilla/contrib/bzdbcopy.pl
276     %{bzinstallprefix}/bugzilla/contrib/bz_webservice_demo.pl
277     %{bzinstallprefix}/bugzilla/contrib/cmdline
278     %{bzinstallprefix}/bugzilla/contrib/console.pl
279     %{bzinstallprefix}/bugzilla/contrib/convert-workflow.pl
280     %{bzinstallprefix}/bugzilla/contrib/extension-convert.pl
281     %{bzinstallprefix}/bugzilla/contrib/fixperms.pl
282     %{bzinstallprefix}/bugzilla/contrib/jb2bz.py*
283     %{bzinstallprefix}/bugzilla/contrib/merge-users.pl
284     %{bzinstallprefix}/bugzilla/contrib/mysqld-watcher.pl
285     %{bzinstallprefix}/bugzilla/contrib/new-yui.sh
286     %{bzinstallprefix}/bugzilla/contrib/perl-fmt
287     %{bzinstallprefix}/bugzilla/contrib/recode.pl
288     %{bzinstallprefix}/bugzilla/contrib/sendbugmail.pl
289     %{bzinstallprefix}/bugzilla/contrib/sendunsentbugmail.pl
290     %{bzinstallprefix}/bugzilla/contrib/syncLDAP.pl
291     %{bzinstallprefix}/bugzilla/contrib/Bugzilla.pm
292    
293     %changelog
294 jpp 1.3 * Mon May 23 2022 Jean-Philippe Pialasse <tests@pialasse.com> 5.0.6-16.sme
295     - first build for SME Server 10 [SME: 11977]
296 jpp 1.2
297 jpp 1.1 * Wed Jan 19 2022 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-14
298     - Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
299    
300     * Wed Jul 21 2021 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-13
301     - Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
302    
303     * Sun Feb 14 2021 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.6-12
304     - Add make to BuildRequires
305    
306     * Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-11
307     - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
308    
309     * Mon Oct 19 2020 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.6-10
310     - Replace calls to %%{__perl} with /usr/bin/perl
311     - Remove contrib/bugzilla-submit (no longers works) (#1835451)
312    
313     * Tue Sep 29 2020 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.6-9
314     - Remove automagic Python bytecompilation macro
315     - Include upstream patch for text mails (#1855962)
316    
317     * Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-8
318     - Second attempt - Rebuilt for
319     https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
320    
321     * Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-7
322     - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
323     * Tue Mar 24 2020 Jitka Plesnikova <jplesnik@redhat.com> - 5.0.6-6
324     - Add all perl dependencies needed for build
325    
326     * Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-5
327     - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
328    
329     * Wed Sep 04 2019 Miro Hrončok <mhroncok@redhat.com> - 5.0.6-4
330     - Drop unused build dependency on Python 2
331    
332     * Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.6-3
333     - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
334    
335     * Sun Mar 10 2019 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.6-2
336     - Use %%{__python3} instead of %%{__python2}
337     - Depend on python3-sphinx instead of python2-sphinx
338    
339     * Thu Feb 14 2019 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.6-1
340     - Update to 5.0.6
341    
342     * Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.4-3
343     - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
344    
345     * Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.4-2
346     - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
347    
348     * Sun Feb 18 2018 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.4-1
349     - Update to 5.0.4
350     - Remove backported File::Slurp patch, no longer needed
351     - use %%{__python2} instead of %%{__python}
352     - Disable the concatenation of assets (#1438957)
353    
354     * Wed Feb 07 2018 Iryna Shcherbina <ishcherb@redhat.com> - 5.0.3-10
355     - Update Python 2 dependency declarations to new packaging standards
356     (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
357    
358     * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.3-9
359     - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
360    
361     * Sun Aug 20 2017 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.3-8
362     - Tighten macro expansion (thanks to ppisar)
363     - Drop Group tag
364     - Use tex(..) BuildRequires where possible
365    
366     * Mon Aug 07 2017 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.3-7
367     - Add doc-building requirement to fix FTBS
368     - Add perl(ExtUtils::MM) to the list of required modules
369    
370     * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.3-6
371     - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
372    
373     * Tue Apr 04 2017 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.3-5
374     - Include more dependencies to fix FTBFS (#1423283)
375     - Allow AuthConfig directives in Bugzilla's directory (#1403588)
376     - Backport patch to use internal functions rather than File::Slurp (#1425077)
377    
378     * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.3-4
379     - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
380    
381     * Sun Nov 27 2016 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.3-3
382     - Check for perl(JSON::RPC::Legacy::Server::CGI) instead of perl(JSON::RPC)
383    
384     * Sun Jul 17 2016 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.3-2
385     - Add build requirements for texlive sub-packages
386     - Filter out more optional dependencies
387    
388     * Mon May 16 2016 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.3-1
389     - Update to 5.0.3, dropping backported patch
390    
391     * Sun May 01 2016 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.2-3
392     - backport patch to prevent email address encoding
393    
394     * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.2-2
395     - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
396    
397     * Sat Jan 16 2016 Emmanuel Seyman <emmanuel@seyman.fr> - 5.0.2-1
398     - Update to 5.0.2, with thanks to Tuomo Soini (#1275609)
399     - Use dnf instead of yum when advising to install perl modules
400     - Change documentation URL to bugzilla.readthedocs.org
401    
402     * Mon Sep 28 2015 Tuomo Soini <tis@foobar.fi> - 5.0.1-3
403     - fix data directory permissions and config dir permissions
404    
405     * Mon Sep 28 2015 Tuomo Soini <tis@foobar.fi> - 5.0.1-2
406     - Fix file owners to be mostly correct
407     - rewrite patching of paths in Constants.pm
408    
409     * Fri Sep 11 2015 Tuomo Soini <tis@foobar.fi> - 5.0.1-1
410     - Update to 5.0.1 new stable series
411     - update dependencies for 5.0.1
412     - build documentation
413     - add documentation build dependencies
414    
415     * Thu Sep 10 2015 Tuomo Soini <tis@foobar.fi> - 4.4.10-1
416     - Update to 4.4.10 to fix CVE-2015-4499
417    
418     * Wed Jun 17 2015 Tuomo Soini <tis@foobar.fi> - 4.4.9-1
419     - Update to 4.4.9 for several important bug fixes
420    
421     * Tue Jun 16 2015 Tuomo Soini <tis@foobar.fi> - 4.4.8-1
422     - Import from rawhide (F23)
423    
424     * Sat Jan 31 2015 Emmanuel Seyman <emmanuel@seyman.fr> - 4.4.8-1
425     - Update to 4.4.8 (fixes regressions in 4.4.7 which itself
426     fixed security flaws) (CVE-2014-1571, CVE-2014-8630)
427    
428     * Sun Jan 04 2015 Emmanuel Seyman <emmanuel@seyman.fr> - 4.4.6-2
429     - Remove bundled binary files (#1000245)
430     - Add webdot directory perms to apache configuration
431    
432     * Wed Oct 08 2014 Emmanuel Seyman <emmanuel@seyman.fr> - 4.4.6-1
433     - Update to 4.4.6
434    
435     * Fri Jul 25 2014 Emmanuel Seyman <emmanuel@seyman.fr> - 4.4.5-1
436     - Update to 4.4.5
437    
438     * Mon Jul 07 2014 Emmanuel Seyman <emmanuel@seyman.fr> - 4.4.4-1
439     - Update to 4.4.4
440    
441     * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.9-2
442     - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
443    
444     * Sat Apr 19 2014 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.9-1
445     - Update to 4.2.9 (regression fix for 4.2.8 which was a security update)
446     - Drop backported patches
447    
448     * Tue Jan 14 2014 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.7-3
449     - Fix the comparison of module versions (#1044854)
450     - Really honor the PROJECT environment variable (#911943)
451    
452     * Thu Nov 14 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.7-2
453     - Add patch to cache bz_locations() (bmo #843457)
454     - Fix constants patch to honor the PROJECT environment variable (#911943)
455    
456     * Thu Oct 17 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.7-1
457     - Update to 4.2.7 (security updates)
458     - Patch bugzilla to write compiled templates under /var (#949130)
459    
460     * Thu Aug 15 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.6-5
461     - Stop creating /usr/share/doc/bugzilla-<version> (#993688)
462     - Fix incorrect date in changelog
463    
464     * Sun Aug 04 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.6-4
465     - Change apache conf to enable access to all machines
466    
467     * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.6-3
468     - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
469    
470     * Thu Jul 18 2013 Petr Pisar <ppisar@redhat.com> - 4.2.6-2
471     - Perl 5.18 rebuild
472    
473     * Sun May 26 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.6-1
474     - Update to 4.2.6
475    
476     * Wed Feb 20 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.5-1
477     - Update to 4.2.5 (fixes CVE-2013-0785)
478    
479     * Tue Feb 05 2013 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.4-2
480     - Update httpd configuration file for Apache 2.4
481     - Update httpd configuration file for the upcoming bugzilla 4.4
482    
483     * Wed Nov 14 2012 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.4-1
484     - Update to 4.2.4
485     - Remove the defattr and clean macros (no longer used)
486    
487     * Sun Sep 02 2012 Emmanuel Seyman <emmanuel@seyman.fr> - 4.2.3-1
488     - Update to 4.2.3
489    
490     * Mon Jul 30 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.2.2-1
491     - Update to 4.2.2
492    
493     * Wed Jul 18 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.2.1-2
494     - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
495    
496     * Fri Apr 20 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.2.1-1
497     - Update to 4.2.1 (CVE-2012-0465, CVE-2012-0466)
498    
499     * Sun Feb 26 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.2-1
500     - Update to 4.2 (#797225)
501     - Include contrib/README instead of contrib/recode.pl in the main package
502    
503     * Sun Feb 26 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0.5-2
504     - Leave perl(Bugzilla::Extension::Example::Util) in the provides stream
505    
506     * Thu Feb 23 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0.5-1
507     - Update to 4.0.5 to fix security issues
508     - Block all ModPerl::* and Apache2::* from requires
509     - Remove rpm4.8 filters
510    
511     * Wed Feb 1 2012 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0.4-1
512     - Update to 4.0.4 to fix security flaws (#786550)
513     - Remove JSON:RPC patch, upstreamed (bmo #706753)
514     - Correct upstream URL in README.fedora.bugzilla, thanks to Ken Dreyer (#783014)
515    
516     * Tue Jan 10 2012 Tom Callaway <spot@fedoraproject.org> - 4.0.3-2
517     - patch bz to use JSON::RPC::Legacy::Server::CGI
518    
519     * Fri Dec 30 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0.3-1
520     - Update to 4.0.3
521     - Add perl(Locale::Language) to the Requires
522     - Put the xml docs source in the doc-build subpackage
523     - Add index.html to the DirectoryIndex
524     - Fix typo in README.fedora.bugzilla
525    
526     * Fri Aug 05 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0.2-1
527     - Update to 4.0.2
528     - Add RPM-4.9-style filtering
529     - Put graphs in /var/lib/bugzilla/graphs.
530    
531     * Sun May 01 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0.1-1
532     - Update to 4.0.1
533     - Patch the installation procedure to recommend yum
534    
535     * Sun Mar 27 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 4.0-1
536     - Update to 4.0
537    
538     * Sun Mar 06 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.4-7
539     - Put contrib/recode.pl in the main package so that it no longer depends on
540     python and ruby
541     - Remove the contents of the lib/ directory, not the directory itself.
542    
543     * Tue Feb 15 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.4-6
544     - More filtering
545    
546     * Mon Feb 14 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.4-5
547     - Fix broken dependencies
548     - Remove unused patch
549    
550     * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.6.4-4
551     - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
552    
553     * Sat Jan 29 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.4-3
554     - Remove no-longer-needed files
555    
556     * Sat Jan 29 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.4-2
557     - Move to the current filtering system for provides and requires
558    
559     * Tue Jan 25 2011 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.4-1
560     - Update to 3.6.4
561     - Add RPM-4.9-style filtering
562     -
563    
564     * Wed Nov 03 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.3-1
565     - Update to 3.6.3 (#649406)
566     - Fix webdot alias in /etc/httpd/conf.d/bugzilla (#630255)
567     - Do not apply graphs patch (upstreamed)
568    
569     * Wed Aug 18 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.2-1
570     - Update to 3.6.2 (#623426)
571     - Only run checksetup if /etc/bugzilla/localconfig does not exist (#610210)
572     - Add bugzilla-contrib to Requires (#610198)
573    
574     * Wed Aug 11 2010 David Malcolm <dmalcolm@redhat.com> - 3.6.1-2
575     - recompiling .py files against Python 2.7 (rhbz#623281)
576    
577     * Fri Jun 25 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6.1-1
578     - Update to 3.6.1
579    
580     * Sun Jun 6 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6-3
581     - Remove mod_perl from the requirements (#600924)
582    
583     * Sun Jun 6 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6-2
584     - Fix missing provides (#600922)
585    
586     * Tue Apr 13 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.6-1
587     - Update to 3.6 (#598377)
588     - Patch to put graphs in /var/lib/bugzilla/ (brc #564450, bmo #313739)
589    
590     * Mon Feb 01 2010 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.4.5-1
591     - Update to 3.4.5 (CVE-2009-3989, CVE-2009-3387)
592     - Remove bugzilla-EL5-perl-versions.patch which is EPEL-specific
593    
594     * Thu Nov 19 2009 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.4.4-1
595     - Update to 3.4.4 (CVE-2009-3386)
596    
597     * Wed Nov 11 2009 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.4.3-1
598     - Update to 3.4.3 (fixes memory leak issues)
599     - Add perl(Digest::SHA) in the Requires
600     - Specify Perl module versions in the Requires (fixes #524309)
601     - Add an alias to make $webdotdir a working path (fixes #458848)
602    
603     * Fri Sep 11 2009 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.4.2-1
604     - Update to 3.4.2 (CVE-2009-3125, CVE-2009-3165 and CVE-2009-3166)
605    
606     * Tue Aug 04 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 3.4.1-2
607     - fix EL-5 perl dependencies bz#515158
608    
609     * Sun Aug 02 2009 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.4.1-1
610     - Update to 3.4.1, fixing a security leak
611    
612     * Wed Jul 29 2009 Emmanuel Seyman <emmanuel.seyman@club-internet.fr> - 3.4-1
613     - Update to 3.4 (fixes #514315)
614     - move makedocs.pl to its own package (fixes #509041)
615     - move the extensions dir to /usr/share/ (fixes #450636)
616    
617     * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.4-2
618     - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
619    
620     * Wed Jul 08 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> - 3.2.4-1
621     - fix https://bugzilla.mozilla.org/show_bug.cgi?id=495257
622    
623     * Mon Apr 06 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> 3.2.3-1
624     - fix CVE-2009-1213
625    
626     * Thu Mar 05 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> 3.2.2-2
627     - fix from BZ #474250 Comment #16, from Chris Eveleigh -->
628     - add python BR for contrib subpackage
629     - fix description
630     - change Requires perl-SOAP-Lite to perl(SOAP::Lite) according guidelines
631    
632     * Sun Mar 01 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> 3.2.2-1
633     - thanks to Chris Eveleigh <chris dot eveleigh at planningportal dot gov dot uk>
634     - for contributing with patches :-)
635     - Upgrade to upstream 3.2.2 to fix multiple security vulns
636     - Removed old perl_requires exclusions, added new ones for RADIUS, Oracle and sanitycheck.cgi
637     - Added Oracle to supported DBs in description (and moved line breaks)
638     - Include a patch to fix max_allowed_packet warnin when using with mysql
639    
640     * Sat Feb 28 2009 Itamar Reis Peixoto <itamar@ispbrasil.com.br> 3.0.8-1
641     - Upgrade to 3.0.8, fix #466077 #438080
642     - fix macro in changelog rpmlint warning
643     - fix files-attr-not-set rpmlint warning for doc and contrib sub-packages
644    
645     * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.4-4
646     - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
647    
648     * Mon Feb 2 2009 Stepan Kasal <skasal@redhat.com> - 3.0.4-3
649     - do not require perl-Email-Simple, it is (no longer) in use
650     - remove several explicit perl-* requires; the automatic dependencies
651     do handle them
652    
653     * Mon Jul 14 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 3.0.4-2
654     - fix license tag
655    
656     * Fri May 9 2008 John Berninger <john at ncphotography dot com> - 3.0.4-1
657     - Update to upstream 3.0.4 to fix multiple security vulns
658     - Change perms on /etc/bugzilla for bz 427981
659    
660     * Sun May 4 2008 John Berninger <john at ncphotography dot com> - 3.0.3-0
661     - Update to upstream 3.0.3 - bz 444669
662    
663     * Fri Dec 28 2007 John Berninger <john at ncphotography dot com> - 3.0.2-6
664     - Add cron.daily, cron.whine to payload list
665    
666     * Fri Dec 28 2007 John Berninger <john at ncphotography dot com> - 3.0.2-5
667     - Typo in spec file, rebuild
668    
669     * Fri Dec 28 2007 John Berninger <john at ncphotography dot com> - 3.0.2-3
670     - bz 426465 - don't enable cron jobs so cron doesn't complain about
671     an unconfigured installation
672    
673     * Fri Oct 26 2007 John Berninger <john at ncphotography dot com> - 3.0.2-2
674     - fix issue with AlowOverride Options
675    
676     * Mon Oct 22 2007 John Berninger <john at ncphotography dot com> - 3.0.2-1
677     - updates to requires and httpd conf for BZ's 279961, 295861, 339531
678    
679     * Mon Sep 24 2007 John Berninger <john at ncphotography dot com> - 3.0.2-0
680     - update to 3.0.2 - bz 299981
681    
682     * Mon Aug 27 2007 John Berninger <john at ncphotography dot com> - 3.0.1-0
683     - update to 3.0.1 - bz 256021
684    
685     * Fri May 18 2007 John Berninger <jwb at redhat dot com> - 3.0-2
686     - update Requires for bz's 241037, 241206
687    
688     * Fri May 18 2007 John Berninger <jwb at redhat dot com> - 3.0-1
689     - update to upstream version 3.0
690     - add new dependencies on mod_perl, perl-SOAP-Lite
691     - refactor patch(es) to change paths for read-only /usr
692    
693     * Tue Feb 20 2007 John Berninger <jwb at redhat dot com> - 2.22.2-1
694     - update to 2.22.2 - bz 229163
695    
696     * Wed Feb 14 2007 John Berninger <jwb at redhat dot com> - 2.22-12
697     - More cron job fixes
698    
699     * Wed Jan 31 2007 John Berninger <jwb at redhat dot com> - 2.22-11
700     - Fix cron job perms
701    
702     * Sat Jan 27 2007 John Berninger <jwb at redhat dot com> - 2.22-10
703     - Fix collectstats cron job, bx 224550
704    
705     * Mon Jan 22 2007 John Berninger <jwb at redhat dot com> - 2.22-9
706     - Fix linebreak issues in specfile
707    
708     * Mon Jan 22 2007 John Berninger <jwb at redhat dot com> - 2.22-8
709     - Put daily and hourly cronjobs in place per bz 223747
710    
711     * Wed Nov 8 2006 John Berninger <johnw at berningeronline dot net> - 2.22-7
712     - Fixes for bz # 212355
713    
714     * Tue Jun 27 2006 John Berninger <johnw at berningeronline dot net> - 2.22-6
715     - Clean up BugzillaEmail requires (filter it out)
716    
717     * Mon Jun 26 2006 John Berninger <johnw at berningeronline dot net> - 2.22-5
718     - License is MPL, not GPL
719     - Clean up %%doc specs
720    
721     * Sun Jun 25 2006 John Benringer <johnw at berningeronline dot net> - 2.22-4
722     - Remove localconfig file per upstream
723     - Patch to have localconfig appear in /etc/bugzilla when checksetup.pl is run
724    
725     * Tue Jun 20 2006 John Berninger <johnw at berningeronline dot net> - 2.22-3
726     - Add README.fedora file
727     - Add additional requires per comments from upstream
728    
729     * Mon Jun 19 2006 John Berninger <johnw at berningeronline dot net> - 2.22-2
730     - Code to /usr/share, data to /var/lib/bugzilla per FE packaging req's
731    
732     * Tue Jun 13 2006 John Berninger <johnw at berningeronline dot net> - 2.22-1
733     - Shift to /var/lib/bugzilla install dir per discussion in review request
734     - Minor change in filtering requires
735    
736     * Tue May 23 2006 John Berninger <johnw at berningeronline dot net> - 2.22-0
737     - Update to upstream 2.22 release
738     - Split off -contrib package, but keep it where it usually gets installed
739    
740     * Wed Apr 26 2006 John Berninger <johnw at berningeronline dot net> - 2.20.1-4
741     - rpmlint cleanups
742    
743     * Mon Apr 24 2006 John Berninger <johnw at berningeronline dot net> - 2.20.1-3
744     - Cleanup of prov/req filters
745     - Split docs into -doc package
746    
747     * Thu Apr 20 2006 John Berninger <johnw at berningeronline dot net> - 2.20.1-2
748     - No need for CVS tarball - I was thinking things too far through. Change
749     to 2.20.1 release.
750    
751     * Fri Apr 7 2006 John Berninger <johnw at berningeronline dot net> - 2.20-0.1cvs20060407
752     - Initial spec creation/build for Fedora Extras packaging.
753    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed