/[smecontribs]/rpms/c-icap/contribs10/c-icap.spec
ViewVC logotype

Annotation of /rpms/c-icap/contribs10/c-icap.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Wed May 25 15:30:17 2022 UTC (2 years, 4 months ago) by jpp
Branch: MAIN
CVS Tags: c-icap-0_5_8-2_el7_fws, c-icap-0_5_8-2_el7_sme, HEAD
Initial import

1 jpp 1.1 Summary: An implementation of an ICAP server
2     Name: c-icap
3     Version: 0.5.8
4     Release: 2%{?dist}
5     License: LGPL
6    
7     Source0: http://sourceforge.net/projects/c-icap/files/c-icap/0.5.x/c_icap-%{version}.tar.gz
8     Source1: %{name}.service
9     Source2: %{name}.logrotate
10     Source4: tmpfiles.conf
11    
12     URL: http://%{name}.sourceforge.net/
13    
14     Requires: %{name}-libs = %{version}-%{release}
15    
16     BuildRequires: libdb-devel
17     BuildRequires: gdbm-devel
18     BuildRequires: openldap-devel
19     BuildRequires: zlib-devel perl-devel
20    
21     %description
22     C-icap is an implementation of an ICAP server. It can be used with HTTP
23     proxies that support the ICAP protocol to implement content adaptation
24     and filtering services. Most of the commercial HTTP proxies must support
25     the ICAP protocol, the open source Squid 3.x proxy server supports it too.
26    
27    
28     %package devel
29     Summary: Development tools for %{name}
30     Group: Development/Libraries
31     Requires: %{name}-libs = %{version}-%{release}
32     Requires: zlib-devel
33    
34     %description devel
35     The %{name}-devel package contains the static libraries and header files
36     for developing software using %{name}.
37    
38     %package ldap
39     Summary: The LDAP module for %{name}
40     Group: System Environment/Libraries
41     Requires: %{name} = %{version}-%{release}
42    
43     %description ldap
44     The %{name}-ldap package contains the LDAP module for %{name}.
45    
46     %package libs
47     Summary: Libraries used by %{name}
48     Group: System Environment/Libraries
49    
50     %description libs
51     The %{name}-libs package contains all runtime libraries used by %{name} and
52     the utilities.
53    
54    
55     %package perl
56     Summary: The Perl handler for %{name}
57     Group: System Environment/Libraries
58     Requires: %{name} = %{version}-%{release}
59    
60     %description perl
61     The %{name}-perl package contains the Perl handler for %{name}.
62    
63    
64     %package progs
65     Summary: Related programs for %{name}
66     Group: Applications/Internet
67     Requires: %{name}-libs = %{version}-%{release}
68    
69     %description progs
70     The %{name}-progs package contains several commandline tools for %{name}.
71    
72     %prep
73     %setup -q -n c_icap-%{version}
74    
75     %build
76     %configure \
77     CFLAGS="${RPM_OPT_FLAGS} -fno-strict-aliasing" \
78     --disable-static \
79     --sysconfdir=%{_sysconfdir}/%{name} \
80     --prefix='' \
81     --with-perl \
82     --with-zlib \
83     --with-bdb \
84     --with-ldap \
85     --enable-large-files
86    
87     %{__make} %{?_smp_mflags}
88    
89    
90     %install
91     [ -n "%{buildroot}" -a "%{buildroot}" != "/" ] && %{__rm} -rf %{buildroot}
92     %{__mkdir_p} %{buildroot}%{_sysconfdir}/logrotate.d
93     %{__mkdir_p} %{buildroot}%{_sbindir}
94     %{__mkdir_p} %{buildroot}%{_datadir}/c_icap/{contrib,templates}
95     %{__mkdir_p} %{buildroot}%{_localstatedir}/log/%{name}
96    
97     %{__make} DESTDIR=%{buildroot} install
98     %{__mv} -f %{buildroot}%{_bindir}/%{name} %{buildroot}%{_sbindir}
99     %{__install} -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
100     %{__install} -D -p -m 0644 %{SOURCE4} %{buildroot}%{_tmpfilesdir}/%{name}.conf
101     %{__install} -D -m 644 %{SOURCE1} %{buildroot}%{_unitdir}/c-icap.service
102     %{__install} -m 0755 contrib/*.pl %{buildroot}%{_datadir}/c_icap/contrib
103     %{__rm} -f %{buildroot}%{_libdir}/lib*.so.{?,??}
104    
105    
106     %pre
107     if ! getent group %{name} >/dev/null 2>&1; then
108     /usr/sbin/groupadd -r %{name}
109     fi
110     if ! getent passwd %{name} >/dev/null 2>&1; then
111     /usr/sbin/useradd -r -g %{name} \
112     -d %{_localstatedir}/run/%{name} \
113     -c "C-ICAP Service user" -M \
114     -s /sbin/nologin %{name}
115     fi
116     exit 0 # Always pass
117    
118    
119     %post
120     %systemd_post c-icap.service
121    
122     %post libs -p /sbin/ldconfig
123    
124     %preun
125     %systemd_preun c-icap.service
126    
127     %postun
128     %systemd_postun_with_restart c-icap.service
129    
130     %postun libs -p /sbin/ldconfig
131    
132     %files
133     %defattr(-,root,root)
134     %doc AUTHORS COPYING INSTALL README TODO
135     %attr(750,root,%{name}) %dir %{_sysconfdir}/%{name}
136     %attr(640,root,%{name}) %config(noreplace) %{_sysconfdir}/%{name}/*.conf
137     %attr(640,root,%{name}) %config(noreplace) %{_sysconfdir}/%{name}/*.magic
138     %attr(640,root,%{name}) %{_sysconfdir}/%{name}/*.default
139     %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
140     %{_unitdir}/c-icap.service
141     %dir %{_libdir}/c_icap
142     %{_libdir}/c_icap/bdb_tables.so
143     %{_libdir}/c_icap/dnsbl_tables.so
144     %{_libdir}/c_icap/srv_echo.so
145     %{_libdir}/c_icap/sys_logger.so
146     %{_libdir}/c_icap/shared_cache.so
147     %{_sbindir}/%{name}
148     %{_datadir}/c_icap
149     %{_mandir}/man8/%{name}.8*
150     %attr(750,%{name},%{name}) %dir %{_localstatedir}/log/%{name}
151     %attr(750,%{name},%{name}) %dir %{_localstatedir}/run/%{name}
152     %{_tmpfilesdir}/c-icap.conf
153    
154     %files devel
155     %defattr(-,root,root)
156     %{_bindir}/%{name}-*config
157     %{_includedir}/c_icap
158     %{_libdir}/libicapapi.*a
159     %{_libdir}/libicapapi.so
160     %{_libdir}/c_icap/bdb_tables.*a
161     %{_libdir}/c_icap/dnsbl_tables.*a
162     %{_libdir}/c_icap/ldap_module.*a
163     %{_libdir}/c_icap/perl_handler.*a
164     %{_libdir}/c_icap/srv_echo.*a
165     %{_libdir}/c_icap/sys_logger.*a
166     %{_libdir}/c_icap/srv_ex206.*a
167     %{_libdir}/c_icap/shared_cache.*a
168     %{_mandir}/man8/%{name}-*config.8*
169    
170     %files ldap
171     %defattr(-,root,root)
172     %{_libdir}/c_icap/ldap_module.so
173    
174     %files libs
175     %defattr(-,root,root)
176     %doc COPYING
177     %{_libdir}/libicapapi.so.*
178    
179     %{_libdir}/c_icap/srv_ex206.so
180    
181     %files perl
182     %defattr(-,root,root)
183     %{_libdir}/c_icap/perl_handler.so
184    
185     %files progs
186     %defattr(-,root,root)
187     %{_bindir}/%{name}-client
188     %{_bindir}/%{name}-mkbdb
189     %{_bindir}/%{name}-stretch
190     %{_mandir}/man8/%{name}-client.8*
191     %{_mandir}/man8/%{name}-mkbdb.8*
192     %{_mandir}/man8/%{name}-stretch.8*
193    
194    
195     %changelog
196     * Fri Aug 27 2021 Daniel Berteaud <daniel@firewall-services.com> 0.5.8-2
197     - Update to 0.5.8 (daniel@firewall-services.com)
198    
199     * Thu Nov 12 2020 Daniel Berteaud <daniel@firewall-services.com> 0.5.7-1
200     - Update to 0.5.7 (daniel@firewall-services.com)
201    
202     * Sat Nov 07 2020 Daniel Berteaud <daniel@firewall-services.com> 0.5.6-2
203     - BuildReq libdb-devel instead of db4-devel (daniel@firewall-services.com)
204    
205     * Wed Dec 11 2019 Daniel Berteaud <daniel@firewall-services.com> 0.5.6-1
206     - Update to 0.5.6 (daniel@firewall-services.com)
207    
208     * Tue Nov 27 2018 Daniel Berteaud <daniel@firewall-services.com> 0.5.5-1
209     - Update sources to 0.5.5 (daniel@firewall-services.com)
210     - Update tito config to use GitLfsBuilder (daniel@firewall-services.com)
211     - Track sources with git lfs (daniel@firewall-services.com)
212    
213     * Mon Feb 19 2018 Daniel Berteaud <daniel@firewall-services.com> 0.5.3-0.beta6
214     - Remove debug statements in service unit (daniel@firewall-services.com)
215    
216     * Sun Feb 18 2018 Daniel Berteaud <daniel@firewall-services.com> 0.5.3-1
217     - Stable release
218     - Clean spec file
219     - Use syslog for daemon logging
220     - Update to 0.5.3
221    
222     * Wed Sep 27 2017 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 0.5.2
223     - Rebuild for 0.5.2 on el7
224    
225     * Thu May 21 2015 Davide Principi <davide.principi@nethesis.it> - 0.4.2-1
226     - Rebuild for 0.4.2 on el7
227    
228     * Thu May 21 2015 Davide Principi <davide.principi@nethesis.it> - 0.3.5-1
229     - Rebuild for 0.3.5 on ns7
230    
231     * Thu May 30 2013 Giacomo Sanchietti <giacomo.sanchietti@nethesis.it> - 0.2.5
232     - Enable large files support
233     - New version 0.2.5
234    
235     * Fri Oct 21 2011 Peter Pramberger <peterpramb@member.fsf.org> - 0.1.7-1
236     - New version (0.1.7)
237    
238     * Mon Jun 06 2011 Peter Pramberger <peterpramb@member.fsf.org> - 0.1.6-1
239     - New version (0.1.6)
240    
241     * Mon Apr 04 2011 Peter Pramberger <peterpramb@member.fsf.org> - 0.1.5-1
242     - New version (0.1.5)
243    
244     * Mon Jan 17 2011 Peter Pramberger <peterpramb@member.fsf.org> - 0.1.4-1
245     - New version (0.1.4)
246    
247     * Tue Nov 02 2010 Peter Pramberger <peterpramb@member.fsf.org> - 0.1.3-1
248     - New version (0.1.3)
249    
250     * Fri Oct 15 2010 Peter Pramberger <peterpramb@member.fsf.org> - 0.1.2-1
251     - New version (0.1.2)
252    
253     * Mon Jul 05 2010 Peter Pramberger <peterpramb@member.fsf.org> - 0.1.1-1
254     - New version (0.1.1)
255    
256     * Wed Jun 02 2010 Peter Pramberger <peterpramb@member.fsf.org> - 0.1.1-0.1.pre3
257     - Initial build

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed