/[smecontribs]/rpms/c3/contribs8/c3.spec
ViewVC logotype

Annotation of /rpms/c3/contribs8/c3.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Sat Dec 4 16:26:10 2010 UTC (13 years, 5 months ago) by slords
Branch: MAIN
Initial import

1 slords 1.1 # $Id: c3-4.0.spec,v 1.2 2003/06/24 20:24:50 zbml1 Exp $
2    
3     %define name c3
4     %define ver 4.0.1
5     %define rel 1
6     %define prefix /opt/c3-4
7     %define profiled /etc/profile.d
8    
9     Summary: Cluster Command and Control (C3) - command line tool suite
10     Name: %{name}
11     Version: %{ver}
12     Release: %{rel}
13     License: freely distributable
14     Group: Application/System
15     Source0: %{name}-%{ver}.tar.gz
16     Packager: Thomas Naughton <naughtont@ornl.gov>
17     URL: http://www.csm.ornl.gov/torc/C3/
18     AutoReqProv: no
19     Requires: rsync
20     Requires: perl
21     Requires: /usr/bin/python2
22     BuildRoot: %{_tmppath}/%{name}-%{ver}-root
23    
24     %description
25     The Cluster Command and Control (C3) tool suite offers a command line
26     interface for system and user administration tasks on a cluster.
27    
28    
29    
30    
31     %package ckillnode
32     Summary: Cluster Command and Control (C3) - ckillnode
33     Group: Application/System
34    
35     %description ckillnode
36     The Cluster Command and Control (C3) - 'ckillnode' command used
37     on client nodes in conjunction with 'ckill' from headnode.
38    
39     NOTE: Only needed on client nodes.
40    
41    
42    
43     %package profiled
44     Summary: Cluster Command and Control (C3) - profile.d scripts
45     Group: Application/System
46     Requires: c3 >= 4
47    
48     %description profiled
49     The Cluster Command and Control (C3) tool suite offers a command line
50     interface for system and user administration tasks on a cluster.
51    
52     Scripts for PATHing information placed in the '/etc/profile.d/' area.
53    
54    
55    
56     #---------------------------------------------------------------------
57     # Prep install section
58     #---------------------------------------------------------------------
59    
60     %prep
61    
62     # Get rid of any previously built stuff that might cause problems.
63     # (only worried about things in RPM-land '/usr/src/redhat/' here)
64     %__rm -rf $RPM_BUILD_ROOT
65    
66     # Actually do the untar/gzip stuff
67     %setup -n %{name}-%{ver}
68    
69    
70    
71     #---------------------------------------------------------------------
72     # Build section
73     #---------------------------------------------------------------------
74    
75     %build
76    
77     # Copy the build distribution to target install dir. The files must
78     # exist in the desired location (path) when RPM checks the filelist. This
79     # is greatly simplified by using the BuildRoot (chroot sort of thing) method.
80     %__mkdir -p $RPM_BUILD_ROOT/%{prefix}
81     %__mkdir -p $RPM_BUILD_ROOT/%{profiled}
82    
83     %__cp -Rf $RPM_BUILD_DIR/%{name}-%{ver}/* \
84     $RPM_BUILD_ROOT/%{prefix}
85    
86     %__cp -Rf $RPM_BUILD_DIR/%{name}-%{ver}/c3.sh \
87     $RPM_BUILD_ROOT/%{profiled}
88    
89     %__cp -Rf $RPM_BUILD_DIR/%{name}-%{ver}/c3.csh \
90     $RPM_BUILD_ROOT/%{profiled}
91    
92    
93     #---------------------------------------------------------------------
94     # Clean section
95     #---------------------------------------------------------------------
96    
97     %clean
98     # Get rid of any tmp files in RPM land, ie. '/usr/src/redhat/BUILD/...'
99     %__rm -rf $RPM_BUILD_DIR/%{name}-%{ver}
100     %__rm -rf $RPM_BUILD_ROOT
101    
102    
103    
104     #---------------------------------------------------------------------
105     # Pre-un(install) section
106     #---------------------------------------------------------------------
107     %preun
108     %__rm -f %{prefix}/*.pyc
109    
110    
111    
112     #---------------------------------------------------------------------
113     # Post-un(install) section
114     #---------------------------------------------------------------------
115     %postun
116    
117    
118    
119     #---------------------------------------------------------------------
120     # Files section
121     #
122     # List all files that will make it to the target machine here. Note,
123     # that listing the entire dir, gets all the files withing. The %doc
124     # files are treated special and copied into the system doc area (eg. share).
125     #---------------------------------------------------------------------
126    
127     %files
128     %defattr(-,root,root)
129     %doc INSTALL KNOWN_BUGS README CHANGELOG
130     %{prefix}
131    
132    
133     %files ckillnode
134     %defattr(-,root,root)
135     %{prefix}/ckillnode
136    
137    
138     %files profiled
139     %defattr(-,root,root)
140     %{profiled}
141    
142    
143     #---------------------------------------------------------------------
144     # ChangeLog section
145     #---------------------------------------------------------------------
146     %changelog
147     * Wed Dec 04 2002 01:36:38AM Thomas Naughton <naughtont@ornl.gov>
148     - (3.1-3) Overhaul the RPM spec stuffo.
149     Consolidate 'c3, -profiled, -ckillnode' RPMs into a single SPEC file.
150     - Fix path for ckillnode, change to also be '/opt/c3-3'.
151     - Additionally, this is using the newer version of 'ckillnode' that was
152     in the 3.1.1 tarball.
153    
154     * Wed May 29 2002 11:15:18AM Thomas Naughton <naughtont@ornl.gov>
155     - (3.1-2) Changed the pre-reqs to be '/usr/bin/python2' to work better
156     w/ OSCAR and non-RedHat based systems that don't use the "Python" (1.x)
157     and "Python2" (2.x) RPM naming for co-existence.
158    
159     * Thu May 16 2002 21:00:32PM modified by: tjn <naughtont@ornl.gov>
160     - Upgraded to c3-3.1 (BRANCH-TAG=branch-c3-3-1, rel=1)
161     - LAM/MPI rocks (http://www.lam-mpi.org/) THANKS JEFF! :)
162     Jeff Squyres fixed things up to use BuildRoot, which fixed lots!
163     - Added the %preun to get rid of the *.pyc files (pre-compiled bytecode).
164     - Moved the 'profile.d' stuff to a seperate RPM "c3-profiled". This
165     cleans things up here and also allows for use of switcher only w/o
166     the profile.d/ scripts (partially OSCAR related).
167     - Fixed the '-U' & '-e' errors for similarly named files.
168     - Cleaning things up, everything stays in '/opt/c3-3' (ie. %{prefix} )
169     including the Man pages, Brian moved mans to the more std man/manN/ form.
170     - Removed the postun stuff that breaks stuff! Bad tjn...
171     - Misc clean ups and added *many* more comments.
172     - Generate these as noarch.
173     - Generate these w/ Python2 deps
174    
175     * Tue May 14 2002 10:25:23AM modified by: tjn <naughtont@ornl.gov>
176     - Adding this to a CVS repository...not changing the rel# (2.7.2-4)
177    
178     * Mon Apr 01 2002 10:21:34AM modified by: tjn <naughtont@ornl.gov>
179     - Using RPM provided macros for cat, cp & rm until I upgrade the entire RPM
180     see also: /usr/lib/rpm/macros
181     - Also removed echo to STDOUT, assume users can edit c3.conf and created
182     a 'c3-ckillnode-2.7.2-X' RPM for use on client nodes.
183     - On a related note, I created a c3-ckillnode RPM for use on clients.
184    
185     * Thu Dec 13 2001 09:35:50AM modified by: tjn <naughtont@ornl.org>
186     - Changed the c3.conf stuff to only create a new if one doesn't exist.
187    
188     * Wed Dec 12 2001 11:18:02AM modified by: tjn <naughtont@ornl.org>
189     - removed some of the extra stuff printed upon 'rpm -ivh' & added 'Requires:'.
190    
191     * Tue Dec 11 2001 13:28:32PM modified by: tjn <naughtont@ornl.org>
192     - fixed problem related to only c3.1 man page being install.
193    
194     * Fri Aug 24 2001 10:25:55AM modified by: tjn <naughtont@ornl.gov>
195     - changed the name for the Source1 & Source2 to be specific to version
196    
197     * Tue Jul 31 2001 14:06:02PM modified by: tjn <naughtont@ornl.gov>
198     - check for exiting defs on the /etc/profile.d/ files
199     (this also required me to change the echo of the contents to actual a copy!)
200    
201     * Tue Jun 19 2001 Thomas Naughton <naughtontiii@ornl.gov>
202     - Creation of initial c3-2.7.2 rpm

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed