/[smecontribs]/rpms/c3/contribs8/c3.spec
ViewVC logotype

Annotation of /rpms/c3/contribs8/c3.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Sat Dec 4 16:31:53 2010 UTC (13 years, 5 months ago) by slords
Branch: MAIN
CVS Tags: c3-4_0_1-1_el5_sme, HEAD
Changes since 1.1: +4 -3 lines
Spec cleanups

1 slords 1.2 # $Id$
2     # Authority: slords
3     # Name: Shad L. Lords
4 slords 1.1
5     %define name c3
6     %define ver 4.0.1
7     %define rel 1
8     %define prefix /opt/c3-4
9     %define profiled /etc/profile.d
10    
11     Summary: Cluster Command and Control (C3) - command line tool suite
12     Name: %{name}
13     Version: %{ver}
14 slords 1.2 Release: %{rel}%{?dist}
15 slords 1.1 License: freely distributable
16     Group: Application/System
17     Source0: %{name}-%{ver}.tar.gz
18     URL: http://www.csm.ornl.gov/torc/C3/
19     AutoReqProv: no
20     Requires: rsync
21     Requires: perl
22     Requires: /usr/bin/python2
23     BuildRoot: %{_tmppath}/%{name}-%{ver}-root
24    
25     %description
26     The Cluster Command and Control (C3) tool suite offers a command line
27     interface for system and user administration tasks on a cluster.
28    
29    
30    
31    
32     %package ckillnode
33     Summary: Cluster Command and Control (C3) - ckillnode
34     Group: Application/System
35    
36     %description ckillnode
37     The Cluster Command and Control (C3) - 'ckillnode' command used
38     on client nodes in conjunction with 'ckill' from headnode.
39    
40     NOTE: Only needed on client nodes.
41    
42    
43    
44     %package profiled
45     Summary: Cluster Command and Control (C3) - profile.d scripts
46     Group: Application/System
47     Requires: c3 >= 4
48    
49     %description profiled
50     The Cluster Command and Control (C3) tool suite offers a command line
51     interface for system and user administration tasks on a cluster.
52    
53     Scripts for PATHing information placed in the '/etc/profile.d/' area.
54    
55    
56    
57     #---------------------------------------------------------------------
58     # Prep install section
59     #---------------------------------------------------------------------
60    
61     %prep
62    
63     # Get rid of any previously built stuff that might cause problems.
64     # (only worried about things in RPM-land '/usr/src/redhat/' here)
65     %__rm -rf $RPM_BUILD_ROOT
66    
67     # Actually do the untar/gzip stuff
68     %setup -n %{name}-%{ver}
69    
70    
71    
72     #---------------------------------------------------------------------
73     # Build section
74     #---------------------------------------------------------------------
75    
76     %build
77    
78     # Copy the build distribution to target install dir. The files must
79     # exist in the desired location (path) when RPM checks the filelist. This
80     # is greatly simplified by using the BuildRoot (chroot sort of thing) method.
81     %__mkdir -p $RPM_BUILD_ROOT/%{prefix}
82     %__mkdir -p $RPM_BUILD_ROOT/%{profiled}
83    
84     %__cp -Rf $RPM_BUILD_DIR/%{name}-%{ver}/* \
85     $RPM_BUILD_ROOT/%{prefix}
86    
87     %__cp -Rf $RPM_BUILD_DIR/%{name}-%{ver}/c3.sh \
88     $RPM_BUILD_ROOT/%{profiled}
89    
90     %__cp -Rf $RPM_BUILD_DIR/%{name}-%{ver}/c3.csh \
91     $RPM_BUILD_ROOT/%{profiled}
92    
93    
94     #---------------------------------------------------------------------
95     # Clean section
96     #---------------------------------------------------------------------
97    
98     %clean
99     # Get rid of any tmp files in RPM land, ie. '/usr/src/redhat/BUILD/...'
100     %__rm -rf $RPM_BUILD_DIR/%{name}-%{ver}
101     %__rm -rf $RPM_BUILD_ROOT
102    
103    
104    
105     #---------------------------------------------------------------------
106     # Pre-un(install) section
107     #---------------------------------------------------------------------
108     %preun
109     %__rm -f %{prefix}/*.pyc
110    
111    
112    
113     #---------------------------------------------------------------------
114     # Post-un(install) section
115     #---------------------------------------------------------------------
116     %postun
117    
118    
119    
120     #---------------------------------------------------------------------
121     # Files section
122     #
123     # List all files that will make it to the target machine here. Note,
124     # that listing the entire dir, gets all the files withing. The %doc
125     # files are treated special and copied into the system doc area (eg. share).
126     #---------------------------------------------------------------------
127    
128     %files
129     %defattr(-,root,root)
130     %doc INSTALL KNOWN_BUGS README CHANGELOG
131     %{prefix}
132    
133    
134     %files ckillnode
135     %defattr(-,root,root)
136     %{prefix}/ckillnode
137    
138    
139     %files profiled
140     %defattr(-,root,root)
141     %{profiled}
142    
143    
144     #---------------------------------------------------------------------
145     # ChangeLog section
146     #---------------------------------------------------------------------
147     %changelog
148     * Wed Dec 04 2002 01:36:38AM Thomas Naughton <naughtont@ornl.gov>
149     - (3.1-3) Overhaul the RPM spec stuffo.
150     Consolidate 'c3, -profiled, -ckillnode' RPMs into a single SPEC file.
151     - Fix path for ckillnode, change to also be '/opt/c3-3'.
152     - Additionally, this is using the newer version of 'ckillnode' that was
153     in the 3.1.1 tarball.
154    
155     * Wed May 29 2002 11:15:18AM Thomas Naughton <naughtont@ornl.gov>
156     - (3.1-2) Changed the pre-reqs to be '/usr/bin/python2' to work better
157     w/ OSCAR and non-RedHat based systems that don't use the "Python" (1.x)
158     and "Python2" (2.x) RPM naming for co-existence.
159    
160     * Thu May 16 2002 21:00:32PM modified by: tjn <naughtont@ornl.gov>
161     - Upgraded to c3-3.1 (BRANCH-TAG=branch-c3-3-1, rel=1)
162     - LAM/MPI rocks (http://www.lam-mpi.org/) THANKS JEFF! :)
163     Jeff Squyres fixed things up to use BuildRoot, which fixed lots!
164     - Added the %preun to get rid of the *.pyc files (pre-compiled bytecode).
165     - Moved the 'profile.d' stuff to a seperate RPM "c3-profiled". This
166     cleans things up here and also allows for use of switcher only w/o
167     the profile.d/ scripts (partially OSCAR related).
168     - Fixed the '-U' & '-e' errors for similarly named files.
169     - Cleaning things up, everything stays in '/opt/c3-3' (ie. %{prefix} )
170     including the Man pages, Brian moved mans to the more std man/manN/ form.
171     - Removed the postun stuff that breaks stuff! Bad tjn...
172     - Misc clean ups and added *many* more comments.
173     - Generate these as noarch.
174     - Generate these w/ Python2 deps
175    
176     * Tue May 14 2002 10:25:23AM modified by: tjn <naughtont@ornl.gov>
177     - Adding this to a CVS repository...not changing the rel# (2.7.2-4)
178    
179     * Mon Apr 01 2002 10:21:34AM modified by: tjn <naughtont@ornl.gov>
180     - Using RPM provided macros for cat, cp & rm until I upgrade the entire RPM
181     see also: /usr/lib/rpm/macros
182     - Also removed echo to STDOUT, assume users can edit c3.conf and created
183     a 'c3-ckillnode-2.7.2-X' RPM for use on client nodes.
184     - On a related note, I created a c3-ckillnode RPM for use on clients.
185    
186     * Thu Dec 13 2001 09:35:50AM modified by: tjn <naughtont@ornl.org>
187     - Changed the c3.conf stuff to only create a new if one doesn't exist.
188    
189     * Wed Dec 12 2001 11:18:02AM modified by: tjn <naughtont@ornl.org>
190     - removed some of the extra stuff printed upon 'rpm -ivh' & added 'Requires:'.
191    
192     * Tue Dec 11 2001 13:28:32PM modified by: tjn <naughtont@ornl.org>
193     - fixed problem related to only c3.1 man page being install.
194    
195     * Fri Aug 24 2001 10:25:55AM modified by: tjn <naughtont@ornl.gov>
196     - changed the name for the Source1 & Source2 to be specific to version
197    
198     * Tue Jul 31 2001 14:06:02PM modified by: tjn <naughtont@ornl.gov>
199     - check for exiting defs on the /etc/profile.d/ files
200     (this also required me to change the echo of the contents to actual a copy!)
201    
202     * Tue Jun 19 2001 Thomas Naughton <naughtontiii@ornl.gov>
203     - Creation of initial c3-2.7.2 rpm

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed