1 |
# define name of the scl |
2 |
%global scl python27 |
3 |
%scl_package %scl |
4 |
|
5 |
# Defaults for the values for the python27/rh-python35 Software Collection. These |
6 |
# will be used when python27-scldevel (or rh-python35-scldevel) is not in the |
7 |
# build root |
8 |
%{!?scl_python:%global scl_python python27} |
9 |
%{!?scl_no_vendor:%global scl_no_vendor python27} |
10 |
%{!?scl_prefix_python:%global scl_prefix_python %{scl_python}-} |
11 |
|
12 |
# Only for this build, you need to override default __os_install_post, |
13 |
# because the default one would find /opt/.../lib/python2.7/ and try |
14 |
# to bytecompile with the system /usr/bin/python2.7 |
15 |
%global __os_install_post %{%{scl_no_vendor}_os_install_post} |
16 |
# Similarly, override __python_requires for automatic dependency generator |
17 |
%global __python_requires %{%{scl_no_vendor}_python_requires} |
18 |
|
19 |
|
20 |
%define major 0 |
21 |
%define libname lib%{ccnet} |
22 |
%define develname %{ccnet}-devel |
23 |
%define release 1 |
24 |
%define ccnet ccnet |
25 |
Name: %{ccnet}-server |
26 |
Version: 6.2.5 |
27 |
Release: %{release}%{dist} |
28 |
Summary: Networking library for Seafile |
29 |
License: GPLv3+ |
30 |
Group: Networking/File transfer |
31 |
URL: https://github.com/haiwen/ccnet-server |
32 |
Source0: https://github.com/haiwen/ccnet-server/archive/v%{version}/%{name}-%{version}.tar.gz |
33 |
BuildRequires: pkgconfig(glib-2.0) |
34 |
# BuildRequires: pkgconfig(jansson) |
35 |
BuildRequires: sqlite-devel |
36 |
BuildRequires: sqlite |
37 |
Buildrequires: postgresql-devel |
38 |
Buildrequires: mysql-devel |
39 |
BuildRequires: pkgconfig(openssl) |
40 |
BuildRequires: pkgconfig(libevent) |
41 |
BuildRequires: pkgconfig(uuid) >= 2.0 |
42 |
BuildRequires: pkgconfig(libsearpc) |
43 |
# maybe better with Buildrequires: %{scl_prefix_python}-libsearpc-devel |
44 |
#BuildRequires: pkgconfig(python2) |
45 |
# not for sclo py27 BuildRequires: python-devel |
46 |
#BuildRequires: vala >= 0.26 |
47 |
BuildRequires: vala |
48 |
Buildrequires: autoconf |
49 |
Buildrequires: automake |
50 |
Buildrequires: libtool |
51 |
# server requirements |
52 |
BuildRequires: pkgconfig(zdb) |
53 |
# scl python27 |
54 |
BuildRequires: scl-utils-build |
55 |
BuildRequires: %{scl_prefix_python}scldevel |
56 |
BuildRequires: %{scl_prefix_python}python-devel |
57 |
BuildRequires: %{scl_prefix_python}build |
58 |
BuildArch: x86_64 |
59 |
|
60 |
Requires: %{scl_prefix_python}pythonegg(2)(ccnet) = %{version}-%{release} |
61 |
|
62 |
%description |
63 |
Ccnet is a framework for writing networked applications in C. |
64 |
|
65 |
#---------------------------------------------------- |
66 |
|
67 |
%package server |
68 |
Summary: Ccnet server |
69 |
Group: Networking/File transfer |
70 |
Requires: %{scl_prefix_python}pythonegg(2)(ccnet) = %{version}-%{release} |
71 |
|
72 |
%description server |
73 |
Ccnet is a framework for writing networked applications in C. |
74 |
This package contains the server part for %{name}. |
75 |
|
76 |
#---------------------------------------------------- |
77 |
|
78 |
%package -n %{libname} |
79 |
Summary: Library for %{name} |
80 |
Group: System/Libraries |
81 |
|
82 |
%description -n %{libname} |
83 |
Ccnet is a framework for writing networked applications in C. |
84 |
This package contains library files for %{name}. |
85 |
|
86 |
#---------------------------------------------------- |
87 |
|
88 |
%package -n %{develname} |
89 |
Summary: Development files for %{name} |
90 |
Group: Development/C |
91 |
Requires: %{libname} = %{version}-%{release} |
92 |
Provides: %{name}-devel = %{version}-%{release} |
93 |
Provides: lib%{name}-devel = %{version}-%{release} |
94 |
|
95 |
%description -n %{develname} |
96 |
The %{develname} package contains libraries and header files for |
97 |
developing applications that use %{name}. |
98 |
|
99 |
#---------------------------------------------------- |
100 |
|
101 |
%package -n %{scl_prefix_python}python-%{ccnet} |
102 |
Summary: Python 2 bindings for %{name} |
103 |
Group: Development/Python |
104 |
Provides: %{scl_prefix_python}pythonegg(2)(ccnet) = %{version}-%{release} |
105 |
|
106 |
%description -n %{scl_prefix_python}python-%{ccnet} |
107 |
Ccnet is a framework for writing networked applications in C. |
108 |
This package contains the python 2 bindings for %{name}. |
109 |
|
110 |
#---------------------------------------------------- |
111 |
|
112 |
%package -n %{name}-debug |
113 |
Summary: Debug for %{name} |
114 |
Group: Development/C |
115 |
|
116 |
%description -n %{name}-debug |
117 |
Ccnet is a framework for writing networked applications in C. |
118 |
|
119 |
#---------------------------------------------------- |
120 |
|
121 |
%prep |
122 |
%setup -q |
123 |
|
124 |
sed -i -e /\(DESTDIR\)/d libccnet.pc.in |
125 |
|
126 |
NOCONFIGURE=1 ./autogen.sh |
127 |
|
128 |
%build |
129 |
scl enable %{scl_python} "bash" |
130 |
%{?scl:scl enable %{scl_python} - << \EOF} |
131 |
export PYTHON='/opt/rh/python27/root/usr/bin/python' |
132 |
%configure \ |
133 |
--disable-static \ |
134 |
make |
135 |
%{?scl:EOF} |
136 |
|
137 |
%install |
138 |
%scl_install |
139 |
%{?scl:scl enable %{scl_python} - << \EOF} |
140 |
export PYTHON='/opt/rh/python27/root/usr/bin/python' |
141 |
%{__make} install DESTDIR=%{buildroot} |
142 |
%{?scl:EOF} |
143 |
|
144 |
# we don't want these |
145 |
find %{buildroot} -name '*.la' -delete |
146 |
rm -rf %{buildroot}/etc/rpm/macros.python27-config |
147 |
rm -rf %{buildroot}/etc/scl/prefixes/python27 |
148 |
rm -rf %{buildroot}/opt/rh/python27/root/usr/tmp |
149 |
rm -rf %{buildroot}/opt/rh/python27/root/var/mail |
150 |
|
151 |
ls -R %{buildroot} |grep -v man >/dev/stderr |
152 |
|
153 |
%files |
154 |
%doc HACKING README.markdown |
155 |
#%doc COPYRIGHT |
156 |
%{_bindir}/%{name} |
157 |
%{_bindir}/ccnet-init |
158 |
# %{_bindir}/ccnet-tool |
159 |
# %{_bindir}/ccnet-servtool |
160 |
|
161 |
%files -n %{libname} |
162 |
%{_libdir}/libccnet.so.%{major} |
163 |
%{_libdir}/libccnet.so.%{major}.* |
164 |
|
165 |
%files -n %{develname} |
166 |
%doc HACKING README.markdown |
167 |
%{_includedir}/* |
168 |
%{_libdir}/libccnet.so |
169 |
%{_libdir}/pkgconfig/libccnet.pc |
170 |
|
171 |
%files -n %{scl_prefix_python}python-%{ccnet} |
172 |
%doc HACKING README.markdown |
173 |
%{python_sitearch}/ccnet/ |
174 |
|
175 |
%files -n %{name}-debug |
176 |
/usr/src/debug/* |
177 |
/usr/lib/debug/.build-id/* |
178 |
/usr/lib/debug/opt/rh/python27/root/usr/bin/* |
179 |
/usr/lib/debug/opt/rh/python27/root/usr/lib64/* |
180 |
|
181 |
%changelog |
182 |
* Sat Apr 07 2018 Jean-Philipe Pialasse <tests@pialasse.com> Version: 6.2.5-1.sme |
183 |
- initial build of ccnet-server 6.2.5 |
184 |
|
185 |
|