1 |
jpp |
1.2 |
%define major 0 |
2 |
|
|
%define libname lib%{name} |
3 |
|
|
%define develname %{name}-devel |
4 |
jpp |
1.3 |
%define release 4 |
5 |
jpp |
1.2 |
Name: ccnet |
6 |
|
|
Version: 5.1.3 |
7 |
|
|
Release: %{release}%{dist} |
8 |
|
|
Summary: Networking library for Seafile |
9 |
|
|
License: GPLv3+ |
10 |
|
|
Group: Networking/File transfer |
11 |
|
|
URL: https://github.com/haiwen/ccnet |
12 |
|
|
Source0: https://github.com/haiwen/ccnet/archive/v%{version}/%{name}-%{version}.tar.gz |
13 |
|
|
#Source0: https://github.com/haiwen/ccnet/archive/v%{version}/v%{version}.tar.gz |
14 |
|
|
BuildRequires: pkgconfig(glib-2.0) |
15 |
|
|
BuildRequires: pkgconfig(jansson) |
16 |
|
|
#BuildRequires: pkgconfig(sqlite3) |
17 |
|
|
BuildRequires: sqlite-devel |
18 |
|
|
BuildRequires: sqlite |
19 |
|
|
BuildRequires: pkgconfig(openssl) |
20 |
|
|
BuildRequires: pkgconfig(libevent) |
21 |
|
|
BuildRequires: pkgconfig(uuid) >= 2.0 |
22 |
|
|
BuildRequires: pkgconfig(libsearpc) |
23 |
|
|
#BuildRequires: pkgconfig(python2) |
24 |
|
|
BuildRequires: python-devel |
25 |
|
|
#BuildRequires: vala >= 0.26 |
26 |
|
|
BuildRequires: vala |
27 |
|
|
Buildrequires: autoconf |
28 |
|
|
Buildrequires: automake |
29 |
|
|
Buildrequires: libtool |
30 |
|
|
# server requirements |
31 |
|
|
BuildRequires: pkgconfig(zdb) |
32 |
jpp |
1.1 |
|
33 |
jpp |
1.2 |
Requires: pythonegg(2)(ccnet) = %{version}-%{release} |
34 |
jpp |
1.1 |
|
35 |
jpp |
1.2 |
%description |
36 |
|
|
Ccnet is a framework for writing networked applications in C. |
37 |
|
|
|
38 |
|
|
#---------------------------------------------------- |
39 |
jpp |
1.1 |
|
40 |
jpp |
1.2 |
%package server |
41 |
|
|
Summary: Ccnet server |
42 |
|
|
Group: Networking/File transfer |
43 |
|
|
Requires: pythonegg(2)(ccnet) = %{version}-%{release} |
44 |
jpp |
1.1 |
|
45 |
jpp |
1.2 |
%description server |
46 |
|
|
Ccnet is a framework for writing networked applications in C. |
47 |
|
|
This package contains the server part for %{name}. |
48 |
jpp |
1.1 |
|
49 |
jpp |
1.2 |
#---------------------------------------------------- |
50 |
jpp |
1.1 |
|
51 |
jpp |
1.2 |
%package -n %{libname} |
52 |
|
|
Summary: Library for %{name} |
53 |
|
|
Group: System/Libraries |
54 |
jpp |
1.1 |
|
55 |
jpp |
1.2 |
%description -n %{libname} |
56 |
|
|
Ccnet is a framework for writing networked applications in C. |
57 |
|
|
This package contains library files for %{name}. |
58 |
jpp |
1.1 |
|
59 |
jpp |
1.2 |
#---------------------------------------------------- |
60 |
jpp |
1.1 |
|
61 |
jpp |
1.2 |
%package -n %{develname} |
62 |
|
|
Summary: Development files for %{name} |
63 |
|
|
Group: Development/C |
64 |
|
|
Requires: %{libname} = %{version}-%{release} |
65 |
|
|
Provides: %{name}-devel = %{version}-%{release} |
66 |
|
|
Provides: lib%{name}-devel = %{version}-%{release} |
67 |
jpp |
1.1 |
|
68 |
jpp |
1.2 |
%description -n %{develname} |
69 |
|
|
The %{develname} package contains libraries and header files for |
70 |
jpp |
1.1 |
developing applications that use %{name}. |
71 |
|
|
|
72 |
jpp |
1.2 |
#---------------------------------------------------- |
73 |
|
|
|
74 |
|
|
%package -n python-%{name} |
75 |
|
|
Summary: Python 2 bindings for %{name} |
76 |
|
|
Group: Development/Python |
77 |
|
|
BuildArch: noarch |
78 |
|
|
Provides: pythonegg(2)(ccnet) = %{version}-%{release} |
79 |
|
|
|
80 |
|
|
%description -n python-%{name} |
81 |
|
|
Ccnet is a framework for writing networked applications in C. |
82 |
|
|
This package contains the python 2 bindings for %{name}. |
83 |
|
|
|
84 |
|
|
#---------------------------------------------------- |
85 |
jpp |
1.1 |
|
86 |
|
|
%prep |
87 |
jpp |
1.2 |
%setup -q |
88 |
|
|
|
89 |
jpp |
1.1 |
sed -i -e /\(DESTDIR\)/d libccnet.pc.in |
90 |
|
|
|
91 |
jpp |
1.2 |
NOCONFIGURE=1 ./autogen.sh |
92 |
jpp |
1.1 |
|
93 |
|
|
%build |
94 |
jpp |
1.2 |
#%configure2_5x \ |
95 |
|
|
%configure \ |
96 |
|
|
--enable-server \ |
97 |
|
|
--disable-static \ |
98 |
|
|
--disable-compile-demo |
99 |
|
|
#%make_build |
100 |
|
|
make |
101 |
jpp |
1.1 |
|
102 |
|
|
%install |
103 |
jpp |
1.2 |
#%make_install |
104 |
|
|
#make install |
105 |
jpp |
1.1 |
%{__make} install DESTDIR=%{buildroot} |
106 |
|
|
|
107 |
jpp |
1.2 |
# we don't want these |
108 |
|
|
find %{buildroot} -name '*.la' -delete |
109 |
jpp |
1.1 |
|
110 |
|
|
%files |
111 |
|
|
%doc HACKING README.markdown |
112 |
jpp |
1.2 |
#%doc COPYRIGHT |
113 |
|
|
%{_bindir}/%{name} |
114 |
|
|
%{_bindir}/%{name}-init |
115 |
|
|
%{_bindir}/%{name}-tool |
116 |
jpp |
1.1 |
|
117 |
jpp |
1.2 |
%files server |
118 |
|
|
%doc HACKING README.markdown |
119 |
|
|
#%doc COPYRIGHT |
120 |
|
|
%{_bindir}/%{name}-server |
121 |
|
|
%{_bindir}/%{name}-servtool |
122 |
|
|
|
123 |
|
|
%files -n %{libname} |
124 |
|
|
%{_libdir}/lib%{name}.so.%{major} |
125 |
|
|
%{_libdir}/lib%{name}.so.%{major}.* |
126 |
jpp |
1.1 |
|
127 |
jpp |
1.2 |
%files -n %{develname} |
128 |
|
|
%doc HACKING README.markdown |
129 |
jpp |
1.1 |
%{_includedir}/* |
130 |
jpp |
1.2 |
%{_libdir}/lib%{name}.so |
131 |
jpp |
1.1 |
%{_libdir}/pkgconfig/lib%{name}.pc |
132 |
|
|
|
133 |
jpp |
1.2 |
%files -n python-%{name} |
134 |
|
|
%doc HACKING README.markdown |
135 |
|
|
%{python_sitearch}/%{name}/ |
136 |
|
|
|
137 |
jpp |
1.1 |
|
138 |
|
|
%changelog |
139 |
jpp |
1.3 |
* Mon Feb 19 2018 Jean-Philippe Pialasse <tests@pialasse.com> - 5.1.3-4 |
140 |
jpp |
1.2 |
- rebuild with lib and server packages |
141 |
|
|
|
142 |
|
|
* Mon Feb 19 2018 Jean-Philippe Pialasse <tests@pialasse.com> - 5.1.3-2 |
143 |
jpp |
1.1 |
- first import for SME Server |
144 |
|
|
- adapt spec file for buildsystem |
145 |
|
|
|
146 |
jpp |
1.2 |
* Tue Nov 01 2016 daviddavid <daviddavid> 5.1.3-1.mga5 |
147 |
|
|
+ Revision: 1064478 |
148 |
|
|
- new version: 5.1.3 |
149 |
|
|
|
150 |
|
|
+ neoclust <neoclust> |
151 |
|
|
- Use version 5.1.2 in backports |
152 |
|
|
- Add to backports |
153 |
|
|
|
154 |
|
|
* Thu Jun 30 2016 daviddavid <daviddavid> 5.1.3-1.mga6 |
155 |
|
|
+ Revision: 1038171 |
156 |
|
|
- new version: 5.1.3 |
157 |
|
|
|
158 |
|
|
* Thu May 12 2016 daviddavid <daviddavid> 5.1.1-2.mga6 |
159 |
|
|
+ Revision: 1014278 |
160 |
|
|
- add the server part of ccnet |
161 |
|
|
|
162 |
|
|
* Fri May 06 2016 daviddavid <daviddavid> 5.1.1-1.mga6 |
163 |
|
|
+ Revision: 1009881 |
164 |
|
|
- initial package ccnet |
165 |
jpp |
1.1 |
|