/[smecontribs]/rpms/ccnet/contribs9/ccnet.spec
ViewVC logotype

Annotation of /rpms/ccnet/contribs9/ccnet.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Mon Mar 26 20:51:50 2018 UTC (6 years, 2 months ago) by jpp
Branch: MAIN
CVS Tags: ccnet-5_1_3-5_el6_sme
Changes since 1.3: +62 -10 lines
* Mon Mar 26 2018 Jean-Philipe Pialasse <tests@pialasse.com> Version:	5.1.3-5.sme
- rebuild for python27 sclo

1 jpp 1.4 # define name of the scl
2     %global scl python27
3     %scl_package %scl
4    
5     # Defaults for the values for the python27/rh-python35 Software Collection. These
6     # will be used when python27-scldevel (or rh-python35-scldevel) is not in the
7     # build root
8     %{!?scl_python:%global scl_python python27}
9     %{!?scl_no_vendor:%global scl_no_vendor python27}
10     %{!?scl_prefix_python:%global scl_prefix_python %{scl_python}-}
11    
12     # Only for this build, you need to override default __os_install_post,
13     # because the default one would find /opt/.../lib/python2.7/ and try
14     # to bytecompile with the system /usr/bin/python2.7
15     %global __os_install_post %{%{scl_no_vendor}_os_install_post}
16     # Similarly, override __python_requires for automatic dependency generator
17     %global __python_requires %{%{scl_no_vendor}_python_requires}
18    
19    
20 jpp 1.2 %define major 0
21     %define libname lib%{name}
22     %define develname %{name}-devel
23 jpp 1.4 %define release 5
24 jpp 1.2 Name: ccnet
25     Version: 5.1.3
26     Release: %{release}%{dist}
27     Summary: Networking library for Seafile
28     License: GPLv3+
29     Group: Networking/File transfer
30     URL: https://github.com/haiwen/ccnet
31     Source0: https://github.com/haiwen/ccnet/archive/v%{version}/%{name}-%{version}.tar.gz
32     #Source0: https://github.com/haiwen/ccnet/archive/v%{version}/v%{version}.tar.gz
33     BuildRequires: pkgconfig(glib-2.0)
34     BuildRequires: pkgconfig(jansson)
35     #BuildRequires: pkgconfig(sqlite3)
36     BuildRequires: sqlite-devel
37     BuildRequires: sqlite
38     BuildRequires: pkgconfig(openssl)
39     BuildRequires: pkgconfig(libevent)
40     BuildRequires: pkgconfig(uuid) >= 2.0
41     BuildRequires: pkgconfig(libsearpc)
42 jpp 1.4 # maybe better with Buildrequires: %{scl_prefix_python}-libsearpc-devel
43 jpp 1.2 #BuildRequires: pkgconfig(python2)
44 jpp 1.4 # not for sclo py27 BuildRequires: python-devel
45 jpp 1.2 #BuildRequires: vala >= 0.26
46     BuildRequires: vala
47     Buildrequires: autoconf
48     Buildrequires: automake
49     Buildrequires: libtool
50     # server requirements
51     BuildRequires: pkgconfig(zdb)
52 jpp 1.4 # scl python27
53     BuildRequires: scl-utils-build
54     BuildRequires: %{scl_prefix_python}scldevel
55     BuildRequires: %{scl_prefix_python}python-devel
56     BuildRequires: %{scl_prefix_python}build
57     BuildArch: x86_64
58 jpp 1.1
59 jpp 1.4 Requires: %{scl_prefix_python}pythonegg(2)(ccnet) = %{version}-%{release}
60 jpp 1.1
61 jpp 1.2 %description
62     Ccnet is a framework for writing networked applications in C.
63    
64     #----------------------------------------------------
65 jpp 1.1
66 jpp 1.2 %package server
67     Summary: Ccnet server
68     Group: Networking/File transfer
69     Requires: pythonegg(2)(ccnet) = %{version}-%{release}
70 jpp 1.1
71 jpp 1.2 %description server
72     Ccnet is a framework for writing networked applications in C.
73     This package contains the server part for %{name}.
74 jpp 1.1
75 jpp 1.2 #----------------------------------------------------
76 jpp 1.1
77 jpp 1.2 %package -n %{libname}
78     Summary: Library for %{name}
79     Group: System/Libraries
80 jpp 1.1
81 jpp 1.2 %description -n %{libname}
82     Ccnet is a framework for writing networked applications in C.
83     This package contains library files for %{name}.
84 jpp 1.1
85 jpp 1.2 #----------------------------------------------------
86 jpp 1.1
87 jpp 1.2 %package -n %{develname}
88     Summary: Development files for %{name}
89     Group: Development/C
90     Requires: %{libname} = %{version}-%{release}
91     Provides: %{name}-devel = %{version}-%{release}
92     Provides: lib%{name}-devel = %{version}-%{release}
93 jpp 1.1
94 jpp 1.2 %description -n %{develname}
95     The %{develname} package contains libraries and header files for
96 jpp 1.1 developing applications that use %{name}.
97    
98 jpp 1.2 #----------------------------------------------------
99    
100 jpp 1.4 %package -n %{scl_prefix_python}python-%{name}
101 jpp 1.2 Summary: Python 2 bindings for %{name}
102     Group: Development/Python
103 jpp 1.4 Provides: %{scl_prefix_python}pythonegg(2)(ccnet) = %{version}-%{release}
104 jpp 1.2
105 jpp 1.4 %description -n %{scl_prefix_python}python-%{name}
106 jpp 1.2 Ccnet is a framework for writing networked applications in C.
107     This package contains the python 2 bindings for %{name}.
108    
109     #----------------------------------------------------
110 jpp 1.1
111 jpp 1.4 %package -n %{name}-debug
112     Summary: Debug for %{name}
113     Group: Development/C
114    
115     %description -n %{name}-debug
116     Ccnet is a framework for writing networked applications in C.
117    
118     #----------------------------------------------------
119    
120 jpp 1.1 %prep
121 jpp 1.2 %setup -q
122    
123 jpp 1.1 sed -i -e /\(DESTDIR\)/d libccnet.pc.in
124    
125 jpp 1.2 NOCONFIGURE=1 ./autogen.sh
126 jpp 1.1
127     %build
128 jpp 1.4 scl enable %{scl_python} "bash"
129     %{?scl:scl enable %{scl_python} - << \EOF}
130     export PYTHON='/opt/rh/python27/root/usr/bin/python'
131 jpp 1.2 #%configure2_5x \
132     %configure \
133     --enable-server \
134     --disable-static \
135     --disable-compile-demo
136     #%make_build
137     make
138 jpp 1.4 %{?scl:EOF}
139 jpp 1.1
140     %install
141 jpp 1.4 %scl_install
142     %{?scl:scl enable %{scl_python} - << \EOF}
143     export PYTHON='/opt/rh/python27/root/usr/bin/python'
144 jpp 1.1 %{__make} install DESTDIR=%{buildroot}
145 jpp 1.4 %{?scl:EOF}
146 jpp 1.1
147 jpp 1.2 # we don't want these
148     find %{buildroot} -name '*.la' -delete
149 jpp 1.4 rm -rf %{buildroot}/etc/rpm/macros.python27-config
150     rm -rf %{buildroot}/etc/scl/prefixes/python27
151     rm -rf %{buildroot}/opt/rh/python27/root/usr/tmp
152     rm -rf %{buildroot}/opt/rh/python27/root/var/mail
153 jpp 1.1
154     %files
155     %doc HACKING README.markdown
156 jpp 1.2 #%doc COPYRIGHT
157     %{_bindir}/%{name}
158     %{_bindir}/%{name}-init
159     %{_bindir}/%{name}-tool
160 jpp 1.1
161 jpp 1.2 %files server
162     %doc HACKING README.markdown
163     #%doc COPYRIGHT
164     %{_bindir}/%{name}-server
165     %{_bindir}/%{name}-servtool
166    
167     %files -n %{libname}
168     %{_libdir}/lib%{name}.so.%{major}
169     %{_libdir}/lib%{name}.so.%{major}.*
170 jpp 1.1
171 jpp 1.2 %files -n %{develname}
172     %doc HACKING README.markdown
173 jpp 1.1 %{_includedir}/*
174 jpp 1.2 %{_libdir}/lib%{name}.so
175 jpp 1.1 %{_libdir}/pkgconfig/lib%{name}.pc
176    
177 jpp 1.4 %files -n %{scl_prefix_python}python-%{name}
178 jpp 1.2 %doc HACKING README.markdown
179     %{python_sitearch}/%{name}/
180    
181 jpp 1.4 %files -n %{name}-debug
182     /usr/src/debug/*
183     /usr/lib/debug/.build-id/*
184     /usr/lib/debug/opt/rh/python27/root/usr/bin/*
185     /usr/lib/debug/opt/rh/python27/root/usr/lib64/*
186 jpp 1.1
187     %changelog
188 jpp 1.4 * Mon Mar 26 2018 Jean-Philipe Pialasse <tests@pialasse.com> Version: 5.1.3-5.sme
189     - rebuild for python27 sclo
190    
191 jpp 1.3 * Mon Feb 19 2018 Jean-Philippe Pialasse <tests@pialasse.com> - 5.1.3-4
192 jpp 1.2 - rebuild with lib and server packages
193    
194     * Mon Feb 19 2018 Jean-Philippe Pialasse <tests@pialasse.com> - 5.1.3-2
195 jpp 1.1 - first import for SME Server
196     - adapt spec file for buildsystem
197    
198 jpp 1.2 * Tue Nov 01 2016 daviddavid <daviddavid> 5.1.3-1.mga5
199     + Revision: 1064478
200     - new version: 5.1.3
201    
202     + neoclust <neoclust>
203     - Use version 5.1.2 in backports
204     - Add to backports
205    
206     * Thu Jun 30 2016 daviddavid <daviddavid> 5.1.3-1.mga6
207     + Revision: 1038171
208     - new version: 5.1.3
209    
210     * Thu May 12 2016 daviddavid <daviddavid> 5.1.1-2.mga6
211     + Revision: 1014278
212     - add the server part of ccnet
213    
214     * Fri May 06 2016 daviddavid <daviddavid> 5.1.1-1.mga6
215     + Revision: 1009881
216     - initial package ccnet
217 jpp 1.1

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed