/[smecontribs]/rpms/clearsilver/contribs8/clearsilver.spec
ViewVC logotype

Annotation of /rpms/clearsilver/contribs8/clearsilver.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Thu Apr 21 08:06:36 2016 UTC (8 years ago) by unnilennium
Branch: MAIN
CVS Tags: clearsilver-0_10_5-20_el5_sme
Changes since 1.1: +4 -1 lines
* Thu Apr 21 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.10.5-1.sme
- build against SME [SME: 9474]

1 unnilennium 1.1 %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2    
3     Name: clearsilver
4     Version: 0.10.5
5 unnilennium 1.2 Release: 20%{?dist}
6 unnilennium 1.1 Summary: Fast and powerful HTML templating system
7     Group: Development/Libraries
8     # Technically, the license is "Neotonic ClearSilver", but it is a copy of
9     # ASL 1.1 with the trademarks as the only difference.
10     License: ASL 1.1
11     URL: http://www.clearsilver.net/
12     Source0: http://www.clearsilver.net/downloads/%{name}-%{version}.tar.gz
13     Patch0: clearsilver-0.10.5-fedora.patch
14     Patch1: clearsilver-0.10.5-regression.patch
15     Patch2: clearsilver-0.10.5-CVE-2011-4357.patch
16     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
17     BuildRequires: zlib-devel
18     BuildRequires: httpd-devel
19     BuildRequires: perl(ExtUtils::MM)
20    
21     %description
22     ClearSilver is a fast, powerful, and language-neutral HTML template
23     system. In both static content sites and dynamic HTML applications,
24     it provides a separation between presentation code and application
25     logic which makes working with your project easier. The design of
26     ClearSilver began in 1999, and evolved during its use at onelist.com,
27     egroups.com, and Yahoo! Groups. Today many other projects and
28     websites are using it.
29    
30     %package devel
31     Summary: ClearSilver development package
32     Group: Development/Libraries
33     Provides: %{name}-static = %{version}-%{release}
34    
35     %description devel
36     This package provides needed files to develop extensions
37     to ClearSilver.
38    
39     %package -n python-%{name}
40     Summary: Python interface to the ClearSilver HTML templating system
41     Group: Development/Libraries
42     BuildRequires: python-devel >= 2.1
43     Provides: %{name}-python = %{version}-%{release}
44    
45     %description -n python-%{name}
46     %{summary}.
47    
48     %package -n perl-%{name}
49     Summary: Perl interface to the ClearSilver HTML templating system
50     Group: Development/Libraries
51     BuildRequires: perl
52     %if 0%{?fedora} > 6
53     BuildRequires: perl-devel
54     %endif
55     Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
56     Provides: %{name}-perl = %{version}-%{release}
57    
58     %description -n perl-%{name}
59     %{summary}.
60    
61     %package -n ruby-%{name}
62     Summary: Ruby interface to the ClearSilver HTML templating system
63     Group: Development/Libraries
64     BuildRequires: ruby
65     BuildRequires: ruby-devel
66     Provides: %{name}-ruby = %{version}-%{release}
67     %define ruby_sitearchdir %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')
68     %define ruby_sitelibdir %(ruby -rrbconfig -e 'puts Config::CONFIG["sitelibdir"]')
69    
70     %description -n ruby-%{name}
71     %{summary}.
72    
73     %if 0%{?rhel} > 4
74     %package -n java-%{name}
75     Summary: Java interface to the ClearSilver HTML templating system
76     Group: Development/Libraries
77     BuildRequires: java-devel
78     Provides: %{name}-java = %{version}-%{release}
79    
80     %description -n java-%{name}
81     %{summary}.
82     %endif
83    
84     %prep
85     %setup -q
86     %patch0 -p1
87     %patch1 -p1
88     %patch2 -p1
89     touch configure
90     sed -i 's|/neo/opt/bin/python|%{__python}|' python/examples/*/*.py
91     sed -i 's|PYTHON_SITE = @PYTHON_SITE@|PYTHON_SITE = %{python_sitearch}|' rules.mk.in
92     find python/examples -type f | xargs chmod -x
93    
94     %build
95     # java and ruby does not build on x86_64
96     %ifarch %{ix86} ppc alpha
97     %configure \
98     %if 0%{?rhel} > 4
99     --with-java=%{_libdir}/jvm/java \
100     %endif
101     --with-python=%{__python} \
102     --disable-csharp
103     %else
104     %configure \
105     --with-python=%{__python} \
106     --disable-java \
107     --disable-ruby \
108     --disable-csharp
109     %endif
110     cd perl && %{__perl} Makefile.PL INSTALLDIRS=vendor && cd ..
111     make %{?_smp_mflags} OPTIMIZE="$RPM_OPT_FLAGS"
112    
113     %install
114     rm -rf $RPM_BUILD_ROOT
115     make install DESTDIR=$RPM_BUILD_ROOT
116     find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
117     find $RPM_BUILD_ROOT -type f -name perllocal.pod -exec rm -f {} ';'
118     find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
119     find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
120     chmod -R u+w $RPM_BUILD_ROOT/*
121    
122     %ifarch %{ix86} ppc
123     %if 0%{?rhel} > 4
124     install -dm 755 $RPM_BUILD_ROOT%{_libdir}/java
125     mv $RPM_BUILD_ROOT%{_libdir}{,/java}/libclearsilver-jni.so
126     mv $RPM_BUILD_ROOT%{_libdir}/clearsilver.jar \
127     $RPM_BUILD_ROOT%{_libdir}/java/clearsilver-%{version}.jar
128     chmod 644 $RPM_BUILD_ROOT%{_libdir}/java/clearsilver-%{version}.jar
129     ln -s clearsilver-%{version}.jar $RPM_BUILD_ROOT%{_libdir}/java/clearsilver.jar
130     %endif
131     %endif
132    
133     %clean
134     rm -rf $RPM_BUILD_ROOT
135    
136     %files
137     %defattr(-,root,root,-)
138     %doc CS_LICENSE INSTALL LICENSE README
139     %{_bindir}/cs
140     %{_bindir}/cstest
141     %{_bindir}/cs_static.cgi
142     %{_mandir}/man3/*
143    
144     %files devel
145     %defattr(-, root, root, 0755)
146     %doc CS_LICENSE LICENSE
147     %{_includedir}/ClearSilver/
148     %{_libdir}/libneo_*.a
149    
150     %files -n python-clearsilver
151     %doc CS_LICENSE LICENSE
152     %defattr(-,root,root,-)
153     %doc README.python python/examples/
154     %{python_sitearch}/neo_cgi.so
155    
156     %files -n perl-clearsilver
157     %doc CS_LICENSE LICENSE
158     %defattr(-,root,root,-)
159     %{perl_vendorarch}/auto/ClearSilver/
160     %{perl_vendorarch}/ClearSilver.pm
161    
162     %ifarch %{ix86} ppc alpha
163     %files -n ruby-clearsilver
164     %doc CS_LICENSE LICENSE
165     %defattr(-,root,root,-)
166     %{ruby_sitearchdir}/hdf.so
167     %{ruby_sitelibdir}/neo.rb
168    
169     %if 0%{?rhel} > 4
170     %files -n java-clearsilver
171     %doc CS_LICENSE LICENSE
172     %defattr(-,root,root,-)
173     %{_libdir}/java/*clearsilver*
174     %endif
175     %endif
176    
177     %changelog
178 unnilennium 1.2 * Thu Apr 21 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.10.5-1.sme
179     - build against SME [SME: 9474]
180    
181 unnilennium 1.1 * Mon Dec 12 2011 Jon Ciesla <limburgher@gmail.com> - 0.10.5-15
182     - Patch for CVE-2011-4357, BZ 757543.
183    
184     * Fri Jun 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.10.5-14
185     - Perl mass rebuild
186    
187     * Fri Jun 10 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.10.5-13
188     - Perl 5.14 mass rebuild
189    
190     * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.5-12
191     - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
192    
193     * Mon Oct 04 2010 Jon Ciesla <limb@jcomserv.net> - 0.10.5-11
194     - Added virtual provides for -static, BZ 609601.
195    
196     * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.10.5-10
197     - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
198    
199     * Thu Apr 29 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.10.5-9
200     - Mass rebuild with perl-5.12.0
201    
202     * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 0.10.5-8
203     - rebuild against perl 5.10.1
204    
205     * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.5-7
206     - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
207    
208     * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.10.5-6
209     - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
210    
211     * Mon Apr 14 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.5-4
212     - Add patch from Kevin Kofler to fix build failures.
213    
214     * Thu Mar 06 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.10.5-3
215     Rebuild for new perl
216    
217     * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.10.5-2
218     - Autorebuild for GCC 4.3
219    
220     * Mon Jun 4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.4-5
221     - Add BR perl-devel for fedora > 6
222    
223     * Fri Jun 01 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.4-4
224     - Minor cleanups
225    
226     * Fri Jun 01 2007 Jesse Keating <jkeating@redhat.com> - 0.10.4-3.1
227     - Disable java subpackages on el4
228    
229     * Thu Apr 12 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.4-3
230     - Remove bogus -devel provides.
231    
232     * Wed Mar 28 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.4-2
233     - Bump release.
234    
235     * Wed Mar 28 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.4-1
236     - Update to 0.10.4
237    
238     * Sat Dec 9 2006 Joost Soeterbroek <joost.soeterbroek@gmail.com> - 0.10.3-5
239     - Rebuild for python 2.5
240    
241     * Mon Aug 28 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.10.3-4
242     - Rebuild for Fedora Extras 6
243    
244     * Thu Jun 1 2006 Paul Howarth <paul@city-fan.org> - 0.10.3-4
245     - ruby subpackage fix: use ruby_sitearchdir and ruby_sitelibdir
246    
247     * Fri Mar 17 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.10.3-3
248     - fix for x86_64
249    
250     * Mon Mar 13 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.10.3-1
251     - release 0.10.3
252    
253     * Mon Feb 13 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.10.2-3
254     - Rebuild for Fedora Extras 5
255    
256     * Fri Jan 6 2006 Joost Soeterbroek <fedora@soeterbroek.com> - 0.10.2-2
257     - Rebuild with disable-ruby, disable-java for any arch other than i386
258     - hardcoded version in Patch0
259     - extra line in prep-section
260     - license files in all subpackages
261    
262     * Thu Dec 15 2005 Joost Soeterbroek <fedora@soeterbroek.com> - 0.10.2-1
263     - Rebuild for 0.10.2
264    
265     * Tue Nov 29 2005 Joost Soeterbroek <fedora@soeterbroek.com> - 0.10.1-1
266     - Rebuild for Fedora Extras
267    
268     * Sun Jul 31 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.10.1-0.1
269     - 0.10.1, PIC issues fixed upstream.
270    
271     * Sun May 29 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.9.14-0.3
272     - Rebuild for FC4.
273     - Rename subpackages to $foo-clearsilver.
274    
275     * Mon Apr 25 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.9.14-0.2
276     - Build as PIC, fixes Ruby and Java builds on FC4.
277     - More parallel make fixing.
278    
279     * Fri Apr 8 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.9.14-0.1
280     - First build.

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed