1 |
brianr |
1.1 |
%define realname coova-chilli |
2 |
|
|
%define realver 1.3.0 |
3 |
|
|
%define srcext tar.gz |
4 |
|
|
|
5 |
|
|
# Common info |
6 |
|
|
Name: %{realname} |
7 |
|
|
Version: %{realver} |
8 |
brianr |
1.2 |
Release: 1.2 |
9 |
brianr |
1.1 |
License: GPL |
10 |
|
|
Group: Productivity/Networking/Security |
11 |
|
|
URL: http://coova.org/CoovaChilli |
12 |
|
|
Summary: A Software Access Controller for Captive Portal and WPA |
13 |
|
|
|
14 |
|
|
# Install-time parameters |
15 |
|
|
Requires: haserl |
16 |
|
|
|
17 |
|
|
# Build-time parameters |
18 |
|
|
BuildRequires: openssl-devel |
19 |
|
|
BuildRoot: %{_tmppath}/%{name}-root |
20 |
|
|
Source: http://ap.coova.org/chilli/%{realname}-%{realver}%{?extraver}.%{srcext} |
21 |
|
|
|
22 |
|
|
%description |
23 |
|
|
chilli is a software access controller typically used in Wireless LAN HotSpot. |
24 |
|
|
It supports of two different access methods for a Wireless LAN HotSpot: |
25 |
|
|
Universal Access Method (UAM) as well as Wireless Protected Access (WPA). |
26 |
|
|
This version of chilli is called CoovaChilli, a fork of the original ChilliSpot. |
27 |
|
|
|
28 |
|
|
%package devel |
29 |
|
|
Group: Development/Languages/C and C++ |
30 |
|
|
Summary: Development files for %{name} |
31 |
|
|
Requires: %{name} = %{version} |
32 |
|
|
|
33 |
|
|
%description devel |
34 |
|
|
Development files for %{name} |
35 |
|
|
|
36 |
|
|
# Preparation step (unpackung and patching if necessary) |
37 |
|
|
%prep |
38 |
|
|
%setup -q -n %{realname}-%{realver}%{?extraver} |
39 |
|
|
|
40 |
|
|
%build |
41 |
|
|
%configure \ |
42 |
|
|
--disable-static \ |
43 |
|
|
--disable-debug \ |
44 |
|
|
--enable-miniportal \ |
45 |
|
|
--enable-dhcpopt \ |
46 |
|
|
--enable-multilan \ |
47 |
|
|
--enable-mdns \ |
48 |
|
|
--enable-netbios \ |
49 |
|
|
--enable-ieee8023 \ |
50 |
|
|
--enable-ssdp \ |
51 |
|
|
--with-openssl \ |
52 |
|
|
LDFLAGS="-Wl,--as-needed -Wl,--strip-all" |
53 |
|
|
%__sed -i 's/ -Werror//' src/Makefile |
54 |
|
|
%__make %{?_smp_mflags} |
55 |
|
|
|
56 |
|
|
%install |
57 |
|
|
%__make install DESTDIR=%{buildroot} |
58 |
|
|
%if %{expand:%_vendor == "suse"} |
59 |
|
|
%__ln_s %{_initrddir}/chilli %{buildroot}%{_sbindir}/rcchilli |
60 |
|
|
%else |
61 |
|
|
%__mkdir -p %{buildroot}%{_initrddir} |
62 |
|
|
%__mv -f %{buildroot}%{_sysconfdir}/init.d/chilli %{buildroot}%{_initrddir}/ |
63 |
|
|
%endif |
64 |
|
|
|
65 |
|
|
%clean |
66 |
|
|
[ "%{buildroot}" != "/" ] && rm -rf %{buildroot} |
67 |
|
|
|
68 |
|
|
%files |
69 |
|
|
%defattr(-,root,root) |
70 |
|
|
%doc AUTHORS COPYING CREDITS LICENSE README doc/dictionary.chillispot doc/attributes doc/hotspotlogin.cgi |
71 |
|
|
%config(noreplace) %{_sysconfdir}/chilli.conf |
72 |
|
|
%dir %{_sysconfdir}/chilli |
73 |
|
|
%config(noreplace) %{_sysconfdir}/chilli/* |
74 |
|
|
%{_initrddir}/chilli |
75 |
|
|
%{_sbindir}/* |
76 |
|
|
%{_libdir}/*.so.* |
77 |
|
|
%exclude %{_libdir}/python/CoovaChilliLib.py* |
78 |
|
|
%doc %{_mandir}/man1/* |
79 |
|
|
%doc %{_mandir}/man5/* |
80 |
|
|
%doc %{_mandir}/man8/* |
81 |
|
|
|
82 |
|
|
# Development stuff |
83 |
|
|
%files devel |
84 |
|
|
%defattr(-,root,root) |
85 |
|
|
%dir %{_includedir}/chilli |
86 |
|
|
%{_includedir}/chilli/*.h |
87 |
|
|
%{_libdir}/*.so |
88 |
|
|
%exclude %{_libdir}/*.la |
89 |
|
|
|
90 |
|
|
%if 0%{?suse_version} |
91 |
|
|
%post |
92 |
|
|
%{fillup_and_insserv chilli} |
93 |
|
|
|
94 |
|
|
%preun |
95 |
|
|
%{stop_on_removal chilli} |
96 |
|
|
|
97 |
|
|
%postun |
98 |
|
|
%{restart_on_update chilli} |
99 |
|
|
%{insserv_cleanup} |
100 |
|
|
%endif |
101 |
|
|
|
102 |
|
|
%changelog |
103 |
brianr |
1.2 |
* Mon Dec 21 2020 Brian Read <brianr@bjsystems.co.uk> %{realver}-1.2.sme |
104 |
|
|
- Initial import to SME10 [SME: 11289] |
105 |
|
|
|