/[smecontribs]/rpms/dansguardian/contribs10/dansguardian.spec
ViewVC logotype

Annotation of /rpms/dansguardian/contribs10/dansguardian.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Wed Oct 21 12:03:54 2020 UTC (3 years, 6 months ago) by brianr
Branch: MAIN
CVS Tags: HEAD
Initial import

1 brianr 1.1 # $Id: dansguardian.spec,v 1.3 2018/12/17 13:23:46 jcrisp Exp $
2     # Authority: dag
3     # Upstream: Daniel Barron <author$dansguardian,org>
4    
5     %define real_name DansGuardian
6    
7     Summary: Content filtering web proxy
8     Name: dansguardian
9     Version: 2.10.1.1
10     Release: 2%{?dist}
11     License: GPLv2+
12     Group: System Environment/Daemons
13     URL: http://www.dansguardian.org/
14    
15     Source0: http://dansguardian.org/downloads/2/Stable/%{name}-%{version}.tar.gz
16     Source1: dansguardian.init
17     Source2: dansguardian.httpd
18     Source3: dansguardian.logrotate
19    
20     # Fixes some compilation errors with gcc 4.4
21     Patch1: dansguardian-gcc44.patch
22     Patch2: dansguardian-clamav.patch
23    
24     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
25    
26     BuildRequires: gcc-c++
27     BuildRequires: pcre-devel
28     BuildRequires: zlib-devel
29     BuildRequires: pkgconfig
30     BuildRequires: which
31     BuildRequires: clamav-devel
32    
33     Requires(pre): shadow-utils
34     Requires(post): chkconfig
35     Requires(preun): chkconfig
36     Requires(preun): initscripts
37    
38     %description
39     DansGuardian is a web filtering engine that checks the content within
40     the page itself in addition to the more traditional URL filtering.
41    
42     DansGuardian is a content filtering proxy. It filters using multiple methods,
43     including URL and domain filtering, content phrase filtering, PICS filtering,
44     MIME filtering, file extension filtering, POST filtering.
45    
46     %prep
47     %setup
48     %patch1 -p1
49     %patch2 -p1
50    
51     %build
52    
53     %configure \
54     --disable-clamav \
55     --enable-clamd \
56     --enable-icap \
57     --disable-kavd \
58     --enable-commandline \
59     --enable-trickledm \
60     --enable-ntlm \
61     --enable-email \
62     --with-proxyuser=dansguardian \
63     --with-proxygroup=dansguardian
64    
65     %{__make} %{?_smp_mflags}
66    
67     %install
68     %{__rm} -rf %{buildroot}
69    
70     %{__make} install DESTDIR=%{buildroot}
71    
72     install -Dpm 644 %{SOURCE3} \
73     $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/%{name}
74    
75     # delete the other scripts since they are of no use for Fedora users
76     rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/scripts
77     chmod 755 $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}.pl
78    
79     # install init script and httpd config
80     install -Dpm 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/%{name}
81     install -Dp -m0644 %{SOURCE2} \
82     $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/%{name}.conf
83    
84     # we'll install this later within %doc
85     rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/%{name}
86    
87     # create the log dir
88     install -dm 755 $RPM_BUILD_ROOT%{_localstatedir}/log/%{name}
89    
90     %clean
91     %{__rm} -rf %{buildroot}
92    
93     %pre
94     getent group %{name} >/dev/null || groupadd -r %{name}
95     getent passwd %{name} >/dev/null || \
96     useradd -r -g %{name} -d %{_datadir}/%{name} -s /sbin/nologin \
97     -c "DansGuardian web content filter" %{name}
98     exit 0
99    
100     %post
101     if [ $1 -eq 1 ]; then
102     /sbin/chkconfig --add %{name}
103     fi
104    
105     %preun
106     if [ $1 -eq 0 ]; then
107     /sbin/service %{name} stop >/dev/null 2>&1
108     /sbin/chkconfig --del %{name}
109     fi
110    
111     %postun
112     if [ $1 -ge 1 ] ; then
113     /sbin/service %{name} condrestart >/dev/null 2>&1 || :
114     fi
115    
116     %files
117     %defattr(-, root, root, 0755)
118     %doc COPYING INSTALL README UPGRADING
119     %doc doc/AuthPlugins doc/ContentScanners doc/DownloadManagers doc/FAQ
120     %doc doc/FAQ.html doc/Plugins
121     %doc %{_mandir}/man8/%{name}.8.gz
122     %{_sbindir}/%{name}
123     %attr(-,%{name},%{name}) %{_datadir}/%{name}
124     %{_initrddir}/%{name}
125     %dir %{_sysconfdir}/%{name}
126     %config(noreplace) %{_sysconfdir}/%{name}/%{name}*.conf
127     %dir %{_sysconfdir}/%{name}/authplugins
128     %config(noreplace) %{_sysconfdir}/%{name}/authplugins/*
129     %dir %{_sysconfdir}/%{name}/contentscanners
130     %config(noreplace) %{_sysconfdir}/%{name}/contentscanners/*
131     %dir %{_sysconfdir}/%{name}/downloadmanagers
132     %config(noreplace) %{_sysconfdir}/%{name}/downloadmanagers/*
133     %dir %{_sysconfdir}/%{name}/lists
134     %config(noreplace) %{_sysconfdir}/%{name}/lists/*
135     %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
136     %config(noreplace) %{_sysconfdir}/httpd/conf.d/%{name}.conf
137    
138     %defattr(644, %{name}, %{name}, 755)
139     %dir %{_localstatedir}/log/%{name}
140    
141     %changelog
142     * Tue Dec 11 2018 T Fage <tfage@yahoo.com.au> 2.10.1.1-2.sme
143     - Add clamav daemonuser and clamd socket for SME 9 [Bug 10663]
144    
145     * Sat Apr 16 2016 Jean-Philipe Pialasse <tests@pialasse.com> -1.sme
146     - build for SME 9 [SME: 8436]
147    
148     * Tue Jul 15 2013 JP Pialasse <tests@pialasse.com> 2.10.1.1-1.sme
149     - Update to build against clamav/clamd 0.97
150    
151     * Thu Jul 14 2011 Yury V. Zaytsev <yury@shurup.com> - 2.10.1.1-1
152     - Synced the SPEC with Fedora Rawhide where appropriate.
153     - Updated to release 2.10.1.1.
154    
155     * Sat Apr 08 2006 Dries Verachtert <dries@ulyssis.org> - 2.8.0.6-1.2
156     - Rebuild for Fedora Core 5.
157    
158     * Mon Aug 15 2005 Dries Verachtert <dries@ulyssis.org> - 2.8.0.6-1
159     - Updated to release 2.8.0.6.
160    
161     * Thu Mar 31 2005 Dag Wieers <dag@wieers.com> - 2.8.0.4-1
162     - Updated to release 2.8.0.4.
163    
164     * Fri Jul 30 2004 Dag Wieers <dag@wieers.com> - 2.8.0.2-1
165     - Updated to release 2.8.0.2.
166    
167     * Wed Jul 21 2004 Dag Wieers <dag@wieers.com> - 2.8.0-1
168     - Updated to release 2.8.0-0.
169    
170     * Thu Apr 15 2004 Dag Wieers <dag@wieers.com> - 2.6.1.13-1
171     - Updated to release 2.6.1-13.
172    
173     * Fri Mar 26 2004 Dag Wieers <dag@wieers.com> - 2.6.1.12-1
174     - Initial package. (using DAR)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed