/[smecontribs]/rpms/dansguardian/contribs9/dansguardian.spec
ViewVC logotype

Annotation of /rpms/dansguardian/contribs9/dansguardian.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Sat Apr 16 05:44:10 2016 UTC (8 years, 1 month ago) by unnilennium
Branch: MAIN
Initial import

1 unnilennium 1.1 # $Id: dansguardian.spec,v 1.3 2013/07/15 14:09:58 slords Exp $
2     # Authority: dag
3     # Upstream: Daniel Barron <author$dansguardian,org>
4    
5     %define real_name DansGuardian
6    
7     Summary: Content filtering web proxy
8     Name: dansguardian
9     Version: 2.10.1.1
10     Release: 1%{?dist}
11     License: GPLv2+
12     Group: System Environment/Daemons
13     URL: http://www.dansguardian.org/
14    
15     Source0: http://dansguardian.org/downloads/2/Stable/%{name}-%{version}.tar.gz
16     Source1: dansguardian.init
17     Source2: dansguardian.httpd
18     Source3: dansguardian.logrotate
19    
20     # Fixes some compilation errors with gcc 4.4
21     Patch1: dansguardian-gcc44.patch
22    
23     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
24    
25     BuildRequires: gcc-c++
26     BuildRequires: pcre-devel
27     BuildRequires: zlib-devel
28     BuildRequires: pkgconfig
29     BuildRequires: which
30     BuildRequires: clamav-devel
31    
32     Requires(pre): shadow-utils
33     Requires(post): chkconfig
34     Requires(preun): chkconfig
35     Requires(preun): initscripts
36    
37     %description
38     DansGuardian is a web filtering engine that checks the content within
39     the page itself in addition to the more traditional URL filtering.
40    
41     DansGuardian is a content filtering proxy. It filters using multiple methods,
42     including URL and domain filtering, content phrase filtering, PICS filtering,
43     MIME filtering, file extension filtering, POST filtering.
44    
45     %prep
46     %setup
47     %patch1 -p1
48    
49     %build
50    
51     %configure \
52     --disable-clamav \
53     --enable-clamd \
54     --enable-icap \
55     --disable-kavd \
56     --enable-commandline \
57     --enable-trickledm \
58     --enable-ntlm \
59     --enable-email \
60     --with-proxyuser=dansguardian \
61     --with-proxygroup=dansguardian
62    
63     %{__make} %{?_smp_mflags}
64    
65     %install
66     %{__rm} -rf %{buildroot}
67    
68     %{__make} install DESTDIR=%{buildroot}
69    
70     install -Dpm 644 %{SOURCE3} \
71     $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/%{name}
72    
73     # delete the other scripts since they are of no use for Fedora users
74     rm -rf $RPM_BUILD_ROOT%{_datadir}/%{name}/scripts
75     chmod 755 $RPM_BUILD_ROOT%{_datadir}/%{name}/%{name}.pl
76    
77     # install init script and httpd config
78     install -Dpm 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initrddir}/%{name}
79     install -Dp -m0644 %{SOURCE2} \
80     $RPM_BUILD_ROOT%{_sysconfdir}/httpd/conf.d/%{name}.conf
81    
82     # we'll install this later within %doc
83     rm -rf $RPM_BUILD_ROOT%{_datadir}/doc/%{name}
84    
85     # create the log dir
86     install -dm 755 $RPM_BUILD_ROOT%{_localstatedir}/log/%{name}
87    
88     %clean
89     %{__rm} -rf %{buildroot}
90    
91     %pre
92     getent group %{name} >/dev/null || groupadd -r %{name}
93     getent passwd %{name} >/dev/null || \
94     useradd -r -g %{name} -d %{_datadir}/%{name} -s /sbin/nologin \
95     -c "DansGuardian web content filter" %{name}
96     exit 0
97    
98     %post
99     if [ $1 -eq 1 ]; then
100     /sbin/chkconfig --add %{name}
101     fi
102    
103     %preun
104     if [ $1 -eq 0 ]; then
105     /sbin/service %{name} stop >/dev/null 2>&1
106     /sbin/chkconfig --del %{name}
107     fi
108    
109     %postun
110     if [ $1 -ge 1 ] ; then
111     /sbin/service %{name} condrestart >/dev/null 2>&1 || :
112     fi
113    
114     %files
115     %defattr(-, root, root, 0755)
116     %doc COPYING INSTALL README UPGRADING
117     %doc doc/AuthPlugins doc/ContentScanners doc/DownloadManagers doc/FAQ
118     %doc doc/FAQ.html doc/Plugins
119     %doc %{_mandir}/man8/%{name}.8.gz
120     %{_sbindir}/%{name}
121     %attr(-,%{name},%{name}) %{_datadir}/%{name}
122     %{_initrddir}/%{name}
123     %dir %{_sysconfdir}/%{name}
124     %config(noreplace) %{_sysconfdir}/%{name}/%{name}*.conf
125     %dir %{_sysconfdir}/%{name}/authplugins
126     %config(noreplace) %{_sysconfdir}/%{name}/authplugins/*
127     %dir %{_sysconfdir}/%{name}/contentscanners
128     %config(noreplace) %{_sysconfdir}/%{name}/contentscanners/*
129     %dir %{_sysconfdir}/%{name}/downloadmanagers
130     %config(noreplace) %{_sysconfdir}/%{name}/downloadmanagers/*
131     %dir %{_sysconfdir}/%{name}/lists
132     %config(noreplace) %{_sysconfdir}/%{name}/lists/*
133     %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
134     %config(noreplace) %{_sysconfdir}/httpd/conf.d/%{name}.conf
135    
136     %defattr(644, %{name}, %{name}, 755)
137     %dir %{_localstatedir}/log/%{name}
138    
139     %changelog
140     * Tue Jul 15 2013 JP Pialasse <tests@pialasse.com> 2.10.1.1-1.sme
141     - Update to build against clamav/clamd 0.97
142    
143     * Thu Jul 14 2011 Yury V. Zaytsev <yury@shurup.com> - 2.10.1.1-1
144     - Synced the SPEC with Fedora Rawhide where appropriate.
145     - Updated to release 2.10.1.1.
146    
147     * Sat Apr 08 2006 Dries Verachtert <dries@ulyssis.org> - 2.8.0.6-1.2
148     - Rebuild for Fedora Core 5.
149    
150     * Mon Aug 15 2005 Dries Verachtert <dries@ulyssis.org> - 2.8.0.6-1
151     - Updated to release 2.8.0.6.
152    
153     * Thu Mar 31 2005 Dag Wieers <dag@wieers.com> - 2.8.0.4-1
154     - Updated to release 2.8.0.4.
155    
156     * Fri Jul 30 2004 Dag Wieers <dag@wieers.com> - 2.8.0.2-1
157     - Updated to release 2.8.0.2.
158    
159     * Wed Jul 21 2004 Dag Wieers <dag@wieers.com> - 2.8.0-1
160     - Updated to release 2.8.0-0.
161    
162     * Thu Apr 15 2004 Dag Wieers <dag@wieers.com> - 2.6.1.13-1
163     - Updated to release 2.6.1-13.
164    
165     * Fri Mar 26 2004 Dag Wieers <dag@wieers.com> - 2.6.1.12-1
166     - Initial package. (using DAR)

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed