1 |
# $Id: dimp-h3.spec,v 1.2 2010/11/07 03:28:27 mrjhb3 Exp $ |
2 |
# Authority: mrjhb3 |
3 |
# Name: John H. Bennett III |
4 |
|
5 |
%define apachedir /etc/httpd |
6 |
%define apacheuser www |
7 |
%define apachegroup www |
8 |
%define contentdir /home/httpd |
9 |
|
10 |
Summary: The Dymanic Internet Messaging Program: webmail access to IMAP/POP3 accounts. |
11 |
Name: dimp-h3 |
12 |
Version: 1.1.6 |
13 |
Release: 1%{?dist} |
14 |
License: GPL |
15 |
Group: Applications/Horde |
16 |
Source: ftp://ftp.horde.org/pub/dimp/tarballs/dimp-h3-%{version}.tar.gz |
17 |
URL: http://www.horde.org/ |
18 |
BuildArchitectures: noarch |
19 |
BuildRoot: /tmp/dimp-root |
20 |
Requires: php >= 4.3.0 |
21 |
Requires: php-imap >= 4.3.0 |
22 |
Requires: httpd >= 2.0.46 |
23 |
Requires: horde >= 3.3 |
24 |
Requires: imp >= 4.3.4 |
25 |
Provides: dimp |
26 |
Prereq: /usr/bin/perl |
27 |
|
28 |
%description |
29 |
DIMP is a alternate presentation view of IMP using AJAX-ish |
30 |
technologies to create a more dynamic user experience |
31 |
(DIMP stands for Dynamic IMP). |
32 |
|
33 |
%prep |
34 |
%setup -q -n %{name}-%{version} |
35 |
|
36 |
%build |
37 |
|
38 |
%install |
39 |
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
40 |
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
41 |
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/dimp |
42 |
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/dimp |
43 |
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/dimp/config |
44 |
for d in *.dist; do |
45 |
d0=`basename $d .dist` |
46 |
if [ ! -f "$d0" ]; then |
47 |
cp -p $d $d0 |
48 |
fi |
49 |
done |
50 |
|
51 |
%clean |
52 |
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
53 |
|
54 |
%files |
55 |
%defattr(-,root,root) |
56 |
# Include top level with %dir so not all files are sucked in |
57 |
%dir %{contentdir}/html/horde/dimp |
58 |
# Include top-level files by hand |
59 |
%{contentdir}/html/horde/dimp/*.php |
60 |
# Include these dirs so that all files _will_ get sucked in |
61 |
%{contentdir}/html/horde/dimp/js |
62 |
%{contentdir}/html/horde/dimp/lib |
63 |
%{contentdir}/html/horde/dimp/locale |
64 |
%{contentdir}/html/horde/dimp/po |
65 |
#%{contentdir}/html/horde/dimp/scripts |
66 |
%{contentdir}/html/horde/dimp/templates |
67 |
%{contentdir}/html/horde/dimp/themes |
68 |
# Mark documentation files with %doc and %docdir |
69 |
%doc %{contentdir}/html/horde/dimp/COPYING |
70 |
%doc %{contentdir}/html/horde/dimp/README |
71 |
%docdir %{contentdir}/html/horde/dimp/docs |
72 |
%{contentdir}/html/horde/dimp/docs |
73 |
# Mark configuration files with %config and use secure permissions |
74 |
# (note that .dist files are considered software; don't mark %config) |
75 |
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/dimp/config |
76 |
%defattr(640,root,%{apachegroup}) |
77 |
%{contentdir}/html/horde/dimp/config/.htaccess |
78 |
%{contentdir}/html/horde/dimp/config/*.dist |
79 |
%config %{contentdir}/html/horde/dimp/config/*.php |
80 |
#%config %{contentdir}/html/horde/dimp/config/*.txt |
81 |
%config %{contentdir}/html/horde/dimp/config/*.xml |
82 |
|
83 |
%changelog |
84 |
* Sat Nov 06 2010 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.6-1 |
85 |
- Update to Dimp 1.1.6 |
86 |
|
87 |
* Sun Dec 27 2009 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.4-1 |
88 |
- Update to Dimp 1.1.4 |
89 |
|
90 |
* Sun Sep 27 2009 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.3-1 |
91 |
- Update to Dimp 1.1.3 |
92 |
|
93 |
* Wed Jun 17 2009 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.2-1 |
94 |
- Update to Dimp 1.1.2 |
95 |
|
96 |
* Mon Dec 22 2008 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.1-1 |
97 |
- Update to Dimp 1.1.1 |
98 |
|
99 |
* Fri Dec 05 2008 John H. Bennett III <bennettj@johnbennettservices.com> 1.1-1 |
100 |
- Update to Dimp 1.1 |
101 |
|
102 |
* Mon Jun 2 2008 John H. Bennett III <bennettj@johnbennettservices.com> 1.0-1 |
103 |
- initial RPM roll for Dimp 1.0 |
104 |
|