/[smecontribs]/rpms/dokuwiki-plugins/contribs10/dokuwiki-plugins.spec
ViewVC logotype

Annotation of /rpms/dokuwiki-plugins/contribs10/dokuwiki-plugins.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Tue Oct 5 16:57:36 2021 UTC (2 years, 9 months ago) by jcrisp
Branch: MAIN
CVS Tags: dokuwiki-plugins-20210220-1_el7_sme
Initial import

1 jcrisp 1.1 %define realversion 20210220
2     %define version %(echo %{realversion} | sed -e 's/-//g')
3     %define releasenum 1
4    
5     %if 0%{?fedora} >= 11 || 0%{?rhel} >= 5
6     %global useselinux 1
7     %else
8     %global useselinux 0
9     %endif
10    
11     Name: dokuwiki-plugins
12     Version: %{version}
13     Release: %{releasenum}%{?dist}
14     Summary: Standards compliant simple to use wiki
15     Group: Applications/Internet
16     License: GPLv2
17     URL: http://www.dokuwiki.org/dokuwiki
18    
19     Source10: changes.zip
20     Source11: ckgedit.zip
21     Source12: color.zip
22     Source13: dw2pdf.zip
23     Source14: edittable.zip
24     Source15: encryptedpasswords.zip
25     Source16: hidden.zip
26     Source17: howhard.zip
27     Source18: loglog.zip
28     Source19: note.zip
29     Source20: nspages.zip
30     Source21: odt.zip
31     Source22: pagelist.zip
32     Source23: pagemove.zip
33     Source24: sortablejs.zip
34     Source25: tag.zip
35     Source26: todo.zip
36    
37    
38     Patch1: dokuwiki-plugins-2021-10-05-ckgedit_fix_media_dir.patch
39     Patch2: dokuwiki-plugins-2021-10-05-mupdf_tmp_dir.patch
40    
41     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
42     BuildArch: noarch
43     Requires: dokuwiki = %{version}
44    
45    
46     %description
47     DokuWiki is a standards compliant, simple to use Wiki, mainly aimed at creating
48     documentation of any kind. It has a simple but powerful syntax which makes sure
49     the data files remain readable outside the Wiki and eases the creation of
50     structured texts.
51    
52     All data is stored in plain text files no database is required.
53    
54     This package provides several useful plugins for dokuwiki
55    
56     %prep
57     %{__rm} -rf lib
58     %{__mkdir_p} lib/{plugins,tpl}
59     # Extract plugins
60     for S in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16} %{SOURCE17} %{SOURCE18} %{SOURCE19} %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24} %{SOURCE25} %{SOURCE26}; do
61     unzip -o -d lib/plugins $S
62     done
63    
64     mv lib/plugins/changes-master lib/plugins/changes
65     mv lib/plugins/ckgedit-master lib/plugins/ckgedit
66     mv lib/plugins/color-master lib/plugins/color
67     mv lib/plugins/dw2pdf-master lib/plugins/dw2pdf
68     mv lib/plugins/edittable-master lib/plugins/edittable
69     mv lib/plugins/encryptedpasswords-master lib/plugins/encryptedpasswords
70     mv lib/plugins/hidden-master lib/plugins/hidden
71     mv lib/plugins/howhard-master lib/plugins/howhard
72     mv lib/plugins/loglog-master lib/plugins/loglog
73     mv lib/plugins/note-master lib/plugins/note
74     mv lib/plugins/nspages-master lib/plugins/nspages
75     mv lib/plugins/odt-master lib/plugins/odt
76     mv lib/plugins/pagelist-master lib/plugins/pagelist
77     mv lib/plugins/pagemove-master lib/plugins/pagemove
78     mv lib/plugins/sortablejs-master lib/plugins/sortablejs
79     mv lib/plugins/tag-master lib/plugins/tag
80     mv lib/plugins/todo-master lib/plugins/todo
81    
82     ls -l lib/plugins/ckgedit
83    
84     find lib -type d -exec chmod 755 "{}" \;
85     find lib -type f -exec chmod 644 "{}" \;
86    
87     %patch1 -p0
88     %patch2 -p0
89    
90     %build
91    
92     %install
93     rm -rf $RPM_BUILD_ROOT
94     install -d -p $RPM_BUILD_ROOT%{_datadir}/dokuwiki/
95     cp -rp lib $RPM_BUILD_ROOT%{_datadir}/dokuwiki/
96    
97     %files
98     %defattr(-,root,root,-)
99     %attr(0755,apache,apache) %dir %{_datadir}/dokuwiki/lib/plugins
100     %attr(0775,root,apache) %dir %{_datadir}/dokuwiki/lib/plugins/*
101     %{_datadir}/dokuwiki/lib/plugins/*
102    
103     %clean
104     %{__rm} -rf $RPM_BUILD_ROOT
105    
106     %changelog
107     * Tue Oct 05 2021 John Crisp <jcrisp@safeandsoundit.co.uk> - 20210220-1
108     - First import to SME [SME: 11704]
109     - Updated plugins to lastest versions
110     - Scripted gut pulls for plugins and zipping them
111     - Sorted plugin names alphabetically
112    
113     * Mon Sep 25 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219e-2
114     - Fix syntax error in ckgedit lang file preventing access to settings
115    
116     * Mon Aug 28 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219e-1
117     - Bump for 2017-02-19e
118    
119     * Wed Aug 23 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219d-1
120     - Bump for 2017-02-19d
121     - Update ckgedit
122     - Update hidden
123     - Update tag
124     - Update pagelist
125     - Update loglog
126     - Update edittable
127     - Update odt
128     - Update nspages
129     - Update changes
130     - Update dw2pdf
131    
132     * Thu Mar 9 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219b-1
133     - Bump for 2017-02-19b
134    
135     * Tue Feb 21 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219a-1
136     - Bump for 2017-02-19a
137     - Update note
138     - Update odt
139     - Update dw2pdf
140     - Update color
141     - Update hidden
142     - Update encryptedpasswords
143     - Update tag
144     - Update pagelist
145     - Update changes
146     - Update loglog
147     - Update todo
148     - Update ckgedit
149     - Update edittable
150     - Update sortablejs
151     - Update howhard
152    
153     * Wed Jul 20 2016 Daniel Berteaud <daniel@firewall-services.com> - 20160626a-2
154     - Fix odt export when notes are used
155     See https://github.com/LarsGit223/dokuwiki-plugin-odt/issues/144
156    
157     * Mon Jul 4 2016 Daniel Berteaud <daniel@firewall-services.com> - 20160626a-1
158     - Bump for 2016-06-26a
159    
160     * Tue Jun 28 2016 Daniel Berteaud <daniel@firewall-services.com> - 20160626-1
161     - Bump for 2016-06-26
162     - Update changes
163     - Update ckgedit
164     - Update dw2pdf
165     - Update edittable
166     - Update hidden
167     - Update howhard
168     - Update loglog
169     - Update nspages
170     - Update odt
171     - Update pagelist
172     - Update pagemove
173     - Update tag
174     - Update todo
175    
176     * Wed Sep 9 2015 Daniel Berteaud <daniel@firewall-services.com> - 20150810a-2
177     - Update edittable to 2015-09-01
178    
179     * Tue Sep 1 2015 Daniel Berteaud <daniel@firewall-services.com> - 20150810a-1
180     - Bump for 2015-08-10a
181     - Update odt
182     - Update dw2pdf
183     - Update hidden
184     - Update encryptedpassword
185     - Update nspage
186     - Update ckgedit
187     - Update edittable
188     - Update sortablejs
189     - Update howhard
190     - Remove useless dokuwiki_export template
191    
192     * Fri Mar 20 2015 Daniel Berteaud <daniel@firewall-services.com> - 20140029d-1
193     - Bump for 2014-09-29d
194     - Update changes
195     - Update edittable
196     - Update encryptedpassword
197     - Update loglog
198     - Update odt
199    
200     * Thu Feb 26 2015 Daniel Berteaud <daniel@firewall-services.com> - 20140029c-1
201     - Bump for 2014-09-29c
202     - Update odt
203     - Update dw2pdf
204     - Update nspage
205     - Update changes
206     - Update todo
207     - Update ckgedit
208     - Update edittable
209    
210     * Thu Dec 4 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140029b-1
211     - Bump for 2014-09-29b
212    
213     * Tue Oct 14 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140029a-1
214     - Bump version for 2014-09-29a
215     - Update default template
216     - Update ckgedit
217     - Update dw2pdf
218     - Update encryptedpassword
219     - Update howhard
220     - Update odt
221     - Update pagemove
222     - Update sortablejs
223     - Update todo
224    
225     * Tue Aug 12 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140505a-2
226     - update odt
227     - update tag
228     - update hidden
229     - update todo
230     - update pagelist
231     - update pagemove
232     - update dw2pdf
233     - update loglog
234     - update ckgedit
235     - update nspage
236     - update encryptedpasswords
237     - add edittable
238     - add sertablejs
239     - add howhard
240     - remove toolbox
241     - remove floartdiv
242     - remove iframe
243    
244     * Fri Jun 27 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140505a-1
245     - bump version for 2014-05-05a
246    
247     * Tue May 6 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140505-1
248     - Bump release for new dokuwiki (2014-05-05)
249     - Update dokuwiki tpl
250     - Update dw2pdf
251     - Update tag
252     - Update pagelist
253     - Update ckgedit
254    
255     * Mon Dec 9 2013 Daniel Berteaud <daniel@firewall-services.com> - 20131208-1
256     - bump release for new dokuwiki version (2013-12-08)
257     - Update dokuwiki tpl
258     - Remove the old default template
259    
260     * Thu Nov 28 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510a-4
261     - Fix permissions on the plugins dir
262    
263     * Fri Nov 15 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510a-3
264     - Cleanup the spec file
265    
266     * Thu Oct 31 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510a-2
267     - Fix media manager in ckgedit
268     - Update dw2pdf
269     - Update tag
270     - Update pagelist
271     - Update nspages
272     - Update todo
273     - Update ckgedit
274    
275     * Wed Aug 21 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510a-1
276     - bump version to 2013-05-10a
277    
278     * Thu Mar 28 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510-1
279     - update hidden
280     - update encryptpassword
281     - update tag
282     - update pagelist
283     - update todo
284     - replace fckgLite with ckgedit
285     - remove edittable
286     - bump version for dokuwiki 2013-05-10
287    
288     * Mon Oct 15 2012 Daniel Berteaud <daniel@firewall-services.com> - 20121013-1
289     - bump release for new dokuwiki version
290    
291     * Thu Sep 13 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120910-1
292     - bump release for new dokuwiki version
293     - update hidden
294     - update tag
295     - update fckgLite
296     - update encryptedpasswords
297    
298     * Sun Jul 15 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120125b-1
299     - bump release for dokuwiki 2012-01-25b
300     - update default tpl
301     - update dw2pdf
302     - update hidden
303     - update encryptedpasswords
304     - update pagelist
305     - update nspages
306     - update pagemove
307     - update fckgLite
308     - add iframe plugin
309    
310     * Tue May 29 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120125a-4
311     - update dw2pdf, tag and hidden plugins
312    
313     * Mon Apr 23 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120125a-3
314     - bump release for new dokuwiki version
315    
316     * Fri Jan 27 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120125-3
317     - upgrade for upstream dokuwiki
318     - upgrade dw2pdf to latest release
319    
320     * Fri Nov 18 2011 Daniel Berteaud <daniel@firewall-services.com> - 20110525a-2
321     - Add fckgLite plugin
322    
323     * Mon Jul 18 2011 Daniel Berteaud <daniel@firewall-services.com> - 20110525a-1
324     - Initial release
325    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed