/[smecontribs]/rpms/dokuwiki-plugins/contribs10/dokuwiki-plugins.spec
ViewVC logotype

Annotation of /rpms/dokuwiki-plugins/contribs10/dokuwiki-plugins.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Wed Oct 6 08:32:04 2021 UTC (2 years, 9 months ago) by jcrisp
Branch: MAIN
CVS Tags: dokuwiki-plugins-20210220-2_el7_sme
Changes since 1.1: +6 -3 lines
* Wed Oct 06 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 20210220-2
- Update the dokuwiki requires version

1 jcrisp 1.1 %define realversion 20210220
2     %define version %(echo %{realversion} | sed -e 's/-//g')
3 jcrisp 1.2 %define releasenum 2
4 jcrisp 1.1
5     %if 0%{?fedora} >= 11 || 0%{?rhel} >= 5
6     %global useselinux 1
7     %else
8     %global useselinux 0
9     %endif
10    
11     Name: dokuwiki-plugins
12     Version: %{version}
13     Release: %{releasenum}%{?dist}
14     Summary: Standards compliant simple to use wiki
15     Group: Applications/Internet
16     License: GPLv2
17     URL: http://www.dokuwiki.org/dokuwiki
18    
19     Source10: changes.zip
20     Source11: ckgedit.zip
21     Source12: color.zip
22     Source13: dw2pdf.zip
23     Source14: edittable.zip
24     Source15: encryptedpasswords.zip
25     Source16: hidden.zip
26     Source17: howhard.zip
27     Source18: loglog.zip
28     Source19: note.zip
29     Source20: nspages.zip
30     Source21: odt.zip
31     Source22: pagelist.zip
32     Source23: pagemove.zip
33     Source24: sortablejs.zip
34     Source25: tag.zip
35     Source26: todo.zip
36    
37    
38     Patch1: dokuwiki-plugins-2021-10-05-ckgedit_fix_media_dir.patch
39     Patch2: dokuwiki-plugins-2021-10-05-mupdf_tmp_dir.patch
40    
41     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
42     BuildArch: noarch
43 jcrisp 1.2 Requires: dokuwiki >= 20200729
44 jcrisp 1.1
45    
46     %description
47     DokuWiki is a standards compliant, simple to use Wiki, mainly aimed at creating
48     documentation of any kind. It has a simple but powerful syntax which makes sure
49     the data files remain readable outside the Wiki and eases the creation of
50     structured texts.
51    
52     All data is stored in plain text files no database is required.
53    
54     This package provides several useful plugins for dokuwiki
55    
56     %prep
57     %{__rm} -rf lib
58     %{__mkdir_p} lib/{plugins,tpl}
59     # Extract plugins
60     for S in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16} %{SOURCE17} %{SOURCE18} %{SOURCE19} %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24} %{SOURCE25} %{SOURCE26}; do
61     unzip -o -d lib/plugins $S
62     done
63    
64     mv lib/plugins/changes-master lib/plugins/changes
65     mv lib/plugins/ckgedit-master lib/plugins/ckgedit
66     mv lib/plugins/color-master lib/plugins/color
67     mv lib/plugins/dw2pdf-master lib/plugins/dw2pdf
68     mv lib/plugins/edittable-master lib/plugins/edittable
69     mv lib/plugins/encryptedpasswords-master lib/plugins/encryptedpasswords
70     mv lib/plugins/hidden-master lib/plugins/hidden
71     mv lib/plugins/howhard-master lib/plugins/howhard
72     mv lib/plugins/loglog-master lib/plugins/loglog
73     mv lib/plugins/note-master lib/plugins/note
74     mv lib/plugins/nspages-master lib/plugins/nspages
75     mv lib/plugins/odt-master lib/plugins/odt
76     mv lib/plugins/pagelist-master lib/plugins/pagelist
77     mv lib/plugins/pagemove-master lib/plugins/pagemove
78     mv lib/plugins/sortablejs-master lib/plugins/sortablejs
79     mv lib/plugins/tag-master lib/plugins/tag
80     mv lib/plugins/todo-master lib/plugins/todo
81    
82     ls -l lib/plugins/ckgedit
83    
84     find lib -type d -exec chmod 755 "{}" \;
85     find lib -type f -exec chmod 644 "{}" \;
86    
87     %patch1 -p0
88     %patch2 -p0
89    
90     %build
91    
92     %install
93     rm -rf $RPM_BUILD_ROOT
94     install -d -p $RPM_BUILD_ROOT%{_datadir}/dokuwiki/
95     cp -rp lib $RPM_BUILD_ROOT%{_datadir}/dokuwiki/
96    
97     %files
98     %defattr(-,root,root,-)
99     %attr(0755,apache,apache) %dir %{_datadir}/dokuwiki/lib/plugins
100     %attr(0775,root,apache) %dir %{_datadir}/dokuwiki/lib/plugins/*
101     %{_datadir}/dokuwiki/lib/plugins/*
102    
103     %clean
104     %{__rm} -rf $RPM_BUILD_ROOT
105    
106     %changelog
107 jcrisp 1.2 * Wed Oct 06 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 20210220-2
108     - Update the dokuwiki requires version
109    
110 jcrisp 1.1 * Tue Oct 05 2021 John Crisp <jcrisp@safeandsoundit.co.uk> - 20210220-1
111     - First import to SME [SME: 11704]
112     - Updated plugins to lastest versions
113 jcrisp 1.2 - Scripted git pulls for plugins and zipping them
114 jcrisp 1.1 - Sorted plugin names alphabetically
115    
116     * Mon Sep 25 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219e-2
117     - Fix syntax error in ckgedit lang file preventing access to settings
118    
119     * Mon Aug 28 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219e-1
120     - Bump for 2017-02-19e
121    
122     * Wed Aug 23 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219d-1
123     - Bump for 2017-02-19d
124     - Update ckgedit
125     - Update hidden
126     - Update tag
127     - Update pagelist
128     - Update loglog
129     - Update edittable
130     - Update odt
131     - Update nspages
132     - Update changes
133     - Update dw2pdf
134    
135     * Thu Mar 9 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219b-1
136     - Bump for 2017-02-19b
137    
138     * Tue Feb 21 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219a-1
139     - Bump for 2017-02-19a
140     - Update note
141     - Update odt
142     - Update dw2pdf
143     - Update color
144     - Update hidden
145     - Update encryptedpasswords
146     - Update tag
147     - Update pagelist
148     - Update changes
149     - Update loglog
150     - Update todo
151     - Update ckgedit
152     - Update edittable
153     - Update sortablejs
154     - Update howhard
155    
156     * Wed Jul 20 2016 Daniel Berteaud <daniel@firewall-services.com> - 20160626a-2
157     - Fix odt export when notes are used
158     See https://github.com/LarsGit223/dokuwiki-plugin-odt/issues/144
159    
160     * Mon Jul 4 2016 Daniel Berteaud <daniel@firewall-services.com> - 20160626a-1
161     - Bump for 2016-06-26a
162    
163     * Tue Jun 28 2016 Daniel Berteaud <daniel@firewall-services.com> - 20160626-1
164     - Bump for 2016-06-26
165     - Update changes
166     - Update ckgedit
167     - Update dw2pdf
168     - Update edittable
169     - Update hidden
170     - Update howhard
171     - Update loglog
172     - Update nspages
173     - Update odt
174     - Update pagelist
175     - Update pagemove
176     - Update tag
177     - Update todo
178    
179     * Wed Sep 9 2015 Daniel Berteaud <daniel@firewall-services.com> - 20150810a-2
180     - Update edittable to 2015-09-01
181    
182     * Tue Sep 1 2015 Daniel Berteaud <daniel@firewall-services.com> - 20150810a-1
183     - Bump for 2015-08-10a
184     - Update odt
185     - Update dw2pdf
186     - Update hidden
187     - Update encryptedpassword
188     - Update nspage
189     - Update ckgedit
190     - Update edittable
191     - Update sortablejs
192     - Update howhard
193     - Remove useless dokuwiki_export template
194    
195     * Fri Mar 20 2015 Daniel Berteaud <daniel@firewall-services.com> - 20140029d-1
196     - Bump for 2014-09-29d
197     - Update changes
198     - Update edittable
199     - Update encryptedpassword
200     - Update loglog
201     - Update odt
202    
203     * Thu Feb 26 2015 Daniel Berteaud <daniel@firewall-services.com> - 20140029c-1
204     - Bump for 2014-09-29c
205     - Update odt
206     - Update dw2pdf
207     - Update nspage
208     - Update changes
209     - Update todo
210     - Update ckgedit
211     - Update edittable
212    
213     * Thu Dec 4 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140029b-1
214     - Bump for 2014-09-29b
215    
216     * Tue Oct 14 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140029a-1
217     - Bump version for 2014-09-29a
218     - Update default template
219     - Update ckgedit
220     - Update dw2pdf
221     - Update encryptedpassword
222     - Update howhard
223     - Update odt
224     - Update pagemove
225     - Update sortablejs
226     - Update todo
227    
228     * Tue Aug 12 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140505a-2
229     - update odt
230     - update tag
231     - update hidden
232     - update todo
233     - update pagelist
234     - update pagemove
235     - update dw2pdf
236     - update loglog
237     - update ckgedit
238     - update nspage
239     - update encryptedpasswords
240     - add edittable
241     - add sertablejs
242     - add howhard
243     - remove toolbox
244     - remove floartdiv
245     - remove iframe
246    
247     * Fri Jun 27 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140505a-1
248     - bump version for 2014-05-05a
249    
250     * Tue May 6 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140505-1
251     - Bump release for new dokuwiki (2014-05-05)
252     - Update dokuwiki tpl
253     - Update dw2pdf
254     - Update tag
255     - Update pagelist
256     - Update ckgedit
257    
258     * Mon Dec 9 2013 Daniel Berteaud <daniel@firewall-services.com> - 20131208-1
259     - bump release for new dokuwiki version (2013-12-08)
260     - Update dokuwiki tpl
261     - Remove the old default template
262    
263     * Thu Nov 28 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510a-4
264     - Fix permissions on the plugins dir
265    
266     * Fri Nov 15 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510a-3
267     - Cleanup the spec file
268    
269     * Thu Oct 31 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510a-2
270     - Fix media manager in ckgedit
271     - Update dw2pdf
272     - Update tag
273     - Update pagelist
274     - Update nspages
275     - Update todo
276     - Update ckgedit
277    
278     * Wed Aug 21 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510a-1
279     - bump version to 2013-05-10a
280    
281     * Thu Mar 28 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510-1
282     - update hidden
283     - update encryptpassword
284     - update tag
285     - update pagelist
286     - update todo
287     - replace fckgLite with ckgedit
288     - remove edittable
289     - bump version for dokuwiki 2013-05-10
290    
291     * Mon Oct 15 2012 Daniel Berteaud <daniel@firewall-services.com> - 20121013-1
292     - bump release for new dokuwiki version
293    
294     * Thu Sep 13 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120910-1
295     - bump release for new dokuwiki version
296     - update hidden
297     - update tag
298     - update fckgLite
299     - update encryptedpasswords
300    
301     * Sun Jul 15 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120125b-1
302     - bump release for dokuwiki 2012-01-25b
303     - update default tpl
304     - update dw2pdf
305     - update hidden
306     - update encryptedpasswords
307     - update pagelist
308     - update nspages
309     - update pagemove
310     - update fckgLite
311     - add iframe plugin
312    
313     * Tue May 29 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120125a-4
314     - update dw2pdf, tag and hidden plugins
315    
316     * Mon Apr 23 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120125a-3
317     - bump release for new dokuwiki version
318    
319     * Fri Jan 27 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120125-3
320     - upgrade for upstream dokuwiki
321     - upgrade dw2pdf to latest release
322    
323     * Fri Nov 18 2011 Daniel Berteaud <daniel@firewall-services.com> - 20110525a-2
324     - Add fckgLite plugin
325    
326     * Mon Jul 18 2011 Daniel Berteaud <daniel@firewall-services.com> - 20110525a-1
327     - Initial release
328    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed