/[smecontribs]/rpms/dokuwiki-plugins/contribs10/dokuwiki-plugins.spec
ViewVC logotype

Annotation of /rpms/dokuwiki-plugins/contribs10/dokuwiki-plugins.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Thu Oct 14 12:53:42 2021 UTC (2 years, 11 months ago) by jcrisp
Branch: MAIN
CVS Tags: dokuwiki-plugins-20210220-4_el7_sme, HEAD
Changes since 1.3: +6 -3 lines
* Thu Oct 14 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 20210220-4
- remove attr dir line in files to fix conflicts [SME: 11703]

1 jcrisp 1.1 %define realversion 20210220
2     %define version %(echo %{realversion} | sed -e 's/-//g')
3 jcrisp 1.4 %define releasenum 4
4 jcrisp 1.1
5     %if 0%{?fedora} >= 11 || 0%{?rhel} >= 5
6     %global useselinux 1
7     %else
8     %global useselinux 0
9     %endif
10    
11     Name: dokuwiki-plugins
12     Version: %{version}
13     Release: %{releasenum}%{?dist}
14     Summary: Standards compliant simple to use wiki
15     Group: Applications/Internet
16     License: GPLv2
17     URL: http://www.dokuwiki.org/dokuwiki
18    
19     Source10: changes.zip
20     Source11: ckgedit.zip
21     Source12: color.zip
22     Source13: dw2pdf.zip
23     Source14: edittable.zip
24     Source15: encryptedpasswords.zip
25     Source16: hidden.zip
26     Source17: howhard.zip
27     Source18: loglog.zip
28     Source19: note.zip
29     Source20: nspages.zip
30     Source21: odt.zip
31     Source22: pagelist.zip
32     Source23: pagemove.zip
33     Source24: sortablejs.zip
34     Source25: tag.zip
35     Source26: todo.zip
36    
37    
38     Patch1: dokuwiki-plugins-2021-10-05-ckgedit_fix_media_dir.patch
39     Patch2: dokuwiki-plugins-2021-10-05-mupdf_tmp_dir.patch
40    
41     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
42     BuildArch: noarch
43 jcrisp 1.2 Requires: dokuwiki >= 20200729
44 jcrisp 1.1
45    
46     %description
47     DokuWiki is a standards compliant, simple to use Wiki, mainly aimed at creating
48     documentation of any kind. It has a simple but powerful syntax which makes sure
49     the data files remain readable outside the Wiki and eases the creation of
50     structured texts.
51    
52     All data is stored in plain text files no database is required.
53    
54     This package provides several useful plugins for dokuwiki
55    
56     %prep
57     %{__rm} -rf lib
58     %{__mkdir_p} lib/{plugins,tpl}
59     # Extract plugins
60     for S in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE13} %{SOURCE14} %{SOURCE15} %{SOURCE16} %{SOURCE17} %{SOURCE18} %{SOURCE19} %{SOURCE20} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24} %{SOURCE25} %{SOURCE26}; do
61     unzip -o -d lib/plugins $S
62     done
63    
64     mv lib/plugins/changes-master lib/plugins/changes
65     mv lib/plugins/ckgedit-master lib/plugins/ckgedit
66     mv lib/plugins/color-master lib/plugins/color
67     mv lib/plugins/dw2pdf-master lib/plugins/dw2pdf
68     mv lib/plugins/edittable-master lib/plugins/edittable
69     mv lib/plugins/encryptedpasswords-master lib/plugins/encryptedpasswords
70     mv lib/plugins/hidden-master lib/plugins/hidden
71     mv lib/plugins/howhard-master lib/plugins/howhard
72     mv lib/plugins/loglog-master lib/plugins/loglog
73     mv lib/plugins/note-master lib/plugins/note
74     mv lib/plugins/nspages-master lib/plugins/nspages
75     mv lib/plugins/odt-master lib/plugins/odt
76     mv lib/plugins/pagelist-master lib/plugins/pagelist
77     mv lib/plugins/pagemove-master lib/plugins/pagemove
78     mv lib/plugins/sortablejs-master lib/plugins/sortablejs
79     mv lib/plugins/tag-master lib/plugins/tag
80     mv lib/plugins/todo-master lib/plugins/todo
81    
82     ls -l lib/plugins/ckgedit
83    
84     find lib -type d -exec chmod 755 "{}" \;
85     find lib -type f -exec chmod 644 "{}" \;
86    
87     %patch1 -p0
88     %patch2 -p0
89    
90     %build
91    
92     %install
93     rm -rf $RPM_BUILD_ROOT
94     install -d -p $RPM_BUILD_ROOT%{_datadir}/dokuwiki/
95     cp -rp lib $RPM_BUILD_ROOT%{_datadir}/dokuwiki/
96    
97     %files
98     %defattr(-,root,root,-)
99 jcrisp 1.4 #%attr(0755,apache,apache) %dir %{_datadir}/dokuwiki/lib/plugins
100     # %attr(0775,root,apache) %dir %{_datadir}/dokuwiki/lib/plugins/*
101 jcrisp 1.1 %{_datadir}/dokuwiki/lib/plugins/*
102    
103     %clean
104     %{__rm} -rf $RPM_BUILD_ROOT
105    
106     %changelog
107 jcrisp 1.4 * Thu Oct 14 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 20210220-4
108     - remove attr dir line in files to fix conflicts [SME: 11703]
109    
110 terryfage 1.3 * Mon Oct 11 2021 Terry Fage <terry@fage.id.au> 20210220-3
111     - reapply patchs ckgedit_fix_media_dir mupdf_tmp_dir [SME: 11704]
112    
113 jcrisp 1.2 * Wed Oct 06 2021 John Crisp <jcrisp@safeandsoundit.co.uk> 20210220-2
114     - Update the dokuwiki requires version
115    
116 jcrisp 1.1 * Tue Oct 05 2021 John Crisp <jcrisp@safeandsoundit.co.uk> - 20210220-1
117     - First import to SME [SME: 11704]
118     - Updated plugins to lastest versions
119 jcrisp 1.2 - Scripted git pulls for plugins and zipping them
120 jcrisp 1.1 - Sorted plugin names alphabetically
121    
122     * Mon Sep 25 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219e-2
123     - Fix syntax error in ckgedit lang file preventing access to settings
124    
125     * Mon Aug 28 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219e-1
126     - Bump for 2017-02-19e
127    
128     * Wed Aug 23 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219d-1
129     - Bump for 2017-02-19d
130     - Update ckgedit
131     - Update hidden
132     - Update tag
133     - Update pagelist
134     - Update loglog
135     - Update edittable
136     - Update odt
137     - Update nspages
138     - Update changes
139     - Update dw2pdf
140    
141     * Thu Mar 9 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219b-1
142     - Bump for 2017-02-19b
143    
144     * Tue Feb 21 2017 Daniel Berteaud <daniel@firewall-services.com> - 20170219a-1
145     - Bump for 2017-02-19a
146     - Update note
147     - Update odt
148     - Update dw2pdf
149     - Update color
150     - Update hidden
151     - Update encryptedpasswords
152     - Update tag
153     - Update pagelist
154     - Update changes
155     - Update loglog
156     - Update todo
157     - Update ckgedit
158     - Update edittable
159     - Update sortablejs
160     - Update howhard
161    
162     * Wed Jul 20 2016 Daniel Berteaud <daniel@firewall-services.com> - 20160626a-2
163     - Fix odt export when notes are used
164     See https://github.com/LarsGit223/dokuwiki-plugin-odt/issues/144
165    
166     * Mon Jul 4 2016 Daniel Berteaud <daniel@firewall-services.com> - 20160626a-1
167     - Bump for 2016-06-26a
168    
169     * Tue Jun 28 2016 Daniel Berteaud <daniel@firewall-services.com> - 20160626-1
170     - Bump for 2016-06-26
171     - Update changes
172     - Update ckgedit
173     - Update dw2pdf
174     - Update edittable
175     - Update hidden
176     - Update howhard
177     - Update loglog
178     - Update nspages
179     - Update odt
180     - Update pagelist
181     - Update pagemove
182     - Update tag
183     - Update todo
184    
185     * Wed Sep 9 2015 Daniel Berteaud <daniel@firewall-services.com> - 20150810a-2
186     - Update edittable to 2015-09-01
187    
188     * Tue Sep 1 2015 Daniel Berteaud <daniel@firewall-services.com> - 20150810a-1
189     - Bump for 2015-08-10a
190     - Update odt
191     - Update dw2pdf
192     - Update hidden
193     - Update encryptedpassword
194     - Update nspage
195     - Update ckgedit
196     - Update edittable
197     - Update sortablejs
198     - Update howhard
199     - Remove useless dokuwiki_export template
200    
201     * Fri Mar 20 2015 Daniel Berteaud <daniel@firewall-services.com> - 20140029d-1
202     - Bump for 2014-09-29d
203     - Update changes
204     - Update edittable
205     - Update encryptedpassword
206     - Update loglog
207     - Update odt
208    
209     * Thu Feb 26 2015 Daniel Berteaud <daniel@firewall-services.com> - 20140029c-1
210     - Bump for 2014-09-29c
211     - Update odt
212     - Update dw2pdf
213     - Update nspage
214     - Update changes
215     - Update todo
216     - Update ckgedit
217     - Update edittable
218    
219     * Thu Dec 4 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140029b-1
220     - Bump for 2014-09-29b
221    
222     * Tue Oct 14 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140029a-1
223     - Bump version for 2014-09-29a
224     - Update default template
225     - Update ckgedit
226     - Update dw2pdf
227     - Update encryptedpassword
228     - Update howhard
229     - Update odt
230     - Update pagemove
231     - Update sortablejs
232     - Update todo
233    
234     * Tue Aug 12 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140505a-2
235     - update odt
236     - update tag
237     - update hidden
238     - update todo
239     - update pagelist
240     - update pagemove
241     - update dw2pdf
242     - update loglog
243     - update ckgedit
244     - update nspage
245     - update encryptedpasswords
246     - add edittable
247     - add sertablejs
248     - add howhard
249     - remove toolbox
250     - remove floartdiv
251     - remove iframe
252    
253     * Fri Jun 27 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140505a-1
254     - bump version for 2014-05-05a
255    
256     * Tue May 6 2014 Daniel Berteaud <daniel@firewall-services.com> - 20140505-1
257     - Bump release for new dokuwiki (2014-05-05)
258     - Update dokuwiki tpl
259     - Update dw2pdf
260     - Update tag
261     - Update pagelist
262     - Update ckgedit
263    
264     * Mon Dec 9 2013 Daniel Berteaud <daniel@firewall-services.com> - 20131208-1
265     - bump release for new dokuwiki version (2013-12-08)
266     - Update dokuwiki tpl
267     - Remove the old default template
268    
269     * Thu Nov 28 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510a-4
270     - Fix permissions on the plugins dir
271    
272     * Fri Nov 15 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510a-3
273     - Cleanup the spec file
274    
275     * Thu Oct 31 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510a-2
276     - Fix media manager in ckgedit
277     - Update dw2pdf
278     - Update tag
279     - Update pagelist
280     - Update nspages
281     - Update todo
282     - Update ckgedit
283    
284     * Wed Aug 21 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510a-1
285     - bump version to 2013-05-10a
286    
287     * Thu Mar 28 2013 Daniel Berteaud <daniel@firewall-services.com> - 20130510-1
288     - update hidden
289     - update encryptpassword
290     - update tag
291     - update pagelist
292     - update todo
293     - replace fckgLite with ckgedit
294     - remove edittable
295     - bump version for dokuwiki 2013-05-10
296    
297     * Mon Oct 15 2012 Daniel Berteaud <daniel@firewall-services.com> - 20121013-1
298     - bump release for new dokuwiki version
299    
300     * Thu Sep 13 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120910-1
301     - bump release for new dokuwiki version
302     - update hidden
303     - update tag
304     - update fckgLite
305     - update encryptedpasswords
306    
307     * Sun Jul 15 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120125b-1
308     - bump release for dokuwiki 2012-01-25b
309     - update default tpl
310     - update dw2pdf
311     - update hidden
312     - update encryptedpasswords
313     - update pagelist
314     - update nspages
315     - update pagemove
316     - update fckgLite
317     - add iframe plugin
318    
319     * Tue May 29 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120125a-4
320     - update dw2pdf, tag and hidden plugins
321    
322     * Mon Apr 23 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120125a-3
323     - bump release for new dokuwiki version
324    
325     * Fri Jan 27 2012 Daniel Berteaud <daniel@firewall-services.com> - 20120125-3
326     - upgrade for upstream dokuwiki
327     - upgrade dw2pdf to latest release
328    
329     * Fri Nov 18 2011 Daniel Berteaud <daniel@firewall-services.com> - 20110525a-2
330     - Add fckgLite plugin
331    
332     * Mon Jul 18 2011 Daniel Berteaud <daniel@firewall-services.com> - 20110525a-1
333     - Initial release
334    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed