/[smecontribs]/rpms/ejabberd/contribs7/ejabberd.spec
ViewVC logotype

Annotation of /rpms/ejabberd/contribs7/ejabberd.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Thu May 8 19:50:17 2008 UTC (16 years ago) by slords
Branch: MAIN
CVS Tags: ejabberd-2_0_0-3_el4_sme
Initial import of ejabberd-2.0.0-3.el4.sme.src.rpm

1 slords 1.1 Name: ejabberd
2     Version: 2.0.0
3     Release: 3%{?dist}
4     Summary: A distributed, fault-tolerant Jabber/XMPP server
5    
6     Group: Applications/Internet
7     License: GPLv2
8     URL: http://www.ejabberd.im/
9     Source0: http://www.process-one.net/downloads/%{name}/%{version}/%{name}-%{version}.tar.gz
10     Source1: ejabberd.init
11     Source2: ejabberd.logrotate
12    
13     # http://ejabberd.jabber.ru/ejabberdctl-extra
14     Source4: https://svn.process-one.net/ejabberd-modules/mod_ctlextra/trunk/src/mod_ctlextra.erl
15    
16     # The following were extracted from a patch found on http://realloc.spb.ru/share/ejabberdad.html
17     Source5: ejabberd_auth_ad.erl
18     Source6: mod_shared_roster_ad.erl
19     Source7: mod_vcard_ad.erl
20     #
21     #Source8: ejabberdctl
22     Source9: ejabberdctl.pam
23     Source10: ejabberdctl.apps
24    
25     # originally from
26     # https://support.process-one.net/secure/attachment/11788/ejab-446.patch
27     Patch0: ejab-446.patch
28    
29     # local stuff
30     Patch1: ejabberd-build.patch
31    
32     # R12B
33     Patch2: ejabberd-ssl.patch
34    
35     # R11B SSL
36     Patch3: ejabberd_s2s_in_erl.diff
37    
38     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
39    
40     BuildRequires: expat-devel
41     BuildRequires: openssl-devel
42     BuildRequires: pam-devel
43     BuildRequires: erlang
44     %if %{?rhel:0}%{!?rhel:1}
45     BuildRequires: hevea
46     %endif
47    
48     Requires: erlang
49     Requires: usermode
50    
51     Requires(pre): fedora-usermgmt
52     Requires(post): /sbin/chkconfig
53     Requires(preun): /sbin/chkconfig
54     Requires(preun): /sbin/service
55     Requires(postun): /sbin/service
56    
57     #https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=250253
58     ExcludeArch: ppc64
59    
60     %description
61     ejabberd is a Free and Open Source distributed fault-tolerant
62     Jabber/XMPP server. It is mostly written in Erlang, and runs on many
63     platforms (tested on Linux, FreeBSD, NetBSD, Solaris, Mac OS X and
64     Windows NT/2000/XP).
65    
66     %package doc
67     Summary: Documentation for ejabberd
68     Group: Documentation
69    
70     %description doc
71     Documentation for ejabberd.
72    
73     %pre
74     /usr/sbin/fedora-groupadd 27 -r ejabberd &>/dev/null || :
75     /usr/sbin/fedora-useradd 27 -r -s /sbin/nologin -d /var/lib/ejabberd -M \
76     -c 'ejabberd' -g ejabberd ejabberd &>/dev/null || :
77    
78     %post
79     /sbin/chkconfig --add ejabberd
80    
81     %preun
82     if [ $1 = 0 ]; then
83     /sbin/service ejabberd stop >/dev/null 2>&1
84     /sbin/chkconfig --del ejabberd
85     fi
86    
87     %postun
88     if [ "$1" -ge "1" ]; then
89     /sbin/service ejabberd condrestart >/dev/null 2>&1
90     fi
91    
92     %prep
93     %setup -q -n %{name}-%{version}
94     %patch0 -p1 -b .Er12b-build
95     %patch1 -p1 -b .MC-build
96     #%patch2 -p1 -b .R12B
97     %patch3 -p0 -b .r11_ssl
98    
99     %{__perl} -pi -e "s!/var/lib/ejabberd!%{_libdir}/ejabberd-%{version}!g" src/Makefile.in
100     %{__perl} -pi -e "s!/etc!%{_sysconfdir}!g" src/Makefile.in
101     %{__perl} -pi -e "s!\@prefix\@!!g" src/Makefile.in
102    
103     cp %{S:4} src
104     cp %{S:5} src
105     cp %{S:6} src
106     cp %{S:7} src
107    
108     %build
109     pushd src
110     %configure --enable-odbc --enable-debug
111     make %{?_smp_mflags}
112     popd
113     %if %{?rhel:0}%{!?rhel:1}
114     pushd doc
115     make html pdf
116     popd
117     %endif
118    
119     %install
120     rm -rf %{buildroot}
121    
122     pushd src
123     make install DESTDIR=%{buildroot}
124     popd
125    
126     chmod a+x %{buildroot}%{_libdir}/ejabberd-%{version}/priv/lib/*.so
127    
128     %{__perl} -pi -e 's!./ssl.pem!/etc/ejabberd/ejabberd.pem!g' %{buildroot}/etc/ejabberd/ejabberd.cfg
129    
130     mkdir -p %{buildroot}/var/log/ejabberd
131     mkdir -p %{buildroot}/var/lib/ejabberd/spool
132    
133     mkdir -p %{buildroot}%{_bindir}
134     ln -s consolehelper %{buildroot}%{_bindir}/ejabberdctl
135     #install -D -p -m 0755 %{S:8} %{buildroot}%{_sbindir}/ejabberdctl
136     install -D -p -m 0644 %{S:9} %{buildroot}%{_sysconfdir}/pam.d/ejabberdctl
137     install -D -p -m 0644 %{S:10} %{buildroot}%{_sysconfdir}/security/console.apps/ejabberdctl
138    
139     mkdir -p %{buildroot}%{_initrddir}
140     install -p -m 0755 %{S:1} %{buildroot}%{_initrddir}/ejabberd
141     chmod a+x %{buildroot}%{_initrddir}/ejabberd
142    
143     mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
144     cp -p %{S:2} %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd
145    
146     %{__perl} -pi -e 's!\@libdir\@!%{_libdir}!g' %{buildroot}%{_initrddir}/ejabberd %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd %{buildroot}%{_sbindir}/ejabberdctl
147     %{__perl} -pi -e 's!\@version\@!%{version}!g' %{buildroot}%{_initrddir}/ejabberd %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd %{buildroot}%{_sbindir}/ejabberdctl
148    
149     #cp %{S:3} %{buildroot}%{_sysconfdir}/ejabberd/inetrc
150     #mv %{buildroot}%{_sysconfdir}/ejabberd/{ejabberd.,}inetrc
151    
152     %clean
153     rm -rf %{buildroot}
154    
155     %files
156     %defattr(-,root,root,-)
157     %doc COPYING
158    
159     %attr(750,ejabberd,ejabberd) %dir %{_sysconfdir}/ejabberd
160     %attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/ejabberd.cfg
161     %attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/ejabberdctl.cfg
162     %attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/inetrc
163    
164     %{_initrddir}/ejabberd
165     %config(noreplace) %{_sysconfdir}/logrotate.d/ejabberd
166    
167     %config(noreplace) %{_sysconfdir}/pam.d/ejabberdctl
168     %config(noreplace) %{_sysconfdir}/security/console.apps/ejabberdctl
169     %{_bindir}/ejabberdctl
170     %{_sbindir}/ejabberdctl
171    
172     %dir %{_libdir}/ejabberd-%{version}
173     %dir %{_libdir}/ejabberd-%{version}/ebin
174     %{_libdir}/ejabberd-%{version}/ebin/*.app
175     %{_libdir}/ejabberd-%{version}/ebin/*.beam
176    
177     %dir %{_libdir}/ejabberd-%{version}/priv
178    
179     %dir %{_libdir}/ejabberd-%{version}/priv/lib
180     %{_libdir}/ejabberd-%{version}/priv/lib/*.so
181    
182     %dir %{_libdir}/ejabberd-%{version}/priv/msgs
183     %{_libdir}/ejabberd-%{version}/priv/msgs/*.msg
184    
185     %attr(750,ejabberd,ejabberd) %dir /var/lib/ejabberd
186     %attr(750,ejabberd,ejabberd) %dir /var/lib/ejabberd/spool
187    
188     %attr(750,ejabberd,ejabberd) %dir /var/log/ejabberd
189    
190     %files doc
191     %defattr(-,root,root,-)
192     %if %{?rhel:0}%{!?rhel:1}
193     %doc ChangeLog COPYING doc/*.pdf doc/*.html doc/*.png doc/release_notes_*
194     %else
195     %doc ChangeLog COPYING doc/release_notes_*
196     %endif
197    
198     %changelog
199     * Mon May 5 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-3
200     - Fix build against R11B-2
201    
202     * Sat Feb 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-2
203     - Disable docs again for EPEL (we haven't hevea for EPEL)
204    
205     * Sat Feb 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-1
206     - Version 2.0.0
207    
208     * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-0.4.rc1
209     - Autorebuild for GCC 4.3
210    
211     * Wed Jan 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-0.3.rc1
212     - Really enabled some previously disabled modules
213    
214     * Wed Jan 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-0.2.rc1
215     - Enabled some previously disabled modules
216    
217     * Sat Jan 19 2008 Matej Cepl <mcepl@redhat.com> 2.0.0-0.1.rc1
218     - Upgrade to the current upsteram version.
219     - Make ejabberd.init LSB compliant (missing Provides: tag)
220    
221     * Thu Dec 27 2007 Matej Cepl <mcepl@redhat.com> 2.0.0-0.beta1.mc.1
222     - Experimental build from the upstream betaversion.
223    
224     * Tue Dec 11 2007 Matej Cepl <mcepl@redhat.com> 1.1.4-2.fc9
225     - rebuild against new ssl library.
226     - rebuild against the newest erlang (see Patch
227     - fix %%changelog
228    
229     * Wed Sep 5 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.4-1
230     - Drop LDAP patch
231     - Update mod_ctlextra
232     - Update to 1.1.4
233    
234     * Tue Sep 4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-11
235     - Fix ejabberdctl wrapper script - #276071
236    
237     * Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-10
238     - Re-exclude ppc64
239    
240     * Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-9
241     - Fix license
242     - Don't exclude ppc64
243    
244     * Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-8
245     - Bump & rebuild to build against latest erlang package.
246    
247     * Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-7
248     - Bump release and rebuild due to Koji hiccups.
249    
250     * Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-6
251     - Don't try building on PPC64 since hevea isn't available on PPC64.
252    
253     * Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-5
254     - Sigh...
255    
256     * Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-4
257     - Don't forget to add patch.
258    
259     * Thu Jul 26 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-3
260     - Add ejabberdctl (#199873)
261     - Add patch to fix LDAP authentication. (#248268)
262     - Add a sleep in init script between stop/start when restarting.
263     - LSB compliance cleanups for init script. (#246917)
264     - Don't mention "reload" in the init script usage string. (#227254)
265    
266     * Tue Jul 24 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-2
267     - Update mod_ctlextra
268    
269     * Fri Feb 2 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-1
270     - Update to 1.1.3
271    
272     * Wed Oct 11 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.2-2
273     - Fix logrotate script (BZ#210366)
274    
275     * Mon Aug 28 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-10
276     - Bump release and rebuild.
277    
278     * Mon Jul 3 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-9
279     - Updated init script - should hopefully fix some problems with status & stop commands.
280    
281     * Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-8
282     - Bump release to that tagging works on FC-5.
283    
284     * Thu Jun 22 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-7
285     - Oops drop bad patch.
286    
287     * Thu Jun 22 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-6
288     - Split documentation off to a subpackage.
289     - Own %%{_libdir}/ejabberd-%{version}
290     - Mark %%{_sysconfdir}/logrotate.d/ejabberd as %%config
291    
292     * Thu Jun 8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-5
293     - Patch the makefile so that it adds a soname to shared libs.
294    
295     * Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-4
296     - Modify AD modules not to check for group membership.
297    
298     * Thu May 25 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-3
299     - Add some extra modules
300    
301     * Wed May 24 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-2
302     - Munge Makefile.in a bit more...
303     - Change ownership/permissions - not *everything* needs to be owned by ejabberd
304    
305     * Wed May 24 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-1
306     - First version for Fedora Extras

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed