/[smecontribs]/rpms/ejabberd/contribs7/ejabberd.spec
ViewVC logotype

Annotation of /rpms/ejabberd/contribs7/ejabberd.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.4 - (hide annotations) (download)
Wed Jun 25 19:02:58 2008 UTC (15 years, 11 months ago) by slords
Branch: MAIN
Changes since 1.3: +50 -56 lines
Initial import of ejabberd-2.0.1-4.el5.src.rpm

1 slords 1.1 Name: ejabberd
2 slords 1.4 Version: 2.0.1
3 gnujpl 1.3 Release: 4%{?dist}
4 slords 1.1 Summary: A distributed, fault-tolerant Jabber/XMPP server
5    
6     Group: Applications/Internet
7 slords 1.4 License: GPLv2+
8 slords 1.1 URL: http://www.ejabberd.im/
9 slords 1.4 Source0: http://www.process-one.net/downloads/%{name}/%{version}/%{name}-%{version}_2.tar.gz
10 slords 1.1 Source1: ejabberd.init
11     Source2: ejabberd.logrotate
12    
13     # http://ejabberd.jabber.ru/ejabberdctl-extra
14     Source4: https://svn.process-one.net/ejabberd-modules/mod_ctlextra/trunk/src/mod_ctlextra.erl
15    
16     # The following were extracted from a patch found on http://realloc.spb.ru/share/ejabberdad.html
17     Source5: ejabberd_auth_ad.erl
18     Source6: mod_shared_roster_ad.erl
19     Source7: mod_vcard_ad.erl
20     #
21     #Source8: ejabberdctl
22     Source9: ejabberdctl.pam
23     Source10: ejabberdctl.apps
24    
25 slords 1.4 # Fedora-specific stuff - fixing paths
26 slords 1.1 Patch1: ejabberd-build.patch
27 slords 1.4 # BZ# 439583, 452326, 451554
28     Patch2: ejabberd-ejabberdctl_fix.diff
29 slords 1.1
30     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
31    
32     BuildRequires: expat-devel
33     BuildRequires: openssl-devel
34     BuildRequires: pam-devel
35     BuildRequires: erlang
36 slords 1.4 BuildRequires: dos2unix
37     %if %{undefined rhel}
38 slords 1.1 BuildRequires: hevea
39     %endif
40    
41     Requires: erlang
42     Requires: usermode
43    
44 slords 1.4 Requires(pre): fedora-usermgmt
45 slords 1.1 Requires(post): /sbin/chkconfig
46     Requires(preun): /sbin/chkconfig
47     Requires(preun): /sbin/service
48     Requires(postun): /sbin/service
49    
50     #https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=250253
51     ExcludeArch: ppc64
52    
53     %description
54     ejabberd is a Free and Open Source distributed fault-tolerant
55     Jabber/XMPP server. It is mostly written in Erlang, and runs on many
56     platforms (tested on Linux, FreeBSD, NetBSD, Solaris, Mac OS X and
57     Windows NT/2000/XP).
58    
59     %package doc
60     Summary: Documentation for ejabberd
61     Group: Documentation
62    
63     %description doc
64     Documentation for ejabberd.
65    
66     %pre
67 slords 1.4 /usr/sbin/fedora-groupadd 27 -r ejabberd &>/dev/null || :
68     /usr/sbin/fedora-useradd 27 -r -s /sbin/nologin -d /var/lib/ejabberd -M \
69 slords 1.1 -c 'ejabberd' -g ejabberd ejabberd &>/dev/null || :
70    
71     %post
72     /sbin/chkconfig --add ejabberd
73    
74     %preun
75     if [ $1 = 0 ]; then
76     /sbin/service ejabberd stop >/dev/null 2>&1
77     /sbin/chkconfig --del ejabberd
78     fi
79    
80     %postun
81     if [ "$1" -ge "1" ]; then
82     /sbin/service ejabberd condrestart >/dev/null 2>&1
83     fi
84    
85     %prep
86     %setup -q -n %{name}-%{version}
87 slords 1.4 %patch1 -p0 -b .fix_paths
88     %patch2 -p0 -b .fix_user
89     dos2unix src/odbc/mssql.sql
90 slords 1.1
91     cp %{S:4} src
92     cp %{S:5} src
93     cp %{S:6} src
94     cp %{S:7} src
95    
96     %build
97     pushd src
98     %configure --enable-odbc --enable-debug
99 slords 1.4 # doesn't builds on SMP currently
100     make
101 slords 1.1 popd
102 slords 1.4 %if %{undefined rhel}
103 slords 1.1 pushd doc
104     make html pdf
105     popd
106     %endif
107    
108     %install
109     rm -rf %{buildroot}
110    
111     pushd src
112     make install DESTDIR=%{buildroot}
113     popd
114    
115 slords 1.4 chmod a+x %{buildroot}%{_libdir}/%{name}/priv/lib/*.so
116 slords 1.1
117     %{__perl} -pi -e 's!./ssl.pem!/etc/ejabberd/ejabberd.pem!g' %{buildroot}/etc/ejabberd/ejabberd.cfg
118    
119     mkdir -p %{buildroot}/var/log/ejabberd
120     mkdir -p %{buildroot}/var/lib/ejabberd/spool
121    
122     mkdir -p %{buildroot}%{_bindir}
123     ln -s consolehelper %{buildroot}%{_bindir}/ejabberdctl
124     #install -D -p -m 0755 %{S:8} %{buildroot}%{_sbindir}/ejabberdctl
125     install -D -p -m 0644 %{S:9} %{buildroot}%{_sysconfdir}/pam.d/ejabberdctl
126     install -D -p -m 0644 %{S:10} %{buildroot}%{_sysconfdir}/security/console.apps/ejabberdctl
127    
128     mkdir -p %{buildroot}%{_initrddir}
129     install -p -m 0755 %{S:1} %{buildroot}%{_initrddir}/ejabberd
130     chmod a+x %{buildroot}%{_initrddir}/ejabberd
131    
132     mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
133     cp -p %{S:2} %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd
134    
135 slords 1.4 %{__perl} -pi -e 's!\@libdir\@!%{_libdir}!g' %{buildroot}%{_initrddir}/ejabberd %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd %{buildroot}%{_sbindir}/ejabberdctl
136 slords 1.1 %{__perl} -pi -e 's!\@version\@!%{version}!g' %{buildroot}%{_initrddir}/ejabberd %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd %{buildroot}%{_sbindir}/ejabberdctl
137    
138 slords 1.4 # BZ# 439583
139     %{__perl} -pi -e 's!MAINDIR=!MAINDIR=%{_libdir}/ejabberd!g' %{buildroot}%{_sbindir}/ejabberdctl
140 slords 1.1
141     %clean
142     rm -rf %{buildroot}
143    
144     %files
145     %defattr(-,root,root,-)
146 slords 1.4 %doc COPYING src/odbc/mysql.sql src/odbc/mssql.sql src/odbc/pg.sql
147 slords 1.1
148     %attr(750,ejabberd,ejabberd) %dir %{_sysconfdir}/ejabberd
149     %attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/ejabberd.cfg
150     %attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/ejabberdctl.cfg
151     %attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/inetrc
152    
153     %{_initrddir}/ejabberd
154     %config(noreplace) %{_sysconfdir}/logrotate.d/ejabberd
155    
156     %config(noreplace) %{_sysconfdir}/pam.d/ejabberdctl
157     %config(noreplace) %{_sysconfdir}/security/console.apps/ejabberdctl
158     %{_bindir}/ejabberdctl
159     %{_sbindir}/ejabberdctl
160    
161 slords 1.4 %dir %{_libdir}/%{name}
162     %dir %{_libdir}/%{name}/ebin
163     %dir %{_libdir}/%{name}/priv
164     %dir %{_libdir}/%{name}/priv/bin
165     %dir %{_libdir}/%{name}/priv/lib
166     %dir %{_libdir}/%{name}/priv/msgs
167    
168     %{_libdir}/%{name}/ebin/*.app
169     %{_libdir}/%{name}/ebin/*.beam
170     %{_libdir}/%{name}/priv/lib/*.so
171     %{_libdir}/%{name}/priv/msgs/*.msg
172 slords 1.1
173     %attr(750,ejabberd,ejabberd) %dir /var/lib/ejabberd
174     %attr(750,ejabberd,ejabberd) %dir /var/lib/ejabberd/spool
175     %attr(750,ejabberd,ejabberd) %dir /var/log/ejabberd
176    
177     %files doc
178     %defattr(-,root,root,-)
179 slords 1.4 %if %{undefined rhel}
180     %doc ChangeLog COPYING doc/release_notes_* doc/*.pdf doc/*.html doc/*.png
181 slords 1.1 %else
182     %doc ChangeLog COPYING doc/release_notes_*
183     %endif
184    
185     %changelog
186 slords 1.4 * Sun Jun 22 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-4
187     - Last minute fix (issue with shortnames/fqdn)
188    
189     * Sun Jun 22 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-3
190     -Fixed BZ# 439583, 452326, 451554
191    
192     * Thu May 29 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-2
193     - Fixed BZ# 439583
194    
195     * Sat May 24 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-1
196     - Ver. 2.0.1
197     - Upstreamed patches dropped
198     - No longer uses versioned libdir (/usr/lib/ejabberd-x.x.x)
199     - Added sql-scripts in docs-directory
200 gnujpl 1.3
201 slords 1.1 * Mon May 5 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-3
202     - Fix build against R11B-2
203    
204     * Sat Feb 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-2
205     - Disable docs again for EPEL (we haven't hevea for EPEL)
206    
207     * Sat Feb 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-1
208     - Version 2.0.0
209    
210     * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-0.4.rc1
211     - Autorebuild for GCC 4.3
212    
213     * Wed Jan 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-0.3.rc1
214     - Really enabled some previously disabled modules
215    
216     * Wed Jan 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-0.2.rc1
217     - Enabled some previously disabled modules
218 slords 1.4
219 slords 1.1 * Sat Jan 19 2008 Matej Cepl <mcepl@redhat.com> 2.0.0-0.1.rc1
220     - Upgrade to the current upsteram version.
221     - Make ejabberd.init LSB compliant (missing Provides: tag)
222    
223     * Thu Dec 27 2007 Matej Cepl <mcepl@redhat.com> 2.0.0-0.beta1.mc.1
224     - Experimental build from the upstream betaversion.
225    
226     * Tue Dec 11 2007 Matej Cepl <mcepl@redhat.com> 1.1.4-2.fc9
227     - rebuild against new ssl library.
228     - rebuild against the newest erlang (see Patch
229     - fix %%changelog
230    
231     * Wed Sep 5 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.4-1
232     - Drop LDAP patch
233     - Update mod_ctlextra
234     - Update to 1.1.4
235    
236     * Tue Sep 4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-11
237     - Fix ejabberdctl wrapper script - #276071
238    
239     * Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-10
240     - Re-exclude ppc64
241    
242     * Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-9
243     - Fix license
244     - Don't exclude ppc64
245    
246     * Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-8
247     - Bump & rebuild to build against latest erlang package.
248    
249     * Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-7
250     - Bump release and rebuild due to Koji hiccups.
251    
252     * Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-6
253     - Don't try building on PPC64 since hevea isn't available on PPC64.
254    
255     * Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-5
256     - Sigh...
257    
258     * Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-4
259     - Don't forget to add patch.
260    
261     * Thu Jul 26 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-3
262     - Add ejabberdctl (#199873)
263     - Add patch to fix LDAP authentication. (#248268)
264     - Add a sleep in init script between stop/start when restarting.
265     - LSB compliance cleanups for init script. (#246917)
266     - Don't mention "reload" in the init script usage string. (#227254)
267    
268     * Tue Jul 24 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-2
269     - Update mod_ctlextra
270    
271     * Fri Feb 2 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-1
272     - Update to 1.1.3
273    
274     * Wed Oct 11 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.2-2
275     - Fix logrotate script (BZ#210366)
276    
277     * Mon Aug 28 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-10
278     - Bump release and rebuild.
279    
280     * Mon Jul 3 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-9
281     - Updated init script - should hopefully fix some problems with status & stop commands.
282    
283     * Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-8
284     - Bump release to that tagging works on FC-5.
285    
286     * Thu Jun 22 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-7
287     - Oops drop bad patch.
288    
289     * Thu Jun 22 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-6
290     - Split documentation off to a subpackage.
291     - Own %%{_libdir}/ejabberd-%{version}
292     - Mark %%{_sysconfdir}/logrotate.d/ejabberd as %%config
293    
294     * Thu Jun 8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-5
295     - Patch the makefile so that it adds a soname to shared libs.
296    
297     * Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-4
298     - Modify AD modules not to check for group membership.
299    
300     * Thu May 25 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-3
301     - Add some extra modules
302    
303     * Wed May 24 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-2
304     - Munge Makefile.in a bit more...
305     - Change ownership/permissions - not *everything* needs to be owned by ejabberd
306    
307     * Wed May 24 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-1
308     - First version for Fedora Extras

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed