/[smecontribs]/rpms/ejabberd/contribs7/ejabberd.spec
ViewVC logotype

Annotation of /rpms/ejabberd/contribs7/ejabberd.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.5 - (hide annotations) (download)
Wed Jun 25 19:06:40 2008 UTC (15 years, 11 months ago) by slords
Branch: MAIN
Changes since 1.4: +15 -6 lines
Reapply sme changes

1 slords 1.5 # $Id: ejabberd.spec,v 1.3 2008/05/10 15:41:02 gnujpl Exp $
2     # Authority: gnujpl
3     # Name: Jean-Paul Leclère
4    
5 slords 1.1 Name: ejabberd
6 slords 1.4 Version: 2.0.1
7 gnujpl 1.3 Release: 4%{?dist}
8 slords 1.1 Summary: A distributed, fault-tolerant Jabber/XMPP server
9    
10     Group: Applications/Internet
11 slords 1.4 License: GPLv2+
12 slords 1.1 URL: http://www.ejabberd.im/
13 slords 1.4 Source0: http://www.process-one.net/downloads/%{name}/%{version}/%{name}-%{version}_2.tar.gz
14 slords 1.1 Source1: ejabberd.init
15     Source2: ejabberd.logrotate
16    
17     # http://ejabberd.jabber.ru/ejabberdctl-extra
18     Source4: https://svn.process-one.net/ejabberd-modules/mod_ctlextra/trunk/src/mod_ctlextra.erl
19    
20     # The following were extracted from a patch found on http://realloc.spb.ru/share/ejabberdad.html
21     Source5: ejabberd_auth_ad.erl
22     Source6: mod_shared_roster_ad.erl
23     Source7: mod_vcard_ad.erl
24     #
25     #Source8: ejabberdctl
26     Source9: ejabberdctl.pam
27     Source10: ejabberdctl.apps
28    
29 slords 1.4 # Fedora-specific stuff - fixing paths
30 slords 1.1 Patch1: ejabberd-build.patch
31 slords 1.4 # BZ# 439583, 452326, 451554
32     Patch2: ejabberd-ejabberdctl_fix.diff
33 slords 1.1
34     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
35    
36     BuildRequires: expat-devel
37     BuildRequires: openssl-devel
38     BuildRequires: pam-devel
39     BuildRequires: erlang
40 slords 1.4 BuildRequires: dos2unix
41 slords 1.5 %if %{?rhel:0}%{!?rhel:1}
42 slords 1.1 BuildRequires: hevea
43     %endif
44    
45     Requires: erlang
46     Requires: usermode
47    
48 slords 1.5 #Requires(pre): fedora-usermgmt
49 slords 1.1 Requires(post): /sbin/chkconfig
50     Requires(preun): /sbin/chkconfig
51     Requires(preun): /sbin/service
52     Requires(postun): /sbin/service
53    
54     #https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=250253
55     ExcludeArch: ppc64
56    
57     %description
58     ejabberd is a Free and Open Source distributed fault-tolerant
59     Jabber/XMPP server. It is mostly written in Erlang, and runs on many
60     platforms (tested on Linux, FreeBSD, NetBSD, Solaris, Mac OS X and
61     Windows NT/2000/XP).
62    
63     %package doc
64     Summary: Documentation for ejabberd
65     Group: Documentation
66    
67     %description doc
68     Documentation for ejabberd.
69    
70     %pre
71 slords 1.5 /usr/sbin/groupadd 33 -r ejabberd &>/dev/null || :
72     /usr/sbin/useradd 33 -r -s /sbin/nologin -d /var/lib/ejabberd -M \
73 slords 1.1 -c 'ejabberd' -g ejabberd ejabberd &>/dev/null || :
74    
75     %post
76     /sbin/chkconfig --add ejabberd
77    
78     %preun
79     if [ $1 = 0 ]; then
80     /sbin/service ejabberd stop >/dev/null 2>&1
81     /sbin/chkconfig --del ejabberd
82     fi
83    
84     %postun
85     if [ "$1" -ge "1" ]; then
86     /sbin/service ejabberd condrestart >/dev/null 2>&1
87     fi
88    
89     %prep
90     %setup -q -n %{name}-%{version}
91 slords 1.4 %patch1 -p0 -b .fix_paths
92     %patch2 -p0 -b .fix_user
93     dos2unix src/odbc/mssql.sql
94 slords 1.1
95     cp %{S:4} src
96     cp %{S:5} src
97     cp %{S:6} src
98     cp %{S:7} src
99    
100     %build
101     pushd src
102     %configure --enable-odbc --enable-debug
103 slords 1.4 # doesn't builds on SMP currently
104     make
105 slords 1.1 popd
106 slords 1.5 %if %{?rhel:0}%{!?rhel:1}
107 slords 1.1 pushd doc
108     make html pdf
109     popd
110     %endif
111    
112     %install
113     rm -rf %{buildroot}
114    
115     pushd src
116     make install DESTDIR=%{buildroot}
117     popd
118    
119 slords 1.4 chmod a+x %{buildroot}%{_libdir}/%{name}/priv/lib/*.so
120 slords 1.1
121     %{__perl} -pi -e 's!./ssl.pem!/etc/ejabberd/ejabberd.pem!g' %{buildroot}/etc/ejabberd/ejabberd.cfg
122    
123     mkdir -p %{buildroot}/var/log/ejabberd
124     mkdir -p %{buildroot}/var/lib/ejabberd/spool
125    
126     mkdir -p %{buildroot}%{_bindir}
127     ln -s consolehelper %{buildroot}%{_bindir}/ejabberdctl
128     #install -D -p -m 0755 %{S:8} %{buildroot}%{_sbindir}/ejabberdctl
129     install -D -p -m 0644 %{S:9} %{buildroot}%{_sysconfdir}/pam.d/ejabberdctl
130     install -D -p -m 0644 %{S:10} %{buildroot}%{_sysconfdir}/security/console.apps/ejabberdctl
131    
132     mkdir -p %{buildroot}%{_initrddir}
133     install -p -m 0755 %{S:1} %{buildroot}%{_initrddir}/ejabberd
134     chmod a+x %{buildroot}%{_initrddir}/ejabberd
135    
136     mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
137     cp -p %{S:2} %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd
138    
139 slords 1.4 %{__perl} -pi -e 's!\@libdir\@!%{_libdir}!g' %{buildroot}%{_initrddir}/ejabberd %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd %{buildroot}%{_sbindir}/ejabberdctl
140 slords 1.1 %{__perl} -pi -e 's!\@version\@!%{version}!g' %{buildroot}%{_initrddir}/ejabberd %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd %{buildroot}%{_sbindir}/ejabberdctl
141    
142 slords 1.4 # BZ# 439583
143     %{__perl} -pi -e 's!MAINDIR=!MAINDIR=%{_libdir}/ejabberd!g' %{buildroot}%{_sbindir}/ejabberdctl
144 slords 1.1
145     %clean
146     rm -rf %{buildroot}
147    
148     %files
149     %defattr(-,root,root,-)
150 slords 1.4 %doc COPYING src/odbc/mysql.sql src/odbc/mssql.sql src/odbc/pg.sql
151 slords 1.1
152     %attr(750,ejabberd,ejabberd) %dir %{_sysconfdir}/ejabberd
153     %attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/ejabberd.cfg
154     %attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/ejabberdctl.cfg
155     %attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/inetrc
156    
157     %{_initrddir}/ejabberd
158     %config(noreplace) %{_sysconfdir}/logrotate.d/ejabberd
159    
160     %config(noreplace) %{_sysconfdir}/pam.d/ejabberdctl
161     %config(noreplace) %{_sysconfdir}/security/console.apps/ejabberdctl
162     %{_bindir}/ejabberdctl
163     %{_sbindir}/ejabberdctl
164    
165 slords 1.4 %dir %{_libdir}/%{name}
166     %dir %{_libdir}/%{name}/ebin
167     %dir %{_libdir}/%{name}/priv
168     %dir %{_libdir}/%{name}/priv/bin
169     %dir %{_libdir}/%{name}/priv/lib
170     %dir %{_libdir}/%{name}/priv/msgs
171    
172     %{_libdir}/%{name}/ebin/*.app
173     %{_libdir}/%{name}/ebin/*.beam
174     %{_libdir}/%{name}/priv/lib/*.so
175     %{_libdir}/%{name}/priv/msgs/*.msg
176 slords 1.1
177     %attr(750,ejabberd,ejabberd) %dir /var/lib/ejabberd
178     %attr(750,ejabberd,ejabberd) %dir /var/lib/ejabberd/spool
179     %attr(750,ejabberd,ejabberd) %dir /var/log/ejabberd
180    
181     %files doc
182     %defattr(-,root,root,-)
183 slords 1.5 %if %{?rhel:0}%{!?rhel:1}
184 slords 1.4 %doc ChangeLog COPYING doc/release_notes_* doc/*.pdf doc/*.html doc/*.png
185 slords 1.1 %else
186     %doc ChangeLog COPYING doc/release_notes_*
187     %endif
188    
189     %changelog
190 slords 1.5 * Wed Jun 25 2008 Jean-Paul Leclere <jean-paul@leclere.org> 2.0.1-4.sme
191     - Don't use fedora-usermgmt
192     - set ejabberd uid to 33 for SME compatibility
193     - only spec file changes
194    
195 slords 1.4 * Sun Jun 22 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-4
196     - Last minute fix (issue with shortnames/fqdn)
197    
198     * Sun Jun 22 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-3
199     -Fixed BZ# 439583, 452326, 451554
200    
201     * Thu May 29 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-2
202     - Fixed BZ# 439583
203    
204     * Sat May 24 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-1
205     - Ver. 2.0.1
206     - Upstreamed patches dropped
207     - No longer uses versioned libdir (/usr/lib/ejabberd-x.x.x)
208     - Added sql-scripts in docs-directory
209 gnujpl 1.3
210 slords 1.1 * Mon May 5 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-3
211     - Fix build against R11B-2
212    
213     * Sat Feb 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-2
214     - Disable docs again for EPEL (we haven't hevea for EPEL)
215    
216     * Sat Feb 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-1
217     - Version 2.0.0
218    
219     * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-0.4.rc1
220     - Autorebuild for GCC 4.3
221    
222     * Wed Jan 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-0.3.rc1
223     - Really enabled some previously disabled modules
224    
225     * Wed Jan 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-0.2.rc1
226     - Enabled some previously disabled modules
227 slords 1.4
228 slords 1.1 * Sat Jan 19 2008 Matej Cepl <mcepl@redhat.com> 2.0.0-0.1.rc1
229     - Upgrade to the current upsteram version.
230     - Make ejabberd.init LSB compliant (missing Provides: tag)
231    
232     * Thu Dec 27 2007 Matej Cepl <mcepl@redhat.com> 2.0.0-0.beta1.mc.1
233     - Experimental build from the upstream betaversion.
234    
235     * Tue Dec 11 2007 Matej Cepl <mcepl@redhat.com> 1.1.4-2.fc9
236     - rebuild against new ssl library.
237     - rebuild against the newest erlang (see Patch
238     - fix %%changelog
239    
240     * Wed Sep 5 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.4-1
241     - Drop LDAP patch
242     - Update mod_ctlextra
243     - Update to 1.1.4
244    
245     * Tue Sep 4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-11
246     - Fix ejabberdctl wrapper script - #276071
247    
248     * Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-10
249     - Re-exclude ppc64
250    
251     * Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-9
252     - Fix license
253     - Don't exclude ppc64
254    
255     * Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-8
256     - Bump & rebuild to build against latest erlang package.
257    
258     * Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-7
259     - Bump release and rebuild due to Koji hiccups.
260    
261     * Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-6
262     - Don't try building on PPC64 since hevea isn't available on PPC64.
263    
264     * Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-5
265     - Sigh...
266    
267     * Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-4
268     - Don't forget to add patch.
269    
270     * Thu Jul 26 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-3
271     - Add ejabberdctl (#199873)
272     - Add patch to fix LDAP authentication. (#248268)
273     - Add a sleep in init script between stop/start when restarting.
274     - LSB compliance cleanups for init script. (#246917)
275     - Don't mention "reload" in the init script usage string. (#227254)
276    
277     * Tue Jul 24 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-2
278     - Update mod_ctlextra
279    
280     * Fri Feb 2 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-1
281     - Update to 1.1.3
282    
283     * Wed Oct 11 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.2-2
284     - Fix logrotate script (BZ#210366)
285    
286     * Mon Aug 28 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-10
287     - Bump release and rebuild.
288    
289     * Mon Jul 3 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-9
290     - Updated init script - should hopefully fix some problems with status & stop commands.
291    
292     * Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-8
293     - Bump release to that tagging works on FC-5.
294    
295     * Thu Jun 22 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-7
296     - Oops drop bad patch.
297    
298     * Thu Jun 22 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-6
299     - Split documentation off to a subpackage.
300     - Own %%{_libdir}/ejabberd-%{version}
301     - Mark %%{_sysconfdir}/logrotate.d/ejabberd as %%config
302    
303     * Thu Jun 8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-5
304     - Patch the makefile so that it adds a soname to shared libs.
305    
306     * Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-4
307     - Modify AD modules not to check for group membership.
308    
309     * Thu May 25 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-3
310     - Add some extra modules
311    
312     * Wed May 24 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-2
313     - Munge Makefile.in a bit more...
314     - Change ownership/permissions - not *everything* needs to be owned by ejabberd
315    
316     * Wed May 24 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-1
317     - First version for Fedora Extras

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed