1 |
slords |
1.7 |
# $Id: ejabberd.spec,v 1.6 2008/06/25 20:50:43 gnujpl Exp $ |
2 |
slords |
1.5 |
# Authority: gnujpl |
3 |
|
|
# Name: Jean-Paul Leclère |
4 |
|
|
|
5 |
slords |
1.1 |
Name: ejabberd |
6 |
slords |
1.4 |
Version: 2.0.1 |
7 |
gnujpl |
1.3 |
Release: 4%{?dist} |
8 |
slords |
1.1 |
Summary: A distributed, fault-tolerant Jabber/XMPP server |
9 |
|
|
|
10 |
|
|
Group: Applications/Internet |
11 |
slords |
1.4 |
License: GPLv2+ |
12 |
slords |
1.1 |
URL: http://www.ejabberd.im/ |
13 |
slords |
1.4 |
Source0: http://www.process-one.net/downloads/%{name}/%{version}/%{name}-%{version}_2.tar.gz |
14 |
slords |
1.1 |
Source1: ejabberd.init |
15 |
|
|
Source2: ejabberd.logrotate |
16 |
|
|
|
17 |
|
|
# http://ejabberd.jabber.ru/ejabberdctl-extra |
18 |
|
|
Source4: https://svn.process-one.net/ejabberd-modules/mod_ctlextra/trunk/src/mod_ctlextra.erl |
19 |
|
|
|
20 |
|
|
# The following were extracted from a patch found on http://realloc.spb.ru/share/ejabberdad.html |
21 |
|
|
Source5: ejabberd_auth_ad.erl |
22 |
|
|
Source6: mod_shared_roster_ad.erl |
23 |
|
|
Source7: mod_vcard_ad.erl |
24 |
|
|
# |
25 |
|
|
#Source8: ejabberdctl |
26 |
|
|
Source9: ejabberdctl.pam |
27 |
|
|
Source10: ejabberdctl.apps |
28 |
|
|
|
29 |
slords |
1.4 |
# Fedora-specific stuff - fixing paths |
30 |
slords |
1.1 |
Patch1: ejabberd-build.patch |
31 |
slords |
1.4 |
# BZ# 439583, 452326, 451554 |
32 |
|
|
Patch2: ejabberd-ejabberdctl_fix.diff |
33 |
slords |
1.1 |
|
34 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
35 |
|
|
|
36 |
|
|
BuildRequires: expat-devel |
37 |
|
|
BuildRequires: openssl-devel |
38 |
|
|
BuildRequires: pam-devel |
39 |
|
|
BuildRequires: erlang |
40 |
slords |
1.4 |
BuildRequires: dos2unix |
41 |
slords |
1.5 |
%if %{?rhel:0}%{!?rhel:1} |
42 |
slords |
1.1 |
BuildRequires: hevea |
43 |
|
|
%endif |
44 |
|
|
|
45 |
|
|
Requires: erlang |
46 |
|
|
Requires: usermode |
47 |
|
|
|
48 |
slords |
1.5 |
#Requires(pre): fedora-usermgmt |
49 |
slords |
1.1 |
Requires(post): /sbin/chkconfig |
50 |
|
|
Requires(preun): /sbin/chkconfig |
51 |
|
|
Requires(preun): /sbin/service |
52 |
|
|
Requires(postun): /sbin/service |
53 |
|
|
|
54 |
|
|
#https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=250253 |
55 |
|
|
ExcludeArch: ppc64 |
56 |
|
|
|
57 |
|
|
%description |
58 |
|
|
ejabberd is a Free and Open Source distributed fault-tolerant |
59 |
|
|
Jabber/XMPP server. It is mostly written in Erlang, and runs on many |
60 |
|
|
platforms (tested on Linux, FreeBSD, NetBSD, Solaris, Mac OS X and |
61 |
|
|
Windows NT/2000/XP). |
62 |
|
|
|
63 |
|
|
%package doc |
64 |
|
|
Summary: Documentation for ejabberd |
65 |
|
|
Group: Documentation |
66 |
|
|
|
67 |
|
|
%description doc |
68 |
|
|
Documentation for ejabberd. |
69 |
|
|
|
70 |
|
|
%pre |
71 |
slords |
1.5 |
/usr/sbin/groupadd 33 -r ejabberd &>/dev/null || : |
72 |
|
|
/usr/sbin/useradd 33 -r -s /sbin/nologin -d /var/lib/ejabberd -M \ |
73 |
slords |
1.1 |
-c 'ejabberd' -g ejabberd ejabberd &>/dev/null || : |
74 |
|
|
|
75 |
|
|
%post |
76 |
|
|
/sbin/chkconfig --add ejabberd |
77 |
|
|
|
78 |
|
|
%preun |
79 |
|
|
if [ $1 = 0 ]; then |
80 |
|
|
/sbin/service ejabberd stop >/dev/null 2>&1 |
81 |
|
|
/sbin/chkconfig --del ejabberd |
82 |
|
|
fi |
83 |
|
|
|
84 |
|
|
%postun |
85 |
|
|
if [ "$1" -ge "1" ]; then |
86 |
|
|
/sbin/service ejabberd condrestart >/dev/null 2>&1 |
87 |
|
|
fi |
88 |
|
|
|
89 |
|
|
%prep |
90 |
|
|
%setup -q -n %{name}-%{version} |
91 |
slords |
1.4 |
%patch1 -p0 -b .fix_paths |
92 |
|
|
%patch2 -p0 -b .fix_user |
93 |
|
|
dos2unix src/odbc/mssql.sql |
94 |
slords |
1.1 |
|
95 |
|
|
cp %{S:4} src |
96 |
|
|
cp %{S:5} src |
97 |
|
|
cp %{S:6} src |
98 |
|
|
cp %{S:7} src |
99 |
|
|
|
100 |
|
|
%build |
101 |
|
|
pushd src |
102 |
gnujpl |
1.6 |
%configure --enable-odbc --enable-debug --enable-pam |
103 |
slords |
1.4 |
# doesn't builds on SMP currently |
104 |
|
|
make |
105 |
slords |
1.1 |
popd |
106 |
slords |
1.5 |
%if %{?rhel:0}%{!?rhel:1} |
107 |
slords |
1.1 |
pushd doc |
108 |
|
|
make html pdf |
109 |
|
|
popd |
110 |
|
|
%endif |
111 |
|
|
|
112 |
|
|
%install |
113 |
|
|
rm -rf %{buildroot} |
114 |
|
|
|
115 |
|
|
pushd src |
116 |
|
|
make install DESTDIR=%{buildroot} |
117 |
|
|
popd |
118 |
|
|
|
119 |
slords |
1.4 |
chmod a+x %{buildroot}%{_libdir}/%{name}/priv/lib/*.so |
120 |
slords |
1.1 |
|
121 |
|
|
%{__perl} -pi -e 's!./ssl.pem!/etc/ejabberd/ejabberd.pem!g' %{buildroot}/etc/ejabberd/ejabberd.cfg |
122 |
|
|
|
123 |
|
|
mkdir -p %{buildroot}/var/log/ejabberd |
124 |
|
|
mkdir -p %{buildroot}/var/lib/ejabberd/spool |
125 |
|
|
|
126 |
|
|
mkdir -p %{buildroot}%{_bindir} |
127 |
|
|
ln -s consolehelper %{buildroot}%{_bindir}/ejabberdctl |
128 |
|
|
#install -D -p -m 0755 %{S:8} %{buildroot}%{_sbindir}/ejabberdctl |
129 |
|
|
install -D -p -m 0644 %{S:9} %{buildroot}%{_sysconfdir}/pam.d/ejabberdctl |
130 |
|
|
install -D -p -m 0644 %{S:10} %{buildroot}%{_sysconfdir}/security/console.apps/ejabberdctl |
131 |
|
|
|
132 |
|
|
mkdir -p %{buildroot}%{_initrddir} |
133 |
|
|
install -p -m 0755 %{S:1} %{buildroot}%{_initrddir}/ejabberd |
134 |
|
|
chmod a+x %{buildroot}%{_initrddir}/ejabberd |
135 |
|
|
|
136 |
|
|
mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d |
137 |
|
|
cp -p %{S:2} %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd |
138 |
|
|
|
139 |
slords |
1.4 |
%{__perl} -pi -e 's!\@libdir\@!%{_libdir}!g' %{buildroot}%{_initrddir}/ejabberd %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd %{buildroot}%{_sbindir}/ejabberdctl |
140 |
slords |
1.1 |
%{__perl} -pi -e 's!\@version\@!%{version}!g' %{buildroot}%{_initrddir}/ejabberd %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd %{buildroot}%{_sbindir}/ejabberdctl |
141 |
|
|
|
142 |
slords |
1.4 |
# BZ# 439583 |
143 |
|
|
%{__perl} -pi -e 's!MAINDIR=!MAINDIR=%{_libdir}/ejabberd!g' %{buildroot}%{_sbindir}/ejabberdctl |
144 |
slords |
1.1 |
|
145 |
|
|
%clean |
146 |
|
|
rm -rf %{buildroot} |
147 |
|
|
|
148 |
|
|
%files |
149 |
|
|
%defattr(-,root,root,-) |
150 |
slords |
1.4 |
%doc COPYING src/odbc/mysql.sql src/odbc/mssql.sql src/odbc/pg.sql |
151 |
slords |
1.1 |
|
152 |
|
|
%attr(750,ejabberd,ejabberd) %dir %{_sysconfdir}/ejabberd |
153 |
|
|
%attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/ejabberd.cfg |
154 |
|
|
%attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/ejabberdctl.cfg |
155 |
|
|
%attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/inetrc |
156 |
|
|
|
157 |
|
|
%{_initrddir}/ejabberd |
158 |
|
|
%config(noreplace) %{_sysconfdir}/logrotate.d/ejabberd |
159 |
|
|
|
160 |
|
|
%config(noreplace) %{_sysconfdir}/pam.d/ejabberdctl |
161 |
|
|
%config(noreplace) %{_sysconfdir}/security/console.apps/ejabberdctl |
162 |
|
|
%{_bindir}/ejabberdctl |
163 |
|
|
%{_sbindir}/ejabberdctl |
164 |
|
|
|
165 |
slords |
1.4 |
%dir %{_libdir}/%{name} |
166 |
|
|
%dir %{_libdir}/%{name}/ebin |
167 |
|
|
%dir %{_libdir}/%{name}/priv |
168 |
|
|
%dir %{_libdir}/%{name}/priv/bin |
169 |
|
|
%dir %{_libdir}/%{name}/priv/lib |
170 |
|
|
%dir %{_libdir}/%{name}/priv/msgs |
171 |
|
|
|
172 |
|
|
%{_libdir}/%{name}/ebin/*.app |
173 |
|
|
%{_libdir}/%{name}/ebin/*.beam |
174 |
|
|
%{_libdir}/%{name}/priv/lib/*.so |
175 |
|
|
%{_libdir}/%{name}/priv/msgs/*.msg |
176 |
gnujpl |
1.6 |
%{_libdir}/%{name}/priv/bin/epam |
177 |
slords |
1.1 |
|
178 |
|
|
%attr(750,ejabberd,ejabberd) %dir /var/lib/ejabberd |
179 |
|
|
%attr(750,ejabberd,ejabberd) %dir /var/lib/ejabberd/spool |
180 |
|
|
%attr(750,ejabberd,ejabberd) %dir /var/log/ejabberd |
181 |
gnujpl |
1.6 |
%attr(4750,root,ejabberd) %{_libdir}/%{name}/priv/bin/epam |
182 |
slords |
1.1 |
|
183 |
|
|
%files doc |
184 |
|
|
%defattr(-,root,root,-) |
185 |
slords |
1.5 |
%if %{?rhel:0}%{!?rhel:1} |
186 |
slords |
1.4 |
%doc ChangeLog COPYING doc/release_notes_* doc/*.pdf doc/*.html doc/*.png |
187 |
slords |
1.1 |
%else |
188 |
|
|
%doc ChangeLog COPYING doc/release_notes_* |
189 |
|
|
%endif |
190 |
|
|
|
191 |
|
|
%changelog |
192 |
slords |
1.5 |
* Wed Jun 25 2008 Jean-Paul Leclere <jean-paul@leclere.org> 2.0.1-4.sme |
193 |
|
|
- Don't use fedora-usermgmt |
194 |
|
|
- set ejabberd uid to 33 for SME compatibility |
195 |
gnujpl |
1.6 |
- enable pam auth (thanks to daniel@firewall-servicers.com) |
196 |
slords |
1.5 |
- only spec file changes |
197 |
|
|
|
198 |
slords |
1.4 |
* Sun Jun 22 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-4 |
199 |
|
|
- Last minute fix (issue with shortnames/fqdn) |
200 |
|
|
|
201 |
|
|
* Sun Jun 22 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-3 |
202 |
|
|
-Fixed BZ# 439583, 452326, 451554 |
203 |
|
|
|
204 |
|
|
* Thu May 29 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-2 |
205 |
|
|
- Fixed BZ# 439583 |
206 |
|
|
|
207 |
|
|
* Sat May 24 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-1 |
208 |
|
|
- Ver. 2.0.1 |
209 |
|
|
- Upstreamed patches dropped |
210 |
|
|
- No longer uses versioned libdir (/usr/lib/ejabberd-x.x.x) |
211 |
|
|
- Added sql-scripts in docs-directory |
212 |
gnujpl |
1.3 |
|
213 |
slords |
1.1 |
* Mon May 5 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-3 |
214 |
|
|
- Fix build against R11B-2 |
215 |
|
|
|
216 |
|
|
* Sat Feb 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-2 |
217 |
|
|
- Disable docs again for EPEL (we haven't hevea for EPEL) |
218 |
|
|
|
219 |
|
|
* Sat Feb 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-1 |
220 |
|
|
- Version 2.0.0 |
221 |
|
|
|
222 |
|
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-0.4.rc1 |
223 |
|
|
- Autorebuild for GCC 4.3 |
224 |
|
|
|
225 |
|
|
* Wed Jan 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-0.3.rc1 |
226 |
|
|
- Really enabled some previously disabled modules |
227 |
|
|
|
228 |
|
|
* Wed Jan 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-0.2.rc1 |
229 |
|
|
- Enabled some previously disabled modules |
230 |
slords |
1.4 |
|
231 |
slords |
1.1 |
* Sat Jan 19 2008 Matej Cepl <mcepl@redhat.com> 2.0.0-0.1.rc1 |
232 |
|
|
- Upgrade to the current upsteram version. |
233 |
|
|
- Make ejabberd.init LSB compliant (missing Provides: tag) |
234 |
|
|
|
235 |
|
|
* Thu Dec 27 2007 Matej Cepl <mcepl@redhat.com> 2.0.0-0.beta1.mc.1 |
236 |
|
|
- Experimental build from the upstream betaversion. |
237 |
|
|
|
238 |
|
|
* Tue Dec 11 2007 Matej Cepl <mcepl@redhat.com> 1.1.4-2.fc9 |
239 |
|
|
- rebuild against new ssl library. |
240 |
|
|
- rebuild against the newest erlang (see Patch |
241 |
|
|
- fix %%changelog |
242 |
|
|
|
243 |
|
|
* Wed Sep 5 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.4-1 |
244 |
|
|
- Drop LDAP patch |
245 |
|
|
- Update mod_ctlextra |
246 |
|
|
- Update to 1.1.4 |
247 |
|
|
|
248 |
|
|
* Tue Sep 4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-11 |
249 |
|
|
- Fix ejabberdctl wrapper script - #276071 |
250 |
|
|
|
251 |
|
|
* Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-10 |
252 |
|
|
- Re-exclude ppc64 |
253 |
|
|
|
254 |
|
|
* Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-9 |
255 |
|
|
- Fix license |
256 |
|
|
- Don't exclude ppc64 |
257 |
|
|
|
258 |
|
|
* Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-8 |
259 |
|
|
- Bump & rebuild to build against latest erlang package. |
260 |
|
|
|
261 |
|
|
* Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-7 |
262 |
|
|
- Bump release and rebuild due to Koji hiccups. |
263 |
|
|
|
264 |
|
|
* Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-6 |
265 |
|
|
- Don't try building on PPC64 since hevea isn't available on PPC64. |
266 |
|
|
|
267 |
|
|
* Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-5 |
268 |
|
|
- Sigh... |
269 |
|
|
|
270 |
|
|
* Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-4 |
271 |
|
|
- Don't forget to add patch. |
272 |
|
|
|
273 |
|
|
* Thu Jul 26 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-3 |
274 |
|
|
- Add ejabberdctl (#199873) |
275 |
|
|
- Add patch to fix LDAP authentication. (#248268) |
276 |
|
|
- Add a sleep in init script between stop/start when restarting. |
277 |
|
|
- LSB compliance cleanups for init script. (#246917) |
278 |
|
|
- Don't mention "reload" in the init script usage string. (#227254) |
279 |
|
|
|
280 |
|
|
* Tue Jul 24 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-2 |
281 |
|
|
- Update mod_ctlextra |
282 |
|
|
|
283 |
|
|
* Fri Feb 2 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-1 |
284 |
|
|
- Update to 1.1.3 |
285 |
|
|
|
286 |
|
|
* Wed Oct 11 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.2-2 |
287 |
|
|
- Fix logrotate script (BZ#210366) |
288 |
|
|
|
289 |
|
|
* Mon Aug 28 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-10 |
290 |
|
|
- Bump release and rebuild. |
291 |
|
|
|
292 |
|
|
* Mon Jul 3 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-9 |
293 |
|
|
- Updated init script - should hopefully fix some problems with status & stop commands. |
294 |
|
|
|
295 |
|
|
* Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-8 |
296 |
|
|
- Bump release to that tagging works on FC-5. |
297 |
|
|
|
298 |
|
|
* Thu Jun 22 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-7 |
299 |
|
|
- Oops drop bad patch. |
300 |
|
|
|
301 |
|
|
* Thu Jun 22 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-6 |
302 |
|
|
- Split documentation off to a subpackage. |
303 |
|
|
- Own %%{_libdir}/ejabberd-%{version} |
304 |
|
|
- Mark %%{_sysconfdir}/logrotate.d/ejabberd as %%config |
305 |
|
|
|
306 |
|
|
* Thu Jun 8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-5 |
307 |
|
|
- Patch the makefile so that it adds a soname to shared libs. |
308 |
|
|
|
309 |
|
|
* Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-4 |
310 |
|
|
- Modify AD modules not to check for group membership. |
311 |
|
|
|
312 |
|
|
* Thu May 25 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-3 |
313 |
|
|
- Add some extra modules |
314 |
|
|
|
315 |
|
|
* Wed May 24 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-2 |
316 |
|
|
- Munge Makefile.in a bit more... |
317 |
|
|
- Change ownership/permissions - not *everything* needs to be owned by ejabberd |
318 |
|
|
|
319 |
|
|
* Wed May 24 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-1 |
320 |
|
|
- First version for Fedora Extras |