1 |
slords |
1.1 |
Name: ejabberd |
2 |
slords |
1.9 |
Version: 2.0.5 |
3 |
|
|
Release: 2%{?dist} |
4 |
slords |
1.1 |
Summary: A distributed, fault-tolerant Jabber/XMPP server |
5 |
|
|
|
6 |
|
|
Group: Applications/Internet |
7 |
slords |
1.4 |
License: GPLv2+ |
8 |
slords |
1.1 |
URL: http://www.ejabberd.im/ |
9 |
slords |
1.9 |
Source0: http://www.process-one.net/downloads/%{name}/%{version}/%{name}-%{version}.tar.gz |
10 |
slords |
1.1 |
Source1: ejabberd.init |
11 |
|
|
Source2: ejabberd.logrotate |
12 |
slords |
1.9 |
Source3: ejabberd.sysconfig |
13 |
slords |
1.1 |
|
14 |
slords |
1.9 |
# http://www.ejabberd.im/mod_ctlextra |
15 |
|
|
# svn export -r 873 https://svn.process-one.net/ejabberd-modules/mod_ctlextra/trunk/src/mod_ctlextra.erl |
16 |
|
|
Source4: mod_ctlextra.erl |
17 |
slords |
1.1 |
|
18 |
|
|
# The following were extracted from a patch found on http://realloc.spb.ru/share/ejabberdad.html |
19 |
|
|
Source5: ejabberd_auth_ad.erl |
20 |
|
|
Source6: mod_shared_roster_ad.erl |
21 |
|
|
Source7: mod_vcard_ad.erl |
22 |
slords |
1.9 |
|
23 |
|
|
# PAM support |
24 |
slords |
1.1 |
Source9: ejabberdctl.pam |
25 |
|
|
Source10: ejabberdctl.apps |
26 |
slords |
1.9 |
Source11: ejabberd.pam |
27 |
slords |
1.1 |
|
28 |
slords |
1.4 |
# Fedora-specific stuff - fixing paths |
29 |
slords |
1.1 |
Patch1: ejabberd-build.patch |
30 |
slords |
1.9 |
# BZ# 439583, 452326, 451554, 465196 |
31 |
slords |
1.4 |
Patch2: ejabberd-ejabberdctl_fix.diff |
32 |
slords |
1.9 |
# Use ejabberd as an example for PAM service name |
33 |
|
|
Patch3: ejabberd-ejabberd_cfg_pam_name.diff |
34 |
|
|
# CAPTCHA support, see https://support.process-one.net/doc/display/XAAI/Fighting+Multi-User+Chat+SPAM+with+CAPTCHA |
35 |
|
|
# wget https://support.process-one.net/secure/attachment/13851/XEP-0158_ejabberd-2.0.4.patch -O ejabberd-captcha.patch |
36 |
|
|
Patch4: ejabberd-captcha.patch |
37 |
|
|
|
38 |
slords |
1.1 |
|
39 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n) |
40 |
|
|
|
41 |
|
|
BuildRequires: expat-devel |
42 |
|
|
BuildRequires: openssl-devel |
43 |
|
|
BuildRequires: pam-devel |
44 |
|
|
BuildRequires: erlang |
45 |
slords |
1.4 |
BuildRequires: dos2unix |
46 |
slords |
1.9 |
%if %{undefined rhel} |
47 |
slords |
1.1 |
BuildRequires: hevea |
48 |
|
|
%endif |
49 |
|
|
|
50 |
|
|
Requires: erlang |
51 |
|
|
Requires: usermode |
52 |
|
|
|
53 |
slords |
1.9 |
Requires(pre): fedora-usermgmt |
54 |
slords |
1.1 |
Requires(post): /sbin/chkconfig |
55 |
slords |
1.9 |
Requires(post): /usr/bin/openssl |
56 |
slords |
1.1 |
Requires(preun): /sbin/chkconfig |
57 |
|
|
Requires(preun): /sbin/service |
58 |
|
|
Requires(postun): /sbin/service |
59 |
|
|
|
60 |
|
|
#https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=250253 |
61 |
|
|
ExcludeArch: ppc64 |
62 |
|
|
|
63 |
|
|
%description |
64 |
|
|
ejabberd is a Free and Open Source distributed fault-tolerant |
65 |
|
|
Jabber/XMPP server. It is mostly written in Erlang, and runs on many |
66 |
|
|
platforms (tested on Linux, FreeBSD, NetBSD, Solaris, Mac OS X and |
67 |
|
|
Windows NT/2000/XP). |
68 |
|
|
|
69 |
|
|
%package doc |
70 |
|
|
Summary: Documentation for ejabberd |
71 |
|
|
Group: Documentation |
72 |
|
|
|
73 |
|
|
%description doc |
74 |
|
|
Documentation for ejabberd. |
75 |
|
|
|
76 |
|
|
%pre |
77 |
slords |
1.9 |
/usr/sbin/fedora-groupadd 27 -r ejabberd &>/dev/null || : |
78 |
|
|
/usr/sbin/fedora-useradd 27 -r -s /sbin/nologin -d /var/lib/ejabberd -M \ |
79 |
slords |
1.1 |
-c 'ejabberd' -g ejabberd ejabberd &>/dev/null || : |
80 |
|
|
|
81 |
|
|
%post |
82 |
|
|
/sbin/chkconfig --add ejabberd |
83 |
|
|
|
84 |
slords |
1.9 |
(cd /etc/ejabberd |
85 |
|
|
if [ ! -f ejabberd.pem ] |
86 |
|
|
then |
87 |
|
|
echo "Generating SSL certificate /etc/ejabberd/ejabberd.pem..." |
88 |
|
|
HOSTNAME=$(hostname -s) |
89 |
|
|
DOMAINNAME=$(hostname -d) |
90 |
|
|
openssl req -new -x509 -days 365 -nodes -out ejabberd.pem \ |
91 |
|
|
-keyout ejabberd.pem > /dev/null 2>&1 <<+++ |
92 |
|
|
. |
93 |
|
|
. |
94 |
|
|
. |
95 |
|
|
$DOMAINNAME |
96 |
|
|
$HOSTNAME |
97 |
|
|
ejabberd |
98 |
|
|
root@$HOSTNAME.$DOMAINNAME |
99 |
|
|
+++ |
100 |
|
|
chown ejabberd:ejabberd ejabberd.pem |
101 |
|
|
chmod 600 ejabberd.pem |
102 |
|
|
fi) |
103 |
|
|
|
104 |
slords |
1.1 |
%preun |
105 |
|
|
if [ $1 = 0 ]; then |
106 |
|
|
/sbin/service ejabberd stop >/dev/null 2>&1 |
107 |
|
|
/sbin/chkconfig --del ejabberd |
108 |
|
|
fi |
109 |
|
|
|
110 |
|
|
%postun |
111 |
|
|
if [ "$1" -ge "1" ]; then |
112 |
|
|
/sbin/service ejabberd condrestart >/dev/null 2>&1 |
113 |
|
|
fi |
114 |
|
|
|
115 |
|
|
%prep |
116 |
slords |
1.9 |
%setup -q |
117 |
slords |
1.4 |
%patch1 -p0 -b .fix_paths |
118 |
|
|
%patch2 -p0 -b .fix_user |
119 |
slords |
1.9 |
%patch3 -p0 -b .pam_name |
120 |
|
|
#%patch4 -p1 -b .captcha |
121 |
slords |
1.4 |
dos2unix src/odbc/mssql.sql |
122 |
slords |
1.1 |
|
123 |
|
|
cp %{S:4} src |
124 |
|
|
cp %{S:5} src |
125 |
|
|
cp %{S:6} src |
126 |
|
|
cp %{S:7} src |
127 |
|
|
|
128 |
|
|
%build |
129 |
|
|
pushd src |
130 |
gnujpl |
1.6 |
%configure --enable-odbc --enable-debug --enable-pam |
131 |
slords |
1.4 |
# doesn't builds on SMP currently |
132 |
|
|
make |
133 |
slords |
1.1 |
popd |
134 |
slords |
1.9 |
%if %{undefined rhel} |
135 |
slords |
1.1 |
pushd doc |
136 |
|
|
make html pdf |
137 |
|
|
popd |
138 |
|
|
%endif |
139 |
|
|
|
140 |
|
|
%install |
141 |
|
|
rm -rf %{buildroot} |
142 |
|
|
|
143 |
|
|
pushd src |
144 |
|
|
make install DESTDIR=%{buildroot} |
145 |
|
|
popd |
146 |
|
|
|
147 |
slords |
1.4 |
chmod a+x %{buildroot}%{_libdir}/%{name}/priv/lib/*.so |
148 |
slords |
1.1 |
|
149 |
|
|
%{__perl} -pi -e 's!./ssl.pem!/etc/ejabberd/ejabberd.pem!g' %{buildroot}/etc/ejabberd/ejabberd.cfg |
150 |
|
|
|
151 |
|
|
mkdir -p %{buildroot}/var/log/ejabberd |
152 |
|
|
mkdir -p %{buildroot}/var/lib/ejabberd/spool |
153 |
|
|
|
154 |
|
|
mkdir -p %{buildroot}%{_bindir} |
155 |
|
|
ln -s consolehelper %{buildroot}%{_bindir}/ejabberdctl |
156 |
|
|
install -D -p -m 0644 %{S:9} %{buildroot}%{_sysconfdir}/pam.d/ejabberdctl |
157 |
|
|
install -D -p -m 0644 %{S:10} %{buildroot}%{_sysconfdir}/security/console.apps/ejabberdctl |
158 |
slords |
1.9 |
install -D -p -m 0644 %{S:11} %{buildroot}%{_sysconfdir}/pam.d/ejabberd |
159 |
|
|
|
160 |
|
|
# install init-script |
161 |
|
|
install -D -p -m 0755 %{S:1} %{buildroot}%{_initrddir}/ejabberd |
162 |
slords |
1.1 |
|
163 |
slords |
1.9 |
# install config for logrotate |
164 |
|
|
install -D -p -m 0644 %{S:2} %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd |
165 |
slords |
1.1 |
|
166 |
slords |
1.9 |
# install sysconfig file |
167 |
|
|
install -D -p -m 0644 %{S:3} %{buildroot}%{_sysconfdir}/sysconfig/ejabberd |
168 |
slords |
1.1 |
|
169 |
slords |
1.4 |
%{__perl} -pi -e 's!\@libdir\@!%{_libdir}!g' %{buildroot}%{_initrddir}/ejabberd %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd %{buildroot}%{_sbindir}/ejabberdctl |
170 |
slords |
1.1 |
%{__perl} -pi -e 's!\@version\@!%{version}!g' %{buildroot}%{_initrddir}/ejabberd %{buildroot}%{_sysconfdir}/logrotate.d/ejabberd %{buildroot}%{_sbindir}/ejabberdctl |
171 |
|
|
|
172 |
slords |
1.4 |
# BZ# 439583 |
173 |
|
|
%{__perl} -pi -e 's!MAINDIR=!MAINDIR=%{_libdir}/ejabberd!g' %{buildroot}%{_sbindir}/ejabberdctl |
174 |
slords |
1.1 |
|
175 |
|
|
%clean |
176 |
|
|
rm -rf %{buildroot} |
177 |
|
|
|
178 |
|
|
%files |
179 |
|
|
%defattr(-,root,root,-) |
180 |
slords |
1.4 |
%doc COPYING src/odbc/mysql.sql src/odbc/mssql.sql src/odbc/pg.sql |
181 |
slords |
1.9 |
# tools/captcha.sh |
182 |
slords |
1.1 |
|
183 |
|
|
%attr(750,ejabberd,ejabberd) %dir %{_sysconfdir}/ejabberd |
184 |
|
|
%attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/ejabberd.cfg |
185 |
|
|
%attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/ejabberdctl.cfg |
186 |
|
|
%attr(640,ejabberd,ejabberd) %config(noreplace) %{_sysconfdir}/ejabberd/inetrc |
187 |
|
|
|
188 |
|
|
%{_initrddir}/ejabberd |
189 |
|
|
%config(noreplace) %{_sysconfdir}/logrotate.d/ejabberd |
190 |
slords |
1.9 |
%config(noreplace) %{_sysconfdir}/sysconfig/ejabberd |
191 |
|
|
%config(noreplace) %{_sysconfdir}/pam.d/ejabberd |
192 |
slords |
1.1 |
%config(noreplace) %{_sysconfdir}/pam.d/ejabberdctl |
193 |
|
|
%config(noreplace) %{_sysconfdir}/security/console.apps/ejabberdctl |
194 |
|
|
%{_bindir}/ejabberdctl |
195 |
|
|
%{_sbindir}/ejabberdctl |
196 |
|
|
|
197 |
slords |
1.4 |
%dir %{_libdir}/%{name} |
198 |
|
|
%dir %{_libdir}/%{name}/ebin |
199 |
|
|
%dir %{_libdir}/%{name}/priv |
200 |
|
|
%dir %{_libdir}/%{name}/priv/bin |
201 |
slords |
1.9 |
%attr(4750,root,ejabberd) %{_libdir}/%{name}/priv/bin/epam |
202 |
slords |
1.4 |
%dir %{_libdir}/%{name}/priv/lib |
203 |
|
|
%dir %{_libdir}/%{name}/priv/msgs |
204 |
|
|
|
205 |
|
|
%{_libdir}/%{name}/ebin/*.app |
206 |
|
|
%{_libdir}/%{name}/ebin/*.beam |
207 |
|
|
%{_libdir}/%{name}/priv/lib/*.so |
208 |
|
|
%{_libdir}/%{name}/priv/msgs/*.msg |
209 |
slords |
1.1 |
|
210 |
|
|
%attr(750,ejabberd,ejabberd) %dir /var/lib/ejabberd |
211 |
|
|
%attr(750,ejabberd,ejabberd) %dir /var/lib/ejabberd/spool |
212 |
|
|
%attr(750,ejabberd,ejabberd) %dir /var/log/ejabberd |
213 |
|
|
|
214 |
|
|
%files doc |
215 |
|
|
%defattr(-,root,root,-) |
216 |
slords |
1.9 |
%if %{undefined rhel} |
217 |
slords |
1.4 |
%doc ChangeLog COPYING doc/release_notes_* doc/*.pdf doc/*.html doc/*.png |
218 |
slords |
1.1 |
%else |
219 |
|
|
%doc ChangeLog COPYING doc/release_notes_* |
220 |
|
|
%endif |
221 |
|
|
|
222 |
|
|
%changelog |
223 |
slords |
1.9 |
* Sat Apr 4 2009 Peter Lemenkov <lemenkov@gmail.com> 2.0.5-2 |
224 |
|
|
- Really disable CAPTCHA |
225 |
|
|
|
226 |
|
|
* Fri Apr 3 2009 Peter Lemenkov <lemenkov@gmail.com> 2.0.5-1 |
227 |
|
|
- Ver. 2.0.5 |
228 |
|
|
- Temporarily disabled CAPTCHA support |
229 |
|
|
|
230 |
|
|
* Sun Mar 15 2009 Peter Lemenkov <lemenkov@gmail.com> 2.0.4-2 |
231 |
|
|
- Support for CAPTCHA (XEP-0158) |
232 |
|
|
- Updated mod_ctlextra.erl (fixed EJAB-789, EJAB-864) |
233 |
|
|
|
234 |
|
|
* Sun Mar 15 2009 Peter Lemenkov <lemenkov@gmail.com> 2.0.4-1 |
235 |
|
|
- Ver. 2.0.4 |
236 |
|
|
|
237 |
|
|
* Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-2 |
238 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild |
239 |
|
|
|
240 |
|
|
* Mon Jan 26 2009 Peter Lemenkov <lemenkov@gmail.com> 2.0.3-1 |
241 |
|
|
- Ver. 2.0.3 |
242 |
|
|
- Merged some stuff from git://dev.laptop.org/users/martin/ejabberd-xs.git |
243 |
|
|
|
244 |
|
|
* Fri Jan 16 2009 Tomas Mraz <tmraz@redhat.com> 2.0.2-4 |
245 |
|
|
- rebuild with new openssl |
246 |
|
|
|
247 |
|
|
* Thu Oct 2 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.2-3 |
248 |
|
|
- Fixed broken ejabberdctl (BZ# 465196) |
249 |
|
|
|
250 |
|
|
* Sat Aug 30 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.2-2 |
251 |
|
|
- Added missing Requires |
252 |
|
|
|
253 |
|
|
* Fri Aug 29 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.2-1 |
254 |
|
|
- Ver. 2.0.2 |
255 |
|
|
|
256 |
|
|
* Sat Aug 9 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.2-0.3.beta1 |
257 |
|
|
- PAM support (BZ# 452803) |
258 |
|
|
|
259 |
|
|
* Sat Aug 9 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.2-0.2.beta1 |
260 |
|
|
- Fix build with --fuzz=0 |
261 |
|
|
|
262 |
|
|
* Sat Aug 9 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.2-0.1.beta1 |
263 |
|
|
- Version 2.0.2-beta1 |
264 |
|
|
- Fixed BZ# 452326 |
265 |
|
|
- Fixed BZ# 227270 |
266 |
slords |
1.5 |
|
267 |
slords |
1.4 |
* Sun Jun 22 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-4 |
268 |
|
|
- Last minute fix (issue with shortnames/fqdn) |
269 |
|
|
|
270 |
|
|
* Sun Jun 22 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-3 |
271 |
|
|
-Fixed BZ# 439583, 452326, 451554 |
272 |
|
|
|
273 |
|
|
* Thu May 29 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-2 |
274 |
|
|
- Fixed BZ# 439583 |
275 |
|
|
|
276 |
|
|
* Sat May 24 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.1-1 |
277 |
|
|
- Ver. 2.0.1 |
278 |
|
|
- Upstreamed patches dropped |
279 |
|
|
- No longer uses versioned libdir (/usr/lib/ejabberd-x.x.x) |
280 |
|
|
- Added sql-scripts in docs-directory |
281 |
gnujpl |
1.3 |
|
282 |
slords |
1.1 |
* Mon May 5 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-3 |
283 |
|
|
- Fix build against R11B-2 |
284 |
|
|
|
285 |
|
|
* Sat Feb 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-2 |
286 |
|
|
- Disable docs again for EPEL (we haven't hevea for EPEL) |
287 |
|
|
|
288 |
|
|
* Sat Feb 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-1 |
289 |
|
|
- Version 2.0.0 |
290 |
|
|
|
291 |
|
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.0-0.4.rc1 |
292 |
|
|
- Autorebuild for GCC 4.3 |
293 |
|
|
|
294 |
|
|
* Wed Jan 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-0.3.rc1 |
295 |
|
|
- Really enabled some previously disabled modules |
296 |
|
|
|
297 |
|
|
* Wed Jan 23 2008 Peter Lemenkov <lemenkov@gmail.com> 2.0.0-0.2.rc1 |
298 |
|
|
- Enabled some previously disabled modules |
299 |
slords |
1.4 |
|
300 |
slords |
1.1 |
* Sat Jan 19 2008 Matej Cepl <mcepl@redhat.com> 2.0.0-0.1.rc1 |
301 |
|
|
- Upgrade to the current upsteram version. |
302 |
|
|
- Make ejabberd.init LSB compliant (missing Provides: tag) |
303 |
|
|
|
304 |
|
|
* Thu Dec 27 2007 Matej Cepl <mcepl@redhat.com> 2.0.0-0.beta1.mc.1 |
305 |
|
|
- Experimental build from the upstream betaversion. |
306 |
|
|
|
307 |
|
|
* Tue Dec 11 2007 Matej Cepl <mcepl@redhat.com> 1.1.4-2.fc9 |
308 |
|
|
- rebuild against new ssl library. |
309 |
|
|
- rebuild against the newest erlang (see Patch |
310 |
|
|
- fix %%changelog |
311 |
|
|
|
312 |
|
|
* Wed Sep 5 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.4-1 |
313 |
|
|
- Drop LDAP patch |
314 |
|
|
- Update mod_ctlextra |
315 |
|
|
- Update to 1.1.4 |
316 |
|
|
|
317 |
|
|
* Tue Sep 4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-11 |
318 |
|
|
- Fix ejabberdctl wrapper script - #276071 |
319 |
|
|
|
320 |
|
|
* Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-10 |
321 |
|
|
- Re-exclude ppc64 |
322 |
|
|
|
323 |
|
|
* Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-9 |
324 |
|
|
- Fix license |
325 |
|
|
- Don't exclude ppc64 |
326 |
|
|
|
327 |
|
|
* Wed Aug 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-8 |
328 |
|
|
- Bump & rebuild to build against latest erlang package. |
329 |
|
|
|
330 |
|
|
* Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-7 |
331 |
|
|
- Bump release and rebuild due to Koji hiccups. |
332 |
|
|
|
333 |
|
|
* Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-6 |
334 |
|
|
- Don't try building on PPC64 since hevea isn't available on PPC64. |
335 |
|
|
|
336 |
|
|
* Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-5 |
337 |
|
|
- Sigh... |
338 |
|
|
|
339 |
|
|
* Tue Jul 31 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-4 |
340 |
|
|
- Don't forget to add patch. |
341 |
|
|
|
342 |
|
|
* Thu Jul 26 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-3 |
343 |
|
|
- Add ejabberdctl (#199873) |
344 |
|
|
- Add patch to fix LDAP authentication. (#248268) |
345 |
|
|
- Add a sleep in init script between stop/start when restarting. |
346 |
|
|
- LSB compliance cleanups for init script. (#246917) |
347 |
|
|
- Don't mention "reload" in the init script usage string. (#227254) |
348 |
|
|
|
349 |
|
|
* Tue Jul 24 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-2 |
350 |
|
|
- Update mod_ctlextra |
351 |
|
|
|
352 |
|
|
* Fri Feb 2 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.3-1 |
353 |
|
|
- Update to 1.1.3 |
354 |
|
|
|
355 |
|
|
* Wed Oct 11 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.2-2 |
356 |
|
|
- Fix logrotate script (BZ#210366) |
357 |
|
|
|
358 |
|
|
* Mon Aug 28 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-10 |
359 |
|
|
- Bump release and rebuild. |
360 |
|
|
|
361 |
|
|
* Mon Jul 3 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-9 |
362 |
|
|
- Updated init script - should hopefully fix some problems with status & stop commands. |
363 |
|
|
|
364 |
|
|
* Mon Jun 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-8 |
365 |
|
|
- Bump release to that tagging works on FC-5. |
366 |
|
|
|
367 |
|
|
* Thu Jun 22 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-7 |
368 |
|
|
- Oops drop bad patch. |
369 |
|
|
|
370 |
|
|
* Thu Jun 22 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-6 |
371 |
|
|
- Split documentation off to a subpackage. |
372 |
|
|
- Own %%{_libdir}/ejabberd-%{version} |
373 |
|
|
- Mark %%{_sysconfdir}/logrotate.d/ejabberd as %%config |
374 |
|
|
|
375 |
|
|
* Thu Jun 8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-5 |
376 |
|
|
- Patch the makefile so that it adds a soname to shared libs. |
377 |
|
|
|
378 |
|
|
* Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-4 |
379 |
|
|
- Modify AD modules not to check for group membership. |
380 |
|
|
|
381 |
|
|
* Thu May 25 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-3 |
382 |
|
|
- Add some extra modules |
383 |
|
|
|
384 |
|
|
* Wed May 24 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-2 |
385 |
|
|
- Munge Makefile.in a bit more... |
386 |
|
|
- Change ownership/permissions - not *everything* needs to be owned by ejabberd |
387 |
|
|
|
388 |
|
|
* Wed May 24 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.1.1-1 |
389 |
|
|
- First version for Fedora Extras |