1 |
slords |
1.1 |
%{expand: %%{global} _i_am_%{_target_os} %%{nil}} |
2 |
|
|
# If OS is Linux |
3 |
|
|
%{?_i_am_linux: %global ezroot /usr} |
4 |
|
|
%{?_i_am_linux: %global ezcgi /var/www/cgi-bin} |
5 |
|
|
%{?_i_am_linux: %global rcdir /etc/ezmlm} |
6 |
|
|
# If OS is not Linux |
7 |
|
|
%{!?_i_am_linux: %global ezroot /usr/local} |
8 |
|
|
%{!?_i_am_linux: %global ezcgi /usr/local/apache/cgi-bin} |
9 |
|
|
%{!?_i_am_linux: %global rcdir /usr/local/etc/ezmlm} |
10 |
|
|
# endif OS |
11 |
|
|
%define dbase std |
12 |
|
|
%define destdir %buildroot |
13 |
|
|
%global ezver 0.53 |
14 |
|
|
%global idxver 5.1.2 |
15 |
|
|
Buildprereq: rpm >= 3.0.2 |
16 |
|
|
Buildroot: %_tmppath/%name-%version-root |
17 |
|
|
License: GPL |
18 |
|
|
Group: Utilities/System |
19 |
|
|
Name: ezmlm-idx |
20 |
|
|
Packager: mw@csi.hu |
21 |
|
|
Prereq: rpm >= 3.0.2 |
22 |
|
|
Release: 7%{?dist} |
23 |
|
|
Source0: ftp://cr.yp.to/software/ezmlm-%{ezver}.tar.gz |
24 |
|
|
Source1: http://ezmlm.org/archive/%{idxver}/%{name}-%{idxver}.tar.gz |
25 |
|
|
Source3: ezmlm-idx.spec-kit.tar.gz |
26 |
|
|
Summary: Qmail Easy Mailing List Manager + IDX patches. |
27 |
|
|
URL: http://www.ezmlm.org |
28 |
|
|
Version: %{idxver} |
29 |
|
|
|
30 |
|
|
%description |
31 |
|
|
None. See subpackages. |
32 |
|
|
|
33 |
|
|
%package %{dbase} |
34 |
|
|
Summary: Qmail Easy Mailing List Manager + IDX patches with %{dbase} database support. |
35 |
|
|
Group: Utilities/System |
36 |
|
|
Obsoletes: ezmlm-idx |
37 |
|
|
Provides: EZMLM |
38 |
|
|
Conflicts: ezmlm ezmlm-idx-mysql ezmlm-idx-pgsql |
39 |
|
|
|
40 |
|
|
%description %{dbase} |
41 |
|
|
ezmlm lets users set up their own mailing lists within qmail's address |
42 |
|
|
hierarchy. A user, Joe, types |
43 |
|
|
|
44 |
|
|
ezmlm-make ~/SOS ~/.qmail-sos joe-sos isp.net |
45 |
|
|
|
46 |
|
|
and instantly has a functioning mailing list, joe-sos@isp.net, with all |
47 |
|
|
relevant information stored in a new ~/SOS directory. |
48 |
|
|
|
49 |
|
|
ezmlm sets up joe-sos-subscribe and joe-sos-unsubscribe for automatic |
50 |
|
|
processing of subscription and unsubscription requests. Any message to |
51 |
|
|
joe-sos-subscribe will work; Joe doesn't have to explain any tricky |
52 |
|
|
command formats. ezmlm will send back instructions if a subscriber sends |
53 |
|
|
a message to joe-sos-request or joe-sos-help. |
54 |
|
|
|
55 |
|
|
ezmlm automatically archives new messages. Messages are labelled with |
56 |
|
|
sequence numbers; a subscriber can fetch message 123 by sending mail to |
57 |
|
|
joe-sos-get.123. The archive format supports fast message retrieval even |
58 |
|
|
when there are thousands of messages. |
59 |
|
|
|
60 |
|
|
ezmlm takes advantage of qmail's VERPs to reliably determine the |
61 |
|
|
recipient address and message number for every incoming bounce message. |
62 |
|
|
It waits ten days and then sends the subscriber a list of message |
63 |
|
|
numbers that bounced. If that warning bounces, ezmlm sends a probe; if |
64 |
|
|
the probe bounces, ezmlm automatically removes the subscriber from the |
65 |
|
|
mailing list. |
66 |
|
|
|
67 |
|
|
|
68 |
|
|
ezmlm is easy for users to control. Joe can edit ~/SOS/text/* to change |
69 |
|
|
any of the administrative messages sent to subscribers. He can remove |
70 |
|
|
~/SOS/public and ~/SOS/archived to disable automatic subscription and |
71 |
|
|
archiving. He can put his own address into ~/SOS/editor to set up a |
72 |
|
|
moderated mailing list. He can edit ~/SOS/{headeradd,headerremove} to |
73 |
|
|
control outgoing headers. ezmlm has several utilities to manually |
74 |
|
|
inspect and manage mailing lists. |
75 |
|
|
|
76 |
|
|
ezmlm uses Delivered-To to stop forwarding loops, Mailing-List to |
77 |
|
|
protect other mailing lists against false subscription requests, and |
78 |
|
|
real cryptographic cookies to protect normal users against false |
79 |
|
|
subscription requests. ezmlm can also be used for a sublist, |
80 |
|
|
redistributing messages from another list. |
81 |
|
|
|
82 |
|
|
ezmlm is reliable, even in the face of system crashes. It writes each |
83 |
|
|
new subscription and each new message safely to disk before it reports |
84 |
|
|
success to qmail. |
85 |
|
|
|
86 |
|
|
ezmlm doesn't mind huge mailing lists. Lists don't even have to fit into |
87 |
|
|
memory. ezmlm hashes the subscription list into a set of independent |
88 |
|
|
files so that it can handle subscription requests quickly. ezmlm uses |
89 |
|
|
qmail for blazingly fast parallel SMTP deliveries. |
90 |
|
|
|
91 |
|
|
The IDX patches add: Indexing, (Remote) Moderation, digest, make |
92 |
|
|
patches, multi-language, MIME, global interface, %{dbase} database support. |
93 |
|
|
|
94 |
|
|
%description %{dbase} -l pl |
95 |
|
|
Menad<BF>er pocztowych list dyskusyjnych, ca<B3>kowicie spolszczony, mo<BF>liwo |
96 |
|
|
<B6><F6> zdalnego moderowania, MIME. |
97 |
|
|
|
98 |
|
|
%package cgi |
99 |
|
|
Prefix: %ezcgi |
100 |
|
|
Summary: www archiver for %name |
101 |
|
|
Group: Utilities/System |
102 |
|
|
Requires: EZMLM |
103 |
|
|
|
104 |
|
|
%description cgi |
105 |
|
|
www archiver for %name. |
106 |
|
|
|
107 |
|
|
|
108 |
|
|
%prep |
109 |
|
|
%setup -q -T -b 0 -n ezmlm-%{ezver} |
110 |
|
|
%setup -q -D -T -a 1 -n ezmlm-%{ezver} |
111 |
|
|
mv -f ezmlm-idx-%{idxver}/* . |
112 |
|
|
|
113 |
|
|
patch -s < idx.patch |
114 |
|
|
|
115 |
|
|
%build |
116 |
|
|
echo gcc -O2 --include /usr/include/errno.h > conf-cc |
117 |
|
|
echo %{rcdir} >conf-etc |
118 |
|
|
echo %{ezroot}/bin > conf-bin |
119 |
|
|
echo %{ezroot}/man > conf-man |
120 |
|
|
|
121 |
|
|
if [ "%{dbase}" = "mysql" ]; then |
122 |
|
|
echo "cc -s -lz" > conf-ld |
123 |
|
|
fi |
124 |
|
|
|
125 |
|
|
|
126 |
|
|
# Check for gcc version with optimizer bug |
127 |
|
|
|
128 |
|
|
GCC_VERSION="$(cc -v 2>& 1 | tail -1 |awk '{print $3}')" |
129 |
|
|
|
130 |
|
|
if [ "$GCC_VERSION" = "2.95" ] || [ "$GCC_VERSION" = "2.95.1" ]; then |
131 |
|
|
echo cc > conf-cc |
132 |
|
|
fi |
133 |
|
|
|
134 |
|
|
echo %{dbase} >conf-sub |
135 |
|
|
make it man install |
136 |
|
|
|
137 |
|
|
%install |
138 |
|
|
/bin/rm -rf %destdir |
139 |
|
|
|
140 |
|
|
mkdir -p %destdir/%{ezroot}/{bin,man} |
141 |
|
|
mkdir -p %destdir/%{rcdir} |
142 |
|
|
mkdir -p %destdir/%ezcgi |
143 |
|
|
|
144 |
|
|
# Do not create cat subdirs on Linux |
145 |
|
|
%ifos Linux |
146 |
|
|
sed '/cat/d' MAN > MAN.tmp |
147 |
|
|
mv MAN.tmp MAN |
148 |
|
|
%endif |
149 |
|
|
|
150 |
|
|
./install %{destdir}/%{rcdir} < ETC |
151 |
|
|
./install %{destdir}/%{ezroot}/bin < BIN |
152 |
|
|
./install %{destdir}/%{ezroot}/man < MAN |
153 |
|
|
ln -s `head -n 1 conf-lang` %{destdir}/%{rcdir}/default |
154 |
|
|
|
155 |
|
|
cp ezmlm-cgi %destdir/%ezcgi |
156 |
|
|
|
157 |
|
|
# create file list for man pages (without ezmlm-cgi.1) |
158 |
|
|
find %destdir/%{ezroot}/man -type f \ |
159 |
|
|
| sed -e "s}%destdir}}" -e "s}$}*}" > man-list |
160 |
|
|
|
161 |
|
|
cp ezmlm-cgi.1 %destdir/%{ezroot}/man/man1 |
162 |
|
|
chmod 644 %destdir/%{ezroot}/man/man1/ezmlm-cgi.1 |
163 |
|
|
|
164 |
|
|
# Create INSTALL file for how to set up ezcgi |
165 |
|
|
cat <<EOF > INSTALL.cgi |
166 |
|
|
The script ezmlm-cgi is installed as %ezcgi/ezmlm-cgi with |
167 |
|
|
permissions 0444. In order to use it, you need to make it |
168 |
|
|
SUID root. So do |
169 |
|
|
|
170 |
|
|
chmod 4755 %ezcgi/ezmlm-cgi |
171 |
|
|
|
172 |
|
|
Please see INSTALL.idx 16-22) in this package's doc directory and the |
173 |
|
|
man page ezmlm-cgi.1 for more details on setting up and using ezmlm-cgi. |
174 |
|
|
|
175 |
|
|
EOF |
176 |
|
|
|
177 |
|
|
%post %{dbase} |
178 |
|
|
echo To create an ezmlmrc file for a language other than US English |
179 |
|
|
echo go to this package\'s doc directory, and type |
180 |
|
|
echo " make iso" |
181 |
|
|
echo 'where "iso" is the ISO language designation.' |
182 |
|
|
echo For currently supported languages, see the INSTALL.idx |
183 |
|
|
echo file, section 7. |
184 |
|
|
|
185 |
|
|
%clean |
186 |
|
|
/bin/rm -rf %destdir |
187 |
|
|
|
188 |
|
|
%files %{dbase} -f man-list |
189 |
|
|
%defattr(-, root, root) |
190 |
|
|
%dir %{rcdir} |
191 |
|
|
%config(noreplace) %{rcdir}/* |
192 |
|
|
%doc BLURB CHANGES* FAQ.idx INSTALL INSTALL.idx README* |
193 |
|
|
%doc THANKS TODO UPGRADE.idx ChangeLog |
194 |
|
|
%doc DOWNGRADE.idx ezmlmrc.template |
195 |
|
|
%dir %{ezroot} |
196 |
|
|
%dir %{ezroot}/* |
197 |
|
|
%{ezroot}/bin/* |
198 |
|
|
|
199 |
|
|
%files cgi |
200 |
|
|
%defattr(-, root, root) |
201 |
|
|
%doc INSTALL.idx INSTALL.cgi ezcgirc ezcgi.css |
202 |
|
|
%attr(0444,root,root) %ezcgi/* |
203 |
|
|
%{ezroot}/man/man1/ezmlm-cgi.1.gz |