1 |
|
2 |
|
3 |
%define DEFAULT_LANGUAGE en_US |
4 |
|
5 |
%define ezcgi /var/www/cgi-bin |
6 |
%define ezcgi %{_localstatedir}/www/cgi-bin |
7 |
%define rcdir %{_sysconfdir}/ezmlm |
8 |
%define version 7.2.2 |
9 |
%define release 1 |
10 |
Name: ezmlm-idx |
11 |
Version: %{version} |
12 |
Release: %{release}%{?dist} |
13 |
Summary: Easy Mailing List Manager for qmail + IDX patches |
14 |
License: GPL-2.0 |
15 |
Group: Productivity/Networking/Email/Mailinglists |
16 |
Url: http://untroubled.org/ezmlm/ |
17 |
Source0: http://untroubled.org/ezmlm/archive/%{version}/%{name}-%{version}.tar.gz |
18 |
BuildRequires: mysql-devel |
19 |
BuildRequires: postgresql-devel |
20 |
Provides: ezmlm = %{version} |
21 |
Obsoletes: ezmlm < %{version} |
22 |
Provides: ezmlm-idx-std = %{version} |
23 |
Obsoletes: ezmlm-idx-std < %{version} |
24 |
Provides: ezmlm-toaster = %{version} |
25 |
Obsoletes: ezmlm-toaster < %{version} |
26 |
BuildRoot: %{_tmppath}/%{name}-%{version}-build |
27 |
BuildRequires: groff |
28 |
|
29 |
%description |
30 |
ezmlm lets users set up their own mailing lists within qmail's address |
31 |
hierarchy. A user, Joe, types |
32 |
|
33 |
ezmlm-make ~/SOS ~/.qmail-sos joe-sos isp.net |
34 |
|
35 |
and instantly has a functioning mailing list, joe-sos@isp.net, with all |
36 |
relevant information stored in a new ~/SOS directory. |
37 |
|
38 |
ezmlm sets up joe-sos-subscribe and joe-sos-unsubscribe for automatic |
39 |
processing of subscription and unsubscription requests. Any message to |
40 |
joe-sos-subscribe will work; Joe doesn't have to explain any tricky |
41 |
command formats. ezmlm will send back instructions if a subscriber sends |
42 |
a message to joe-sos-request or joe-sos-help. |
43 |
|
44 |
ezmlm automatically archives new messages. Messages are labelled with |
45 |
sequence numbers; a subscriber can fetch message 123 by sending mail to |
46 |
joe-sos-get.123. The archive format supports fast message retrieval even |
47 |
when there are thousands of messages. |
48 |
|
49 |
ezmlm takes advantage of qmail's VERPs to reliably determine the |
50 |
recipient address and message number for every incoming bounce message. |
51 |
It waits ten days and then sends the subscriber a list of message |
52 |
numbers that bounced. If that warning bounces, ezmlm sends a probe; if |
53 |
the probe bounces, ezmlm automatically removes the subscriber from the |
54 |
mailing list. |
55 |
|
56 |
ezmlm is easy for users to control. Joe can edit ~/SOS/text/* to change |
57 |
any of the administrative messages sent to subscribers. He can remove |
58 |
~/SOS/public and ~/SOS/archived to disable automatic subscription and |
59 |
archiving. He can put his own address into ~/SOS/editor to set up a |
60 |
moderated mailing list. He can edit ~/SOS/{headeradd,headerremove} to |
61 |
control outgoing headers. ezmlm has several utilities to manually |
62 |
inspect and manage mailing lists. |
63 |
|
64 |
ezmlm uses Delivered-To to stop forwarding loops, Mailing-List to |
65 |
protect other mailing lists against false subscription requests, and |
66 |
real cryptographic cookies to protect normal users against false |
67 |
subscription requests. ezmlm can also be used for a sublist, |
68 |
redistributing messages from another list. |
69 |
|
70 |
ezmlm is reliable, even in the face of system crashes. It writes each |
71 |
new subscription and each new message safely to disk before it reports |
72 |
success to qmail. |
73 |
|
74 |
ezmlm doesn't mind huge mailing lists. Lists don't even have to fit into |
75 |
memory. ezmlm hashes the subscription list into a set of independent |
76 |
files so that it can handle subscription requests quickly. ezmlm uses |
77 |
qmail for blazingly fast parallel SMTP deliveries. |
78 |
|
79 |
The IDX patches add: Indexing, (Remote) Moderation, digest, make |
80 |
patches, multi-language, MIME, global interface, SQL database support. |
81 |
|
82 |
%package mysql |
83 |
Summary: MySQL support module for ezmlm-idx |
84 |
Group: Productivity/Networking/Email/Mailinglists |
85 |
Requires: ezmlm-idx = %{version} |
86 |
|
87 |
%description mysql |
88 |
MySQL support module for ezmlm-idx. A detailed explanation can be found here: |
89 |
http://www.ezmlm.org/faq/ezmlm-support-for-SQL-databases.html |
90 |
|
91 |
%package pgsql |
92 |
Summary: PostgreSQL support module for ezmlm-idx |
93 |
Group: Productivity/Networking/Email/Mailinglists |
94 |
Requires: ezmlm-idx = %{version} |
95 |
|
96 |
%description pgsql |
97 |
PostgreSQL support module for ezmlm-idx. A detailed explanation can be found here: |
98 |
http://www.ezmlm.org/faq/ezmlm-support-for-SQL-databases.html |
99 |
|
100 |
%package cgi |
101 |
Summary: WWW archiver for %{name} |
102 |
Group: Productivity/Networking/Email/Mailinglists |
103 |
Requires: ezmlm-idx = %{version} |
104 |
Prefix: %{ezcgi} |
105 |
|
106 |
%description cgi |
107 |
www archiver for %{name}. After installation change the SUID permission as follows: |
108 |
|
109 |
> chmod 4755 %{ezcgi}/ezmlm-cgi |
110 |
|
111 |
%prep |
112 |
%setup -q |
113 |
|
114 |
%build |
115 |
echo %{rcdir} > conf-etc |
116 |
echo %{_bindir} > conf-bin |
117 |
echo %{_mandir} > conf-man |
118 |
echo %{_libdir}/%{name} > conf-lib |
119 |
echo gcc %{optflags} -I%{_includedir}/mysql -I%{_includedir}/pgsql > conf-cc |
120 |
echo gcc %{optflags} -export-dynamic -L%{_libdir}/mysql > conf-ld |
121 |
|
122 |
make %{?_smp_mflags} clean |
123 |
make %{?_smp_mflags} it man installer mysql pgsql |
124 |
|
125 |
sed '/cat/d' MAN > MAN.tmp |
126 |
mv MAN.tmp MAN |
127 |
|
128 |
# Create INSTALL file for how to set up ezcgi |
129 |
echo "The script ezmlm-cgi is installed as %{ezcgi}/ezmlm-cgi with |
130 |
permissions 0444. In order to use it, you need to make it |
131 |
SUID root. So do |
132 |
|
133 |
chmod 4755 %{ezcgi}/ezmlm-cgi |
134 |
|
135 |
Please see INSTALL 16-22) in this package's doc directory and the |
136 |
man page ezmlm-cgi.1 for more details on setting up and using ezmlm-cgi. |
137 |
" > INSTALL.cgi |
138 |
|
139 |
%install |
140 |
mkdir -p %{buildroot}/%{_bindir} |
141 |
mkdir -p %{buildroot}/%{_libdir}/ezmlm |
142 |
mkdir -p %{buildroot}/%{rcdir} |
143 |
mkdir -p %{buildroot}/%{ezcgi} |
144 |
mkdir -p %{buildroot}/%{_defaultdocdir}/%{name} |
145 |
mkdir -p %{buildroot}/%{_defaultdocdir}/%{name}-cgi |
146 |
|
147 |
./installer %{buildroot}/%{rcdir} < ETC |
148 |
./installer %{buildroot}/%{_bindir} < BIN |
149 |
./installer %{buildroot}/%{_mandir} < MAN |
150 |
./installer %{buildroot}/%{_libdir}/%{name} < LIB |
151 |
|
152 |
ln -s `head -n 1 conf-lang` %{buildroot}/%{rcdir}/default |
153 |
|
154 |
install -m0644 ezmlm-cgi %{buildroot}/%{ezcgi}/ |
155 |
|
156 |
# create file list for man pages (without ezmlm-cgi.1 which goes to a seperate package) |
157 |
find %{buildroot}/%{_mandir} -type f | sed -e "s}%{buildroot}}}" -e "s}$}*}" | grep -v ezmlm-cgi.1 > man-list |
158 |
cp ezmlm-cgi.1 %{buildroot}/%{_mandir}/man1 |
159 |
chmod 644 %{buildroot}/%{_mandir}/man1/ezmlm-cgi.1 |
160 |
|
161 |
%if 0%{?suse_version} > 1020 |
162 |
%fdupes -s %{buildroot}/%{rcdir} |
163 |
%endif |
164 |
|
165 |
%check |
166 |
./ezmlm-test || : |
167 |
|
168 |
%files -f man-list |
169 |
%defattr(-,root,root,0755) |
170 |
%doc BLURB CHANGES* FAQ INSTALL README* ChangeLog |
171 |
%doc THANKS TODO UPGRADE DOWNGRADE ezmlmrc.template |
172 |
%{_bindir}/* |
173 |
%dir %{rcdir} |
174 |
%config(noreplace) %{rcdir}/* |
175 |
%dir %{_libdir}/%{name} |
176 |
%{_libdir}/%{name}/sub-std.so |
177 |
|
178 |
%files cgi |
179 |
%defattr(0644,root,root,0755) |
180 |
%doc INSTALL.cgi ezcgirc ezcgi.css |
181 |
%{_mandir}/man1/ezmlm-cgi.1* |
182 |
%attr(0444,root,root) %{ezcgi}/* |
183 |
|
184 |
%files mysql |
185 |
%defattr(0644,root,root) |
186 |
%{_libdir}/%{name}/sub-mysql.so |
187 |
|
188 |
%files pgsql |
189 |
%defattr(0644,root,root) |
190 |
%{_libdir}/%{name}/sub-pgsql.so |
191 |
|
192 |
%changelog |
193 |
* Mon Apr 18 2016 Jean-Philipe Pialasse <tests@pialasse.com> 7.2.2-2.sme |
194 |
- upgrade to v7.2.2 [SME: 7587] |
195 |
- new spec file created from the one of opensuse |