1 |
jpp |
1.3 |
# $Id: ezmlm-web.spec,v 1.2 2022/03/16 23:50:11 jpp Exp $ |
2 |
jpp |
1.1 |
# Authority: gordonr |
3 |
|
|
# Name: Gordon Rowell |
4 |
|
|
|
5 |
|
|
Summary: Web interface to ezmlm configuration |
6 |
|
|
%define name ezmlm-web |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 3.3.1 |
9 |
jpp |
1.3 |
%define release 9 |
10 |
jpp |
1.1 |
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: BSD-style |
13 |
|
|
Group: Networking/Daemons |
14 |
|
|
URL: https://systemausfall.org/toolforge/ezmlm-web/ |
15 |
|
|
Source: https://systemausfall.org/toolforge/ezmlm-web/download/ezmlm-web-3.3.1.tar.gz |
16 |
|
|
Patch0: ezmlm-web-3.3.1-smeintegration.patch |
17 |
|
|
Patch1: ezmlm-web-3.3.1-cgi.patch |
18 |
|
|
Patch2: ezmlm-web-3.3.1-modiffor722.patch |
19 |
jpp |
1.3 |
Patch3: ezmlm-web-3.3.1-bz11913-deprecateddefined.patch |
20 |
jpp |
1.1 |
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
21 |
|
|
Requires: ezmlm-idx-std |
22 |
|
|
Requires: httpd |
23 |
|
|
Requires: qmail |
24 |
|
|
Requires: perl |
25 |
|
|
Requires: perl-Ezmlm |
26 |
|
|
Requires: perl-MailTools |
27 |
|
|
BuildRequires: gcc |
28 |
|
|
BuildRequires: e-smith-devtools |
29 |
|
|
BuildRequires: perl-Ezmlm |
30 |
|
|
BuildRequires: perl-devel |
31 |
|
|
|
32 |
|
|
%description |
33 |
|
|
The need for ezmlm-web arose from the fact that we host many student |
34 |
|
|
societies on our system. These societies usually have a virtual host for web |
35 |
|
|
and email, which is administered by a computer rep from the society. These |
36 |
|
|
computer reps often have little or no knowledge of Unix and so we needed a |
37 |
|
|
user friendly system that would let the create and maintain mailing lists |
38 |
|
|
(such as members@foo.soc.ru.ac.za, committee@foo.soc.ru.ac.za, etc). |
39 |
|
|
|
40 |
|
|
Since I am never keen to re-invent the wheel, I had a look at Steve Peterson's |
41 |
|
|
script (http://virtation.com/qmail/ml-sub), which allows people to subscribe |
42 |
|
|
and unsubscribe from mailing lists using a form->email gateway. This is fine |
43 |
|
|
for putting on a web page saying "here come and join our mailing list", but |
44 |
|
|
doesn't really allow you to administrate a list. |
45 |
|
|
|
46 |
|
|
Security of mailing lists was a concern, as we really didn't want |
47 |
|
|
unauthorised people to be able to alter some users list. Ezmlm-web itself |
48 |
|
|
implements no security checks (apart from un-tainting input) and so relies |
49 |
|
|
on the web server to do this (re-inventing the wheel again :). We use an |
50 |
|
|
Apache webserver, so one can control access to a directory using a .htaccess |
51 |
|
|
file or in the access.conf file. ApacheWeek have a good article on doing |
52 |
|
|
this at http://www.apacheweek.com/features/userauth. I also give examples |
53 |
|
|
later in this document. |
54 |
|
|
|
55 |
|
|
This version of ezmlm-web (2.0) is based to a large extent on previous |
56 |
|
|
versions that I have developed. It has however been totally re-written to |
57 |
|
|
make use of the Mail::Ezmlm perl module I wrote. At the same time it was |
58 |
|
|
updated and extended to include the new features of ezmlm-idx. It includes |
59 |
|
|
many new features that have been suggested to me over the last few months, |
60 |
|
|
and hopefully is now useful to a much larger group of people. |
61 |
|
|
|
62 |
|
|
%changelog |
63 |
jpp |
1.3 |
* Sun Mar 20 2022 Jean-Philippe Pialasse <tests@pialasse.com> 3.3.1-9.sme |
64 |
|
|
- remove deprecated defined array warning [SME: 11913] |
65 |
|
|
|
66 |
jpp |
1.2 |
* Wed Mar 16 2022 Jean-Philippe Pialasse <tests@pialasse.com> 3.3.1-8.sme |
67 |
|
|
- remove /usr/lib64 from filelist, this conflict with base rpm filesystem |
68 |
|
|
|
69 |
jpp |
1.3 |
* Fri Apr 22 2016 Jean-Philippe Pialasse <tests@pialasse.com> 3.3.1-7.sme |
70 |
jpp |
1.1 |
- fix to build against SME 9 centos 6 [SME: 8439] |
71 |
|
|
|
72 |
jpp |
1.3 |
* Thu Apr 21 2016 Jean-Philippe Pialasse <tests@pialasse.com> 3.3.1-5.sme |
73 |
jpp |
1.1 |
- remove non available options (always on) in ezmlm-idx 7.2.2 [SME: 9470] |
74 |
|
|
- remove setting user access to web, as unecessary in SME |
75 |
|
|
- patch ezmlm-web-3.3.1-modiffor722.patch |
76 |
|
|
|
77 |
jpp |
1.3 |
* Wed Apr 20 2016 Jean-Philippe Pialasse <tests@pialasse.com> 3.3.1-4.sme |
78 |
jpp |
1.1 |
- small fix to save some config with 7.2.2 idx [SME: 9470] |
79 |
|
|
|
80 |
jpp |
1.3 |
* Mon Apr 18 2016 Jean-Philippe Pialasse <tests@pialasse.com> 3.3.1-1.sme |
81 |
jpp |
1.1 |
- update to 3.3.1 [SME: 7588] |
82 |
|
|
|
83 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
84 |
|
|
- Clean up spec so package can be built by koji/plague |
85 |
|
|
|
86 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
87 |
|
|
- Update to new release naming. No functional changes. |
88 |
|
|
- Make Packager generic |
89 |
|
|
|
90 |
|
|
* Tue Oct 25 2005 Gordon Rowell <gordonr@gormand.com.au> 2.3-01sme02 |
91 |
|
|
- Retarget previous patches against 2.3 |
92 |
|
|
- Change ezmlm-cgi location |
93 |
|
|
- Access local help icon |
94 |
|
|
- Hide delete button if -c provided |
95 |
|
|
|
96 |
|
|
* Tue Oct 25 2005 Gordon Rowell <gordonr@gormand.com.au> 2.3-01sme01 |
97 |
|
|
- Update to 2.3 - ezmlm-web has moved to a new home |
98 |
|
|
|
99 |
|
|
* Wed Nov 28 2001 Gordon Rowell <gordonr@e-smith.com> |
100 |
|
|
- [2.1-04] |
101 |
|
|
- Create ezmlm user (uid/gid 80) in %pre if it doesn't already exist |
102 |
|
|
|
103 |
|
|
* Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com> |
104 |
|
|
- [2.1-03] |
105 |
|
|
- Allow the web server to execute the CGI script |
106 |
|
|
|
107 |
|
|
* Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com> |
108 |
|
|
- [2.1-02] |
109 |
|
|
- Remove [Delete] button if $opt_c is set |
110 |
|
|
- $opt_c "no list creation" now also means "no list deletion" |
111 |
|
|
|
112 |
|
|
* Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com> |
113 |
|
|
- [2.1-01] |
114 |
|
|
- Initial packaging |
115 |
|
|
- Modified ezmlm-web.cgi path to /usr/bin |
116 |
|
|
- Modified $HELP_ICON_URL for RedHat Apache patch |
117 |
|
|
|
118 |
|
|
%prep |
119 |
|
|
%setup -n %{name}-%{version} |
120 |
|
|
%patch0 -p1 |
121 |
|
|
%patch1 -p1 |
122 |
|
|
%patch2 -p1 |
123 |
jpp |
1.3 |
%patch3 -p1 |
124 |
jpp |
1.1 |
|
125 |
|
|
%build |
126 |
|
|
mkdir build |
127 |
|
|
perl Makefile.PL DESTDIR=build PREFIX=/usr |
128 |
|
|
# REALINSTALLBIN=/usr/bin/ezmlm-web |
129 |
|
|
make |
130 |
|
|
make install |
131 |
|
|
|
132 |
|
|
|
133 |
|
|
|
134 |
|
|
%install |
135 |
|
|
rm -rf $RPM_BUILD_ROOT |
136 |
|
|
|
137 |
|
|
(cd build ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
138 |
|
|
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
139 |
|
|
| sed -e '/ezmlm-web.cgi.1p/d' \ |
140 |
jpp |
1.3 |
| sed -e '/lib64$/d' \ |
141 |
|
|
| sed -e '/lib$/d' \ |
142 |
|
|
> %{name}-%{version}-%{release}-filelist |
143 |
jpp |
1.1 |
#| sed -e '/ezmlm-web.cgi.1p/d' \ |
144 |
|
|
#> %{name}-%{version}-%{release}-filelist |
145 |
|
|
|
146 |
|
|
# creating the cgi index to the suid wrapper |
147 |
|
|
cp -a $RPM_BUILD_ROOT/usr/bin/ezmlm-web.wrapper $RPM_BUILD_ROOT/usr/local/share/ezmlm-web/www-data/index.cgi |
148 |
|
|
|
149 |
|
|
%clean |
150 |
|
|
rm -rf $RPM_BUILD_ROOT |
151 |
|
|
|
152 |
|
|
%pre |
153 |
|
|
if [ -d /home/e-smith ] |
154 |
|
|
then |
155 |
|
|
EZMLMHOME=/home/e-smith/files/ezmlm |
156 |
|
|
else |
157 |
|
|
EZMLMHOME=/home/ezmlm |
158 |
|
|
fi |
159 |
|
|
grep '^ezmlm:' /etc/passwd > /dev/null || \ |
160 |
|
|
/usr/sbin/useradd -c "ezmlm" -u 80 -m -d $EZMLMHOME -s /bin/false ezmlm |
161 |
|
|
|
162 |
|
|
%post |
163 |
|
|
%preun |
164 |
|
|
%postun |
165 |
|
|
|
166 |
|
|
%files -f %{name}-%{version}-%{release}-filelist |
167 |
|
|
%defattr(-,root,root) |
168 |
|
|
%attr(104755,ezmlm,ezmlm) /usr/local/share/ezmlm-web/www-data/index.cgi |
169 |
|
|
%doc /usr/share/man/man1/ezmlm-web.cgi.1p.gz |