1 |
slords |
1.1 |
Summary: Web interface to ezmlm configuration |
2 |
|
|
%define name ezmlm-web |
3 |
|
|
Name: %{name} |
4 |
|
|
%define version 2.3 |
5 |
|
|
%define release 2 |
6 |
|
|
Version: %{version} |
7 |
|
|
Release: %{release}%{?dist} |
8 |
|
|
License: BSD-style |
9 |
|
|
Group: Networking/Daemons |
10 |
|
|
URL: https://systemausfall.org/toolforge/ezmlm-web/ |
11 |
|
|
Source: https://systemausfall.org/toolforge/ezmlm-web/download/ezmlm-web-2.3.tar.gz |
12 |
|
|
Patch0: ezmlm-web-2.3-cgibin.patch |
13 |
|
|
Patch1: ezmlm-web-2.3-helpicon.patch |
14 |
|
|
Patch2: ezmlm-web-2.3-deletebutton.patch2 |
15 |
|
|
|
16 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
17 |
|
|
Requires: ezmlm-idx-std |
18 |
|
|
Requires: httpd |
19 |
|
|
Requires: qmail |
20 |
|
|
Requires: perl |
21 |
|
|
Requires: perl-Ezmlm |
22 |
|
|
Requires: perl-MailTools |
23 |
|
|
BuildRequires: gcc |
24 |
|
|
|
25 |
|
|
%description |
26 |
|
|
The need for ezmlm-web arose from the fact that we host many student |
27 |
|
|
societies on our system. These societies usually have a virtual host for web |
28 |
|
|
and email, which is administered by a computer rep from the society. These |
29 |
|
|
computer reps often have little or no knowledge of Unix and so we needed a |
30 |
|
|
user friendly system that would let the create and maintain mailing lists |
31 |
|
|
(such as members@foo.soc.ru.ac.za, committee@foo.soc.ru.ac.za, etc). |
32 |
|
|
|
33 |
|
|
Since I am never keen to re-invent the wheel, I had a look at Steve Peterson's |
34 |
|
|
script (http://virtation.com/qmail/ml-sub), which allows people to subscribe |
35 |
|
|
and unsubscribe from mailing lists using a form->email gateway. This is fine |
36 |
|
|
for putting on a web page saying "here come and join our mailing list", but |
37 |
|
|
doesn't really allow you to administrate a list. |
38 |
|
|
|
39 |
|
|
Security of mailing lists was a concern, as we really didn't want |
40 |
|
|
unauthorised people to be able to alter some users list. Ezmlm-web itself |
41 |
|
|
implements no security checks (apart from un-tainting input) and so relies |
42 |
|
|
on the web server to do this (re-inventing the wheel again :). We use an |
43 |
|
|
Apache webserver, so one can control access to a directory using a .htaccess |
44 |
|
|
file or in the access.conf file. ApacheWeek have a good article on doing |
45 |
|
|
this at http://www.apacheweek.com/features/userauth. I also give examples |
46 |
|
|
later in this document. |
47 |
|
|
|
48 |
|
|
This version of ezmlm-web (2.0) is based to a large extent on previous |
49 |
|
|
versions that I have developed. It has however been totally re-written to |
50 |
|
|
make use of the Mail::Ezmlm perl module I wrote. At the same time it was |
51 |
|
|
updated and extended to include the new features of ezmlm-idx. It includes |
52 |
|
|
many new features that have been suggested to me over the last few months, |
53 |
|
|
and hopefully is now useful to a much larger group of people. |
54 |
|
|
|
55 |
|
|
%changelog |
56 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
57 |
|
|
- Clean up spec so package can be built by koji/plague |
58 |
|
|
|
59 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
60 |
|
|
- Update to new release naming. No functional changes. |
61 |
|
|
- Make Packager generic |
62 |
|
|
|
63 |
|
|
* Tue Oct 25 2005 Gordon Rowell <gordonr@gormand.com.au> 2.3-01sme02 |
64 |
|
|
- Retarget previous patches against 2.3 |
65 |
|
|
- Change ezmlm-cgi location |
66 |
|
|
- Access local help icon |
67 |
|
|
- Hide delete button if -c provided |
68 |
|
|
|
69 |
|
|
* Tue Oct 25 2005 Gordon Rowell <gordonr@gormand.com.au> 2.3-01sme01 |
70 |
|
|
- Update to 2.3 - ezmlm-web has moved to a new home |
71 |
|
|
|
72 |
|
|
* Wed Nov 28 2001 Gordon Rowell <gordonr@e-smith.com> |
73 |
|
|
- [2.1-04] |
74 |
|
|
- Create ezmlm user (uid/gid 80) in %pre if it doesn't already exist |
75 |
|
|
|
76 |
|
|
* Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com> |
77 |
|
|
- [2.1-03] |
78 |
|
|
- Allow the web server to execute the CGI script |
79 |
|
|
|
80 |
|
|
* Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com> |
81 |
|
|
- [2.1-02] |
82 |
|
|
- Remove [Delete] button if $opt_c is set |
83 |
|
|
- $opt_c "no list creation" now also means "no list deletion" |
84 |
|
|
|
85 |
|
|
* Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com> |
86 |
|
|
- [2.1-01] |
87 |
|
|
- Initial packaging |
88 |
|
|
- Modified ezmlm-web.cgi path to /usr/bin |
89 |
|
|
- Modified $HELP_ICON_URL for RedHat Apache patch |
90 |
|
|
|
91 |
|
|
%prep |
92 |
|
|
%setup -n %{name}-%{version} |
93 |
|
|
%patch0 -p1 |
94 |
|
|
%patch1 -p1 |
95 |
|
|
%patch2 -p1 |
96 |
|
|
|
97 |
|
|
%build |
98 |
|
|
gcc -o index.cgi index.c |
99 |
|
|
|
100 |
|
|
%install |
101 |
|
|
rm -rf $RPM_BUILD_ROOT |
102 |
|
|
|
103 |
|
|
mkdir -p $RPM_BUILD_ROOT/usr/bin |
104 |
|
|
cp ezmlm-web.cgi $RPM_BUILD_ROOT/usr/bin |
105 |
|
|
|
106 |
|
|
mkdir -p $RPM_BUILD_ROOT/home/httpd/html/ezmlm-web |
107 |
|
|
cp index.cgi $RPM_BUILD_ROOT/home/httpd/html/ezmlm-web |
108 |
|
|
|
109 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/ezmlm |
110 |
|
|
cp ezmlmwebrc $RPM_BUILD_ROOT/etc/ezmlm |
111 |
|
|
|
112 |
|
|
%clean |
113 |
|
|
rm -rf $RPM_BUILD_ROOT |
114 |
|
|
|
115 |
|
|
%pre |
116 |
|
|
if [ -d /home/e-smith ] |
117 |
|
|
then |
118 |
|
|
EZMLMHOME=/home/e-smith/files/ezmlm |
119 |
|
|
else |
120 |
|
|
EZMLMHOME=/home/ezmlm |
121 |
|
|
fi |
122 |
|
|
grep '^ezmlm:' /etc/passwd > /dev/null || \ |
123 |
|
|
/usr/sbin/useradd -c "ezmlm" -u 80 -m -d $EZMLMHOME -s /bin/false ezmlm |
124 |
|
|
|
125 |
|
|
%post |
126 |
|
|
%preun |
127 |
|
|
%postun |
128 |
|
|
|
129 |
|
|
%files |
130 |
|
|
%defattr(-,root,root) |
131 |
|
|
%attr(0755,root,root) /usr/bin/ezmlm-web.cgi |
132 |
|
|
%attr(4755,ezmlm,ezmlm) /home/httpd/html/ezmlm-web/index.cgi |
133 |
|
|
%config(noreplace) /etc/ezmlm/ezmlmwebrc |
134 |
|
|
%doc CHANGES README TODO UPGRADING |
135 |
|
|
%doc webusers.sample |
136 |
|
|
%doc htaccess.sample |