1 |
unnilennium |
1.1 |
# $Id: ezmlm-web.spec,v 1.4 2008/11/25 16:20:11 slords Exp $ |
2 |
|
|
# Authority: gordonr |
3 |
|
|
# Name: Gordon Rowell |
4 |
|
|
|
5 |
|
|
Summary: Web interface to ezmlm configuration |
6 |
|
|
%define name ezmlm-web |
7 |
|
|
Name: %{name} |
8 |
|
|
%define version 2.3 |
9 |
|
|
%define release 2 |
10 |
|
|
Version: %{version} |
11 |
|
|
Release: %{release}%{?dist} |
12 |
|
|
License: BSD-style |
13 |
|
|
Group: Networking/Daemons |
14 |
|
|
URL: https://systemausfall.org/toolforge/ezmlm-web/ |
15 |
|
|
Source: https://systemausfall.org/toolforge/ezmlm-web/download/ezmlm-web-2.3.tar.gz |
16 |
|
|
Patch0: ezmlm-web-2.3-cgibin.patch |
17 |
|
|
Patch1: ezmlm-web-2.3-helpicon.patch |
18 |
|
|
Patch2: ezmlm-web-2.3-deletebutton.patch2 |
19 |
|
|
|
20 |
|
|
BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot |
21 |
|
|
Requires: ezmlm-idx-std |
22 |
|
|
Requires: httpd |
23 |
|
|
Requires: qmail |
24 |
|
|
Requires: perl |
25 |
|
|
Requires: perl-Ezmlm |
26 |
|
|
Requires: perl-MailTools |
27 |
|
|
BuildRequires: gcc |
28 |
|
|
|
29 |
|
|
%description |
30 |
|
|
The need for ezmlm-web arose from the fact that we host many student |
31 |
|
|
societies on our system. These societies usually have a virtual host for web |
32 |
|
|
and email, which is administered by a computer rep from the society. These |
33 |
|
|
computer reps often have little or no knowledge of Unix and so we needed a |
34 |
|
|
user friendly system that would let the create and maintain mailing lists |
35 |
|
|
(such as members@foo.soc.ru.ac.za, committee@foo.soc.ru.ac.za, etc). |
36 |
|
|
|
37 |
|
|
Since I am never keen to re-invent the wheel, I had a look at Steve Peterson's |
38 |
|
|
script (http://virtation.com/qmail/ml-sub), which allows people to subscribe |
39 |
|
|
and unsubscribe from mailing lists using a form->email gateway. This is fine |
40 |
|
|
for putting on a web page saying "here come and join our mailing list", but |
41 |
|
|
doesn't really allow you to administrate a list. |
42 |
|
|
|
43 |
|
|
Security of mailing lists was a concern, as we really didn't want |
44 |
|
|
unauthorised people to be able to alter some users list. Ezmlm-web itself |
45 |
|
|
implements no security checks (apart from un-tainting input) and so relies |
46 |
|
|
on the web server to do this (re-inventing the wheel again :). We use an |
47 |
|
|
Apache webserver, so one can control access to a directory using a .htaccess |
48 |
|
|
file or in the access.conf file. ApacheWeek have a good article on doing |
49 |
|
|
this at http://www.apacheweek.com/features/userauth. I also give examples |
50 |
|
|
later in this document. |
51 |
|
|
|
52 |
|
|
This version of ezmlm-web (2.0) is based to a large extent on previous |
53 |
|
|
versions that I have developed. It has however been totally re-written to |
54 |
|
|
make use of the Mail::Ezmlm perl module I wrote. At the same time it was |
55 |
|
|
updated and extended to include the new features of ezmlm-idx. It includes |
56 |
|
|
many new features that have been suggested to me over the last few months, |
57 |
|
|
and hopefully is now useful to a much larger group of people. |
58 |
|
|
|
59 |
|
|
%changelog |
60 |
|
|
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
61 |
|
|
- Clean up spec so package can be built by koji/plague |
62 |
|
|
|
63 |
|
|
* Thu Dec 07 2006 Shad L. Lords <slords@mail.com> |
64 |
|
|
- Update to new release naming. No functional changes. |
65 |
|
|
- Make Packager generic |
66 |
|
|
|
67 |
|
|
* Tue Oct 25 2005 Gordon Rowell <gordonr@gormand.com.au> 2.3-01sme02 |
68 |
|
|
- Retarget previous patches against 2.3 |
69 |
|
|
- Change ezmlm-cgi location |
70 |
|
|
- Access local help icon |
71 |
|
|
- Hide delete button if -c provided |
72 |
|
|
|
73 |
|
|
* Tue Oct 25 2005 Gordon Rowell <gordonr@gormand.com.au> 2.3-01sme01 |
74 |
|
|
- Update to 2.3 - ezmlm-web has moved to a new home |
75 |
|
|
|
76 |
|
|
* Wed Nov 28 2001 Gordon Rowell <gordonr@e-smith.com> |
77 |
|
|
- [2.1-04] |
78 |
|
|
- Create ezmlm user (uid/gid 80) in %pre if it doesn't already exist |
79 |
|
|
|
80 |
|
|
* Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com> |
81 |
|
|
- [2.1-03] |
82 |
|
|
- Allow the web server to execute the CGI script |
83 |
|
|
|
84 |
|
|
* Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com> |
85 |
|
|
- [2.1-02] |
86 |
|
|
- Remove [Delete] button if $opt_c is set |
87 |
|
|
- $opt_c "no list creation" now also means "no list deletion" |
88 |
|
|
|
89 |
|
|
* Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com> |
90 |
|
|
- [2.1-01] |
91 |
|
|
- Initial packaging |
92 |
|
|
- Modified ezmlm-web.cgi path to /usr/bin |
93 |
|
|
- Modified $HELP_ICON_URL for RedHat Apache patch |
94 |
|
|
|
95 |
|
|
%prep |
96 |
|
|
%setup -n %{name}-%{version} |
97 |
|
|
%patch0 -p1 |
98 |
|
|
%patch1 -p1 |
99 |
|
|
%patch2 -p1 |
100 |
|
|
|
101 |
|
|
%build |
102 |
|
|
gcc -o index.cgi index.c |
103 |
|
|
|
104 |
|
|
%install |
105 |
|
|
rm -rf $RPM_BUILD_ROOT |
106 |
|
|
|
107 |
|
|
mkdir -p $RPM_BUILD_ROOT/usr/bin |
108 |
|
|
cp ezmlm-web.cgi $RPM_BUILD_ROOT/usr/bin |
109 |
|
|
|
110 |
|
|
mkdir -p $RPM_BUILD_ROOT/home/httpd/html/ezmlm-web |
111 |
|
|
cp index.cgi $RPM_BUILD_ROOT/home/httpd/html/ezmlm-web |
112 |
|
|
|
113 |
|
|
mkdir -p $RPM_BUILD_ROOT/etc/ezmlm |
114 |
|
|
cp ezmlmwebrc $RPM_BUILD_ROOT/etc/ezmlm |
115 |
|
|
|
116 |
|
|
%clean |
117 |
|
|
rm -rf $RPM_BUILD_ROOT |
118 |
|
|
|
119 |
|
|
%pre |
120 |
|
|
if [ -d /home/e-smith ] |
121 |
|
|
then |
122 |
|
|
EZMLMHOME=/home/e-smith/files/ezmlm |
123 |
|
|
else |
124 |
|
|
EZMLMHOME=/home/ezmlm |
125 |
|
|
fi |
126 |
|
|
grep '^ezmlm:' /etc/passwd > /dev/null || \ |
127 |
|
|
/usr/sbin/useradd -c "ezmlm" -u 80 -m -d $EZMLMHOME -s /bin/false ezmlm |
128 |
|
|
|
129 |
|
|
%post |
130 |
|
|
%preun |
131 |
|
|
%postun |
132 |
|
|
|
133 |
|
|
%files |
134 |
|
|
%defattr(-,root,root) |
135 |
|
|
%attr(0755,root,root) /usr/bin/ezmlm-web.cgi |
136 |
|
|
%attr(4755,ezmlm,ezmlm) /home/httpd/html/ezmlm-web/index.cgi |
137 |
|
|
%config(noreplace) /etc/ezmlm/ezmlmwebrc |
138 |
|
|
%doc CHANGES README TODO UPGRADING |
139 |
|
|
%doc webusers.sample |
140 |
|
|
%doc htaccess.sample |