/[smecontribs]/rpms/ezmlm-web/contribs8/ezmlm-web.spec
ViewVC logotype

Annotation of /rpms/ezmlm-web/contribs8/ezmlm-web.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Tue Apr 19 03:42:56 2016 UTC (8 years, 1 month ago) by unnilennium
Branch: MAIN
CVS Tags: ezmlm-web-3_3_1-1_el5_sme
Changes since 1.1: +29 -24 lines
Upgrade from v2 to v3.3.1

1 unnilennium 1.2 # $Id: ezmlm-web.spec,v 1.1 2013/05/12 19:37:27 unnilennium Exp $
2 unnilennium 1.1 # Authority: gordonr
3     # Name: Gordon Rowell
4    
5     Summary: Web interface to ezmlm configuration
6     %define name ezmlm-web
7     Name: %{name}
8 unnilennium 1.2 %define version 3.3.1
9     %define release 1
10 unnilennium 1.1 Version: %{version}
11     Release: %{release}%{?dist}
12     License: BSD-style
13     Group: Networking/Daemons
14     URL: https://systemausfall.org/toolforge/ezmlm-web/
15 unnilennium 1.2 Source: https://systemausfall.org/toolforge/ezmlm-web/download/ezmlm-web-3.3.1.tar.gz
16     Patch0: ezmlm-web-3.3.1-smeintegration.patch
17     #Patch0: ezmlm-web-3.3.1-smeweb.patch
18     #Patch0: ezmlm-web-2.3-cgibin.patch
19     #Patch1: ezmlm-web-2.3-helpicon.patch
20     #Patch2: ezmlm-web-2.3-deletebutton.patch2
21 unnilennium 1.1
22     BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
23     Requires: ezmlm-idx-std
24     Requires: httpd
25     Requires: qmail
26     Requires: perl
27     Requires: perl-Ezmlm
28     Requires: perl-MailTools
29     BuildRequires: gcc
30 unnilennium 1.2 BuildRequires: e-smith-devtools
31     BuildRequires: perl-Ezmlm
32 unnilennium 1.1
33     %description
34     The need for ezmlm-web arose from the fact that we host many student
35     societies on our system. These societies usually have a virtual host for web
36     and email, which is administered by a computer rep from the society. These
37     computer reps often have little or no knowledge of Unix and so we needed a
38     user friendly system that would let the create and maintain mailing lists
39     (such as members@foo.soc.ru.ac.za, committee@foo.soc.ru.ac.za, etc).
40    
41     Since I am never keen to re-invent the wheel, I had a look at Steve Peterson's
42     script (http://virtation.com/qmail/ml-sub), which allows people to subscribe
43     and unsubscribe from mailing lists using a form->email gateway. This is fine
44     for putting on a web page saying "here come and join our mailing list", but
45     doesn't really allow you to administrate a list.
46    
47     Security of mailing lists was a concern, as we really didn't want
48     unauthorised people to be able to alter some users list. Ezmlm-web itself
49     implements no security checks (apart from un-tainting input) and so relies
50     on the web server to do this (re-inventing the wheel again :). We use an
51     Apache webserver, so one can control access to a directory using a .htaccess
52     file or in the access.conf file. ApacheWeek have a good article on doing
53     this at http://www.apacheweek.com/features/userauth. I also give examples
54     later in this document.
55    
56     This version of ezmlm-web (2.0) is based to a large extent on previous
57     versions that I have developed. It has however been totally re-written to
58     make use of the Mail::Ezmlm perl module I wrote. At the same time it was
59     updated and extended to include the new features of ezmlm-idx. It includes
60     many new features that have been suggested to me over the last few months,
61     and hopefully is now useful to a much larger group of people.
62    
63     %changelog
64 unnilennium 1.2 * Mon Apr 18 2016 Jean-Philipe Pialasse <tests@pialasse.com> 3.3.1-1.sme
65     - update to 3.3.1 [SME: 7588]
66    
67 unnilennium 1.1 * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
68     - Clean up spec so package can be built by koji/plague
69    
70     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
71     - Update to new release naming. No functional changes.
72     - Make Packager generic
73    
74     * Tue Oct 25 2005 Gordon Rowell <gordonr@gormand.com.au> 2.3-01sme02
75     - Retarget previous patches against 2.3
76     - Change ezmlm-cgi location
77     - Access local help icon
78     - Hide delete button if -c provided
79    
80     * Tue Oct 25 2005 Gordon Rowell <gordonr@gormand.com.au> 2.3-01sme01
81     - Update to 2.3 - ezmlm-web has moved to a new home
82    
83     * Wed Nov 28 2001 Gordon Rowell <gordonr@e-smith.com>
84     - [2.1-04]
85     - Create ezmlm user (uid/gid 80) in %pre if it doesn't already exist
86    
87     * Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com>
88     - [2.1-03]
89     - Allow the web server to execute the CGI script
90    
91     * Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com>
92     - [2.1-02]
93     - Remove [Delete] button if $opt_c is set
94     - $opt_c "no list creation" now also means "no list deletion"
95    
96     * Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com>
97     - [2.1-01]
98     - Initial packaging
99     - Modified ezmlm-web.cgi path to /usr/bin
100     - Modified $HELP_ICON_URL for RedHat Apache patch
101    
102     %prep
103     %setup -n %{name}-%{version}
104     %patch0 -p1
105    
106     %build
107 unnilennium 1.2 mkdir build
108     perl Makefile.PL DESTDIR=build REALINSTALLBIN=/usr/local/bin/ezmlm-web
109     make
110     make install
111    
112    
113 unnilennium 1.1
114     %install
115     rm -rf $RPM_BUILD_ROOT
116    
117 unnilennium 1.2 (cd build ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
118     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
119     | sed -e '/ezmlm-web.cgi.1p/d' \
120     > %{name}-%{version}-%{release}-filelist
121 unnilennium 1.1
122 unnilennium 1.2 # creating the cgi index to the suid wrapper
123     cp -a $RPM_BUILD_ROOT/usr/bin/ezmlm-web.wrapper $RPM_BUILD_ROOT/usr/local/share/ezmlm-web/www-data/index.cgi
124 unnilennium 1.1
125     %clean
126     rm -rf $RPM_BUILD_ROOT
127    
128     %pre
129     if [ -d /home/e-smith ]
130     then
131     EZMLMHOME=/home/e-smith/files/ezmlm
132     else
133     EZMLMHOME=/home/ezmlm
134     fi
135     grep '^ezmlm:' /etc/passwd > /dev/null || \
136     /usr/sbin/useradd -c "ezmlm" -u 80 -m -d $EZMLMHOME -s /bin/false ezmlm
137    
138     %post
139     %preun
140     %postun
141    
142 unnilennium 1.2 %files -f %{name}-%{version}-%{release}-filelist
143 unnilennium 1.1 %defattr(-,root,root)
144 unnilennium 1.2 %attr(104755,ezmlm,ezmlm) /usr/local/share/ezmlm-web/www-data/index.cgi
145     %doc /usr/share/man/man1/ezmlm-web.cgi.1p.gz

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed