/[smecontribs]/rpms/ezmlm-web/contribs8/ezmlm-web.spec
ViewVC logotype

Annotation of /rpms/ezmlm-web/contribs8/ezmlm-web.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.3 - (hide annotations) (download)
Wed Apr 20 10:34:09 2016 UTC (8 years, 1 month ago) by unnilennium
Branch: MAIN
CVS Tags: ezmlm-web-3_3_1-2_el5_sme
Changes since 1.2: +8 -7 lines
* Wed Apr 20 2016 Jean-Philipe Pialasse <tests@pialasse.com> 3.3.1-2.sme
- small fix to save some config with 7.2.2 idx [SME: 9470]

1 unnilennium 1.3 # $Id: ezmlm-web.spec,v 1.2 2016/04/19 03:42:56 unnilennium Exp $
2 unnilennium 1.1 # Authority: gordonr
3     # Name: Gordon Rowell
4    
5     Summary: Web interface to ezmlm configuration
6     %define name ezmlm-web
7     Name: %{name}
8 unnilennium 1.2 %define version 3.3.1
9 unnilennium 1.3 %define release 2
10 unnilennium 1.1 Version: %{version}
11     Release: %{release}%{?dist}
12     License: BSD-style
13     Group: Networking/Daemons
14     URL: https://systemausfall.org/toolforge/ezmlm-web/
15 unnilennium 1.2 Source: https://systemausfall.org/toolforge/ezmlm-web/download/ezmlm-web-3.3.1.tar.gz
16     Patch0: ezmlm-web-3.3.1-smeintegration.patch
17 unnilennium 1.3 Patch1: ezmlm-web-3.3.1-cgi.patch
18 unnilennium 1.1 BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
19     Requires: ezmlm-idx-std
20     Requires: httpd
21     Requires: qmail
22     Requires: perl
23     Requires: perl-Ezmlm
24     Requires: perl-MailTools
25     BuildRequires: gcc
26 unnilennium 1.2 BuildRequires: e-smith-devtools
27     BuildRequires: perl-Ezmlm
28 unnilennium 1.1
29     %description
30     The need for ezmlm-web arose from the fact that we host many student
31     societies on our system. These societies usually have a virtual host for web
32     and email, which is administered by a computer rep from the society. These
33     computer reps often have little or no knowledge of Unix and so we needed a
34     user friendly system that would let the create and maintain mailing lists
35     (such as members@foo.soc.ru.ac.za, committee@foo.soc.ru.ac.za, etc).
36    
37     Since I am never keen to re-invent the wheel, I had a look at Steve Peterson's
38     script (http://virtation.com/qmail/ml-sub), which allows people to subscribe
39     and unsubscribe from mailing lists using a form->email gateway. This is fine
40     for putting on a web page saying "here come and join our mailing list", but
41     doesn't really allow you to administrate a list.
42    
43     Security of mailing lists was a concern, as we really didn't want
44     unauthorised people to be able to alter some users list. Ezmlm-web itself
45     implements no security checks (apart from un-tainting input) and so relies
46     on the web server to do this (re-inventing the wheel again :). We use an
47     Apache webserver, so one can control access to a directory using a .htaccess
48     file or in the access.conf file. ApacheWeek have a good article on doing
49     this at http://www.apacheweek.com/features/userauth. I also give examples
50     later in this document.
51    
52     This version of ezmlm-web (2.0) is based to a large extent on previous
53     versions that I have developed. It has however been totally re-written to
54     make use of the Mail::Ezmlm perl module I wrote. At the same time it was
55     updated and extended to include the new features of ezmlm-idx. It includes
56     many new features that have been suggested to me over the last few months,
57     and hopefully is now useful to a much larger group of people.
58    
59     %changelog
60 unnilennium 1.3 * Wed Apr 20 2016 Jean-Philipe Pialasse <tests@pialasse.com> 3.3.1-2.sme
61     - small fix to save some config with 7.2.2 idx [SME: 9470]
62    
63 unnilennium 1.2 * Mon Apr 18 2016 Jean-Philipe Pialasse <tests@pialasse.com> 3.3.1-1.sme
64     - update to 3.3.1 [SME: 7588]
65    
66 unnilennium 1.1 * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
67     - Clean up spec so package can be built by koji/plague
68    
69     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
70     - Update to new release naming. No functional changes.
71     - Make Packager generic
72    
73     * Tue Oct 25 2005 Gordon Rowell <gordonr@gormand.com.au> 2.3-01sme02
74     - Retarget previous patches against 2.3
75     - Change ezmlm-cgi location
76     - Access local help icon
77     - Hide delete button if -c provided
78    
79     * Tue Oct 25 2005 Gordon Rowell <gordonr@gormand.com.au> 2.3-01sme01
80     - Update to 2.3 - ezmlm-web has moved to a new home
81    
82     * Wed Nov 28 2001 Gordon Rowell <gordonr@e-smith.com>
83     - [2.1-04]
84     - Create ezmlm user (uid/gid 80) in %pre if it doesn't already exist
85    
86     * Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com>
87     - [2.1-03]
88     - Allow the web server to execute the CGI script
89    
90     * Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com>
91     - [2.1-02]
92     - Remove [Delete] button if $opt_c is set
93     - $opt_c "no list creation" now also means "no list deletion"
94    
95     * Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com>
96     - [2.1-01]
97     - Initial packaging
98     - Modified ezmlm-web.cgi path to /usr/bin
99     - Modified $HELP_ICON_URL for RedHat Apache patch
100    
101     %prep
102     %setup -n %{name}-%{version}
103     %patch0 -p1
104 unnilennium 1.3 %patch1 -p1
105    
106 unnilennium 1.1
107     %build
108 unnilennium 1.2 mkdir build
109     perl Makefile.PL DESTDIR=build REALINSTALLBIN=/usr/local/bin/ezmlm-web
110     make
111     make install
112    
113    
114 unnilennium 1.1
115     %install
116     rm -rf $RPM_BUILD_ROOT
117    
118 unnilennium 1.2 (cd build ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
119     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
120     | sed -e '/ezmlm-web.cgi.1p/d' \
121     > %{name}-%{version}-%{release}-filelist
122 unnilennium 1.1
123 unnilennium 1.2 # creating the cgi index to the suid wrapper
124     cp -a $RPM_BUILD_ROOT/usr/bin/ezmlm-web.wrapper $RPM_BUILD_ROOT/usr/local/share/ezmlm-web/www-data/index.cgi
125 unnilennium 1.1
126     %clean
127     rm -rf $RPM_BUILD_ROOT
128    
129     %pre
130     if [ -d /home/e-smith ]
131     then
132     EZMLMHOME=/home/e-smith/files/ezmlm
133     else
134     EZMLMHOME=/home/ezmlm
135     fi
136     grep '^ezmlm:' /etc/passwd > /dev/null || \
137     /usr/sbin/useradd -c "ezmlm" -u 80 -m -d $EZMLMHOME -s /bin/false ezmlm
138    
139     %post
140     %preun
141     %postun
142    
143 unnilennium 1.2 %files -f %{name}-%{version}-%{release}-filelist
144 unnilennium 1.1 %defattr(-,root,root)
145 unnilennium 1.2 %attr(104755,ezmlm,ezmlm) /usr/local/share/ezmlm-web/www-data/index.cgi
146     %doc /usr/share/man/man1/ezmlm-web.cgi.1p.gz

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed