/[smecontribs]/rpms/ezmlm-web/contribs9/ezmlm-web.spec
ViewVC logotype

Annotation of /rpms/ezmlm-web/contribs9/ezmlm-web.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Fri Apr 22 09:24:36 2016 UTC (8 years, 1 month ago) by unnilennium
Branch: MAIN
CVS Tags: ezmlm-web-3_3_1-5_el6_sme
Initial import

1 unnilennium 1.1 # $Id: ezmlm-web.spec,v 1.6 2016/04/21 04:35:53 unnilennium Exp $
2     # Authority: gordonr
3     # Name: Gordon Rowell
4    
5     Summary: Web interface to ezmlm configuration
6     %define name ezmlm-web
7     Name: %{name}
8     %define version 3.3.1
9     %define release 5
10     Version: %{version}
11     Release: %{release}%{?dist}
12     License: BSD-style
13     Group: Networking/Daemons
14     URL: https://systemausfall.org/toolforge/ezmlm-web/
15     Source: https://systemausfall.org/toolforge/ezmlm-web/download/ezmlm-web-3.3.1.tar.gz
16     Patch0: ezmlm-web-3.3.1-smeintegration.patch
17     Patch1: ezmlm-web-3.3.1-cgi.patch
18     Patch2: ezmlm-web-3.3.1-modiffor722.patch
19     BuildRoot: /var/tmp/%{name}-%{version}-%{release}-buildroot
20     Requires: ezmlm-idx-std
21     Requires: httpd
22     Requires: qmail
23     Requires: perl
24     Requires: perl-Ezmlm
25     Requires: perl-MailTools
26     BuildRequires: gcc
27     BuildRequires: e-smith-devtools
28     BuildRequires: perl-Ezmlm
29    
30     %description
31     The need for ezmlm-web arose from the fact that we host many student
32     societies on our system. These societies usually have a virtual host for web
33     and email, which is administered by a computer rep from the society. These
34     computer reps often have little or no knowledge of Unix and so we needed a
35     user friendly system that would let the create and maintain mailing lists
36     (such as members@foo.soc.ru.ac.za, committee@foo.soc.ru.ac.za, etc).
37    
38     Since I am never keen to re-invent the wheel, I had a look at Steve Peterson's
39     script (http://virtation.com/qmail/ml-sub), which allows people to subscribe
40     and unsubscribe from mailing lists using a form->email gateway. This is fine
41     for putting on a web page saying "here come and join our mailing list", but
42     doesn't really allow you to administrate a list.
43    
44     Security of mailing lists was a concern, as we really didn't want
45     unauthorised people to be able to alter some users list. Ezmlm-web itself
46     implements no security checks (apart from un-tainting input) and so relies
47     on the web server to do this (re-inventing the wheel again :). We use an
48     Apache webserver, so one can control access to a directory using a .htaccess
49     file or in the access.conf file. ApacheWeek have a good article on doing
50     this at http://www.apacheweek.com/features/userauth. I also give examples
51     later in this document.
52    
53     This version of ezmlm-web (2.0) is based to a large extent on previous
54     versions that I have developed. It has however been totally re-written to
55     make use of the Mail::Ezmlm perl module I wrote. At the same time it was
56     updated and extended to include the new features of ezmlm-idx. It includes
57     many new features that have been suggested to me over the last few months,
58     and hopefully is now useful to a much larger group of people.
59    
60     %changelog
61     * Thu Apr 21 2016 Jean-Philipe Pialasse <tests@pialasse.com> 3.3.1-5.sme
62     - remove non available options (always on) in ezmlm-idx 7.2.2 [SME: 9470]
63     - remove setting user access to web, as unecessary in SME
64     - patch ezmlm-web-3.3.1-modiffor722.patch
65    
66     * Wed Apr 20 2016 Jean-Philipe Pialasse <tests@pialasse.com> 3.3.1-4.sme
67     - small fix to save some config with 7.2.2 idx [SME: 9470]
68    
69     * Mon Apr 18 2016 Jean-Philipe Pialasse <tests@pialasse.com> 3.3.1-1.sme
70     - update to 3.3.1 [SME: 7588]
71    
72     * Sun Apr 29 2007 Shad L. Lords <slords@mail.com>
73     - Clean up spec so package can be built by koji/plague
74    
75     * Thu Dec 07 2006 Shad L. Lords <slords@mail.com>
76     - Update to new release naming. No functional changes.
77     - Make Packager generic
78    
79     * Tue Oct 25 2005 Gordon Rowell <gordonr@gormand.com.au> 2.3-01sme02
80     - Retarget previous patches against 2.3
81     - Change ezmlm-cgi location
82     - Access local help icon
83     - Hide delete button if -c provided
84    
85     * Tue Oct 25 2005 Gordon Rowell <gordonr@gormand.com.au> 2.3-01sme01
86     - Update to 2.3 - ezmlm-web has moved to a new home
87    
88     * Wed Nov 28 2001 Gordon Rowell <gordonr@e-smith.com>
89     - [2.1-04]
90     - Create ezmlm user (uid/gid 80) in %pre if it doesn't already exist
91    
92     * Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com>
93     - [2.1-03]
94     - Allow the web server to execute the CGI script
95    
96     * Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com>
97     - [2.1-02]
98     - Remove [Delete] button if $opt_c is set
99     - $opt_c "no list creation" now also means "no list deletion"
100    
101     * Wed Oct 24 2001 Gordon Rowell <gordonr@e-smith.com>
102     - [2.1-01]
103     - Initial packaging
104     - Modified ezmlm-web.cgi path to /usr/bin
105     - Modified $HELP_ICON_URL for RedHat Apache patch
106    
107     %prep
108     %setup -n %{name}-%{version}
109     %patch0 -p1
110     %patch1 -p1
111     %patch2 -p1
112    
113     %build
114     mkdir build
115     perl Makefile.PL DESTDIR=build REALINSTALLBIN=/usr/local/bin/ezmlm-web
116     make
117     make install
118    
119    
120    
121     %install
122     rm -rf $RPM_BUILD_ROOT
123    
124     (cd build ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT)
125     /sbin/e-smith/genfilelist $RPM_BUILD_ROOT \
126     | sed -e '/ezmlm-web.cgi.1p/d' \
127     > %{name}-%{version}-%{release}-filelist
128    
129     # creating the cgi index to the suid wrapper
130     cp -a $RPM_BUILD_ROOT/usr/bin/ezmlm-web.wrapper $RPM_BUILD_ROOT/usr/local/share/ezmlm-web/www-data/index.cgi
131    
132     %clean
133     rm -rf $RPM_BUILD_ROOT
134    
135     %pre
136     if [ -d /home/e-smith ]
137     then
138     EZMLMHOME=/home/e-smith/files/ezmlm
139     else
140     EZMLMHOME=/home/ezmlm
141     fi
142     grep '^ezmlm:' /etc/passwd > /dev/null || \
143     /usr/sbin/useradd -c "ezmlm" -u 80 -m -d $EZMLMHOME -s /bin/false ezmlm
144    
145     %post
146     %preun
147     %postun
148    
149     %files -f %{name}-%{version}-%{release}-filelist
150     %defattr(-,root,root)
151     %attr(104755,ezmlm,ezmlm) /usr/local/share/ezmlm-web/www-data/index.cgi
152     %doc /usr/share/man/man1/ezmlm-web.cgi.1p.gz

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed