1 |
jpp |
1.1 |
%undefine __cmake_in_source_build |
2 |
|
|
|
3 |
|
|
%bcond_with doc |
4 |
|
|
Name: fmt |
5 |
|
|
Version: 7.1.3 |
6 |
|
|
Release: 2%{?dist} |
7 |
|
|
Summary: Small, safe and fast formatting library for C++ |
8 |
|
|
|
9 |
|
|
License: BSD |
10 |
|
|
URL: https://github.com/fmtlib/%{name} |
11 |
|
|
Source0: %{url}/archive/%{version}.tar.gz |
12 |
|
|
# See https://github.com/fmtlib/fmt/issues/443 and https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/LVKYLDLJVWAVJE4MQVKDO6PYZRD5MCP6/ |
13 |
|
|
Patch1: doc-build-removed-all-pip-internet-stuff.patch |
14 |
|
|
Patch3: doc-build-do-not-create-virtual-environment.patch |
15 |
|
|
Patch4: doc-_templates-layout-stripped-Google-Analytics.patch |
16 |
|
|
Patch5: doc-_templates-layout-stripped-download-links.patch |
17 |
|
|
Patch6: doc-index-removed-GitHub-iframe.patch |
18 |
|
|
Patch7: doc-build-use-sphinx-build-3.patch |
19 |
|
|
|
20 |
|
|
BuildRequires: gcc |
21 |
|
|
BuildRequires: gcc-c++ |
22 |
|
|
BuildRequires: ninja-build |
23 |
|
|
%if 0%{?rhel} && 0%{?rhel} <= 7 |
24 |
|
|
BuildRequires: cmake3 |
25 |
|
|
%else |
26 |
|
|
BuildRequires: cmake |
27 |
|
|
%endif |
28 |
|
|
%if %{with doc} |
29 |
|
|
BuildRequires: doxygen |
30 |
|
|
BuildRequires: nodejs-less |
31 |
|
|
%if 0%{?rhel} && 0%{?rhel} <= 7 |
32 |
|
|
BuildRequires: python%{python3_version_nodots}-sphinx |
33 |
|
|
BuildRequires: python%{python3_version_nodots}-breathe |
34 |
|
|
%else |
35 |
|
|
BuildRequires: python3-sphinx |
36 |
|
|
BuildRequires: python3-breathe |
37 |
|
|
%endif |
38 |
|
|
%else |
39 |
|
|
Provides: %{name}-doc = %{?epoch:%{epoch}:}%{version}-%{release} |
40 |
|
|
Obsoletes: %{name}-doc < %{?epoch:%{epoch}:}%{version}-%{release} |
41 |
|
|
%endif |
42 |
|
|
|
43 |
|
|
# This package replaces the old name of cppformat |
44 |
|
|
Provides: cppformat = %{?epoch:%{epoch}:}%{version}-%{release} |
45 |
|
|
Obsoletes: cppformat < %{?epoch:%{epoch}:}%{version}-%{release} |
46 |
|
|
|
47 |
|
|
%description |
48 |
|
|
C++ Format is an open-source formatting library for C++. It can be used as a |
49 |
|
|
safe alternative to printf or as a fast alternative to IOStreams. |
50 |
|
|
|
51 |
|
|
%package devel |
52 |
|
|
Summary: Development files for %{name} |
53 |
|
|
Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release} |
54 |
|
|
|
55 |
|
|
# This package replaces the old name of cppformat |
56 |
|
|
Provides: cppformat-devel = %{?epoch:%{epoch}:}%{version}-%{release} |
57 |
|
|
Obsoletes: cppformat-devel < %{?epoch:%{epoch}:}%{version}-%{release} |
58 |
|
|
|
59 |
|
|
%description devel |
60 |
|
|
This package contains the header file for using %{name}. |
61 |
|
|
|
62 |
|
|
%if %{with doc} |
63 |
|
|
%package doc |
64 |
|
|
Summary: Documentation files for %{name} |
65 |
|
|
License: Python |
66 |
|
|
BuildArch: noarch |
67 |
|
|
|
68 |
|
|
# This package replaces the old name of cppformat |
69 |
|
|
Provides: cppformat-doc = %{?epoch:%{epoch}:}%{version}-%{release} |
70 |
|
|
Obsoletes: cppformat-doc < %{?epoch:%{epoch}:}%{version}-%{release} |
71 |
|
|
|
72 |
|
|
%description doc |
73 |
|
|
This package contains documentation for developer documentation for %{name}. |
74 |
|
|
%endif |
75 |
|
|
|
76 |
|
|
%prep |
77 |
|
|
%autosetup -p1 |
78 |
|
|
|
79 |
|
|
%if %{with doc} |
80 |
|
|
# Remove --clean-css since that plugin isn't available |
81 |
|
|
sed -i "s/'--clean-css',//" doc/build.py |
82 |
|
|
%endif |
83 |
|
|
|
84 |
|
|
%build |
85 |
|
|
%if 0%{?rhel} && 0%{?rhel} <= 7 |
86 |
|
|
%cmake3 \ |
87 |
|
|
%else |
88 |
|
|
%cmake \ |
89 |
|
|
%endif |
90 |
|
|
-G Ninja \ |
91 |
|
|
-DCMAKE_BUILD_TYPE=RelWithDebInfo \ |
92 |
|
|
-DCMAKE_POSITION_INDEPENDENT_CODE=ON \ |
93 |
|
|
-DFMT_CMAKE_DIR=%{_datadir}/cmake/%{name} \ |
94 |
|
|
-DFMT_LIB_DIR=%{_libdir} |
95 |
|
|
|
96 |
|
|
%cmake_build \ |
97 |
|
|
%if %{with doc} |
98 |
|
|
--target doc \ |
99 |
|
|
%endif |
100 |
|
|
--target all |
101 |
|
|
|
102 |
|
|
%if %{with doc} |
103 |
|
|
# Remove temporary build products |
104 |
|
|
rm -rf %{_vpath_builddir}/doc/html/{.buildinfo,.doctrees,objects.inv} |
105 |
|
|
%endif |
106 |
|
|
|
107 |
|
|
%install |
108 |
|
|
%cmake_install |
109 |
|
|
|
110 |
|
|
%check |
111 |
|
|
%ctest |
112 |
|
|
|
113 |
|
|
%files |
114 |
|
|
%license LICENSE.rst |
115 |
|
|
%doc ChangeLog.rst README.rst |
116 |
|
|
%{_libdir}/lib%{name}.so.7* |
117 |
|
|
|
118 |
|
|
%files devel |
119 |
|
|
%{_includedir}/%{name} |
120 |
|
|
%{_libdir}/lib%{name}.so |
121 |
|
|
%{_datadir}/cmake/%{name} |
122 |
|
|
%{_libdir}/pkgconfig/%{name}.pc |
123 |
|
|
|
124 |
|
|
%if %{with doc} |
125 |
|
|
%files doc |
126 |
|
|
%doc %{_datadir}/doc/%{name} |
127 |
|
|
%license doc/python-license.txt |
128 |
|
|
%endif |
129 |
|
|
|
130 |
|
|
%changelog |
131 |
|
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 7.1.3-2 |
132 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild |
133 |
|
|
|
134 |
|
|
* Sun Nov 29 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.1.3-1 |
135 |
|
|
- Updated to version 7.1.3. |
136 |
|
|
|
137 |
|
|
* Tue Nov 10 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.1.2-1 |
138 |
|
|
- Updated to version 7.1.2. |
139 |
|
|
|
140 |
|
|
* Sat Aug 08 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.0.3-1 |
141 |
|
|
- Updated to version 7.0.3. |
142 |
|
|
|
143 |
|
|
* Wed Jul 29 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.0.2-1 |
144 |
|
|
- Updated to version 7.0.2. |
145 |
|
|
|
146 |
|
|
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.0.1-2 |
147 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild |
148 |
|
|
|
149 |
|
|
* Wed Jul 08 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.0.1-1 |
150 |
|
|
- Updated to version 7.0.1. |
151 |
|
|
|
152 |
|
|
* Sat May 09 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 6.2.1-1 |
153 |
|
|
- Updated to version 6.2.1. |
154 |
|
|
|
155 |
|
|
* Thu Apr 30 2020 Kefu Chai <tchaikov@gmail.com> - 6.2.0-2 |
156 |
|
|
- Incorporate patch from upstream to address https://github.com/fmtlib/fmt/issues/1631 |
157 |
|
|
|
158 |
|
|
* Mon Apr 06 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 6.2.0-1 |
159 |
|
|
- Updated to version 6.2.0. |
160 |
|
|
|
161 |
|
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.2-2 |
162 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild |
163 |
|
|
|
164 |
|
|
* Wed Dec 18 2019 Vitaly Zaitsev <vitaly@easycoding.org> - 6.1.2-1 |
165 |
|
|
- Updated to version 6.1.2. |
166 |
|
|
- Recreated all documentation patches. |
167 |
|
|
- SPEC file cleanup. |
168 |
|
|
|
169 |
|
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.3.0-2 |
170 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild |
171 |
|
|
|
172 |
|
|
* Mon Jun 10 2019 Jan Staněk <jstanek@redhat.com> - 5.3.0-1 |
173 |
|
|
- Update to 5.3.0 |
174 |
|
|
- Recreate documentation build patches |
175 |
|
|
- Package new pkg-config files |
176 |
|
|
|
177 |
|
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.1-2 |
178 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild |
179 |
|
|
|
180 |
|
|
* Thu Oct 11 2018 Kefu Chai <tchaikov@gmail.com> - 5.2.1-1 |
181 |
|
|
- Update to 5.2.1 |
182 |
|
|
- Build using python3 packages on fedora |
183 |
|
|
- Remove links in document accessing network |
184 |
|
|
- Package ChangeLog.rst and README.rst |
185 |
|
|
- Drop fmt-static package |
186 |
|
|
|
187 |
|
|
* Fri Aug 31 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.0.2-7 |
188 |
|
|
- Fix python2 issue for doc |
189 |
|
|
|
190 |
|
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-6 |
191 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild |
192 |
|
|
|
193 |
|
|
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-5 |
194 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild |
195 |
|
|
|
196 |
|
|
* Wed Aug 09 2017 Dave Johansen <davejohansen@gmail.com> - 3.0.2-4 |
197 |
|
|
- Patch for Test 8 segfault |
198 |
|
|
|
199 |
|
|
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-3 |
200 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild |
201 |
|
|
|
202 |
|
|
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-2 |
203 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild |
204 |
|
|
|
205 |
|
|
* Sat Jun 24 2017 Dave Johansen <davejohansen@gmail.com> - 3.0.2-1 |
206 |
|
|
- Upstream release |
207 |
|
|
|
208 |
|
|
* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1-3 |
209 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild |
210 |
|
|
|
211 |
|
|
* Tue Dec 27 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.1-2 |
212 |
|
|
- Build documentation |
213 |
|
|
|
214 |
|
|
* Fri Nov 25 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.1-1 |
215 |
|
|
- Upstream release |
216 |
|
|
|
217 |
|
|
* Tue Nov 15 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.0-2 |
218 |
|
|
- Fix expected unqualified-id before numeric constant error |
219 |
|
|
|
220 |
|
|
* Wed Aug 24 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.0-1 |
221 |
|
|
- Initial RPM release |