1 |
%undefine __cmake_in_source_build |
2 |
|
3 |
%bcond_with doc |
4 |
Name: fmt |
5 |
Version: 7.1.3 |
6 |
Release: 2%{?dist} |
7 |
Summary: Small, safe and fast formatting library for C++ |
8 |
|
9 |
License: BSD |
10 |
URL: https://github.com/fmtlib/%{name} |
11 |
Source0: %{url}/archive/%{version}.tar.gz |
12 |
# See https://github.com/fmtlib/fmt/issues/443 and https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/message/LVKYLDLJVWAVJE4MQVKDO6PYZRD5MCP6/ |
13 |
Patch1: doc-build-removed-all-pip-internet-stuff.patch |
14 |
Patch3: doc-build-do-not-create-virtual-environment.patch |
15 |
Patch4: doc-_templates-layout-stripped-Google-Analytics.patch |
16 |
Patch5: doc-_templates-layout-stripped-download-links.patch |
17 |
Patch6: doc-index-removed-GitHub-iframe.patch |
18 |
Patch7: doc-build-use-sphinx-build-3.patch |
19 |
|
20 |
BuildRequires: gcc |
21 |
BuildRequires: gcc-c++ |
22 |
BuildRequires: ninja-build |
23 |
%if 0%{?rhel} && 0%{?rhel} <= 7 |
24 |
BuildRequires: cmake3 |
25 |
BuildRequires: gcc devtoolset-9-gcc |
26 |
BuildRequires: gcc-c++ devtoolset-9-gcc-c++ |
27 |
%else |
28 |
BuildRequires: cmake |
29 |
%endif |
30 |
%if %{with doc} |
31 |
BuildRequires: doxygen |
32 |
BuildRequires: nodejs-less |
33 |
%if 0%{?rhel} && 0%{?rhel} <= 7 |
34 |
BuildRequires: python%{python3_version_nodots}-sphinx |
35 |
BuildRequires: python%{python3_version_nodots}-breathe |
36 |
%else |
37 |
BuildRequires: python3-sphinx |
38 |
BuildRequires: python3-breathe |
39 |
%endif |
40 |
%else |
41 |
Provides: %{name}-doc = %{?epoch:%{epoch}:}%{version}-%{release} |
42 |
Obsoletes: %{name}-doc < %{?epoch:%{epoch}:}%{version}-%{release} |
43 |
%endif |
44 |
|
45 |
# This package replaces the old name of cppformat |
46 |
Provides: cppformat = %{?epoch:%{epoch}:}%{version}-%{release} |
47 |
Obsoletes: cppformat < %{?epoch:%{epoch}:}%{version}-%{release} |
48 |
|
49 |
%description |
50 |
C++ Format is an open-source formatting library for C++. It can be used as a |
51 |
safe alternative to printf or as a fast alternative to IOStreams. |
52 |
|
53 |
%package devel |
54 |
Summary: Development files for %{name} |
55 |
Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release} |
56 |
|
57 |
# This package replaces the old name of cppformat |
58 |
Provides: cppformat-devel = %{?epoch:%{epoch}:}%{version}-%{release} |
59 |
Obsoletes: cppformat-devel < %{?epoch:%{epoch}:}%{version}-%{release} |
60 |
|
61 |
%description devel |
62 |
This package contains the header file for using %{name}. |
63 |
|
64 |
%if %{with doc} |
65 |
%package doc |
66 |
Summary: Documentation files for %{name} |
67 |
License: Python |
68 |
BuildArch: noarch |
69 |
|
70 |
# This package replaces the old name of cppformat |
71 |
Provides: cppformat-doc = %{?epoch:%{epoch}:}%{version}-%{release} |
72 |
Obsoletes: cppformat-doc < %{?epoch:%{epoch}:}%{version}-%{release} |
73 |
|
74 |
%description doc |
75 |
This package contains documentation for developer documentation for %{name}. |
76 |
%endif |
77 |
|
78 |
%prep |
79 |
. /opt/rh/devtoolset-9/enable |
80 |
%autosetup -p1 |
81 |
|
82 |
%if %{with doc} |
83 |
# Remove --clean-css since that plugin isn't available |
84 |
sed -i "s/'--clean-css',//" doc/build.py |
85 |
%endif |
86 |
|
87 |
%build |
88 |
. /opt/rh/devtoolset-9/enable |
89 |
%cmake3 \ |
90 |
-G Ninja \ |
91 |
-DCMAKE_BUILD_TYPE=RelWithDebInfo \ |
92 |
-DCMAKE_POSITION_INDEPENDENT_CODE=ON \ |
93 |
-DFMT_CMAKE_DIR=%{_datadir}/cmake/%{name} \ |
94 |
-DFMT_LIB_DIR=%{_libdir} |
95 |
|
96 |
%cmake3_build -j1 \ |
97 |
%if %{with doc} |
98 |
--target doc \ |
99 |
%endif |
100 |
--target all |
101 |
|
102 |
%if %{with doc} |
103 |
# Remove temporary build products |
104 |
rm -rf %{_vpath_builddir}/doc/html/{.buildinfo,.doctrees,objects.inv} |
105 |
%endif |
106 |
|
107 |
%install |
108 |
. /opt/rh/devtoolset-9/enable |
109 |
%cmake3_install |
110 |
|
111 |
#%check |
112 |
#%ctest |
113 |
|
114 |
%files |
115 |
%license LICENSE.rst |
116 |
%doc ChangeLog.rst README.rst |
117 |
%{_libdir}/lib%{name}.so.7* |
118 |
|
119 |
%files devel |
120 |
%{_includedir}/%{name} |
121 |
%{_libdir}/lib%{name}.so |
122 |
%{_datadir}/cmake/%{name} |
123 |
%{_libdir}/pkgconfig/%{name}.pc |
124 |
|
125 |
%if %{with doc} |
126 |
%files doc |
127 |
%doc %{_datadir}/doc/%{name} |
128 |
%license doc/python-license.txt |
129 |
%endif |
130 |
|
131 |
%changelog |
132 |
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 7.1.3-2 |
133 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild |
134 |
|
135 |
* Sun Nov 29 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.1.3-1 |
136 |
- Updated to version 7.1.3. |
137 |
|
138 |
* Tue Nov 10 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.1.2-1 |
139 |
- Updated to version 7.1.2. |
140 |
|
141 |
* Sat Aug 08 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.0.3-1 |
142 |
- Updated to version 7.0.3. |
143 |
|
144 |
* Wed Jul 29 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.0.2-1 |
145 |
- Updated to version 7.0.2. |
146 |
|
147 |
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 7.0.1-2 |
148 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild |
149 |
|
150 |
* Wed Jul 08 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 7.0.1-1 |
151 |
- Updated to version 7.0.1. |
152 |
|
153 |
* Sat May 09 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 6.2.1-1 |
154 |
- Updated to version 6.2.1. |
155 |
|
156 |
* Thu Apr 30 2020 Kefu Chai <tchaikov@gmail.com> - 6.2.0-2 |
157 |
- Incorporate patch from upstream to address https://github.com/fmtlib/fmt/issues/1631 |
158 |
|
159 |
* Mon Apr 06 2020 Vitaly Zaitsev <vitaly@easycoding.org> - 6.2.0-1 |
160 |
- Updated to version 6.2.0. |
161 |
|
162 |
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.2-2 |
163 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild |
164 |
|
165 |
* Wed Dec 18 2019 Vitaly Zaitsev <vitaly@easycoding.org> - 6.1.2-1 |
166 |
- Updated to version 6.1.2. |
167 |
- Recreated all documentation patches. |
168 |
- SPEC file cleanup. |
169 |
|
170 |
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.3.0-2 |
171 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild |
172 |
|
173 |
* Mon Jun 10 2019 Jan Staněk <jstanek@redhat.com> - 5.3.0-1 |
174 |
- Update to 5.3.0 |
175 |
- Recreate documentation build patches |
176 |
- Package new pkg-config files |
177 |
|
178 |
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.1-2 |
179 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild |
180 |
|
181 |
* Thu Oct 11 2018 Kefu Chai <tchaikov@gmail.com> - 5.2.1-1 |
182 |
- Update to 5.2.1 |
183 |
- Build using python3 packages on fedora |
184 |
- Remove links in document accessing network |
185 |
- Package ChangeLog.rst and README.rst |
186 |
- Drop fmt-static package |
187 |
|
188 |
* Fri Aug 31 2018 Leigh Scott <leigh123linux@googlemail.com> - 3.0.2-7 |
189 |
- Fix python2 issue for doc |
190 |
|
191 |
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-6 |
192 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild |
193 |
|
194 |
* Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-5 |
195 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild |
196 |
|
197 |
* Wed Aug 09 2017 Dave Johansen <davejohansen@gmail.com> - 3.0.2-4 |
198 |
- Patch for Test 8 segfault |
199 |
|
200 |
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-3 |
201 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild |
202 |
|
203 |
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-2 |
204 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild |
205 |
|
206 |
* Sat Jun 24 2017 Dave Johansen <davejohansen@gmail.com> - 3.0.2-1 |
207 |
- Upstream release |
208 |
|
209 |
* Mon May 15 2017 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.0.1-3 |
210 |
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_27_Mass_Rebuild |
211 |
|
212 |
* Tue Dec 27 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.1-2 |
213 |
- Build documentation |
214 |
|
215 |
* Fri Nov 25 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.1-1 |
216 |
- Upstream release |
217 |
|
218 |
* Tue Nov 15 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.0-2 |
219 |
- Fix expected unqualified-id before numeric constant error |
220 |
|
221 |
* Wed Aug 24 2016 Dave Johansen <davejohansen@gmail.com> - 3.0.0-1 |
222 |
- Initial RPM release |