1 |
jpp |
1.1 |
Name: gerbera |
2 |
|
|
Version: 1.9.1 |
3 |
|
|
Release: 1%{?dist} |
4 |
|
|
Summary: UPnP Media Server |
5 |
|
|
License: GPLv2 and MIT and OFL |
6 |
|
|
Url: https://gerbera.io |
7 |
|
|
Source0: https://github.com/gerbera/gerbera/archive/v%{version}/%{name}-%{version}.tar.gz |
8 |
|
|
Source1: config.xml |
9 |
|
|
Source2: gerbera-sysusers.conf |
10 |
|
|
|
11 |
|
|
BuildRequires: gcc |
12 |
|
|
BuildRequires: gcc-c++ |
13 |
|
|
BuildRequires: libupnp-devel |
14 |
|
|
BuildRequires: libuuid-devel |
15 |
|
|
BuildRequires: sqlite-devel |
16 |
|
|
BuildRequires: duktape-devel |
17 |
|
|
BuildRequires: curl-devel |
18 |
|
|
BuildRequires: taglib-devel |
19 |
|
|
BuildRequires: file-devel |
20 |
|
|
BuildRequires: libexif-devel |
21 |
|
|
BuildRequires: exiv2-devel |
22 |
|
|
BuildRequires: cmake |
23 |
|
|
BuildRequires: zlib-devel |
24 |
|
|
BuildRequires: libebml-devel |
25 |
|
|
BuildRequires: libmatroska-devel |
26 |
|
|
BuildRequires: spdlog-devel |
27 |
|
|
BuildRequires: pugixml-devel |
28 |
|
|
BuildRequires: mariadb-connector-c-devel |
29 |
|
|
%{?sysusers_requires_compat} |
30 |
|
|
%{?systemd_ordering} |
31 |
|
|
BuildRequires: systemd-devel |
32 |
|
|
BuildRequires: systemd-rpm-macros |
33 |
|
|
BuildRequires: make |
34 |
|
|
Requires: %{name}-data = %{version}-%{release} |
35 |
|
|
|
36 |
|
|
%description |
37 |
|
|
Gerbera is a UPnP media server which allows you to stream your digital |
38 |
|
|
media through your home network and consume it on a variety of UPnP |
39 |
|
|
compatible devices. |
40 |
|
|
|
41 |
|
|
%package data |
42 |
|
|
Summary: Data files for Gerbera |
43 |
|
|
BuildArch: noarch |
44 |
|
|
|
45 |
|
|
%description data |
46 |
|
|
Data files for the Gerbera media server. |
47 |
|
|
|
48 |
|
|
%prep |
49 |
|
|
%autosetup -p1 |
50 |
|
|
|
51 |
|
|
%build |
52 |
|
|
%cmake \ |
53 |
|
|
-DWITH_JS=1 \ |
54 |
|
|
-DWITH_MYSQL=1 \ |
55 |
|
|
-DWITH_CURL=1 \ |
56 |
|
|
-DWITH_TAGLIB=1 \ |
57 |
|
|
-DWITH_MAGIC=1 \ |
58 |
|
|
-DWITH_AVCODEC=0 \ |
59 |
|
|
-DWITH_EXIF=1 \ |
60 |
|
|
-DWITH_EXIV2=1 \ |
61 |
|
|
-DWITH_FFMPEGTHUMBNAILER=0 \ |
62 |
|
|
-DWITH_INOTIFY=1 \ |
63 |
|
|
-DWITH_SYSTEMD=1 \ |
64 |
|
|
-DUPNP_HAS_IPV6=1 \ |
65 |
|
|
-DUPNP_HAS_REUSEADDR=1 |
66 |
|
|
|
67 |
|
|
%cmake_build |
68 |
|
|
|
69 |
|
|
%install |
70 |
|
|
install -p -D -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/gerbera/config.xml |
71 |
|
|
install -p -D -m0644 %{SOURCE2} %{buildroot}%{_sysusersdir}/gerbera.conf |
72 |
|
|
|
73 |
|
|
%cmake_install |
74 |
|
|
|
75 |
|
|
# make all files under %%_sysconfdir/gerbera owned by |
76 |
|
|
# this package |
77 |
|
|
mkdir -p %{buildroot}%{_sysconfdir}/gerbera |
78 |
|
|
touch %{buildroot}%{_sysconfdir}/gerbera/{gerbera.db,gerbera.html} |
79 |
|
|
mkdir -p %{buildroot}%{_localstatedir}/log/gerbera |
80 |
|
|
touch %{buildroot}%{_localstatedir}/log/%{name} |
81 |
|
|
mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d |
82 |
|
|
cat > %{buildroot}%{_sysconfdir}/logrotate.d/%{name} << 'EOF' |
83 |
|
|
/var/log/gerbera/gerbera { |
84 |
|
|
create 644 gerbera gerbera |
85 |
|
|
monthly |
86 |
|
|
compress |
87 |
|
|
missingok |
88 |
|
|
} |
89 |
|
|
EOF |
90 |
|
|
|
91 |
|
|
|
92 |
|
|
%pre |
93 |
|
|
%sysusers_create_compat %{SOURCE2} |
94 |
|
|
|
95 |
|
|
%post |
96 |
|
|
%systemd_post gerbera.service |
97 |
|
|
|
98 |
|
|
%preun |
99 |
|
|
%systemd_preun gerbera.service |
100 |
|
|
|
101 |
|
|
%postun |
102 |
|
|
%systemd_postun_with_restart gerbera.service |
103 |
|
|
|
104 |
|
|
%files |
105 |
|
|
%license LICENSE.md |
106 |
|
|
%doc AUTHORS CONTRIBUTING.md ChangeLog.md |
107 |
|
|
%attr(-,gerbera,gerbera)%dir %{_sysconfdir}/%{name}/ |
108 |
|
|
%attr(-,gerbera,gerbera)%config(noreplace) %{_sysconfdir}/%{name}/* |
109 |
|
|
%attr(-,gerbera,gerbera) %{_localstatedir}/log/%{name} |
110 |
|
|
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name} |
111 |
|
|
%dir %{_sysconfdir}/logrotate.d |
112 |
|
|
%{_bindir}/%{name} |
113 |
|
|
%{_mandir}/man1/* |
114 |
|
|
%{_unitdir}/gerbera.service |
115 |
|
|
%{_sysusersdir}/gerbera.conf |
116 |
|
|
|
117 |
|
|
%files data |
118 |
|
|
%{_datadir}/%{name}/ |
119 |
|
|
%config(noreplace) %{_datadir}/%{name}/js/import.js |
120 |
|
|
%config(noreplace) %{_datadir}/%{name}/js/playlists.js |
121 |
|
|
%config(noreplace) %{_datadir}/%{name}/js/common.js |
122 |
|
|
|
123 |
|
|
%changelog |
124 |
|
|
* Sat Aug 28 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.9.1-1 |
125 |
|
|
- 1.9.1 |
126 |
|
|
|
127 |
|
|
* Sun Aug 01 2021 Neal Gompa <ngompa@fedoraproject.org> - 1.9.0-1 |
128 |
|
|
- Update to 1.9.0 |
129 |
|
|
- Update user creation for systemd-sysusers support |
130 |
|
|
- Fix file list for logrotate configuration |
131 |
|
|
- Other minor spec cleanups |
132 |
|
|
|
133 |
|
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-3 |
134 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild |
135 |
|
|
|
136 |
|
|
* Mon Jul 05 2021 Richard Shaw <hobbes1069@gmail.com> - 1.8.2-2 |
137 |
|
|
- Rebuild for new fmt version. |
138 |
|
|
|
139 |
|
|
* Tue Jun 01 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.8.2-1 |
140 |
|
|
- 1.8.2 |
141 |
|
|
|
142 |
|
|
* Mon May 10 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.8.1-1 |
143 |
|
|
- 1.8.1 |
144 |
|
|
|
145 |
|
|
* Wed Apr 07 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.8.0-1 |
146 |
|
|
- 1.8.0 |
147 |
|
|
|
148 |
|
|
* Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.7.0-2 |
149 |
|
|
- Rebuilt for updated systemd-rpm-macros |
150 |
|
|
See https://pagure.io/fesco/issue/2583. |
151 |
|
|
|
152 |
|
|
* Mon Mar 01 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.7.0-1 |
153 |
|
|
- 1.7.0 |
154 |
|
|
|
155 |
|
|
* Fri Feb 12 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.6.4-5 |
156 |
|
|
- Add MySQL support. |
157 |
|
|
|
158 |
|
|
* Tue Feb 09 2021 Nicolas Chauvet <kwizart@gmail.com> - 1.6.4-4 |
159 |
|
|
- Rebuilt for upnp |
160 |
|
|
|
161 |
|
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-3 |
162 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild |
163 |
|
|
|
164 |
|
|
* Wed Oct 28 2020 Jeff Law <law@redhat.com> - 1.6.4-2 |
165 |
|
|
- Fix missing #include for gcc-11 |
166 |
|
|
|
167 |
|
|
* Thu Oct 15 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.4-1 |
168 |
|
|
- 1.6.4 |
169 |
|
|
|
170 |
|
|
* Fri Sep 04 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.1-1 |
171 |
|
|
- 1.6.1 |
172 |
|
|
|
173 |
|
|
* Tue Aug 04 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.0-3 |
174 |
|
|
- fmt rebuild. |
175 |
|
|
|
176 |
|
|
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.0-2 |
177 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild |
178 |
|
|
|
179 |
|
|
* Sun Jul 26 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.0-1 |
180 |
|
|
- 1.6.0 |
181 |
|
|
|
182 |
|
|
* Fri Jul 17 2020 Dominik Mierzejewski <rpm@greysector.net> - 1.5.0-2 |
183 |
|
|
- rebuild for libebml and libmatroska soname bump |
184 |
|
|
|
185 |
|
|
* Thu Jul 16 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.5.0-1 |
186 |
|
|
- 1.5.0 |
187 |
|
|
|
188 |
|
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-3 |
189 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild |
190 |
|
|
|
191 |
|
|
* Mon Dec 30 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.4.0-2 |
192 |
|
|
- Bump EVR for koji error. |
193 |
|
|
|
194 |
|
|
* Mon Dec 30 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.4.0-1 |
195 |
|
|
- 1.4.0 |
196 |
|
|
|
197 |
|
|
* Fri Nov 22 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.5-1 |
198 |
|
|
- 1.3.5 |
199 |
|
|
|
200 |
|
|
* Mon Nov 18 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.4-1 |
201 |
|
|
- 1.3.4 |
202 |
|
|
|
203 |
|
|
* Wed Oct 30 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.3-1 |
204 |
|
|
- 1.3.3 |
205 |
|
|
|
206 |
|
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.2-2 |
207 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild |
208 |
|
|
|
209 |
|
|
* Tue Jun 11 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.2-1 |
210 |
|
|
- 1.3.2 |
211 |
|
|
|
212 |
|
|
* Thu Apr 04 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.1-1 |
213 |
|
|
- 1.3.1 |
214 |
|
|
|
215 |
|
|
* Thu Feb 21 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.0-4 |
216 |
|
|
- Drop lastlibfm, liblastfm not working yet. |
217 |
|
|
|
218 |
|
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-3 |
219 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild |
220 |
|
|
|
221 |
|
|
* Wed Jan 30 2019 Rex Dieter <rdieter@fedoraproject.org> - 1.3.0-2 |
222 |
|
|
- rebuild (exiv2) |
223 |
|
|
|
224 |
|
|
* Tue Jan 29 2019 Gwyn Ciesla <limburgher@gmail.com> - 1.3.0-1 |
225 |
|
|
- 1.3.0 |
226 |
|
|
|
227 |
|
|
* Mon Dec 03 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.2.0-4 |
228 |
|
|
- Fix logrotate config, BZ 1655279. |
229 |
|
|
|
230 |
|
|
* Mon Nov 12 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.2.0-3 |
231 |
|
|
- noconfig js, BZ 1648650. |
232 |
|
|
|
233 |
|
|
* Tue Oct 23 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.2.0-2 |
234 |
|
|
- Correct log directory. |
235 |
|
|
- Fix default config. |
236 |
|
|
|
237 |
|
|
* Fri Oct 05 2018 Dennis Gilmore <dennis@ausil.us> - 1.2.0-1 |
238 |
|
|
- update to the 1.2.0 release |
239 |
|
|
|
240 |
|
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-6.20180413git2f6dcb5 |
241 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild |
242 |
|
|
|
243 |
|
|
* Tue May 29 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.1.0-5.20180413git2f6dcb5 |
244 |
|
|
- Fix Requires |
245 |
|
|
|
246 |
|
|
* Mon May 28 2018 Dennis Gilmore <dennis@ausil.us> - 1.1.0-4.20180413git2f6dcb5 |
247 |
|
|
- Add back the correct requiresso that the data sub package gets pulled in |
248 |
|
|
|
249 |
|
|
* Mon May 28 2018 Dennis Gilmore <dennis@ausil.us> - 1.1.0-3.20180413git2f6dcb5 |
250 |
|
|
- remove requires that prevents installation |
251 |
|
|
|
252 |
|
|
* Thu Apr 19 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.1.0-2.20180413git2f6dcb5 |
253 |
|
|
- Spec corrections. |
254 |
|
|
- Split out data subpackage. |
255 |
|
|
|
256 |
|
|
* Fri Apr 13 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.1.0-1 |
257 |
|
|
- Adapt to modern packaging guidelines. |
258 |
|
|
|
259 |
|
|
* Mon Mar 19 2018 jk@lutty.net |
260 |
|
|
- Initial package derived from mediatomb (fedora) annd gerbera (Suse) |