1 |
jpp |
1.1 |
Name: gerbera |
2 |
|
|
Version: 1.9.1 |
3 |
jpp |
1.2 |
Release: 2%{?dist} |
4 |
jpp |
1.1 |
Summary: UPnP Media Server |
5 |
|
|
License: GPLv2 and MIT and OFL |
6 |
|
|
Url: https://gerbera.io |
7 |
|
|
Source0: https://github.com/gerbera/gerbera/archive/v%{version}/%{name}-%{version}.tar.gz |
8 |
|
|
Source1: config.xml |
9 |
|
|
Source2: gerbera-sysusers.conf |
10 |
|
|
|
11 |
jpp |
1.2 |
BuildRequires: fmt-devel |
12 |
|
|
BuildRequires: gcc devtoolset-9-gcc |
13 |
|
|
BuildRequires: gcc-c++ devtoolset-9-gcc-c++ |
14 |
jpp |
1.1 |
BuildRequires: libupnp-devel |
15 |
|
|
BuildRequires: libuuid-devel |
16 |
|
|
BuildRequires: sqlite-devel |
17 |
jpp |
1.2 |
#BuildRequires: duktape-devel |
18 |
jpp |
1.1 |
BuildRequires: curl-devel |
19 |
|
|
BuildRequires: taglib-devel |
20 |
|
|
BuildRequires: file-devel |
21 |
|
|
BuildRequires: libexif-devel |
22 |
|
|
BuildRequires: exiv2-devel |
23 |
jpp |
1.2 |
BuildRequires: cmake cmake3 |
24 |
jpp |
1.1 |
BuildRequires: zlib-devel |
25 |
|
|
BuildRequires: libebml-devel |
26 |
|
|
BuildRequires: libmatroska-devel |
27 |
|
|
BuildRequires: spdlog-devel |
28 |
|
|
BuildRequires: pugixml-devel |
29 |
jpp |
1.2 |
#BuildRequires: mariadb-connector-c-devel |
30 |
jpp |
1.1 |
%{?sysusers_requires_compat} |
31 |
|
|
%{?systemd_ordering} |
32 |
|
|
BuildRequires: systemd-devel |
33 |
jpp |
1.2 |
# not available for centos7 |
34 |
|
|
#BuildRequires: systemd-rpm-macros |
35 |
jpp |
1.1 |
BuildRequires: make |
36 |
|
|
Requires: %{name}-data = %{version}-%{release} |
37 |
|
|
|
38 |
|
|
%description |
39 |
|
|
Gerbera is a UPnP media server which allows you to stream your digital |
40 |
|
|
media through your home network and consume it on a variety of UPnP |
41 |
|
|
compatible devices. |
42 |
|
|
|
43 |
|
|
%package data |
44 |
|
|
Summary: Data files for Gerbera |
45 |
|
|
BuildArch: noarch |
46 |
|
|
|
47 |
|
|
%description data |
48 |
|
|
Data files for the Gerbera media server. |
49 |
|
|
|
50 |
|
|
%prep |
51 |
jpp |
1.2 |
. /opt/rh/devtoolset-9/enable |
52 |
jpp |
1.1 |
%autosetup -p1 |
53 |
|
|
|
54 |
|
|
%build |
55 |
jpp |
1.2 |
. /opt/rh/devtoolset-9/enable |
56 |
|
|
%cmake3 \ |
57 |
jpp |
1.1 |
-DWITH_JS=1 \ |
58 |
|
|
-DWITH_MYSQL=1 \ |
59 |
|
|
-DWITH_CURL=1 \ |
60 |
|
|
-DWITH_TAGLIB=1 \ |
61 |
|
|
-DWITH_MAGIC=1 \ |
62 |
|
|
-DWITH_AVCODEC=0 \ |
63 |
|
|
-DWITH_EXIF=1 \ |
64 |
|
|
-DWITH_EXIV2=1 \ |
65 |
|
|
-DWITH_FFMPEGTHUMBNAILER=0 \ |
66 |
|
|
-DWITH_INOTIFY=1 \ |
67 |
|
|
-DWITH_SYSTEMD=1 \ |
68 |
|
|
-DUPNP_HAS_IPV6=1 \ |
69 |
|
|
-DUPNP_HAS_REUSEADDR=1 |
70 |
|
|
|
71 |
jpp |
1.2 |
%cmake3_build |
72 |
jpp |
1.1 |
|
73 |
|
|
%install |
74 |
jpp |
1.2 |
. /opt/rh/devtoolset-9/enable |
75 |
|
|
|
76 |
jpp |
1.1 |
install -p -D -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/gerbera/config.xml |
77 |
|
|
install -p -D -m0644 %{SOURCE2} %{buildroot}%{_sysusersdir}/gerbera.conf |
78 |
|
|
|
79 |
jpp |
1.2 |
%cmake3_install |
80 |
jpp |
1.1 |
|
81 |
|
|
# make all files under %%_sysconfdir/gerbera owned by |
82 |
|
|
# this package |
83 |
|
|
mkdir -p %{buildroot}%{_sysconfdir}/gerbera |
84 |
|
|
touch %{buildroot}%{_sysconfdir}/gerbera/{gerbera.db,gerbera.html} |
85 |
|
|
mkdir -p %{buildroot}%{_localstatedir}/log/gerbera |
86 |
|
|
touch %{buildroot}%{_localstatedir}/log/%{name} |
87 |
|
|
mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d |
88 |
|
|
cat > %{buildroot}%{_sysconfdir}/logrotate.d/%{name} << 'EOF' |
89 |
|
|
/var/log/gerbera/gerbera { |
90 |
|
|
create 644 gerbera gerbera |
91 |
|
|
monthly |
92 |
|
|
compress |
93 |
|
|
missingok |
94 |
|
|
} |
95 |
|
|
EOF |
96 |
|
|
|
97 |
|
|
|
98 |
|
|
%pre |
99 |
|
|
%sysusers_create_compat %{SOURCE2} |
100 |
|
|
|
101 |
|
|
%post |
102 |
|
|
%systemd_post gerbera.service |
103 |
|
|
|
104 |
|
|
%preun |
105 |
|
|
%systemd_preun gerbera.service |
106 |
|
|
|
107 |
|
|
%postun |
108 |
|
|
%systemd_postun_with_restart gerbera.service |
109 |
|
|
|
110 |
|
|
%files |
111 |
|
|
%license LICENSE.md |
112 |
|
|
%doc AUTHORS CONTRIBUTING.md ChangeLog.md |
113 |
|
|
%attr(-,gerbera,gerbera)%dir %{_sysconfdir}/%{name}/ |
114 |
|
|
%attr(-,gerbera,gerbera)%config(noreplace) %{_sysconfdir}/%{name}/* |
115 |
|
|
%attr(-,gerbera,gerbera) %{_localstatedir}/log/%{name} |
116 |
|
|
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name} |
117 |
|
|
%dir %{_sysconfdir}/logrotate.d |
118 |
|
|
%{_bindir}/%{name} |
119 |
|
|
%{_mandir}/man1/* |
120 |
|
|
%{_unitdir}/gerbera.service |
121 |
|
|
%{_sysusersdir}/gerbera.conf |
122 |
|
|
|
123 |
|
|
%files data |
124 |
|
|
%{_datadir}/%{name}/ |
125 |
|
|
%config(noreplace) %{_datadir}/%{name}/js/import.js |
126 |
|
|
%config(noreplace) %{_datadir}/%{name}/js/playlists.js |
127 |
|
|
%config(noreplace) %{_datadir}/%{name}/js/common.js |
128 |
|
|
|
129 |
|
|
%changelog |
130 |
jpp |
1.2 |
* Thu Nov 11 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.9.1-2.sme |
131 |
|
|
- add fmt-devel Requirement |
132 |
|
|
|
133 |
jpp |
1.1 |
* Sat Aug 28 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.9.1-1 |
134 |
|
|
- 1.9.1 |
135 |
|
|
|
136 |
|
|
* Sun Aug 01 2021 Neal Gompa <ngompa@fedoraproject.org> - 1.9.0-1 |
137 |
|
|
- Update to 1.9.0 |
138 |
|
|
- Update user creation for systemd-sysusers support |
139 |
|
|
- Fix file list for logrotate configuration |
140 |
|
|
- Other minor spec cleanups |
141 |
|
|
|
142 |
|
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-3 |
143 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild |
144 |
|
|
|
145 |
|
|
* Mon Jul 05 2021 Richard Shaw <hobbes1069@gmail.com> - 1.8.2-2 |
146 |
|
|
- Rebuild for new fmt version. |
147 |
|
|
|
148 |
|
|
* Tue Jun 01 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.8.2-1 |
149 |
|
|
- 1.8.2 |
150 |
|
|
|
151 |
|
|
* Mon May 10 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.8.1-1 |
152 |
|
|
- 1.8.1 |
153 |
|
|
|
154 |
|
|
* Wed Apr 07 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.8.0-1 |
155 |
|
|
- 1.8.0 |
156 |
|
|
|
157 |
|
|
* Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.7.0-2 |
158 |
|
|
- Rebuilt for updated systemd-rpm-macros |
159 |
|
|
See https://pagure.io/fesco/issue/2583. |
160 |
|
|
|
161 |
|
|
* Mon Mar 01 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.7.0-1 |
162 |
|
|
- 1.7.0 |
163 |
|
|
|
164 |
|
|
* Fri Feb 12 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.6.4-5 |
165 |
|
|
- Add MySQL support. |
166 |
|
|
|
167 |
|
|
* Tue Feb 09 2021 Nicolas Chauvet <kwizart@gmail.com> - 1.6.4-4 |
168 |
|
|
- Rebuilt for upnp |
169 |
|
|
|
170 |
|
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-3 |
171 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild |
172 |
|
|
|
173 |
|
|
* Wed Oct 28 2020 Jeff Law <law@redhat.com> - 1.6.4-2 |
174 |
|
|
- Fix missing #include for gcc-11 |
175 |
|
|
|
176 |
|
|
* Thu Oct 15 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.4-1 |
177 |
|
|
- 1.6.4 |
178 |
|
|
|
179 |
|
|
* Fri Sep 04 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.1-1 |
180 |
|
|
- 1.6.1 |
181 |
|
|
|
182 |
|
|
* Tue Aug 04 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.0-3 |
183 |
|
|
- fmt rebuild. |
184 |
|
|
|
185 |
|
|
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.0-2 |
186 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild |
187 |
|
|
|
188 |
|
|
* Sun Jul 26 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.0-1 |
189 |
|
|
- 1.6.0 |
190 |
|
|
|
191 |
|
|
* Fri Jul 17 2020 Dominik Mierzejewski <rpm@greysector.net> - 1.5.0-2 |
192 |
|
|
- rebuild for libebml and libmatroska soname bump |
193 |
|
|
|
194 |
|
|
* Thu Jul 16 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.5.0-1 |
195 |
|
|
- 1.5.0 |
196 |
|
|
|
197 |
|
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-3 |
198 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild |
199 |
|
|
|
200 |
|
|
* Mon Dec 30 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.4.0-2 |
201 |
|
|
- Bump EVR for koji error. |
202 |
|
|
|
203 |
|
|
* Mon Dec 30 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.4.0-1 |
204 |
|
|
- 1.4.0 |
205 |
|
|
|
206 |
|
|
* Fri Nov 22 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.5-1 |
207 |
|
|
- 1.3.5 |
208 |
|
|
|
209 |
|
|
* Mon Nov 18 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.4-1 |
210 |
|
|
- 1.3.4 |
211 |
|
|
|
212 |
|
|
* Wed Oct 30 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.3-1 |
213 |
|
|
- 1.3.3 |
214 |
|
|
|
215 |
|
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.2-2 |
216 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild |
217 |
|
|
|
218 |
|
|
* Tue Jun 11 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.2-1 |
219 |
|
|
- 1.3.2 |
220 |
|
|
|
221 |
|
|
* Thu Apr 04 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.1-1 |
222 |
|
|
- 1.3.1 |
223 |
|
|
|
224 |
|
|
* Thu Feb 21 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.0-4 |
225 |
|
|
- Drop lastlibfm, liblastfm not working yet. |
226 |
|
|
|
227 |
|
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-3 |
228 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild |
229 |
|
|
|
230 |
|
|
* Wed Jan 30 2019 Rex Dieter <rdieter@fedoraproject.org> - 1.3.0-2 |
231 |
|
|
- rebuild (exiv2) |
232 |
|
|
|
233 |
|
|
* Tue Jan 29 2019 Gwyn Ciesla <limburgher@gmail.com> - 1.3.0-1 |
234 |
|
|
- 1.3.0 |
235 |
|
|
|
236 |
|
|
* Mon Dec 03 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.2.0-4 |
237 |
|
|
- Fix logrotate config, BZ 1655279. |
238 |
|
|
|
239 |
|
|
* Mon Nov 12 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.2.0-3 |
240 |
|
|
- noconfig js, BZ 1648650. |
241 |
|
|
|
242 |
|
|
* Tue Oct 23 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.2.0-2 |
243 |
|
|
- Correct log directory. |
244 |
|
|
- Fix default config. |
245 |
|
|
|
246 |
|
|
* Fri Oct 05 2018 Dennis Gilmore <dennis@ausil.us> - 1.2.0-1 |
247 |
|
|
- update to the 1.2.0 release |
248 |
|
|
|
249 |
|
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-6.20180413git2f6dcb5 |
250 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild |
251 |
|
|
|
252 |
|
|
* Tue May 29 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.1.0-5.20180413git2f6dcb5 |
253 |
|
|
- Fix Requires |
254 |
|
|
|
255 |
|
|
* Mon May 28 2018 Dennis Gilmore <dennis@ausil.us> - 1.1.0-4.20180413git2f6dcb5 |
256 |
|
|
- Add back the correct requiresso that the data sub package gets pulled in |
257 |
|
|
|
258 |
|
|
* Mon May 28 2018 Dennis Gilmore <dennis@ausil.us> - 1.1.0-3.20180413git2f6dcb5 |
259 |
|
|
- remove requires that prevents installation |
260 |
|
|
|
261 |
|
|
* Thu Apr 19 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.1.0-2.20180413git2f6dcb5 |
262 |
|
|
- Spec corrections. |
263 |
|
|
- Split out data subpackage. |
264 |
|
|
|
265 |
|
|
* Fri Apr 13 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.1.0-1 |
266 |
|
|
- Adapt to modern packaging guidelines. |
267 |
|
|
|
268 |
|
|
* Mon Mar 19 2018 jk@lutty.net |
269 |
|
|
- Initial package derived from mediatomb (fedora) annd gerbera (Suse) |