1 |
jpp |
1.1 |
Name: gerbera |
2 |
|
|
Version: 1.9.1 |
3 |
jpp |
1.2 |
Release: 2%{?dist} |
4 |
jpp |
1.1 |
Summary: UPnP Media Server |
5 |
|
|
License: GPLv2 and MIT and OFL |
6 |
|
|
Url: https://gerbera.io |
7 |
|
|
Source0: https://github.com/gerbera/gerbera/archive/v%{version}/%{name}-%{version}.tar.gz |
8 |
|
|
Source1: config.xml |
9 |
|
|
Source2: gerbera-sysusers.conf |
10 |
|
|
|
11 |
jpp |
1.2 |
BuildRequires: fmt-devel |
12 |
|
|
BuildRequires: gcc devtoolset-9-gcc |
13 |
|
|
BuildRequires: gcc-c++ devtoolset-9-gcc-c++ |
14 |
jpp |
1.1 |
BuildRequires: libupnp-devel |
15 |
|
|
BuildRequires: libuuid-devel |
16 |
|
|
BuildRequires: sqlite-devel |
17 |
jpp |
1.3 |
BuildRequires: duktape-devel |
18 |
jpp |
1.1 |
BuildRequires: curl-devel |
19 |
|
|
BuildRequires: taglib-devel |
20 |
|
|
BuildRequires: file-devel |
21 |
|
|
BuildRequires: libexif-devel |
22 |
|
|
BuildRequires: exiv2-devel |
23 |
jpp |
1.2 |
BuildRequires: cmake cmake3 |
24 |
jpp |
1.1 |
BuildRequires: zlib-devel |
25 |
|
|
BuildRequires: libebml-devel |
26 |
|
|
BuildRequires: libmatroska-devel |
27 |
|
|
BuildRequires: spdlog-devel |
28 |
|
|
BuildRequires: pugixml-devel |
29 |
jpp |
1.3 |
BuildRequires: mariadb-connector-c-devel |
30 |
jpp |
1.1 |
%{?sysusers_requires_compat} |
31 |
|
|
%{?systemd_ordering} |
32 |
|
|
BuildRequires: systemd-devel |
33 |
jpp |
1.2 |
# not available for centos7 |
34 |
|
|
#BuildRequires: systemd-rpm-macros |
35 |
jpp |
1.1 |
BuildRequires: make |
36 |
|
|
Requires: %{name}-data = %{version}-%{release} |
37 |
|
|
|
38 |
|
|
%description |
39 |
|
|
Gerbera is a UPnP media server which allows you to stream your digital |
40 |
|
|
media through your home network and consume it on a variety of UPnP |
41 |
|
|
compatible devices. |
42 |
|
|
|
43 |
|
|
%package data |
44 |
|
|
Summary: Data files for Gerbera |
45 |
|
|
BuildArch: noarch |
46 |
|
|
|
47 |
|
|
%description data |
48 |
|
|
Data files for the Gerbera media server. |
49 |
|
|
|
50 |
|
|
%prep |
51 |
jpp |
1.2 |
. /opt/rh/devtoolset-9/enable |
52 |
jpp |
1.1 |
%autosetup -p1 |
53 |
|
|
|
54 |
|
|
%build |
55 |
jpp |
1.2 |
. /opt/rh/devtoolset-9/enable |
56 |
jpp |
1.3 |
#sed -i "s/7.1.3/6.2.1/" CMakeLists.txt |
57 |
jpp |
1.2 |
%cmake3 \ |
58 |
jpp |
1.1 |
-DWITH_JS=1 \ |
59 |
|
|
-DWITH_MYSQL=1 \ |
60 |
|
|
-DWITH_CURL=1 \ |
61 |
|
|
-DWITH_TAGLIB=1 \ |
62 |
|
|
-DWITH_MAGIC=1 \ |
63 |
|
|
-DWITH_AVCODEC=0 \ |
64 |
|
|
-DWITH_EXIF=1 \ |
65 |
|
|
-DWITH_EXIV2=1 \ |
66 |
|
|
-DWITH_FFMPEGTHUMBNAILER=0 \ |
67 |
|
|
-DWITH_INOTIFY=1 \ |
68 |
|
|
-DWITH_SYSTEMD=1 \ |
69 |
|
|
-DUPNP_HAS_IPV6=1 \ |
70 |
|
|
-DUPNP_HAS_REUSEADDR=1 |
71 |
|
|
|
72 |
jpp |
1.2 |
%cmake3_build |
73 |
jpp |
1.1 |
|
74 |
|
|
%install |
75 |
jpp |
1.2 |
. /opt/rh/devtoolset-9/enable |
76 |
|
|
|
77 |
jpp |
1.1 |
install -p -D -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/gerbera/config.xml |
78 |
|
|
install -p -D -m0644 %{SOURCE2} %{buildroot}%{_sysusersdir}/gerbera.conf |
79 |
|
|
|
80 |
jpp |
1.2 |
%cmake3_install |
81 |
jpp |
1.1 |
|
82 |
|
|
# make all files under %%_sysconfdir/gerbera owned by |
83 |
|
|
# this package |
84 |
|
|
mkdir -p %{buildroot}%{_sysconfdir}/gerbera |
85 |
|
|
touch %{buildroot}%{_sysconfdir}/gerbera/{gerbera.db,gerbera.html} |
86 |
|
|
mkdir -p %{buildroot}%{_localstatedir}/log/gerbera |
87 |
|
|
touch %{buildroot}%{_localstatedir}/log/%{name} |
88 |
|
|
mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d |
89 |
|
|
cat > %{buildroot}%{_sysconfdir}/logrotate.d/%{name} << 'EOF' |
90 |
|
|
/var/log/gerbera/gerbera { |
91 |
|
|
create 644 gerbera gerbera |
92 |
|
|
monthly |
93 |
|
|
compress |
94 |
|
|
missingok |
95 |
|
|
} |
96 |
|
|
EOF |
97 |
|
|
|
98 |
|
|
|
99 |
|
|
%pre |
100 |
|
|
%sysusers_create_compat %{SOURCE2} |
101 |
|
|
|
102 |
|
|
%post |
103 |
|
|
%systemd_post gerbera.service |
104 |
|
|
|
105 |
|
|
%preun |
106 |
|
|
%systemd_preun gerbera.service |
107 |
|
|
|
108 |
|
|
%postun |
109 |
|
|
%systemd_postun_with_restart gerbera.service |
110 |
|
|
|
111 |
|
|
%files |
112 |
|
|
%license LICENSE.md |
113 |
|
|
%doc AUTHORS CONTRIBUTING.md ChangeLog.md |
114 |
|
|
%attr(-,gerbera,gerbera)%dir %{_sysconfdir}/%{name}/ |
115 |
|
|
%attr(-,gerbera,gerbera)%config(noreplace) %{_sysconfdir}/%{name}/* |
116 |
|
|
%attr(-,gerbera,gerbera) %{_localstatedir}/log/%{name} |
117 |
|
|
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name} |
118 |
|
|
%dir %{_sysconfdir}/logrotate.d |
119 |
|
|
%{_bindir}/%{name} |
120 |
|
|
%{_mandir}/man1/* |
121 |
|
|
%{_unitdir}/gerbera.service |
122 |
|
|
%{_sysusersdir}/gerbera.conf |
123 |
|
|
|
124 |
|
|
%files data |
125 |
|
|
%{_datadir}/%{name}/ |
126 |
|
|
%config(noreplace) %{_datadir}/%{name}/js/import.js |
127 |
|
|
%config(noreplace) %{_datadir}/%{name}/js/playlists.js |
128 |
|
|
%config(noreplace) %{_datadir}/%{name}/js/common.js |
129 |
|
|
|
130 |
|
|
%changelog |
131 |
jpp |
1.2 |
* Thu Nov 11 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.9.1-2.sme |
132 |
|
|
- add fmt-devel Requirement |
133 |
|
|
|
134 |
jpp |
1.1 |
* Sat Aug 28 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.9.1-1 |
135 |
|
|
- 1.9.1 |
136 |
|
|
|
137 |
|
|
* Sun Aug 01 2021 Neal Gompa <ngompa@fedoraproject.org> - 1.9.0-1 |
138 |
|
|
- Update to 1.9.0 |
139 |
|
|
- Update user creation for systemd-sysusers support |
140 |
|
|
- Fix file list for logrotate configuration |
141 |
|
|
- Other minor spec cleanups |
142 |
|
|
|
143 |
|
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-3 |
144 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild |
145 |
|
|
|
146 |
|
|
* Mon Jul 05 2021 Richard Shaw <hobbes1069@gmail.com> - 1.8.2-2 |
147 |
|
|
- Rebuild for new fmt version. |
148 |
|
|
|
149 |
|
|
* Tue Jun 01 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.8.2-1 |
150 |
|
|
- 1.8.2 |
151 |
|
|
|
152 |
|
|
* Mon May 10 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.8.1-1 |
153 |
|
|
- 1.8.1 |
154 |
|
|
|
155 |
|
|
* Wed Apr 07 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.8.0-1 |
156 |
|
|
- 1.8.0 |
157 |
|
|
|
158 |
|
|
* Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.7.0-2 |
159 |
|
|
- Rebuilt for updated systemd-rpm-macros |
160 |
|
|
See https://pagure.io/fesco/issue/2583. |
161 |
|
|
|
162 |
|
|
* Mon Mar 01 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.7.0-1 |
163 |
|
|
- 1.7.0 |
164 |
|
|
|
165 |
|
|
* Fri Feb 12 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.6.4-5 |
166 |
|
|
- Add MySQL support. |
167 |
|
|
|
168 |
|
|
* Tue Feb 09 2021 Nicolas Chauvet <kwizart@gmail.com> - 1.6.4-4 |
169 |
|
|
- Rebuilt for upnp |
170 |
|
|
|
171 |
|
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-3 |
172 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild |
173 |
|
|
|
174 |
|
|
* Wed Oct 28 2020 Jeff Law <law@redhat.com> - 1.6.4-2 |
175 |
|
|
- Fix missing #include for gcc-11 |
176 |
|
|
|
177 |
|
|
* Thu Oct 15 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.4-1 |
178 |
|
|
- 1.6.4 |
179 |
|
|
|
180 |
|
|
* Fri Sep 04 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.1-1 |
181 |
|
|
- 1.6.1 |
182 |
|
|
|
183 |
|
|
* Tue Aug 04 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.0-3 |
184 |
|
|
- fmt rebuild. |
185 |
|
|
|
186 |
|
|
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.0-2 |
187 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild |
188 |
|
|
|
189 |
|
|
* Sun Jul 26 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.0-1 |
190 |
|
|
- 1.6.0 |
191 |
|
|
|
192 |
|
|
* Fri Jul 17 2020 Dominik Mierzejewski <rpm@greysector.net> - 1.5.0-2 |
193 |
|
|
- rebuild for libebml and libmatroska soname bump |
194 |
|
|
|
195 |
|
|
* Thu Jul 16 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.5.0-1 |
196 |
|
|
- 1.5.0 |
197 |
|
|
|
198 |
|
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-3 |
199 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild |
200 |
|
|
|
201 |
|
|
* Mon Dec 30 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.4.0-2 |
202 |
|
|
- Bump EVR for koji error. |
203 |
|
|
|
204 |
|
|
* Mon Dec 30 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.4.0-1 |
205 |
|
|
- 1.4.0 |
206 |
|
|
|
207 |
|
|
* Fri Nov 22 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.5-1 |
208 |
|
|
- 1.3.5 |
209 |
|
|
|
210 |
|
|
* Mon Nov 18 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.4-1 |
211 |
|
|
- 1.3.4 |
212 |
|
|
|
213 |
|
|
* Wed Oct 30 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.3-1 |
214 |
|
|
- 1.3.3 |
215 |
|
|
|
216 |
|
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.2-2 |
217 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild |
218 |
|
|
|
219 |
|
|
* Tue Jun 11 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.2-1 |
220 |
|
|
- 1.3.2 |
221 |
|
|
|
222 |
|
|
* Thu Apr 04 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.1-1 |
223 |
|
|
- 1.3.1 |
224 |
|
|
|
225 |
|
|
* Thu Feb 21 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.0-4 |
226 |
|
|
- Drop lastlibfm, liblastfm not working yet. |
227 |
|
|
|
228 |
|
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-3 |
229 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild |
230 |
|
|
|
231 |
|
|
* Wed Jan 30 2019 Rex Dieter <rdieter@fedoraproject.org> - 1.3.0-2 |
232 |
|
|
- rebuild (exiv2) |
233 |
|
|
|
234 |
|
|
* Tue Jan 29 2019 Gwyn Ciesla <limburgher@gmail.com> - 1.3.0-1 |
235 |
|
|
- 1.3.0 |
236 |
|
|
|
237 |
|
|
* Mon Dec 03 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.2.0-4 |
238 |
|
|
- Fix logrotate config, BZ 1655279. |
239 |
|
|
|
240 |
|
|
* Mon Nov 12 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.2.0-3 |
241 |
|
|
- noconfig js, BZ 1648650. |
242 |
|
|
|
243 |
|
|
* Tue Oct 23 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.2.0-2 |
244 |
|
|
- Correct log directory. |
245 |
|
|
- Fix default config. |
246 |
|
|
|
247 |
|
|
* Fri Oct 05 2018 Dennis Gilmore <dennis@ausil.us> - 1.2.0-1 |
248 |
|
|
- update to the 1.2.0 release |
249 |
|
|
|
250 |
|
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-6.20180413git2f6dcb5 |
251 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild |
252 |
|
|
|
253 |
|
|
* Tue May 29 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.1.0-5.20180413git2f6dcb5 |
254 |
|
|
- Fix Requires |
255 |
|
|
|
256 |
|
|
* Mon May 28 2018 Dennis Gilmore <dennis@ausil.us> - 1.1.0-4.20180413git2f6dcb5 |
257 |
|
|
- Add back the correct requiresso that the data sub package gets pulled in |
258 |
|
|
|
259 |
|
|
* Mon May 28 2018 Dennis Gilmore <dennis@ausil.us> - 1.1.0-3.20180413git2f6dcb5 |
260 |
|
|
- remove requires that prevents installation |
261 |
|
|
|
262 |
|
|
* Thu Apr 19 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.1.0-2.20180413git2f6dcb5 |
263 |
|
|
- Spec corrections. |
264 |
|
|
- Split out data subpackage. |
265 |
|
|
|
266 |
|
|
* Fri Apr 13 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.1.0-1 |
267 |
|
|
- Adapt to modern packaging guidelines. |
268 |
|
|
|
269 |
|
|
* Mon Mar 19 2018 jk@lutty.net |
270 |
|
|
- Initial package derived from mediatomb (fedora) annd gerbera (Suse) |