1 |
jpp |
1.1 |
Name: gerbera |
2 |
|
|
Version: 1.9.1 |
3 |
jpp |
1.2 |
Release: 2%{?dist} |
4 |
jpp |
1.1 |
Summary: UPnP Media Server |
5 |
|
|
License: GPLv2 and MIT and OFL |
6 |
|
|
Url: https://gerbera.io |
7 |
|
|
Source0: https://github.com/gerbera/gerbera/archive/v%{version}/%{name}-%{version}.tar.gz |
8 |
|
|
Source1: config.xml |
9 |
|
|
Source2: gerbera-sysusers.conf |
10 |
|
|
|
11 |
jpp |
1.2 |
BuildRequires: fmt-devel |
12 |
|
|
BuildRequires: gcc devtoolset-9-gcc |
13 |
|
|
BuildRequires: gcc-c++ devtoolset-9-gcc-c++ |
14 |
jpp |
1.1 |
BuildRequires: libupnp-devel |
15 |
|
|
BuildRequires: libuuid-devel |
16 |
|
|
BuildRequires: sqlite-devel |
17 |
jpp |
1.3 |
BuildRequires: duktape-devel |
18 |
jpp |
1.1 |
BuildRequires: curl-devel |
19 |
|
|
BuildRequires: taglib-devel |
20 |
|
|
BuildRequires: file-devel |
21 |
|
|
BuildRequires: libexif-devel |
22 |
|
|
BuildRequires: exiv2-devel |
23 |
jpp |
1.2 |
BuildRequires: cmake cmake3 |
24 |
jpp |
1.1 |
BuildRequires: zlib-devel |
25 |
|
|
BuildRequires: libebml-devel |
26 |
|
|
BuildRequires: libmatroska-devel |
27 |
|
|
BuildRequires: spdlog-devel |
28 |
|
|
BuildRequires: pugixml-devel |
29 |
jpp |
1.4 |
BuildRequires: mariadb-devel |
30 |
|
|
#BuildRequires: mariadb-connector-c-devel |
31 |
jpp |
1.1 |
%{?sysusers_requires_compat} |
32 |
|
|
%{?systemd_ordering} |
33 |
|
|
BuildRequires: systemd-devel |
34 |
jpp |
1.2 |
# not available for centos7 |
35 |
|
|
#BuildRequires: systemd-rpm-macros |
36 |
jpp |
1.4 |
# add for SME10 |
37 |
|
|
#BuildRequires: rh-mariadb103-mariadb-devel |
38 |
jpp |
1.1 |
BuildRequires: make |
39 |
|
|
Requires: %{name}-data = %{version}-%{release} |
40 |
|
|
|
41 |
|
|
%description |
42 |
|
|
Gerbera is a UPnP media server which allows you to stream your digital |
43 |
|
|
media through your home network and consume it on a variety of UPnP |
44 |
|
|
compatible devices. |
45 |
|
|
|
46 |
|
|
%package data |
47 |
|
|
Summary: Data files for Gerbera |
48 |
|
|
BuildArch: noarch |
49 |
|
|
|
50 |
|
|
%description data |
51 |
|
|
Data files for the Gerbera media server. |
52 |
|
|
|
53 |
|
|
%prep |
54 |
jpp |
1.2 |
. /opt/rh/devtoolset-9/enable |
55 |
jpp |
1.1 |
%autosetup -p1 |
56 |
|
|
|
57 |
|
|
%build |
58 |
jpp |
1.2 |
. /opt/rh/devtoolset-9/enable |
59 |
jpp |
1.3 |
#sed -i "s/7.1.3/6.2.1/" CMakeLists.txt |
60 |
jpp |
1.4 |
#taglib 1.11, found: 1.8.0 |
61 |
|
|
#sed -i "s/1.11/1.8.0/" cmake/FindTaglib.cmake |
62 |
|
|
#see error about curl https://note.nogisawa.net/?2021/0303_gerbera_compile |
63 |
|
|
perl -pi -e 's;CURLINFO_CONTENT_LENGTH_DOWNLOAD_T;CURLINFO_CONTENT_LENGTH_DOWNLOAD;g' ./src/util/url.cc |
64 |
|
|
|
65 |
jpp |
1.2 |
%cmake3 \ |
66 |
jpp |
1.1 |
-DWITH_JS=1 \ |
67 |
|
|
-DWITH_MYSQL=1 \ |
68 |
|
|
-DWITH_CURL=1 \ |
69 |
jpp |
1.4 |
-DWITH_TAGLIB=0 \ |
70 |
jpp |
1.1 |
-DWITH_MAGIC=1 \ |
71 |
|
|
-DWITH_AVCODEC=0 \ |
72 |
|
|
-DWITH_EXIF=1 \ |
73 |
|
|
-DWITH_EXIV2=1 \ |
74 |
|
|
-DWITH_FFMPEGTHUMBNAILER=0 \ |
75 |
|
|
-DWITH_INOTIFY=1 \ |
76 |
|
|
-DWITH_SYSTEMD=1 \ |
77 |
|
|
-DUPNP_HAS_IPV6=1 \ |
78 |
|
|
-DUPNP_HAS_REUSEADDR=1 |
79 |
|
|
|
80 |
jpp |
1.2 |
%cmake3_build |
81 |
jpp |
1.1 |
|
82 |
|
|
%install |
83 |
jpp |
1.2 |
. /opt/rh/devtoolset-9/enable |
84 |
|
|
|
85 |
jpp |
1.1 |
install -p -D -m0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/gerbera/config.xml |
86 |
|
|
install -p -D -m0644 %{SOURCE2} %{buildroot}%{_sysusersdir}/gerbera.conf |
87 |
|
|
|
88 |
jpp |
1.2 |
%cmake3_install |
89 |
jpp |
1.1 |
|
90 |
|
|
# make all files under %%_sysconfdir/gerbera owned by |
91 |
|
|
# this package |
92 |
|
|
mkdir -p %{buildroot}%{_sysconfdir}/gerbera |
93 |
|
|
touch %{buildroot}%{_sysconfdir}/gerbera/{gerbera.db,gerbera.html} |
94 |
|
|
mkdir -p %{buildroot}%{_localstatedir}/log/gerbera |
95 |
|
|
touch %{buildroot}%{_localstatedir}/log/%{name} |
96 |
|
|
mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d |
97 |
|
|
cat > %{buildroot}%{_sysconfdir}/logrotate.d/%{name} << 'EOF' |
98 |
|
|
/var/log/gerbera/gerbera { |
99 |
|
|
create 644 gerbera gerbera |
100 |
|
|
monthly |
101 |
|
|
compress |
102 |
|
|
missingok |
103 |
|
|
} |
104 |
|
|
EOF |
105 |
|
|
|
106 |
|
|
|
107 |
|
|
%pre |
108 |
|
|
%sysusers_create_compat %{SOURCE2} |
109 |
|
|
|
110 |
|
|
%post |
111 |
|
|
%systemd_post gerbera.service |
112 |
|
|
|
113 |
|
|
%preun |
114 |
|
|
%systemd_preun gerbera.service |
115 |
|
|
|
116 |
|
|
%postun |
117 |
|
|
%systemd_postun_with_restart gerbera.service |
118 |
|
|
|
119 |
|
|
%files |
120 |
|
|
%license LICENSE.md |
121 |
|
|
%doc AUTHORS CONTRIBUTING.md ChangeLog.md |
122 |
|
|
%attr(-,gerbera,gerbera)%dir %{_sysconfdir}/%{name}/ |
123 |
|
|
%attr(-,gerbera,gerbera)%config(noreplace) %{_sysconfdir}/%{name}/* |
124 |
|
|
%attr(-,gerbera,gerbera) %{_localstatedir}/log/%{name} |
125 |
|
|
%config(noreplace) %{_sysconfdir}/logrotate.d/%{name} |
126 |
|
|
%dir %{_sysconfdir}/logrotate.d |
127 |
|
|
%{_bindir}/%{name} |
128 |
|
|
%{_mandir}/man1/* |
129 |
|
|
%{_unitdir}/gerbera.service |
130 |
|
|
%{_sysusersdir}/gerbera.conf |
131 |
|
|
|
132 |
|
|
%files data |
133 |
|
|
%{_datadir}/%{name}/ |
134 |
|
|
%config(noreplace) %{_datadir}/%{name}/js/import.js |
135 |
|
|
%config(noreplace) %{_datadir}/%{name}/js/playlists.js |
136 |
|
|
%config(noreplace) %{_datadir}/%{name}/js/common.js |
137 |
|
|
|
138 |
|
|
%changelog |
139 |
jpp |
1.2 |
* Thu Nov 11 2021 Jean-Philippe Pialasse <tests@pialasse.com> 1.9.1-2.sme |
140 |
|
|
- add fmt-devel Requirement |
141 |
|
|
|
142 |
jpp |
1.1 |
* Sat Aug 28 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.9.1-1 |
143 |
|
|
- 1.9.1 |
144 |
|
|
|
145 |
|
|
* Sun Aug 01 2021 Neal Gompa <ngompa@fedoraproject.org> - 1.9.0-1 |
146 |
|
|
- Update to 1.9.0 |
147 |
|
|
- Update user creation for systemd-sysusers support |
148 |
|
|
- Fix file list for logrotate configuration |
149 |
|
|
- Other minor spec cleanups |
150 |
|
|
|
151 |
|
|
* Thu Jul 22 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.2-3 |
152 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild |
153 |
|
|
|
154 |
|
|
* Mon Jul 05 2021 Richard Shaw <hobbes1069@gmail.com> - 1.8.2-2 |
155 |
|
|
- Rebuild for new fmt version. |
156 |
|
|
|
157 |
|
|
* Tue Jun 01 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.8.2-1 |
158 |
|
|
- 1.8.2 |
159 |
|
|
|
160 |
|
|
* Mon May 10 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.8.1-1 |
161 |
|
|
- 1.8.1 |
162 |
|
|
|
163 |
|
|
* Wed Apr 07 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.8.0-1 |
164 |
|
|
- 1.8.0 |
165 |
|
|
|
166 |
|
|
* Tue Mar 02 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.7.0-2 |
167 |
|
|
- Rebuilt for updated systemd-rpm-macros |
168 |
|
|
See https://pagure.io/fesco/issue/2583. |
169 |
|
|
|
170 |
|
|
* Mon Mar 01 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.7.0-1 |
171 |
|
|
- 1.7.0 |
172 |
|
|
|
173 |
|
|
* Fri Feb 12 2021 Gwyn Ciesla <gwync@protonmail.com> - 1.6.4-5 |
174 |
|
|
- Add MySQL support. |
175 |
|
|
|
176 |
|
|
* Tue Feb 09 2021 Nicolas Chauvet <kwizart@gmail.com> - 1.6.4-4 |
177 |
|
|
- Rebuilt for upnp |
178 |
|
|
|
179 |
|
|
* Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.4-3 |
180 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild |
181 |
|
|
|
182 |
|
|
* Wed Oct 28 2020 Jeff Law <law@redhat.com> - 1.6.4-2 |
183 |
|
|
- Fix missing #include for gcc-11 |
184 |
|
|
|
185 |
|
|
* Thu Oct 15 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.4-1 |
186 |
|
|
- 1.6.4 |
187 |
|
|
|
188 |
|
|
* Fri Sep 04 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.1-1 |
189 |
|
|
- 1.6.1 |
190 |
|
|
|
191 |
|
|
* Tue Aug 04 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.0-3 |
192 |
|
|
- fmt rebuild. |
193 |
|
|
|
194 |
|
|
* Mon Jul 27 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.6.0-2 |
195 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild |
196 |
|
|
|
197 |
|
|
* Sun Jul 26 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.6.0-1 |
198 |
|
|
- 1.6.0 |
199 |
|
|
|
200 |
|
|
* Fri Jul 17 2020 Dominik Mierzejewski <rpm@greysector.net> - 1.5.0-2 |
201 |
|
|
- rebuild for libebml and libmatroska soname bump |
202 |
|
|
|
203 |
|
|
* Thu Jul 16 2020 Gwyn Ciesla <gwync@protonmail.com> - 1.5.0-1 |
204 |
|
|
- 1.5.0 |
205 |
|
|
|
206 |
|
|
* Tue Jan 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.4.0-3 |
207 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild |
208 |
|
|
|
209 |
|
|
* Mon Dec 30 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.4.0-2 |
210 |
|
|
- Bump EVR for koji error. |
211 |
|
|
|
212 |
|
|
* Mon Dec 30 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.4.0-1 |
213 |
|
|
- 1.4.0 |
214 |
|
|
|
215 |
|
|
* Fri Nov 22 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.5-1 |
216 |
|
|
- 1.3.5 |
217 |
|
|
|
218 |
|
|
* Mon Nov 18 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.4-1 |
219 |
|
|
- 1.3.4 |
220 |
|
|
|
221 |
|
|
* Wed Oct 30 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.3-1 |
222 |
|
|
- 1.3.3 |
223 |
|
|
|
224 |
|
|
* Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.2-2 |
225 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild |
226 |
|
|
|
227 |
|
|
* Tue Jun 11 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.2-1 |
228 |
|
|
- 1.3.2 |
229 |
|
|
|
230 |
|
|
* Thu Apr 04 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.1-1 |
231 |
|
|
- 1.3.1 |
232 |
|
|
|
233 |
|
|
* Thu Feb 21 2019 Gwyn Ciesla <gwync@protonmail.com> - 1.3.0-4 |
234 |
|
|
- Drop lastlibfm, liblastfm not working yet. |
235 |
|
|
|
236 |
|
|
* Thu Jan 31 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.0-3 |
237 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild |
238 |
|
|
|
239 |
|
|
* Wed Jan 30 2019 Rex Dieter <rdieter@fedoraproject.org> - 1.3.0-2 |
240 |
|
|
- rebuild (exiv2) |
241 |
|
|
|
242 |
|
|
* Tue Jan 29 2019 Gwyn Ciesla <limburgher@gmail.com> - 1.3.0-1 |
243 |
|
|
- 1.3.0 |
244 |
|
|
|
245 |
|
|
* Mon Dec 03 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.2.0-4 |
246 |
|
|
- Fix logrotate config, BZ 1655279. |
247 |
|
|
|
248 |
|
|
* Mon Nov 12 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.2.0-3 |
249 |
|
|
- noconfig js, BZ 1648650. |
250 |
|
|
|
251 |
|
|
* Tue Oct 23 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.2.0-2 |
252 |
|
|
- Correct log directory. |
253 |
|
|
- Fix default config. |
254 |
|
|
|
255 |
|
|
* Fri Oct 05 2018 Dennis Gilmore <dennis@ausil.us> - 1.2.0-1 |
256 |
|
|
- update to the 1.2.0 release |
257 |
|
|
|
258 |
|
|
* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.1.0-6.20180413git2f6dcb5 |
259 |
|
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild |
260 |
|
|
|
261 |
|
|
* Tue May 29 2018 Mamoru TASAKA <mtasaka@fedoraproject.org> - 1.1.0-5.20180413git2f6dcb5 |
262 |
|
|
- Fix Requires |
263 |
|
|
|
264 |
|
|
* Mon May 28 2018 Dennis Gilmore <dennis@ausil.us> - 1.1.0-4.20180413git2f6dcb5 |
265 |
|
|
- Add back the correct requiresso that the data sub package gets pulled in |
266 |
|
|
|
267 |
|
|
* Mon May 28 2018 Dennis Gilmore <dennis@ausil.us> - 1.1.0-3.20180413git2f6dcb5 |
268 |
|
|
- remove requires that prevents installation |
269 |
|
|
|
270 |
|
|
* Thu Apr 19 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.1.0-2.20180413git2f6dcb5 |
271 |
|
|
- Spec corrections. |
272 |
|
|
- Split out data subpackage. |
273 |
|
|
|
274 |
|
|
* Fri Apr 13 2018 Gwyn Ciesla <limburgher@gmail.com> - 1.1.0-1 |
275 |
|
|
- Adapt to modern packaging guidelines. |
276 |
|
|
|
277 |
|
|
* Mon Mar 19 2018 jk@lutty.net |
278 |
|
|
- Initial package derived from mediatomb (fedora) annd gerbera (Suse) |