1 |
%define name glpi |
2 |
Summary: glpi is an Information Resource Manager |
3 |
Name: %{name} |
4 |
%define version 0.7 |
5 |
%define release 1 |
6 |
Version: %{version} |
7 |
Release: %{release}%{?dist} |
8 |
License: GNU GPL version 2 |
9 |
URL: http://www.glpi-project.org/ |
10 |
Group: SMEserver/addon |
11 |
Source: glpi-0.70.tar.gz |
12 |
BuildArchitectures: noarch |
13 |
BuildRoot: /var/tmp/%{name}-%{version} |
14 |
Requires: e-smith-release >= 7.0 |
15 |
BuildRequires: e-smith-devtools |
16 |
AutoReqProv: no |
17 |
|
18 |
%description |
19 |
http://www.glpi-project.org |
20 |
GLPI is the Information Resource Manager with an additional Administration Interface. |
21 |
You can use it to build up a database with an inventory for your company (computer, software, printers...). |
22 |
It has enhanced functions to make the daily life for the administrators easier, |
23 |
like a job-tracking-system with mail-notification and methods to build a database with |
24 |
basic information about your network-topology. |
25 |
|
26 |
|
27 |
%changelog |
28 |
* Mon Dec 24 2007 Stephen Noble <support@dungog.net> 0.7-1 |
29 |
- initial release |
30 |
- builds from unchanged .tgz |
31 |
|
32 |
%prep |
33 |
%setup -c -n %{name} |
34 |
%build |
35 |
#this lets you drop a .tgz in with the root of glpi and it builds ok |
36 |
mkdir -p root/opt/inventory/glpi |
37 |
mv %{name} root/opt/inventory/glpi |
38 |
|
39 |
%install |
40 |
rm -rf $RPM_BUILD_ROOT |
41 |
(cd root ; find . -depth -print | cpio -dump $RPM_BUILD_ROOT) |
42 |
rm -f %{name}-%{version}-filelist |
43 |
/sbin/e-smith/genfilelist $RPM_BUILD_ROOT \ |
44 |
--file '/opt/inventory/glpi/config_db.php' 'attr(440,root,www)' \ |
45 |
> %{name}-%{version}-filelist |
46 |
|
47 |
%clean |
48 |
cd .. |
49 |
rm -rf %{name} |
50 |
|
51 |
%pre |
52 |
%preun |
53 |
%post |
54 |
%postun |
55 |
|
56 |
%files -f %{name}-%{version}-filelist |
57 |
%defattr(-,root,root) |