1 |
# $Id: gollem-h3.spec,v 1.6 2009/04/02 01:57:33 mrjhb3 Exp $ |
2 |
# Authority: mrjhb3 |
3 |
# Name: John H. Bennett III |
4 |
|
5 |
%define apachedir /etc/httpd |
6 |
%define apacheuser www |
7 |
%define apachegroup www |
8 |
%define contentdir /home/httpd |
9 |
|
10 |
Summary: The web-based file manager for Horde. |
11 |
Name: gollem-h3 |
12 |
Version: 1.1.1 |
13 |
Release: 1%{?dist} |
14 |
License: LGPL |
15 |
Group: Applications/Horde |
16 |
Source: ftp://ftp.horde.org/pub/gollem/tarballs/gollem-h3-%{version}.tar.gz |
17 |
URL: http://www.horde.org/ |
18 |
BuildArchitectures: noarch |
19 |
BuildRoot: /tmp/horde-root |
20 |
AutoReq: no |
21 |
Requires: horde >= 3.0 |
22 |
Requires: php >= 4.3.0 |
23 |
Requires: httpd >= 2.0.46 |
24 |
Prereq: /usr/bin/perl |
25 |
|
26 |
%description |
27 |
Gollem is a web-based file manager, providing the ability to fully |
28 |
manage a hierarchical file system stored in a variety of backends such as a |
29 |
SQL database, as part of a real filesystem, or on an FTP server. |
30 |
|
31 |
The Horde Project writes web applications in PHP and releases them under |
32 |
Open Source licenses. For more information (including help with Horde |
33 |
and its modules) please visit http://www.horde.org/. |
34 |
|
35 |
This package contains customizations for SME Server |
36 |
and will probably not work properly on other Linux systems. |
37 |
|
38 |
%prep |
39 |
%setup -q -n %{name}-%{version} |
40 |
|
41 |
%build |
42 |
|
43 |
%install |
44 |
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
45 |
mkdir -p $RPM_BUILD_ROOT%{apachedir}/conf |
46 |
mkdir -p $RPM_BUILD_ROOT%{contentdir}/html/horde/gollem |
47 |
cp -pR * $RPM_BUILD_ROOT%{contentdir}/html/horde/gollem |
48 |
chmod go-rwx $RPM_BUILD_ROOT%{contentdir}/html/horde/gollem/test.php |
49 |
cd $RPM_BUILD_ROOT%{contentdir}/html/horde/gollem/config |
50 |
for d in *.dist; do |
51 |
d0=`basename $d .dist` |
52 |
if [ ! -f "$d0" ]; then |
53 |
cp -p $d $d0 |
54 |
fi |
55 |
done |
56 |
|
57 |
%clean |
58 |
[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT |
59 |
|
60 |
%post |
61 |
|
62 |
%postun |
63 |
|
64 |
%files |
65 |
%defattr(-,root,root) |
66 |
# Include top level with %dir so not all files are sucked in |
67 |
%dir %{contentdir}/html/horde/gollem |
68 |
# Include top-level files by hand |
69 |
%{contentdir}/html/horde/gollem/*.php |
70 |
# Include these dirs so that all files _will_ get sucked in |
71 |
%{contentdir}/html/horde/gollem/lib |
72 |
%{contentdir}/html/horde/gollem/locale |
73 |
%{contentdir}/html/horde/gollem/po |
74 |
%{contentdir}/html/horde/gollem/templates |
75 |
%{contentdir}/html/horde/gollem/themes |
76 |
%{contentdir}/html/horde/gollem/js |
77 |
# Mark documentation files with %doc and %docdir |
78 |
%doc %{contentdir}/html/horde/gollem/COPYING |
79 |
%doc %{contentdir}/html/horde/gollem/README |
80 |
%docdir %{contentdir}/html/horde/gollem/docs |
81 |
%{contentdir}/html/horde/gollem/docs |
82 |
# Mark configuration files with %config and use secure permissions |
83 |
# (note that .dist files are considered software; don't mark %config) |
84 |
%attr(750,root,%{apachegroup}) %dir %{contentdir}/html/horde/gollem/config |
85 |
%defattr(640,root,%{apachegroup}) |
86 |
#%{contentdir}/html/horde/gollem/config/.htaccess |
87 |
%{contentdir}/html/horde/gollem/config/*.dist |
88 |
%config %{contentdir}/html/horde/gollem/config/*.php |
89 |
%config %{contentdir}/html/horde/gollem/config/*.xml |
90 |
|
91 |
%changelog |
92 |
* Wed Dec 09 2009 John H. Bennett III <bennettj@johnbennettservices.com> 1.1.1-1 |
93 |
- Updated to gollem 1.1.1 |
94 |
|
95 |
* Wed Apr 1 2009 John H. Bennett III <bennettj@johnbennettservices.com> 1.1-1 |
96 |
- Updated to gollem 1.1 |
97 |
|
98 |
* Fri Dec 05 2008 John H. Bennett III <bennettj@johnbennettservices.com> 1.0.4-1 |
99 |
- Updated to gollem 1.0.4 |
100 |
|
101 |
* Sun Apr 29 2007 Shad L. Lords <slords@mail.com> |
102 |
- Clean up spec so package can be built by koji/plague |
103 |
|
104 |
* Fri Mar 23 2007 John H. Bennett III <bennettj@johnbennettservices.com> 1.0.3-1 |
105 |
- Updated to gollem 1.0.3 |
106 |
|
107 |
* Sat Mar 18 2006 John H. Bennett III <bennettj@johnbennettservices.com> |
108 |
- Re-rolled with Gollem 1.0.2 previous was RC1 |
109 |
|
110 |
* Thu Mar 2 2006 John H. Bennett III <bennettj@johnbennettservices.com> |
111 |
- Re-rolled with Gollem 1.0.2 |
112 |
|
113 |
* Thu Sep 01 2005 Greg Swallow |
114 |
- [1.0-1sme01] |
115 |
- Initial Release |
116 |
|