1 |
brianr |
1.1 |
# |
2 |
|
|
# spec file for package haserl |
3 |
|
|
# |
4 |
|
|
# Copyright (c) 2015 SUSE LINUX GmbH, Nuernberg, Germany. |
5 |
|
|
# |
6 |
|
|
# All modifications and additions to the file contributed by third parties |
7 |
|
|
# remain the property of their copyright owners, unless otherwise agreed |
8 |
|
|
# upon. The license for this file, and modifications and additions to the |
9 |
|
|
# file, is the same license as for the pristine package itself (unless the |
10 |
|
|
# license for the pristine package is not an Open Source License, in which |
11 |
|
|
# case the license is the MIT License). An "Open Source License" is a |
12 |
|
|
# license that conforms to the Open Source Definition (Version 1.9) |
13 |
|
|
# published by the Open Source Initiative. |
14 |
|
|
|
15 |
|
|
# Please submit bugfixes or comments via http://bugs.opensuse.org/ |
16 |
|
|
# |
17 |
|
|
|
18 |
|
|
|
19 |
|
|
Name: haserl |
20 |
|
|
BuildRequires: automake |
21 |
|
|
BuildRequires: lua-devel |
22 |
|
|
#BuildRequires: pkg-config |
23 |
|
|
Version: 0.9.35 |
24 |
|
|
Release: 5 |
25 |
|
|
Url: http://haserl.sourceforge.net/ |
26 |
|
|
Source: http://downloads.sourceforge.net/project/%{name}/haserl-devel/%{name}-%{version}.tar.gz |
27 |
|
|
Summary: CGI scripting with shell/lua |
28 |
|
|
License: GPL-2.0 |
29 |
|
|
Group: Development/Tools/GUI Builders |
30 |
|
|
BuildRoot: %{_tmppath}/%{name}-%{version}-build |
31 |
|
|
|
32 |
|
|
%description |
33 |
|
|
Haserl is a small cgi wrapper that allows "PHP" style cgi programming, |
34 |
|
|
but uses a UNIX bash-like shell or lua as the programming language. It |
35 |
|
|
is very small, so it can be used in embedded environments, or where |
36 |
|
|
something like PHP is too big. |
37 |
|
|
|
38 |
|
|
It combines three features into a small cgi engine: * It parses |
39 |
|
|
POST and GET requests, placing form-elements as name=value |
40 |
|
|
pairs into the environment for the CGI script to use. This is |
41 |
|
|
somewhat like the uncgi wrapper. |
42 |
|
|
|
43 |
|
|
* It opens a shell, and translates all text into printable |
44 |
|
|
statements. All text within <? ... ?> constructs are passed |
45 |
|
|
verbatim to the shell. This is somewhat like writing PHP |
46 |
|
|
scripts. |
47 |
|
|
|
48 |
|
|
* It can optionally be installed to drop its permissions to the |
49 |
|
|
owner of the script, giving it some of the security features of suexec |
50 |
|
|
or cgiwrapper. |
51 |
|
|
|
52 |
|
|
%prep |
53 |
|
|
%setup |
54 |
|
|
|
55 |
|
|
%build |
56 |
|
|
%configure --with-lua --enable-bash-extensions \ |
57 |
|
|
--enable-subshell=/bin/bash |
58 |
|
|
make |
59 |
|
|
|
60 |
|
|
%check |
61 |
|
|
make check |
62 |
|
|
|
63 |
|
|
%install |
64 |
|
|
make install DESTDIR=$RPM_BUILD_ROOT |
65 |
|
|
|
66 |
|
|
%files |
67 |
|
|
%defattr(-,root,root) |
68 |
|
|
/usr/bin/haserl |
69 |
|
|
%{_mandir}/man1/haserl.1.gz |
70 |
|
|
|
71 |
|
|
%changelog |
72 |
|
|
* Mon May 23 2016 Jean-Philipe Pialasse <tests@pialasse.com> 0.9.35-5.sme |
73 |
|
|
- first import in SME9 contrib for coova-chili [SME: 9521] |
74 |
|
|
|
75 |
|
|
* Thu Jul 30 2015 dimstar@opensuse.org |
76 |
|
|
- Update to version 0.9.35: |
77 |
|
|
+ Fixed a possible segfault if CONTENT_TYPE is not specified. |
78 |
|
|
- Changes from version 0.9.34: |
79 |
|
|
+ Haserl is now compatible with Lua 5.3 (in addition to 5.1, and |
80 |
|
|
5.2). |
81 |
|
|
+ Fix processing of headers in rfc2388.c. |
82 |
|
|
* Sat Jan 17 2015 p.drouand@gmail.com |
83 |
|
|
- Update to version 0.9.33 |
84 |
|
|
* Fix various security vulnerabilities - most serious is a |
85 |
|
|
Heap Overflow Vulnerability in sliding_buffer.c |
86 |
|
|
* Allow PUT and DELETE method (But prefix is still POST/GET) |
87 |
|
|
* On POST/PUT, Content-Type is not x-www-urlencoded, then |
88 |
|
|
the body of the message is stored verbatim in POST_body= |
89 |
|
|
- Remove obsolete fix-make.diff |
90 |
|
|
- Remove autoreconf calling; not needed anymore |
91 |
|
|
- Use %%configure instead of./configure |
92 |
|
|
* Fri Dec 2 2011 coolo@suse.com |
93 |
|
|
- add automake as buildrequire to avoid implicit dependency |
94 |
|
|
* Tue Oct 12 2010 coolo@novell.com |
95 |
|
|
- add patch to fix makefile syntax |
96 |
|
|
* Sun Sep 26 2010 ro@suse.de |
97 |
|
|
- add pkg-config to buildrequires |
98 |
|
|
* Tue Aug 19 2008 garloff@suse.de |
99 |
|
|
- Update to haserl-0.9.24: |
100 |
|
|
* bash extensions |
101 |
|
|
* regression tests (make check) |
102 |
|
|
* docu updates |
103 |
|
|
* myputenv enhancements |
104 |
|
|
* observe CONTENT_LENGTH |
105 |
|
|
* Thu Nov 29 2007 garloff@suse.de |
106 |
|
|
- Update to haserl-0.9.21: |
107 |
|
|
* Command line option handling reworked |
108 |
|
|
* major refactoring |
109 |
|
|
* various little bugs killed |
110 |
|
|
* lua support |
111 |
|
|
* custom handler for uploading large files |
112 |
|
|
* new comment tag |
113 |
|
|
* Tue Jul 10 2007 garloff@suse.de |
114 |
|
|
- Initial creation of package haserl-0.8.0 |