/[smecontribs]/rpms/hylafax/contribs7/hylafax.spec
ViewVC logotype

Annotation of /rpms/hylafax/contribs7/hylafax.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.1 - (hide annotations) (download)
Wed Apr 23 21:29:14 2008 UTC (16 years ago) by slords
Branch: MAIN
Initial import of hylafax-4.4.4-1.el4.sme.src.rpm

1 slords 1.1 %define name hylafax
2     %define version 4.4.4
3    
4     %define release 1
5     %define serial %(echo `date +%Y%m%d`)
6    
7     %define faxspool %{_var}/spool/hylafax
8    
9     Summary: HylaFAX(tm) is a sophisticated enterprise strength fax package
10     Name: %{name}
11     Version: %{version}
12     Release: %{release}%{?dist}
13     Epoch: %{serial}
14     License: better than LGPL
15     Group: Applications/Communications
16     URL: http://www.ifax.com/
17    
18     Source: ftp://ftp.hylafax.org/source/%{name}-%{version}.tar.gz
19     Source1: hylafax_init
20     Source2: hylafax_config
21     Source3: hylafax_config.modem
22     Source4: hylafax_setup.cache
23     Source5: hylafax_setup.modem
24     Source6: hylafax_daily.cron
25     Source7: hylafax_hourly.cron
26     Source8: hylafax_logrotate
27     Source9: hylafax_README.rpm
28     Source10: hylafax_hyla.conf
29     Source11: hylafax_FaxDispatch
30     Source12: hylafax_jobcontrol.sh
31     Source13: hylafax_sysconfig
32    
33     BuildPrereq: libjpeg-devel, libtiff-devel, zlib-devel
34     Requires: ghostscript >= 5.5
35     Requires: libtiff >= 3.5.5
36     Requires: gawk
37     Requires: rpm >= 3.0.5
38     Requires: sharutils
39     Conflicts: mgetty-sendfax
40    
41     BuildRoot: %{_tmppath}/%{name}-root
42    
43     %description
44     HylaFAX(tm) is a sophisticated enterprise-strength fax package for
45     class 1 and 2 fax modems on unix systems. It provides spooling
46     services and numerous supporting fax management tools.
47     The fax clients may reside on machines different from the server
48     and client implementations exist for a number of platforms including
49     windows.
50    
51     %prep
52     %setup -q
53    
54     %build
55     # - Can't use the configure macro because HylaFAX configure script does
56     # not understand the config options used by that macro
57     ./configure \
58     --with-DIR_BIN=%{_bindir} \
59     --with-DIR_SBIN=%{_sbindir} \
60     --with-DIR_LIB=%{_libdir} \
61     --with-DIR_LIBEXEC=%{_sbindir} \
62     --with-DIR_LIBDATA=%{_sysconfdir}/hylafax \
63     --with-DIR_LOCKS=%{_var}/lock \
64     --with-LIBDIR=%{_libdir} \
65     --with-TIFFBIN=%{_bindir} \
66     --with-DIR_MAN=%{_mandir} \
67     --with-PATH_GSRIP=%{_bindir}/gs \
68     --with-DBLIBINC=%{_includedir} \
69     --with-LIBTIFF="-ltiff -ljpeg -lz" \
70     --with-DIR_SPOOL=%{faxspool} \
71     --with-AFM=no \
72     --with-AWK=/usr/bin/gawk \
73     --with-PATH_VGETTY=/sbin/vgetty \
74     --with-PATH_GETTY=/sbin/mgetty \
75     --with-HTML=no \
76     --with-PAGESIZE=A4 \
77     --with-PATH_DPSRIP=%{faxspool}/bin/ps2fax \
78     --with-PATH_IMPRIP="" \
79     --with-SYSVINIT=%{initdir}/hylafax \
80     --with-INTERACTIVE=no
81    
82     # CFLAGS is set up by the HylaFAX configure script; setting it up here the
83     # standard way would break things. Since OPTIMIZER is included in CFLAGS
84     # by the HylaFAX configure system, it's used here in place of CFLAGS
85     #make CFLAGS="$RPM_OPT_FLAGS"
86     make OPTIMIZER="$RPM_OPT_FLAGS"
87    
88     %install
89     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
90    
91     # install: make some dirs...
92     mkdir -p -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/{cron.daily,cron.hourly,logrotate.d}
93     mkdir -p -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
94     mkdir -p -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/hylafax
95     mkdir -p -m 755 $RPM_BUILD_ROOT%{initdir}
96     mkdir -p -m 755 $RPM_BUILD_ROOT%{_bindir}
97     mkdir -p -m 755 $RPM_BUILD_ROOT%{_sbindir}
98     mkdir -p -m 755 $RPM_BUILD_ROOT%{_libdir}
99     mkdir -p -m 755 $RPM_BUILD_ROOT%{_mandir}
100     mkdir -p -m 755 $RPM_BUILD_ROOT%{faxspool}/config/defaults
101    
102     # install: binaries and man pages
103     # FAXUSER, FAXGROUP, SYSUSER and SYSGROUP are set to the current user to
104     # avoid warnings about chown/chgrp if the user building the SRPM is not root;
105     # they are set to the correct values with the RPM attr macro
106     %makeinstall -e \
107     FAXUSER=`id -u` \
108     FAXGROUP=`id -g` \
109     SYSUSER=`id -u` \
110     SYSGROUP=`id -g` \
111     BIN=$RPM_BUILD_ROOT%{_bindir} \
112     SBIN=$RPM_BUILD_ROOT%{_sbindir} \
113     LIBDIR=$RPM_BUILD_ROOT%{_libdir} \
114     LIBDATA=$RPM_BUILD_ROOT%{_sysconfdir}/hylafax \
115     LIBEXEC=$RPM_BUILD_ROOT%{_sbindir} \
116     SPOOL=$RPM_BUILD_ROOT%{faxspool} \
117     MAN=$RPM_BUILD_ROOT%{_mandir} \
118     INSTALL_ROOT=$RPM_BUILD_ROOT
119    
120     # Starting from 4.1.6, port/install.sh won't chown/chmod anymore if the current
121     # user is not root; instead a file root.sh is created with chown/chmod inside.
122     #
123     # If you build the rpm as normal user (not root) you get an rpm with all the
124     # permissions messed up and hylafax will give various weird errors.
125     #
126     # The following line fixes that.
127     #
128     [ -f root.sh ] && sh root.sh
129    
130     # install: remaining files
131     install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{initdir}/hylafax
132     install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{faxspool}/config/defaults/config
133     install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{faxspool}/config/defaults/config.modem
134     install -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{faxspool}/config/defaults/setup.cache
135     install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{faxspool}/config/defaults/setup.modem
136     install -m 755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/hylafax
137     install -m 755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/hylafax
138     install -m 644 %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/hylafax
139     install -m 644 %{SOURCE9} ./README.rpm
140     install -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/hylafax/hyla.conf
141     install -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{faxspool}/etc/FaxDispatch
142     install -m 644 %{SOURCE12} $RPM_BUILD_ROOT%{faxspool}/bin/jobcontrol.sh
143     install -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/hylafax
144    
145    
146     # some symlinks
147     ln -s ../..%{faxspool}/etc $RPM_BUILD_ROOT%{_sysconfdir}/hylafax/etc
148     ln -s ../..%{faxspool}/log $RPM_BUILD_ROOT%{_sysconfdir}/hylafax/log
149     ln -s ps2fax.gs $RPM_BUILD_ROOT%{faxspool}/bin/ps2fax
150     ln -s pdf2fax.gs $RPM_BUILD_ROOT%{faxspool}/bin/pdf2fax
151    
152     # Remove files that are not needed on Linux
153     rm -f $RPM_BUILD_ROOT%{_sbindir}/{faxsetup.irix,faxsetup.bsdi}
154     rm -f $RPM_BUILD_ROOT%{faxspool}/bin/{ps2fax.imp,ps2fax.dps}
155     # avoid rpm 4.x errors about files in buildroot but not in file list
156     rm -f $RPM_BUILD_ROOT%{faxspool}/etc/xferfaxlog
157     rm -f $RPM_BUILD_ROOT%{faxspool}/COPYRIGHT
158    
159     %clean
160     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
161    
162     %pre
163     # if necessary (upgrading from < 4.1rc1) move spool dir to the new location
164     # and live with rpm errors :)
165     if [ -f /var/spool/fax/etc/setup.cache -a ! -d %{faxspool} ]; then
166     if [ -f /var/lock/subsys/hylafax ]; then
167     /sbin/service hylafax stop 1>/dev/null 2>&1 || :
168     fi
169     mv /var/spool/fax /var/spool/hylafax
170     fi
171    
172     %post
173     if [ -x /usr/lib/lsb/install_initd ]; then
174     /usr/lib/lsb/install_initd %{initdir}/hylafax
175     elif [ -x /sbin/chkconfig ]; then
176     /sbin/chkconfig --add hylafax
177     else
178     for i in 3 4 5; do
179     ln -sf %{initdir}/hylafax /etc/rc.d/rc${i}.d/S95hylafax
180     done
181     for i in 0 1 2 6; do
182     ln -sf %{initdir}/hylafax /etc/rc.d/rc${i}.d/K05hylafax
183     done
184     fi
185     /sbin/ldconfig
186    
187     echo "#########################################################"
188     echo "# HylaFAX installation complete! #"
189     echo "# #"
190     echo "# You should now run /usr/sbin/faxsetup to #"
191     echo "# create or update HylaFAX configuration #"
192     echo "# before you can begin using the software. #"
193     echo "# #"
194     echo "#########################################################"
195    
196     %preun
197     if [ $1 = 0 ] ; then
198     if [ -x /usr/lib/lsb/remove_initd ]; then
199     /usr/lib/lsb/install_initd %{initdir}/hylafax
200     elif [ -x /sbin/chkconfig ]; then
201     /sbin/chkconfig --del hylafax
202     else
203     rm -f /etc/rc.d/rc?.d/???hylafax
204     fi
205     /sbin/service hylafax stop >/dev/null 2>&1 || :
206     fi
207    
208     %postun
209     /sbin/ldconfig
210     if [ "$1" -ge "1" ]; then
211     /sbin/service hylafax condrestart >/dev/null 2>&1 || :
212     fi
213    
214    
215     %files
216     %defattr(-,root,root)
217     %doc CONTRIBUTORS COPYRIGHT INSTALL README TODO VERSION README.rpm doc/*.txt
218     %attr(755,root,root) %config(noreplace) %{initdir}/hylafax
219     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/hylafax
220     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/logrotate.d/hylafax
221     %attr(755,root,root) %config(noreplace) %{_sysconfdir}/cron.daily/hylafax
222     %attr(755,root,root) %config(noreplace) %{_sysconfdir}/cron.hourly/hylafax
223     %{_bindir}/*
224     %{_sbindir}/*
225     %{_libdir}/*
226     %attr(644,root,root) %{_mandir}/*/*
227     %attr(755,root,root) %dir %{_sysconfdir}/hylafax
228     %attr(644,root,root) %{_sysconfdir}/hylafax/faxcover_example_sgi.ps
229     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/faxcover.ps
230     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/faxmail.ps
231     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/hfaxd.conf
232     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/hyla.conf
233     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/pagesizes
234     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/typerules
235     %attr(-,root,root) %{_sysconfdir}/hylafax/etc
236     %attr(-,root,root) %{_sysconfdir}/hylafax/log
237     %attr(-,uucp,uucp) %dir %{faxspool}
238     %attr(-,uucp,uucp) %dir %{faxspool}/archive
239     %attr(-,uucp,uucp) %dir %{faxspool}/bin
240     %attr(-,uucp,uucp) %dir %{faxspool}/client
241     %attr(-,uucp,uucp) %dir %{faxspool}/config
242     #%attr(-,uucp,uucp) %dir %{faxspool}/config/defaults
243     %attr(-,uucp,uucp) %dir %{faxspool}/dev
244     %attr(-,uucp,uucp) %dir %{faxspool}/docq
245     %attr(-,uucp,uucp) %dir %{faxspool}/doneq
246     %attr(-,uucp,uucp) %dir %{faxspool}/etc
247     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates
248     %attr(644,root,root) %{faxspool}/etc/templates/README
249     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/en
250     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/es
251     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/de
252     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/pt_BR
253     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/pl
254     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/pt
255     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/it
256     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/ro
257     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/fr
258     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/html-sample1
259     %attr(644,root,root) %config %{faxspool}/etc/templates/*/*
260     %attr(-,uucp,uucp) %dir %{faxspool}/info
261     %attr(-,uucp,uucp) %dir %{faxspool}/log
262     %attr(-,uucp,uucp) %dir %{faxspool}/pollq
263     %attr(-,uucp,uucp) %dir %{faxspool}/recvq
264     %attr(-,uucp,uucp) %dir %{faxspool}/sendq
265     %attr(-,uucp,uucp) %dir %{faxspool}/status
266     %attr(-,uucp,uucp) %dir %{faxspool}/tmp
267     %attr(-,root,root) %{faxspool}/bin/*
268     %attr(-,root,root) %{faxspool}/config/*
269     %attr(-,root,root) %{faxspool}/etc/dpsprinter.ps
270     %attr(-,root,root) %{faxspool}/etc/cover.templ
271     %attr(-,root,root) %config(noreplace) %{faxspool}/etc/dialrules*
272     %attr(-,uucp,uucp) %{faxspool}/etc/lutRS18.pcf
273     %attr(-,uucp,uucp) %config(noreplace) %{faxspool}/etc/hosts.hfaxd
274     %attr(-,uucp,uucp) %config(noreplace) %{faxspool}/etc/FaxDispatch
275     %attr(-,uucp,uucp) %{faxspool}/FIFO
276    
277    
278     %changelog
279     * Tue Jan 08 2008 Darren Nickerson <darren.nickerson@ifax.com> 4.4.4-1
280     - update to official 4.4.4 release
281    
282     * Sun Nov 25 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.4.3-1
283     - update to official 4.4.3 release
284    
285     * Wed Oct 03 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.4.2-1
286     - update to official 4.4.2 release
287    
288     * Wed Aug 22 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.4.1-1
289     - update to official 4.4.1 release
290    
291     * Fri Jul 27 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.4.0-1
292     - update to official 4.4.0 release
293    
294     * Fri Jul 06 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.4.0rc2-1
295     - update to second release candidate of 4.4.0
296    
297     * Fri Jun 29 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.4.0rc1-1
298     - update to first release candidate of 4.4.0
299    
300     * Fri May 18 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.4-1
301     - update to official 4.3.4 release
302     - distributed templates are now always replaced
303    
304     * Fri Mar 02 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.3-1
305     - update to official 4.3.3 release
306    
307     * Fri Feb 23 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.2-3
308     - Add requirement for tiff package under SuSE
309    
310     * Fri Feb 23 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.2-2
311     - [bug 849] notify "rejected" templates are wrongly called notify-reject.txt
312     - [bug 850] adds jobtag to notification mails
313    
314     * Fri Feb 16 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.2-1
315     - update to official 4.3.2 release
316    
317     * Mon Jan 29 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.3.2rc1-1
318     - update to first release candidate of 4.3.2
319    
320     * Mon Jan 29 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.3.2beta2-1
321     - update to second beta of 4.3.2
322    
323     * Mon Jan 29 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.3.2beta1-1
324     - update to first beta of 4.3.2
325    
326     * Mon Dec 04 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.1-1
327     - update to offical 4.3.1 release
328    
329     * Wed Nov 22 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.1rc3-1
330     - update to third release candidate of 4.3.1
331    
332     * Tue Nov 14 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.1rc2-1
333     - update to second release candidate of 4.3.1
334    
335     * Fri Oct 27 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.1rc1-1
336     - update to first release candidate of 4.3.1
337    
338     * Tue Oct 12 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.1beta4-1
339     - update to 4.3.1beta4
340    
341     * Fri May 26 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.0-2
342     - [Bug 775] Don't try to start two instances of hfaxd (Simon Matter)
343     - [Bug 776] sysconfig file doesn't need exec permissions (Simon Matter)
344    
345     * Mon May 22 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.0-1
346     - update to official 4.3.0 release
347    
348     * Fri May 12 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.0rc3-1
349     - update to third release candidate of 4.3.0
350    
351     * Fri Apr 28 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.0rc2-1
352     - update to second release candidate of 4.3.0
353    
354     * Fri Apr 21 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.0rc1-1
355     - update to first release candidate of 4.3.0
356     - Added Sample jobcontrol script
357     - Stop logrotate from returning an error when ran before HylaFAX first
358     start (Simon Matter)
359     - [Bug 766] Replaced obsolete Serial tag with Epoch (Dimitris)
360     - HylaFAX init script can now be configured in /etc/sysconfig/hylafax
361     (fixes bug 652)
362    
363     * Thu Jan 12 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.2.5-1
364     - update to official 4.2.5 release
365     - updated urls in README.rpm
366    
367     * Fri Jan 6 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.2.4-1
368     - update to official 4.2.4 release
369    
370     * Tue Nov 15 2005 Darren Nickerson <darren.nickerson@ifax.com> 4.2.3-1
371     - update to official 4.2.3 release
372    
373     * Fri Nov 11 2005 Patrice Fournier <patrice.fournier@ifax.com> 4.2.3rc1-2
374     - only run faxcron when HylaFAX has been setup (Simon Matter)
375     - fixed RPM file naming on RedHat 7 (broken since 4.2.2rc1-2)
376     - put hylafax init script in the right place on SuSE
377     - fixed init script for SuSE
378     - Correctly differentiate between SLES and regular SuSE
379    
380     * Fri Nov 9 2005 Darren Nickerson <darren.nickerson@ifax.com> 4.2.3rc1-1
381     - update to first release candidate of 4.2.3
382    
383     * Fri Sep 23 2005 Patrice Fournier <patrice.fournier@ifax.com> 4.2.2-1
384     - update to official 4.2.2 release
385    
386     * Fri Sep 16 2005 Patrice Fournier <patrice.fournier@ifax.com> 4.2.2rc1-2
387     - added SuSE support to SPECS file
388     - now distinguish between RH and RHEL versions (using version number)
389    
390     * Fri Sep 2 2005 Patrice Fournier <patrice.fournier@ifax.com> 4.2.2rc1-1
391     - update to first release candidate of 4.2.2
392     - updated installation complete message
393    
394     * Tue Jan 11 2005 Darren Nickerson <darren.nickerson@ifax.com> 4.2.1-1
395     - update to official 4.2.1 release
396     - [Bug 617] remove unnecessary debug logging (iFAX Solutions)
397     - [Bug 574] faxsetup cleanups (Lee Howard)
398     - [Bug 118] Improve EOM handling in batched faxes (Lee Howard)
399     - improve previously broken digi config (Lee Howard)
400     - improve redhat release detection and RPM file naming
401    
402     * Thu Jul 15 2004 Darren Nickerson <darren.nickerson@ifax.com> 4.2.0-1
403     - update to official 4.2.0 release
404    
405     * Thu Jul 15 2004 Darren Nickerson <darren.nickerson@ifax.com> 4.2.0rc2-1
406     - update to second release candidate of 4.2.0
407    
408     * Mon May 10 2004 Darren Nickerson <darren.nickerson@ifax.com> 4.2.0beta2-1
409     - update to second beta release of 4.2.0
410    
411     * Fri Apr 16 2004 Darren Nickerson <darren.nickerson@ifax.com> 4.2.0beta1-1
412     - update to first beta release of 4.2.0
413    
414     * Sun Dec 14 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.8-2
415     - [Bug 435] tiffcheck does not properly implement "-3" option
416     (Kevin Fleming)
417     - [Bug 436] tiffcheck does not suppress libtiff warnings
418     (Kevin Fleming)
419    
420     * Fri Oct 10 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.8-1
421     - update to official 4.1.8 release
422     - [Bug 468] Fix remotely executable format string vulnerability in hfaxd
423     (Sebastian Krahmer and the SuSE Security Team)
424    
425     * Fri Oct 10 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.7-2
426     - [Bug 443] Expand & unify sequence namespace (iFAX Solutions)
427     - [Bug 445] Corrected a long-standing problem that would leave old image
428     files in docq/ causing them to be sent again many months later in
429     place of the new image file (iFAX Solutions)
430     - [Bug 454] Faxgetty could hear more than 1 ring at once, doubling
431     things like CIDNAME and CIDNUMBER, and breaking inbound fax
432     routing (iFAX Solutions)
433     - [Bug 424] Updated, slightly cleaner patch. Functionally identical.
434    
435     * Sun Jun 15 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.7-1
436     - update to official 4.1.7 release
437     - add metamail dependency
438     - [Bug 420] Add SaveUnconfirmedPages config option
439     (Lee Howard)
440     - [Bug 427] Fix problem with port/install.sh on non-root builds
441     (Giulio Orsero)
442     - [Bug 424] Add support for tracking CIDName and CIDNumber in
443     xferfaxlog, tiff files, and client/server protocol via hfaxd
444     (iFAX Solutions)
445    
446     * Sun Jun 15 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.6-1
447     - update to official 4.1.6 release
448     - [Bug 410] Added sharutils dependency, and default FaxDispatch
449     - [Bug 407] Remove COPYRIGHT (packaged in %doc) and empty xferfaxlog
450     files from source tree before packaging.
451    
452     * Mon Oct 21 2002 Darren Nickerson <darren@hylafax.org> 4.1.5-1
453     - update to official 4.1.5 release
454    
455     * Wed Oct 16 2002 Darren Nickerson <darren@hylafax.org> 4.1.4-1
456     - update to official 4.1.4 release
457    
458     * Sun Jul 28 2002 Darren Nickerson <darren@hylafax.org> 4.1.3-1
459     - update to official 4.1.3 release
460     - added --with-LIBDIR=%{_libdir} to configure invocation (Lee Howard)
461    
462     * Sun Mar 17 2002 Darren Nickerson <darren@dazza.org> 4.1.1-2
463     - [Bug 160] fix segfault in faxqclean under heavy load
464    
465     * Sun Feb 17 2002 Darren Nickerson <darren@dazza.org> 4.1.1-1
466     - update to official 4.1.1 release
467    
468     * Sun Feb 10 2002 Darren Nickerson <darren@dazza.org>
469     - [Bug 156] Faxquit may not work after an upgrade - init script
470     now uses killall. (Giulio Orsero)
471     - [Bug 188] Roll-up of various fixes (Giulio Orsero)
472     1. removed 'sed' from hylafax_logrotate and similar files, which
473     caused confusion and some missed /var/spool/fax ->
474     /var/spool/hylafax corrections.
475     2. removed 2 unnecessary files on linux: ps2fax.dps and ps2fax.imp
476     3. set IMPRIP to blank since it does not exist on linux
477     4. marked all %config as noreplace
478     5. Changed "Copyright:" to "License:"
479     6. Changed serial to date +%Y%m%d
480     7. Linux DSO support has been merged into CVS. Removed patch
481     and modified .spec accordingly
482     8. Restore CFLAGS to RPM default
483     - [Bug 189] FHS compliance - changed /usr/share/fax -> /etc/hylafax
484     (see http://www.pathname.com/fhs/2.0/fhs-4.8.html) (Giulio Orsero)
485     - [Bug 196] Updated stale source files, commented hylafax_hyla.conf
486     (Giulio Orsero - spotting a trend here?)
487     - [Bug 206] Init script activates SNPP support if pagermap file
488     exists (Matthew Rice)
489    
490    
491     * Sun Jul 01 2001 Darren Nickerson <darren@dazza.org>
492     - [Bug 132] Added Conflicts: to avoid confusion with mgetty-sendfax
493     - [Bug 145] Added BuildPrereq: zlib-devel, since it's necessary
494     - [Bug 156] Init script now restarts faxgetty also
495     - [Bug 133] Set symlink for pdf2fax, added new docs to the %doc macro,
496     add intelligence to set spooldir accordingly, clarify comment for
497     %build macro, migrate /var/spool/fax to /var/spool/hylafax if this
498     is an upgrade, and add serial number to make versioning know 4.1 is
499     newer than 4.1beta3 and 4.1rc2. Thanks Giulio!!
500     - added --with-DIR_LIB=%{_libdir} to configure invocation
501    
502     * Sun Apr 15 2001 Darren Nickerson <darren@dazza.org>
503     - [Bug 89] Modify OPTIMIZER to be less aggressive for binary compatibility
504     on older systems. Tweaked .spec file so that one file produces both the
505     rh6 and rh7 RPMs (requires rpm-3.0.5 or better), remove gawk version
506     requirement. Removed --with-TIFFINC and --with-libdb from configure
507     invocation (Giulio Orsero).
508    
509     * Thu Feb 22 2001 Darren Nickerson <darren@dazza.org>
510     - update to hylafax-4.1beta3
511    
512     * Sun Dec 03 2000 Darren Nickerson <darren@dazza.org>
513     - update to cvs-20001203
514     - break out VRes tweak into hyla.conf for clarity. Makes a nice
515     example of how to use hyla.conf as well.
516    
517     * Fri Sep 01 2000 Darren Nickerson <darren@dazza.org>
518     - remove SysVinit patch due to clash with Tim Rice's work
519     - hard-wire gawk dependency to prevent it defaulting to mawk, which
520     is not installed by default on some systems
521     - use system zlib rather than HylaFAX's bundled one
522     - remove typerules and ps2fax patches, after committing them to CVS
523     - Update README.RPM
524    
525     * Wed Aug 23 2000 Darren Nickerson <darren@dazza.org>
526     - remove libgr dependencies for greater RPM portability
527    
528     * Mon Aug 21 2000 Giulio Orsero <giulioo@pobox.com>
529     - new 'rh7/rpm4 features': uses FHS macros, binaries stripping and man
530     pages gzipping handled by rpm policies, uses /sbin/service.
531     - Red Hat 6.x/7.x style init script (colors, condrestart)
532     - does not use caldera's lisa because I cannot test it.
533     - xferfaxlog and lutRS18.pcf no more tagged as config files
534     - RPM does not own /etc, /usr, ... anymore, just the files in them
535     - no more AFM dir and links (textfmt does not need them since 4.1b1)
536     - page size set to A4
537     - does not use HTML/CGI configure directive, takes html directly from source
538     - configure patched to run 'unattended'
539     - no more in RPM: manpage, man2html, unquote, faxsetup.irix, faxsetup.bsdi
540     - uses the OPTIMIZER variable to pass RPM_OPT_FLAGS to 'make'
541    
542     * Sun May 14 2000 Darren Nickerson <darren@dazza.org>
543     - standardize on libtiff >= 3.5 to resolve run length (16->32 bits)
544     - fixed modes of .dso files in dso.patch to silence ldd warning
545    
546     * Sun Mar 18 2000 Darren Nickerson <darren@dazza.org>
547     - instead of beta2 + patches, begin using CVS snapshot
548     - changed LIBTIFF linker line to include -ljpeg -lz, suggested by Matthew
549     Rice <matt@starnix.com>, and Erik Ratcliffe <erik@calderasystems.com>
550    
551     * Fri Nov 5 1999 Matthew Rice <matt@starnix.com>
552     - hylafax-4.1beta2.tar.gz
553     - added lisa support
554     - fix for installing into a build root
555    
556     * Wed Jun 16 1999 Darren Nickerson <darren@info.tpc.int>
557     - hylafax-4.1beta1.tar.gz
558     - added chkconfig support
559     - removed libjpeg linking and dependency
560    
561     * Tue Sep 29 1998 Darren Nickerson <darren@info.tpc.int>
562     - added security fix proposed by Carsten Hoeger <choeger@suse.de> for
563     potential race condition reported by Tobias Richter
564     <tsr@cave.isdn.cs.tu-berlin.de>
565     * Wed Sep 9 1998 Darren Nickerson <darren@info.tpc.int>
566     - built the RPM on Redhat-5.0 to avoid dependency problems with libjpeg
567     and libstdc++.
568     * Tue May 26 1998 Darren Nickerson <darren@info.tpc.int>
569     - removed .orig files from patch - they were 90 percent of it
570     - removed oversimplified /dev/modem assumptions
571     - faxcron was invoking xferstats, instead of new xferfaxstats - fixed
572     - revised faxcron's manpage
573     - HylaFAX was still writing etc/xferlog. Changed to etc/xferfaxlog as
574     advertised by all supporting docs and scripts.
575     - added hourly faxqclean and daily faxcron cron jobs, and xferlog rotation
576     - hfaxd no longer hard-wired as running from inetd, faxsetup will handle this
577     - no longer assumes /dev/modem and blindly inserts inittab entry
578     - change naming scheme to differentiate rh4/rh5
579     - move documentation back into main rpm, instead of sub-packages
580     - added Robert Colquhoun's textfmt-mailer patch
581     - increased margin on LHS, was too close and getting clipped
582     - make faxsetup warn that modem class = modem pool, not Class1/2/2.0
583     - use HylaFAX's init script, startup with new protocol only and no snpp
584     - added -DFIXEDMEDIA to last command in ps2fax.gs, as posted
585     by "Alan Sparks" <asparks@nss.harris.com>
586     - added fixhtml patch, removed release from the doc dir, now just version
587     - added Nico's skel patch, for class1/2/2.0 modem prototype files
588     - added Robert Colquhoun's patch to hfaxd's tagline generation
589     - fixes to build on 5.1, contributed by Richard Sharpe <sharpe@ns.aus.com>
590     - faxrcvd now treated as a config file, preserved as .rpmsave
591     - fixed ghostscript dependency to require fonts-std, not fonts.
592     - remove requirement for mawk - use gawk instead.
593     - faxsetup now detects is hfaxd is not driven from inetd, and starts it
594     when restarting faxq using SysV init script (Robert Colquhoun)
595    
596    
597     * Wed Mar 04 1998 Markus Pilzecker <mp@rhein-neckar.netsurf.de>
598     - took ldconfig call out of install section
599     - minimized and compressed patch
600     - arch rpm buildable as ordinary user
601     - diverted subpackages for [un]compressed man pages
602     - diverted subpackage for html documentation
603    
604     * Thu Jan 22 1998 Bernd Johannes Wuebben <wuebben@kde.org>
605     - hylafax-4.0-8
606     - A previous version of this spec file was handed to me by
607     Ramana Juvvadi (juvvadi@lekha.org)
608     who unfortunately can no longer provide rpms of hylafax.
609     Thanks so much for you work Ramana!
610     Bernd
611    
612     * Fri Oct 24 1997 Ramana Juvvadi (juvvadi@lekha.org)
613     - hylafax-4.0-6
614    
615    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed