/[smecontribs]/rpms/hylafax/contribs7/hylafax.spec
ViewVC logotype

Annotation of /rpms/hylafax/contribs7/hylafax.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Revision Graph Revision Graph


Revision 1.2 - (hide annotations) (download)
Wed Apr 23 21:30:20 2008 UTC (16 years ago) by slords
Branch: MAIN
Changes since 1.1: +4 -0 lines
Fixes

1 slords 1.2 # $Id$
2     # Authority: dungog
3     # Name: Stephen Noble
4    
5 slords 1.1 %define name hylafax
6     %define version 4.4.4
7    
8     %define release 1
9     %define serial %(echo `date +%Y%m%d`)
10    
11     %define faxspool %{_var}/spool/hylafax
12    
13     Summary: HylaFAX(tm) is a sophisticated enterprise strength fax package
14     Name: %{name}
15     Version: %{version}
16     Release: %{release}%{?dist}
17     Epoch: %{serial}
18     License: better than LGPL
19     Group: Applications/Communications
20     URL: http://www.ifax.com/
21    
22     Source: ftp://ftp.hylafax.org/source/%{name}-%{version}.tar.gz
23     Source1: hylafax_init
24     Source2: hylafax_config
25     Source3: hylafax_config.modem
26     Source4: hylafax_setup.cache
27     Source5: hylafax_setup.modem
28     Source6: hylafax_daily.cron
29     Source7: hylafax_hourly.cron
30     Source8: hylafax_logrotate
31     Source9: hylafax_README.rpm
32     Source10: hylafax_hyla.conf
33     Source11: hylafax_FaxDispatch
34     Source12: hylafax_jobcontrol.sh
35     Source13: hylafax_sysconfig
36    
37     BuildPrereq: libjpeg-devel, libtiff-devel, zlib-devel
38     Requires: ghostscript >= 5.5
39     Requires: libtiff >= 3.5.5
40     Requires: gawk
41     Requires: rpm >= 3.0.5
42     Requires: sharutils
43     Conflicts: mgetty-sendfax
44    
45     BuildRoot: %{_tmppath}/%{name}-root
46    
47     %description
48     HylaFAX(tm) is a sophisticated enterprise-strength fax package for
49     class 1 and 2 fax modems on unix systems. It provides spooling
50     services and numerous supporting fax management tools.
51     The fax clients may reside on machines different from the server
52     and client implementations exist for a number of platforms including
53     windows.
54    
55     %prep
56     %setup -q
57    
58     %build
59     # - Can't use the configure macro because HylaFAX configure script does
60     # not understand the config options used by that macro
61     ./configure \
62     --with-DIR_BIN=%{_bindir} \
63     --with-DIR_SBIN=%{_sbindir} \
64     --with-DIR_LIB=%{_libdir} \
65     --with-DIR_LIBEXEC=%{_sbindir} \
66     --with-DIR_LIBDATA=%{_sysconfdir}/hylafax \
67     --with-DIR_LOCKS=%{_var}/lock \
68     --with-LIBDIR=%{_libdir} \
69     --with-TIFFBIN=%{_bindir} \
70     --with-DIR_MAN=%{_mandir} \
71     --with-PATH_GSRIP=%{_bindir}/gs \
72     --with-DBLIBINC=%{_includedir} \
73     --with-LIBTIFF="-ltiff -ljpeg -lz" \
74     --with-DIR_SPOOL=%{faxspool} \
75     --with-AFM=no \
76     --with-AWK=/usr/bin/gawk \
77     --with-PATH_VGETTY=/sbin/vgetty \
78     --with-PATH_GETTY=/sbin/mgetty \
79     --with-HTML=no \
80     --with-PAGESIZE=A4 \
81     --with-PATH_DPSRIP=%{faxspool}/bin/ps2fax \
82     --with-PATH_IMPRIP="" \
83     --with-SYSVINIT=%{initdir}/hylafax \
84     --with-INTERACTIVE=no
85    
86     # CFLAGS is set up by the HylaFAX configure script; setting it up here the
87     # standard way would break things. Since OPTIMIZER is included in CFLAGS
88     # by the HylaFAX configure system, it's used here in place of CFLAGS
89     #make CFLAGS="$RPM_OPT_FLAGS"
90     make OPTIMIZER="$RPM_OPT_FLAGS"
91    
92     %install
93     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
94    
95     # install: make some dirs...
96     mkdir -p -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/{cron.daily,cron.hourly,logrotate.d}
97     mkdir -p -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
98     mkdir -p -m 755 $RPM_BUILD_ROOT%{_sysconfdir}/hylafax
99     mkdir -p -m 755 $RPM_BUILD_ROOT%{initdir}
100     mkdir -p -m 755 $RPM_BUILD_ROOT%{_bindir}
101     mkdir -p -m 755 $RPM_BUILD_ROOT%{_sbindir}
102     mkdir -p -m 755 $RPM_BUILD_ROOT%{_libdir}
103     mkdir -p -m 755 $RPM_BUILD_ROOT%{_mandir}
104     mkdir -p -m 755 $RPM_BUILD_ROOT%{faxspool}/config/defaults
105    
106     # install: binaries and man pages
107     # FAXUSER, FAXGROUP, SYSUSER and SYSGROUP are set to the current user to
108     # avoid warnings about chown/chgrp if the user building the SRPM is not root;
109     # they are set to the correct values with the RPM attr macro
110     %makeinstall -e \
111     FAXUSER=`id -u` \
112     FAXGROUP=`id -g` \
113     SYSUSER=`id -u` \
114     SYSGROUP=`id -g` \
115     BIN=$RPM_BUILD_ROOT%{_bindir} \
116     SBIN=$RPM_BUILD_ROOT%{_sbindir} \
117     LIBDIR=$RPM_BUILD_ROOT%{_libdir} \
118     LIBDATA=$RPM_BUILD_ROOT%{_sysconfdir}/hylafax \
119     LIBEXEC=$RPM_BUILD_ROOT%{_sbindir} \
120     SPOOL=$RPM_BUILD_ROOT%{faxspool} \
121     MAN=$RPM_BUILD_ROOT%{_mandir} \
122     INSTALL_ROOT=$RPM_BUILD_ROOT
123    
124     # Starting from 4.1.6, port/install.sh won't chown/chmod anymore if the current
125     # user is not root; instead a file root.sh is created with chown/chmod inside.
126     #
127     # If you build the rpm as normal user (not root) you get an rpm with all the
128     # permissions messed up and hylafax will give various weird errors.
129     #
130     # The following line fixes that.
131     #
132     [ -f root.sh ] && sh root.sh
133    
134     # install: remaining files
135     install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{initdir}/hylafax
136     install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{faxspool}/config/defaults/config
137     install -m 644 %{SOURCE3} $RPM_BUILD_ROOT%{faxspool}/config/defaults/config.modem
138     install -m 644 %{SOURCE4} $RPM_BUILD_ROOT%{faxspool}/config/defaults/setup.cache
139     install -m 644 %{SOURCE5} $RPM_BUILD_ROOT%{faxspool}/config/defaults/setup.modem
140     install -m 755 %{SOURCE6} $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/hylafax
141     install -m 755 %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/hylafax
142     install -m 644 %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/hylafax
143     install -m 644 %{SOURCE9} ./README.rpm
144     install -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/hylafax/hyla.conf
145     install -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{faxspool}/etc/FaxDispatch
146     install -m 644 %{SOURCE12} $RPM_BUILD_ROOT%{faxspool}/bin/jobcontrol.sh
147     install -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/hylafax
148    
149    
150     # some symlinks
151     ln -s ../..%{faxspool}/etc $RPM_BUILD_ROOT%{_sysconfdir}/hylafax/etc
152     ln -s ../..%{faxspool}/log $RPM_BUILD_ROOT%{_sysconfdir}/hylafax/log
153     ln -s ps2fax.gs $RPM_BUILD_ROOT%{faxspool}/bin/ps2fax
154     ln -s pdf2fax.gs $RPM_BUILD_ROOT%{faxspool}/bin/pdf2fax
155    
156     # Remove files that are not needed on Linux
157     rm -f $RPM_BUILD_ROOT%{_sbindir}/{faxsetup.irix,faxsetup.bsdi}
158     rm -f $RPM_BUILD_ROOT%{faxspool}/bin/{ps2fax.imp,ps2fax.dps}
159     # avoid rpm 4.x errors about files in buildroot but not in file list
160     rm -f $RPM_BUILD_ROOT%{faxspool}/etc/xferfaxlog
161     rm -f $RPM_BUILD_ROOT%{faxspool}/COPYRIGHT
162    
163     %clean
164     [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
165    
166     %pre
167     # if necessary (upgrading from < 4.1rc1) move spool dir to the new location
168     # and live with rpm errors :)
169     if [ -f /var/spool/fax/etc/setup.cache -a ! -d %{faxspool} ]; then
170     if [ -f /var/lock/subsys/hylafax ]; then
171     /sbin/service hylafax stop 1>/dev/null 2>&1 || :
172     fi
173     mv /var/spool/fax /var/spool/hylafax
174     fi
175    
176     %post
177     if [ -x /usr/lib/lsb/install_initd ]; then
178     /usr/lib/lsb/install_initd %{initdir}/hylafax
179     elif [ -x /sbin/chkconfig ]; then
180     /sbin/chkconfig --add hylafax
181     else
182     for i in 3 4 5; do
183     ln -sf %{initdir}/hylafax /etc/rc.d/rc${i}.d/S95hylafax
184     done
185     for i in 0 1 2 6; do
186     ln -sf %{initdir}/hylafax /etc/rc.d/rc${i}.d/K05hylafax
187     done
188     fi
189     /sbin/ldconfig
190    
191     echo "#########################################################"
192     echo "# HylaFAX installation complete! #"
193     echo "# #"
194     echo "# You should now run /usr/sbin/faxsetup to #"
195     echo "# create or update HylaFAX configuration #"
196     echo "# before you can begin using the software. #"
197     echo "# #"
198     echo "#########################################################"
199    
200     %preun
201     if [ $1 = 0 ] ; then
202     if [ -x /usr/lib/lsb/remove_initd ]; then
203     /usr/lib/lsb/install_initd %{initdir}/hylafax
204     elif [ -x /sbin/chkconfig ]; then
205     /sbin/chkconfig --del hylafax
206     else
207     rm -f /etc/rc.d/rc?.d/???hylafax
208     fi
209     /sbin/service hylafax stop >/dev/null 2>&1 || :
210     fi
211    
212     %postun
213     /sbin/ldconfig
214     if [ "$1" -ge "1" ]; then
215     /sbin/service hylafax condrestart >/dev/null 2>&1 || :
216     fi
217    
218    
219     %files
220     %defattr(-,root,root)
221     %doc CONTRIBUTORS COPYRIGHT INSTALL README TODO VERSION README.rpm doc/*.txt
222     %attr(755,root,root) %config(noreplace) %{initdir}/hylafax
223     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/hylafax
224     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/logrotate.d/hylafax
225     %attr(755,root,root) %config(noreplace) %{_sysconfdir}/cron.daily/hylafax
226     %attr(755,root,root) %config(noreplace) %{_sysconfdir}/cron.hourly/hylafax
227     %{_bindir}/*
228     %{_sbindir}/*
229     %{_libdir}/*
230     %attr(644,root,root) %{_mandir}/*/*
231     %attr(755,root,root) %dir %{_sysconfdir}/hylafax
232     %attr(644,root,root) %{_sysconfdir}/hylafax/faxcover_example_sgi.ps
233     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/faxcover.ps
234     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/faxmail.ps
235     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/hfaxd.conf
236     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/hyla.conf
237     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/pagesizes
238     %attr(644,root,root) %config(noreplace) %{_sysconfdir}/hylafax/typerules
239     %attr(-,root,root) %{_sysconfdir}/hylafax/etc
240     %attr(-,root,root) %{_sysconfdir}/hylafax/log
241     %attr(-,uucp,uucp) %dir %{faxspool}
242     %attr(-,uucp,uucp) %dir %{faxspool}/archive
243     %attr(-,uucp,uucp) %dir %{faxspool}/bin
244     %attr(-,uucp,uucp) %dir %{faxspool}/client
245     %attr(-,uucp,uucp) %dir %{faxspool}/config
246     #%attr(-,uucp,uucp) %dir %{faxspool}/config/defaults
247     %attr(-,uucp,uucp) %dir %{faxspool}/dev
248     %attr(-,uucp,uucp) %dir %{faxspool}/docq
249     %attr(-,uucp,uucp) %dir %{faxspool}/doneq
250     %attr(-,uucp,uucp) %dir %{faxspool}/etc
251     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates
252     %attr(644,root,root) %{faxspool}/etc/templates/README
253     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/en
254     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/es
255     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/de
256     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/pt_BR
257     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/pl
258     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/pt
259     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/it
260     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/ro
261     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/fr
262     %attr(-,uucp,uucp) %dir %{faxspool}/etc/templates/html-sample1
263     %attr(644,root,root) %config %{faxspool}/etc/templates/*/*
264     %attr(-,uucp,uucp) %dir %{faxspool}/info
265     %attr(-,uucp,uucp) %dir %{faxspool}/log
266     %attr(-,uucp,uucp) %dir %{faxspool}/pollq
267     %attr(-,uucp,uucp) %dir %{faxspool}/recvq
268     %attr(-,uucp,uucp) %dir %{faxspool}/sendq
269     %attr(-,uucp,uucp) %dir %{faxspool}/status
270     %attr(-,uucp,uucp) %dir %{faxspool}/tmp
271     %attr(-,root,root) %{faxspool}/bin/*
272     %attr(-,root,root) %{faxspool}/config/*
273     %attr(-,root,root) %{faxspool}/etc/dpsprinter.ps
274     %attr(-,root,root) %{faxspool}/etc/cover.templ
275     %attr(-,root,root) %config(noreplace) %{faxspool}/etc/dialrules*
276     %attr(-,uucp,uucp) %{faxspool}/etc/lutRS18.pcf
277     %attr(-,uucp,uucp) %config(noreplace) %{faxspool}/etc/hosts.hfaxd
278     %attr(-,uucp,uucp) %config(noreplace) %{faxspool}/etc/FaxDispatch
279     %attr(-,uucp,uucp) %{faxspool}/FIFO
280    
281    
282     %changelog
283     * Tue Jan 08 2008 Darren Nickerson <darren.nickerson@ifax.com> 4.4.4-1
284     - update to official 4.4.4 release
285    
286     * Sun Nov 25 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.4.3-1
287     - update to official 4.4.3 release
288    
289     * Wed Oct 03 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.4.2-1
290     - update to official 4.4.2 release
291    
292     * Wed Aug 22 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.4.1-1
293     - update to official 4.4.1 release
294    
295     * Fri Jul 27 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.4.0-1
296     - update to official 4.4.0 release
297    
298     * Fri Jul 06 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.4.0rc2-1
299     - update to second release candidate of 4.4.0
300    
301     * Fri Jun 29 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.4.0rc1-1
302     - update to first release candidate of 4.4.0
303    
304     * Fri May 18 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.4-1
305     - update to official 4.3.4 release
306     - distributed templates are now always replaced
307    
308     * Fri Mar 02 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.3-1
309     - update to official 4.3.3 release
310    
311     * Fri Feb 23 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.2-3
312     - Add requirement for tiff package under SuSE
313    
314     * Fri Feb 23 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.2-2
315     - [bug 849] notify "rejected" templates are wrongly called notify-reject.txt
316     - [bug 850] adds jobtag to notification mails
317    
318     * Fri Feb 16 2007 Patrice Fournier <patrice.fournier@ifax.com> 4.3.2-1
319     - update to official 4.3.2 release
320    
321     * Mon Jan 29 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.3.2rc1-1
322     - update to first release candidate of 4.3.2
323    
324     * Mon Jan 29 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.3.2beta2-1
325     - update to second beta of 4.3.2
326    
327     * Mon Jan 29 2007 Darren Nickerson <darren.nickerson@ifax.com> 4.3.2beta1-1
328     - update to first beta of 4.3.2
329    
330     * Mon Dec 04 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.1-1
331     - update to offical 4.3.1 release
332    
333     * Wed Nov 22 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.1rc3-1
334     - update to third release candidate of 4.3.1
335    
336     * Tue Nov 14 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.1rc2-1
337     - update to second release candidate of 4.3.1
338    
339     * Fri Oct 27 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.1rc1-1
340     - update to first release candidate of 4.3.1
341    
342     * Tue Oct 12 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.1beta4-1
343     - update to 4.3.1beta4
344    
345     * Fri May 26 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.0-2
346     - [Bug 775] Don't try to start two instances of hfaxd (Simon Matter)
347     - [Bug 776] sysconfig file doesn't need exec permissions (Simon Matter)
348    
349     * Mon May 22 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.3.0-1
350     - update to official 4.3.0 release
351    
352     * Fri May 12 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.0rc3-1
353     - update to third release candidate of 4.3.0
354    
355     * Fri Apr 28 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.0rc2-1
356     - update to second release candidate of 4.3.0
357    
358     * Fri Apr 21 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.3.0rc1-1
359     - update to first release candidate of 4.3.0
360     - Added Sample jobcontrol script
361     - Stop logrotate from returning an error when ran before HylaFAX first
362     start (Simon Matter)
363     - [Bug 766] Replaced obsolete Serial tag with Epoch (Dimitris)
364     - HylaFAX init script can now be configured in /etc/sysconfig/hylafax
365     (fixes bug 652)
366    
367     * Thu Jan 12 2006 Darren Nickerson <darren.nickerson@ifax.com> 4.2.5-1
368     - update to official 4.2.5 release
369     - updated urls in README.rpm
370    
371     * Fri Jan 6 2006 Patrice Fournier <patrice.fournier@ifax.com> 4.2.4-1
372     - update to official 4.2.4 release
373    
374     * Tue Nov 15 2005 Darren Nickerson <darren.nickerson@ifax.com> 4.2.3-1
375     - update to official 4.2.3 release
376    
377     * Fri Nov 11 2005 Patrice Fournier <patrice.fournier@ifax.com> 4.2.3rc1-2
378     - only run faxcron when HylaFAX has been setup (Simon Matter)
379     - fixed RPM file naming on RedHat 7 (broken since 4.2.2rc1-2)
380     - put hylafax init script in the right place on SuSE
381     - fixed init script for SuSE
382     - Correctly differentiate between SLES and regular SuSE
383    
384     * Fri Nov 9 2005 Darren Nickerson <darren.nickerson@ifax.com> 4.2.3rc1-1
385     - update to first release candidate of 4.2.3
386    
387     * Fri Sep 23 2005 Patrice Fournier <patrice.fournier@ifax.com> 4.2.2-1
388     - update to official 4.2.2 release
389    
390     * Fri Sep 16 2005 Patrice Fournier <patrice.fournier@ifax.com> 4.2.2rc1-2
391     - added SuSE support to SPECS file
392     - now distinguish between RH and RHEL versions (using version number)
393    
394     * Fri Sep 2 2005 Patrice Fournier <patrice.fournier@ifax.com> 4.2.2rc1-1
395     - update to first release candidate of 4.2.2
396     - updated installation complete message
397    
398     * Tue Jan 11 2005 Darren Nickerson <darren.nickerson@ifax.com> 4.2.1-1
399     - update to official 4.2.1 release
400     - [Bug 617] remove unnecessary debug logging (iFAX Solutions)
401     - [Bug 574] faxsetup cleanups (Lee Howard)
402     - [Bug 118] Improve EOM handling in batched faxes (Lee Howard)
403     - improve previously broken digi config (Lee Howard)
404     - improve redhat release detection and RPM file naming
405    
406     * Thu Jul 15 2004 Darren Nickerson <darren.nickerson@ifax.com> 4.2.0-1
407     - update to official 4.2.0 release
408    
409     * Thu Jul 15 2004 Darren Nickerson <darren.nickerson@ifax.com> 4.2.0rc2-1
410     - update to second release candidate of 4.2.0
411    
412     * Mon May 10 2004 Darren Nickerson <darren.nickerson@ifax.com> 4.2.0beta2-1
413     - update to second beta release of 4.2.0
414    
415     * Fri Apr 16 2004 Darren Nickerson <darren.nickerson@ifax.com> 4.2.0beta1-1
416     - update to first beta release of 4.2.0
417    
418     * Sun Dec 14 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.8-2
419     - [Bug 435] tiffcheck does not properly implement "-3" option
420     (Kevin Fleming)
421     - [Bug 436] tiffcheck does not suppress libtiff warnings
422     (Kevin Fleming)
423    
424     * Fri Oct 10 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.8-1
425     - update to official 4.1.8 release
426     - [Bug 468] Fix remotely executable format string vulnerability in hfaxd
427     (Sebastian Krahmer and the SuSE Security Team)
428    
429     * Fri Oct 10 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.7-2
430     - [Bug 443] Expand & unify sequence namespace (iFAX Solutions)
431     - [Bug 445] Corrected a long-standing problem that would leave old image
432     files in docq/ causing them to be sent again many months later in
433     place of the new image file (iFAX Solutions)
434     - [Bug 454] Faxgetty could hear more than 1 ring at once, doubling
435     things like CIDNAME and CIDNUMBER, and breaking inbound fax
436     routing (iFAX Solutions)
437     - [Bug 424] Updated, slightly cleaner patch. Functionally identical.
438    
439     * Sun Jun 15 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.7-1
440     - update to official 4.1.7 release
441     - add metamail dependency
442     - [Bug 420] Add SaveUnconfirmedPages config option
443     (Lee Howard)
444     - [Bug 427] Fix problem with port/install.sh on non-root builds
445     (Giulio Orsero)
446     - [Bug 424] Add support for tracking CIDName and CIDNumber in
447     xferfaxlog, tiff files, and client/server protocol via hfaxd
448     (iFAX Solutions)
449    
450     * Sun Jun 15 2003 Darren Nickerson <darren.nickerson@ifax.com> 4.1.6-1
451     - update to official 4.1.6 release
452     - [Bug 410] Added sharutils dependency, and default FaxDispatch
453     - [Bug 407] Remove COPYRIGHT (packaged in %doc) and empty xferfaxlog
454     files from source tree before packaging.
455    
456     * Mon Oct 21 2002 Darren Nickerson <darren@hylafax.org> 4.1.5-1
457     - update to official 4.1.5 release
458    
459     * Wed Oct 16 2002 Darren Nickerson <darren@hylafax.org> 4.1.4-1
460     - update to official 4.1.4 release
461    
462     * Sun Jul 28 2002 Darren Nickerson <darren@hylafax.org> 4.1.3-1
463     - update to official 4.1.3 release
464     - added --with-LIBDIR=%{_libdir} to configure invocation (Lee Howard)
465    
466     * Sun Mar 17 2002 Darren Nickerson <darren@dazza.org> 4.1.1-2
467     - [Bug 160] fix segfault in faxqclean under heavy load
468    
469     * Sun Feb 17 2002 Darren Nickerson <darren@dazza.org> 4.1.1-1
470     - update to official 4.1.1 release
471    
472     * Sun Feb 10 2002 Darren Nickerson <darren@dazza.org>
473     - [Bug 156] Faxquit may not work after an upgrade - init script
474     now uses killall. (Giulio Orsero)
475     - [Bug 188] Roll-up of various fixes (Giulio Orsero)
476     1. removed 'sed' from hylafax_logrotate and similar files, which
477     caused confusion and some missed /var/spool/fax ->
478     /var/spool/hylafax corrections.
479     2. removed 2 unnecessary files on linux: ps2fax.dps and ps2fax.imp
480     3. set IMPRIP to blank since it does not exist on linux
481     4. marked all %config as noreplace
482     5. Changed "Copyright:" to "License:"
483     6. Changed serial to date +%Y%m%d
484     7. Linux DSO support has been merged into CVS. Removed patch
485     and modified .spec accordingly
486     8. Restore CFLAGS to RPM default
487     - [Bug 189] FHS compliance - changed /usr/share/fax -> /etc/hylafax
488     (see http://www.pathname.com/fhs/2.0/fhs-4.8.html) (Giulio Orsero)
489     - [Bug 196] Updated stale source files, commented hylafax_hyla.conf
490     (Giulio Orsero - spotting a trend here?)
491     - [Bug 206] Init script activates SNPP support if pagermap file
492     exists (Matthew Rice)
493    
494    
495     * Sun Jul 01 2001 Darren Nickerson <darren@dazza.org>
496     - [Bug 132] Added Conflicts: to avoid confusion with mgetty-sendfax
497     - [Bug 145] Added BuildPrereq: zlib-devel, since it's necessary
498     - [Bug 156] Init script now restarts faxgetty also
499     - [Bug 133] Set symlink for pdf2fax, added new docs to the %doc macro,
500     add intelligence to set spooldir accordingly, clarify comment for
501     %build macro, migrate /var/spool/fax to /var/spool/hylafax if this
502     is an upgrade, and add serial number to make versioning know 4.1 is
503     newer than 4.1beta3 and 4.1rc2. Thanks Giulio!!
504     - added --with-DIR_LIB=%{_libdir} to configure invocation
505    
506     * Sun Apr 15 2001 Darren Nickerson <darren@dazza.org>
507     - [Bug 89] Modify OPTIMIZER to be less aggressive for binary compatibility
508     on older systems. Tweaked .spec file so that one file produces both the
509     rh6 and rh7 RPMs (requires rpm-3.0.5 or better), remove gawk version
510     requirement. Removed --with-TIFFINC and --with-libdb from configure
511     invocation (Giulio Orsero).
512    
513     * Thu Feb 22 2001 Darren Nickerson <darren@dazza.org>
514     - update to hylafax-4.1beta3
515    
516     * Sun Dec 03 2000 Darren Nickerson <darren@dazza.org>
517     - update to cvs-20001203
518     - break out VRes tweak into hyla.conf for clarity. Makes a nice
519     example of how to use hyla.conf as well.
520    
521     * Fri Sep 01 2000 Darren Nickerson <darren@dazza.org>
522     - remove SysVinit patch due to clash with Tim Rice's work
523     - hard-wire gawk dependency to prevent it defaulting to mawk, which
524     is not installed by default on some systems
525     - use system zlib rather than HylaFAX's bundled one
526     - remove typerules and ps2fax patches, after committing them to CVS
527     - Update README.RPM
528    
529     * Wed Aug 23 2000 Darren Nickerson <darren@dazza.org>
530     - remove libgr dependencies for greater RPM portability
531    
532     * Mon Aug 21 2000 Giulio Orsero <giulioo@pobox.com>
533     - new 'rh7/rpm4 features': uses FHS macros, binaries stripping and man
534     pages gzipping handled by rpm policies, uses /sbin/service.
535     - Red Hat 6.x/7.x style init script (colors, condrestart)
536     - does not use caldera's lisa because I cannot test it.
537     - xferfaxlog and lutRS18.pcf no more tagged as config files
538     - RPM does not own /etc, /usr, ... anymore, just the files in them
539     - no more AFM dir and links (textfmt does not need them since 4.1b1)
540     - page size set to A4
541     - does not use HTML/CGI configure directive, takes html directly from source
542     - configure patched to run 'unattended'
543     - no more in RPM: manpage, man2html, unquote, faxsetup.irix, faxsetup.bsdi
544     - uses the OPTIMIZER variable to pass RPM_OPT_FLAGS to 'make'
545    
546     * Sun May 14 2000 Darren Nickerson <darren@dazza.org>
547     - standardize on libtiff >= 3.5 to resolve run length (16->32 bits)
548     - fixed modes of .dso files in dso.patch to silence ldd warning
549    
550     * Sun Mar 18 2000 Darren Nickerson <darren@dazza.org>
551     - instead of beta2 + patches, begin using CVS snapshot
552     - changed LIBTIFF linker line to include -ljpeg -lz, suggested by Matthew
553     Rice <matt@starnix.com>, and Erik Ratcliffe <erik@calderasystems.com>
554    
555     * Fri Nov 5 1999 Matthew Rice <matt@starnix.com>
556     - hylafax-4.1beta2.tar.gz
557     - added lisa support
558     - fix for installing into a build root
559    
560     * Wed Jun 16 1999 Darren Nickerson <darren@info.tpc.int>
561     - hylafax-4.1beta1.tar.gz
562     - added chkconfig support
563     - removed libjpeg linking and dependency
564    
565     * Tue Sep 29 1998 Darren Nickerson <darren@info.tpc.int>
566     - added security fix proposed by Carsten Hoeger <choeger@suse.de> for
567     potential race condition reported by Tobias Richter
568     <tsr@cave.isdn.cs.tu-berlin.de>
569     * Wed Sep 9 1998 Darren Nickerson <darren@info.tpc.int>
570     - built the RPM on Redhat-5.0 to avoid dependency problems with libjpeg
571     and libstdc++.
572     * Tue May 26 1998 Darren Nickerson <darren@info.tpc.int>
573     - removed .orig files from patch - they were 90 percent of it
574     - removed oversimplified /dev/modem assumptions
575     - faxcron was invoking xferstats, instead of new xferfaxstats - fixed
576     - revised faxcron's manpage
577     - HylaFAX was still writing etc/xferlog. Changed to etc/xferfaxlog as
578     advertised by all supporting docs and scripts.
579     - added hourly faxqclean and daily faxcron cron jobs, and xferlog rotation
580     - hfaxd no longer hard-wired as running from inetd, faxsetup will handle this
581     - no longer assumes /dev/modem and blindly inserts inittab entry
582     - change naming scheme to differentiate rh4/rh5
583     - move documentation back into main rpm, instead of sub-packages
584     - added Robert Colquhoun's textfmt-mailer patch
585     - increased margin on LHS, was too close and getting clipped
586     - make faxsetup warn that modem class = modem pool, not Class1/2/2.0
587     - use HylaFAX's init script, startup with new protocol only and no snpp
588     - added -DFIXEDMEDIA to last command in ps2fax.gs, as posted
589     by "Alan Sparks" <asparks@nss.harris.com>
590     - added fixhtml patch, removed release from the doc dir, now just version
591     - added Nico's skel patch, for class1/2/2.0 modem prototype files
592     - added Robert Colquhoun's patch to hfaxd's tagline generation
593     - fixes to build on 5.1, contributed by Richard Sharpe <sharpe@ns.aus.com>
594     - faxrcvd now treated as a config file, preserved as .rpmsave
595     - fixed ghostscript dependency to require fonts-std, not fonts.
596     - remove requirement for mawk - use gawk instead.
597     - faxsetup now detects is hfaxd is not driven from inetd, and starts it
598     when restarting faxq using SysV init script (Robert Colquhoun)
599    
600    
601     * Wed Mar 04 1998 Markus Pilzecker <mp@rhein-neckar.netsurf.de>
602     - took ldconfig call out of install section
603     - minimized and compressed patch
604     - arch rpm buildable as ordinary user
605     - diverted subpackages for [un]compressed man pages
606     - diverted subpackage for html documentation
607    
608     * Thu Jan 22 1998 Bernd Johannes Wuebben <wuebben@kde.org>
609     - hylafax-4.0-8
610     - A previous version of this spec file was handed to me by
611     Ramana Juvvadi (juvvadi@lekha.org)
612     who unfortunately can no longer provide rpms of hylafax.
613     Thanks so much for you work Ramana!
614     Bernd
615    
616     * Fri Oct 24 1997 Ramana Juvvadi (juvvadi@lekha.org)
617     - hylafax-4.0-6
618    
619    

admin@koozali.org
ViewVC Help
Powered by ViewVC 1.2.1 RSS 2.0 feed